Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Fehler beim installieren von gentoolkit
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) Diskussionsforum
View previous topic :: View next topic  
Author Message
jUng3r
n00b
n00b


Joined: 05 Feb 2012
Posts: 5

PostPosted: Sun Feb 05, 2012 8:17 pm    Post subject: [SOLVED] Fehler beim installieren von gentoolkit Reply with quote

Hallo,

ich habe mir in einer virtuellen Maschine ein Gentoo installiert um mich näher mit diesem System zu beschäftigen. Nach der Installation bin ich direkt auf die erste Hürde gestoßen. Ich will gerne das Paket gentoolkit installieren. Hier bekomme ich folgende Fehlermeldung:

Code:
These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] app-portage/gentoolkit-0.3.0.4-r5
[blocks B      ] >=dev-lang/python-2.6[-xml] (">=dev-lang/python-2.6[-xml]" is blocking app-portage/gentoolkit-0.3.0.4-r5)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (dev-lang/python-2.7.2-r3::gentoo, installed) pulled in by
    dev-lang/python:2.7 required by @selected

  (app-portage/gentoolkit-0.3.0.4-r5::gentoo, ebuild scheduled for merge) pulled in by
    gentoolkit


Code:
emerge --info
gibt folgendes aus:

Code:
Portage 2.1.10.44 (default/linux/amd64/10.0/server, gcc-4.5.3, glibc-2.13-r4, 3.2.1-gentoo-r2 x86_64)
=================================================================
System uname: Linux-3.2.1-gentoo-r2-x86_64-Intel-R-_Core-TM-2_Quad_CPU_Q6600_@_2.40GHz-with-gentoo-2.0.3
Timestamp of tree: Sun, 05 Feb 2012 19:30:01 +0000
app-shells/bash:          4.1_p9
dev-lang/python:          2.7.2-r3, 3.1.4-r3
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.0.3
sys-apps/openrc:          0.9.8.4
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.68
sys-devel/automake:       1.11.1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.5.3-r1
sys-devel/gcc-config:     1.4.1-r1
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 3.1 (virtual/os-headers)
sys-libs/glibc:           2.13-r4
Repositories: gentoo
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/gconf /etc/gentoo-release /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=core2 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="acl amd64 berkdb bzip2 cli cracklib crypt cups cxx dri fortran gdbm gpm iconv ipv6 mmx modules mudflap multilib ncurses nls nptl nptlonly openmp pam pcre pppd readline session snmp sse sse2 ssl sysfs tcpd truetype unicode xml xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga neomagic nouveau nv r128 radeon savage sis tdfx trident vesa via vmware dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


Ich habe folgenden Post gefunden: http://forums.gentoo.org/viewtopic-p-6945044.html Aber wieso sollte ich das System neu bauen müssen wegen einer Softwareinstallation nach einer komplett neuen Installation?

Ich freu mich auf Hinweise und Erklärungen um das System besser zu verstehen :-)

VG

jUng3r


Last edited by jUng3r on Mon Feb 06, 2012 7:11 pm; edited 1 time in total
Back to top
View user's profile Send private message
Mr. Anderson
l33t
l33t


Joined: 22 Apr 2004
Posts: 756

PostPosted: Sun Feb 05, 2012 8:51 pm    Post subject: Reply with quote

Die Meldung von Portage ist etwas verwirrend. Im Wesentlichen weigert sich das gentoolkit-ebuild installiert zu werden, solange ein Python 2.6 oder neuer ohne xml-USE-Flag installiert ist oder installiert werden soll. Das Problem sollte sich lösen mit der Zeile
Code:
dev-lang/python xml

in einer Datei mit Namen /etc/portage/package.use (anlegen, falls nicht vorhanden).
Back to top
View user's profile Send private message
jUng3r
n00b
n00b


Joined: 05 Feb 2012
Posts: 5

PostPosted: Sun Feb 05, 2012 9:00 pm    Post subject: Reply with quote

Leider hat dies nicht den Erfolg gebracht. Hatte vorher schon in der make.conf das xml Flag hinzugefügt und python neu gebaut.
Back to top
View user's profile Send private message
Mr. Anderson
l33t
l33t


Joined: 22 Apr 2004
Posts: 756

PostPosted: Sun Feb 05, 2012 9:18 pm    Post subject: Reply with quote

Wie sieht denn der Befehl aus, der zu dem Fehler führt?

edit: die Ausgabe von eix -v -e python könnte auch noch hilfreich sein (app-portage/eix)
Back to top
View user's profile Send private message
jUng3r
n00b
n00b


Joined: 05 Feb 2012
Posts: 5

PostPosted: Mon Feb 06, 2012 9:10 am    Post subject: Reply with quote

Der Befehl ist
Quote:
emerge gentoolkit
. Ich werde eix installieren und dir die Ausgabe senden, wenn ich zu Hause bin :-).
Back to top
View user's profile Send private message
jUng3r
n00b
n00b


Joined: 05 Feb 2012
Posts: 5

PostPosted: Mon Feb 06, 2012 6:41 pm    Post subject: Reply with quote

Hier die Ausgabe von eix -v -e python. Wenn ich die Ausgabe richtig seh, dann ist python 2.7 ohne xml installiert. Oder seh ich dies falsch?

Code:
* dev-lang/python
     Available versions: 
        (2.4)   2.4.6
        (2.5)   2.5.4-r4
        (2.6)   2.6.6-r2 ~2.6.7-r2
        (2.7)   2.7.1-r1 2.7.2-r3
        (3.1)   3.1.3-r1 3.1.4-r3
        (3.2)   ~3.2.2
        {-berkdb bootstrap build +cxx doc elibc_uclibc examples gdbm ipv6 +ncurses +readline sqlite +ssl +threads tk +wide-unicode wininst +xml}
     Installed versions:  Version: 2.7.2-r3(2.7)
                          Date:    06:17:24 01/26/12
                          USE:     build wide-unicode -berkdb -doc -elibc_uclibc -examples -gdbm -ipv6 -ncurses -readline -sqlite -ssl -threads -tk -wininst -xml
                          Version: 3.1.4-r3(3.1)
                          Date:    12:49:08 01/26/12
                          USE:     gdbm ipv6 ncurses readline ssl threads wide-unicode xml -build -doc -elibc_uclibc -examples -sqlite -tk -wininst
     Best versions/slot:  2.4.6(2.4) 2.5.4-r4(2.5) 2.6.6-r2(2.6) 2.7.2-r3(2.7) 3.1.4-r3(3.1)
     Homepage:            http://www.python.org/
     Description:         Python is an interpreted, interactive, object-oriented programming language.
     License:             PSF-2
Back to top
View user's profile Send private message
Mr. Anderson
l33t
l33t


Joined: 22 Apr 2004
Posts: 756

PostPosted: Mon Feb 06, 2012 6:56 pm    Post subject: Reply with quote

Das siehst Du richtig. Als Du Python neu emerged hast, hast Du vermutlich nur die neueste Python-Version erwischt.

Damit solltest Du auch noch Python 2.7 erwischen:
Code:
emerge -1 python:2.7
Back to top
View user's profile Send private message
jUng3r
n00b
n00b


Joined: 05 Feb 2012
Posts: 5

PostPosted: Mon Feb 06, 2012 7:08 pm    Post subject: Reply with quote

Ich habe in package.use die Zeile
Code:
dev-lang/python-2.7 xml

hinzugefügt,
Danach ein
Code:
emerge --newuse --update python
so hat es auch funktioniert.

Ich bin von alleine darauf gekommen :-), wobei deine Variante schöner ist.

Vielen Dank für deine Hilfe.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) Diskussionsforum All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum