Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Konfiguracja uwsgi
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish)
View previous topic :: View next topic  
Author Message
eshlox
n00b
n00b


Joined: 11 Mar 2010
Posts: 13
Location: ~eshlox/public_html

PostPosted: Sat Jan 28, 2012 7:50 pm    Post subject: [SOLVED] Konfiguracja uwsgi Reply with quote

Witam.

Czy ktoś może konfigurował uwsgi pod gentoo? Przy uruchomieniu uwsgi z init.d otrzymuję:

Code:

/etc/init.d/uwsgi start
 * You are not supposed to run this script directly. Create a symlink
 * for the FastCGI application you want to run as well as a copy of the
 * configuration file and modify it appropriately like so...
 *   ln -s uwsgi /etc/init.d/uwsgi.trac
 *   cp /etc/conf.d/uwsgi /etc/conf.d/uwsgi.trac
 *   vi /etc/conf.d/uwsgi.trac
 * ERROR: uwsgi failed to start


Nigdzie nie mogę znaleźć co komunikat ma na myśli jeśli chodzi o ln -s uwsgi /etc/init.d/uwsgi.trac ;-) Jakiego pliku mam niby zrobić symlink?

Pozdrawiam.


Last edited by eshlox on Sat Jan 28, 2012 10:06 pm; edited 1 time in total
Back to top
View user's profile Send private message
SlashBeast
Moderator
Moderator


Joined: 23 May 2006
Posts: 2836

PostPosted: Sat Jan 28, 2012 8:08 pm    Post subject: Reply with quote

Nie wiem czy ten komunikat moze byc latwiejszy do zrozumienia.

tak jak net.lo masz nie wywolywac samodzielnie, masz go zlinkowac np. do net.eth0, tak uwsgi masz sobie zlinkowac do uwsgi.mojazajebistaaplikacja a nastepnie stworzyc /etc/conf.d/uwsgi.mojazajebistaaplikacja, skonfigurowac ja i odpalic z init.d uwsgi.mojazajebistaaplikacja.
_________________
BitBucket -- better-initramfs
Back to top
View user's profile Send private message
eshlox
n00b
n00b


Joined: 11 Mar 2010
Posts: 13
Location: ~eshlox/public_html

PostPosted: Sat Jan 28, 2012 10:06 pm    Post subject: Reply with quote

Fakt. Zmyliły mnie te nazwy i nie pomyślałem o nazwie uwsgi jako o skrypcie z init.d ;-/ Mogłoby być napisane ls -n /etc/init.d/uwsgi /etc/init.d/uwsgi.trac ;-)

No ale cóż. Działa. Dzięki.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum