Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
gnome-base/librsvg no se instala ... [SOLUCIONADO]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
Luciernaga
Guru
Guru


Joined: 05 Apr 2006
Posts: 378
Location: LANDETE (Cuenca)

PostPosted: Thu Jan 19, 2012 6:34 pm    Post subject: gnome-base/librsvg no se instala ... [SOLUCIONADO] Reply with quote

Me explico, después de los nuevos cambios observados en Gentoo me decido a instalar desde cero en mis máquinas (~x86 y ~x86_64) la distro y todo me fue bien hasta que quise instalar GNOME, pues no se quiere instalar la librería "gnome-base/librsvg" en ninguna de mis máquinas y me quedo ATRANCADO ahí en todas.
¿porque? ¿cómo resolverlo?

El archivo /etc/make.conf (en ~x86) es el siguiente:
CFLAGS="-O2 -march=i686 -pipe"
CXXFLAGS="${CFLAGS}"
CHOST="i686-pc-linux-gnu"
MAKEOPTS="-j2"
GENTOO_MIRRORS="ftp://darkstar.ist.utl.pt/pub/gentoo/"
SYNC="rsync://rsync3.de.gentoo.org/gentoo-portage"
USE="-qt3 -qt4 -kde gtk gtk+ gnome dvd cdr alsa nls X svg branding unicode python sqlite"
INPUT_DEVICES="evdev"
LINGUAS="es"
FEATURES="parallel-fetch"
ALSA_CARDS="emu10k1 snd-via82xx"
VIDEO_CARDS="nouveau"
ACCEPT_LICENSE="*"

El archivo /etc/make.conf (en ~x86_64) es el siguiente:
CFLAGS="-march=athlon64 -O2 -pipe"
CXXFLAGS="${CFLAGS}"
CHOST="x86_64-pc-linux-gnu"
USE="mmx sse sse2 -qt3 -qt4 -kde gtk gtk+ gnome dvd cdr alsa nls X svg dbus unicode branding nvidia python sqlite"
MAKEOPTS="-j5"
GENTOO_MIRRORS="ftp://darkstar.ist.utl.pt/pub/gentoo/"
SYNC="rsync://rsync3.de.gentoo.org/gentoo-portage"
INPUT_DEVICES="evdev"
LINGUAS="es"
FEATURES="parallel-fetch"
ALSA_CARDS="emu10k1 snd-hda-intel"
VIDEO_CARDS="nvidia"
ACCEPT_LICENSE="*"

Al parecer los resultados de los ficheros .log no se diferencian, al menos no las he detectado.
http://pastebin.com/Z6eHmzRz

http://pastebin.com/b0jQiEg6

Lo que si he visto en el .log es que no se detectaba cairo instalado y si que está instalado, incluso lo he reinstalado y nada, no consigo resolverlo.
Gracias por vuestra ayuda. Saludetes :)

PostData:
Por supuesto que ejecuté "python-updater" anteriormente.
_________________
Soy como una diminuta luciérnaga, perdido en la inmensa oscuridad del universo.


Last edited by Luciernaga on Fri Jan 20, 2012 10:41 am; edited 1 time in total
Back to top
View user's profile Send private message
esteban_conde
Veteran
Veteran


Joined: 04 Jun 2003
Posts: 1530

PostPosted: Thu Jan 19, 2012 9:18 pm    Post subject: Reply with quote

¿Que te responde a equery f cairo?.
Quote:
/usr/include/cairo
/usr/include/cairo/cairo-deprecated.h
/usr/include/cairo/cairo-features.h
/usr/include/cairo/cairo-ft.h
/usr/include/cairo/cairo-gl.h
/usr/include/cairo/cairo-gobject.h
/usr/include/cairo/cairo-pdf.h
/usr/include/cairo/cairo-ps.h
/usr/include/cairo/cairo-script-interpreter.h
/usr/include/cairo/cairo-svg.h
/usr/include/cairo/cairo-tee.h
/usr/include/cairo/cairo-version.h
/usr/include/cairo/cairo-xlib-xrender.h
/usr/include/cairo/cairo-xlib.h
/usr/include/cairo/cairo.h
esa es la parte que tienes que buscar, si no tienes /usr/include/cairo/cairo.h lo mejor es que reinstales cairo.
_________________
Saludos a tod@s, Esteban.
Back to top
View user's profile Send private message
Luciernaga
Guru
Guru


Joined: 05 Apr 2006
Posts: 378
Location: LANDETE (Cuenca)

PostPosted: Fri Jan 20, 2012 8:35 am    Post subject: Reply with quote

Hola Esteban, gracias por tu ayuda, veamos ...
La respuesta de equery f cairo es la siguiente:
http://pastebin.com/2SKQ7AQM

Lo que he hecho esta mañana aparte de lo anterior es como sigue:
Agregar el flag cairo en la variable USE= del /etc/make.conf
Emitir emerge --sync && emerge -uDNav world
El resultado es que ha instalado un paquete swig y ha reinstalado otros doce, entre ellos no se encontraba 'cairo'.
Emitido ahora emerge cairo para reinstalarlo. OK.
Emito emerge gnome y vuelve a fallar en el mismo sitio, es decir, la compilación de librsvg se trunca en el mismo lugar porque no encuentra cairo.h entre el texto que devuelve la compilación encuentro esto:
.......
In file included from <stdin>:19:0:
/var/tmp/portage/gnome-base/librsvg-2.34.2/work/librsvg-2.34.2/rsvg-cairo-render.h:32:19: error fatal: cairo.h: No existe el fichero o el directorio
compilación terminada.
Error while processing the source.
......

Comentarios:
Bueno, para empezar las fuentes son las que hay en el repositorio, es decir el núcleo 3.1.6-gentoo.
La primera sorpresa la he tenido cuando después del reinicio de la primera fase se truncaba el comando emerge --update --deep --newuse world por un problema de circunstancias redundantes ... hay que joderse ... bueno, visto el mensaje de la pantalla emito lo siguiente:
USE="-filters" emerge net-print/cups y se instala sin problemas.
USE="-cups" emerge net-print/foomatic-filters y se instala sin problemas.
emerge --update --deep --newuse world y termina su ciclo correctamente ahora.
Continuo con el proceso, se instala xorg, se configura, se ejecutan las Xs, emito startx sin problemas, pretendo instalar GNOME y ....
toma castaña, ahí estoy que no puedo continuar ...
La distro está configurada como "enrutador" sin problemas de comunicación en la red local pero el escritorio gráfico no puedo instalarlo por culpa de la librería citada.
Repito gracias por vuesttra ayuda.
:(
_________________
Soy como una diminuta luciérnaga, perdido en la inmensa oscuridad del universo.
Back to top
View user's profile Send private message
gringo
Advocate
Advocate


Joined: 27 Apr 2003
Posts: 3744

PostPosted: Fri Jan 20, 2012 10:29 am    Post subject: Reply with quote

http://forums.gentoo.org/viewtopic-t-902894-start-0.html
https://bugs.gentoo.org/show_bug.cgi?id=391213

al parecer tiene que ver con gobject-introspection y con el use introspection. Mas info en el bug.

saluetes
Back to top
View user's profile Send private message
Luciernaga
Guru
Guru


Joined: 05 Apr 2006
Posts: 378
Location: LANDETE (Cuenca)

PostPosted: Fri Jan 20, 2012 10:40 am    Post subject: Reply with quote

Confirmado ... gracias gringo

Emito lo siguiente emerge -1 gobject-introspection y se instala.
Emito ahora emerge gnome y la librería se ha instalado continuando con el resto de GNOME.

Saludetes ;)
_________________
Soy como una diminuta luciérnaga, perdido en la inmensa oscuridad del universo.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum