Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
NetworkManager avahi "failed running automake" [solved-ish]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
ottembomb
n00b
n00b


Joined: 25 Mar 2007
Posts: 15
Location: Colorado

PostPosted: Sun Jan 01, 2012 7:25 pm    Post subject: NetworkManager avahi "failed running automake" [so Reply with quote

Hello all

I'm trying to install NetworkManager and compile stops at net-dns/avahi with "failed running automake".

Firstly, I was prompted to add net/dns-avahi autoipd to my /etc/portage/package.use; however, the compilation fails with the same error message even if I remove autoipd from package.use.

Code:

ottembomb@fragtastic ~ $ emerged avahi
/usr/lib64/portage/pym/portage/package/ebuild/config.py:353: UserWarning: 'cache.metadata_overlay.database' is deprecated: /etc/portage/modules
  (user_auxdbmodule, modules_file))

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[ebuild   R    ] net-dns/avahi-0.6.30-r2  USE="autoipd* dbus gdbm gtk introspection ipv6 mono qt4 -bookmarks -doc -gtk3 -howl-compat -mdnsresponder-compat -python -test -utils" 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB

Would you like to merge these packages? [Yes/No] y

>>> Verifying ebuild manifests

>>> Emerging (1 of 1) net-dns/avahi-0.6.30-r2
 * avahi-0.6.30.tar.gz RMD160 SHA1 SHA256 size ;-) ...                         [ ok ]
>>> Unpacking source...
>>> Unpacking avahi-0.6.30.tar.gz to /var/tmp/portage/net-dns/avahi-0.6.30-r2/work
>>> Source unpacked in /var/tmp/portage/net-dns/avahi-0.6.30-r2/work
>>> Preparing source in /var/tmp/portage/net-dns/avahi-0.6.30-r2/work/avahi-0.6.30 ...
 * Applying avahi-0.6.30-optional-gtk-utils.patch ...                          [ ok ]
 * Applying avahi-0.6.x-openrc-0.9.x-init-scripts-fixes.patch ...              [ ok ]
 * Running eautoreconf in '/var/tmp/portage/net-dns/avahi-0.6.30-r2/work/avahi-0.6.30' ...
 * Running aclocal -I common ...                                               [ ok ]
 * Running libtoolize --copy --force --install --automake ...                  [ ok ]
 * Running aclocal -I common ...                                               [ ok ]
 * Running autoconf ...                                                        [ ok ]
 * Running autoheader ...                                                      [ ok ]
 * Running automake --add-missing --copy --foreign ...                         [ !! ]

 * Failed Running automake !
 *
 * Include in your bugreport the contents of:
 *
 *   /var/tmp/portage/net-dns/avahi-0.6.30-r2/temp/automake.out

 * ERROR: net-dns/avahi-0.6.30-r2 failed (prepare phase):
 *   Failed Running automake !
 *
 * Call stack:
 *     ebuild.sh, line   85:  Called src_prepare
 *   environment, line 5798:  Called eautoreconf
 *   environment, line 1623:  Called eautomake
 *   environment, line 1592:  Called autotools_run_tool 'automake' '--add-missing' '--copy' '--foreign'
 *   environment, line 1286:  Called die
 * The specific snippet of code:
 *           die "Failed Running $1 !";
 *
 * If you need support, post the output of 'emerge --info =net-dns/avahi-0.6.30-r2',
 * the complete build log and the output of 'emerge -pqv =net-dns/avahi-0.6.30-r2'.
 * The complete build log is located at '/var/tmp/portage/net-dns/avahi-0.6.30-r2/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/net-dns/avahi-0.6.30-r2/temp/environment'.
 * S: '/var/tmp/portage/net-dns/avahi-0.6.30-r2/work/avahi-0.6.30'

>>> Failed to emerge net-dns/avahi-0.6.30-r2, Log file:

>>>  '/var/tmp/portage/net-dns/avahi-0.6.30-r2/temp/build.log'

 * Messages for package net-dns/avahi-0.6.30-r2:

 * Failed Running automake !
 *
 * Include in your bugreport the contents of:
 *
 *   /var/tmp/portage/net-dns/avahi-0.6.30-r2/temp/automake.out
 * ERROR: net-dns/avahi-0.6.30-r2 failed (prepare phase):
 *   Failed Running automake !
 *
 * Call stack:
 *     ebuild.sh, line   85:  Called src_prepare
 *   environment, line 5798:  Called eautoreconf
 *   environment, line 1623:  Called eautomake
 *   environment, line 1592:  Called autotools_run_tool 'automake' '--add-missing' '--copy' '--foreign'
 *   environment, line 1286:  Called die
 * The specific snippet of code:
 *           die "Failed Running $1 !";
 *
 * If you need support, post the output of 'emerge --info =net-dns/avahi-0.6.30-r2',
 * the complete build log and the output of 'emerge -pqv =net-dns/avahi-0.6.30-r2'.
 * The complete build log is located at '/var/tmp/portage/net-dns/avahi-0.6.30-r2/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/net-dns/avahi-0.6.30-r2/temp/environment'.
 * S: '/var/tmp/portage/net-dns/avahi-0.6.30-r2/work/avahi-0.6.30'


emerge --info =net-dns/avahi-0.6.30-r2'
Code:

ottembomb@fragtastic ~ $ emerge --info =net-dns/avahi-0.6.30-r2
/usr/lib64/portage/pym/portage/package/ebuild/config.py:353: UserWarning: 'cache.metadata_overlay.database' is deprecated: /etc/portage/modules
  (user_auxdbmodule, modules_file))
Portage 2.1.10.44 (default/linux/amd64/10.0/desktop, gcc-4.5.3, glibc-2.14.1-r2, 3.1.6-gentoo x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-3.1.6-gentoo-x86_64-Intel-R-_Core-TM-2_Quad_CPU_Q9650_@_3.00GHz-with-gentoo-2.1
Timestamp of tree: Sun, 01 Jan 2012 18:15:01 +0000
app-shells/bash:          4.2_p20
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.6.7-r2, 2.7.2-r3, 3.2.2
dev-util/cmake:           2.8.6-r4
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1
sys-apps/openrc:          0.9.7
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.2
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.3-r2
sys-devel/gcc-config:     1.5-r2
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.1 (virtual/os-headers)
sys-libs/glibc:           2.14.1-r2
Repositories: gentoo multimedia
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=core2 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--quiet-build=n"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="ftp://chi-10g-1-mirror.fastsoft.net/pub/linux/gentoo/gentoo-distfiles/ http://gentoo.mirrors.hoobly.com/ http://gentoo.netnitco.net http://gentoo.mirrors.pair.com/"
LANG="C"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/multimedia"
SYNC="rsync://rsync.us.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 bash-completion berkdb bluetooth branding bzip2 cairo cdda cddb cdr cli consolekit cracklib crypt css cups cxx dbus dga dri dts dvd dvdr emboss encode exif fam ffmpeg firefox flac fortran gdbm gdu gif gphoto2 gpm gstreamer gtk hddtemp iconv ios ipod ipv6 java jpeg lcms ldap libnotify lm_sensors mad mmx mng modules mp3 mp4 mpeg mpi mplayer mtp mudflap multilib ncurses nls nptl nptlonly nsplugin nvidia ogg opengl openmp pam pango pcre pdf png policykit posix ppds pppd qt3support qt4 raw rdesktop readline samba sdl session smp snmp sound spell sse sse2 ssl startup-notification svg symlink sysfs tcpd tiff truetype udev unicode usb vim-syntax vorbis x264 xcb xinerama xml xorg xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="canon" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

=================================================================
                        Package Settings
=================================================================

net-dns/avahi-0.6.30-r2 was built with the following:
USE="dbus gdbm gtk introspection ipv6 mono (multilib) qt4 -autoipd -bookmarks -doc -gtk3 -howl-compat -mdnsresponder-compat -python -test -utils"


emerge -pqv =net-dns/avahi-0.6.30-r2
Code:

ottembomb@fragtastic ~ $ emerge -pqv =net-dns/avahi-0.6.30-r2
/usr/lib64/portage/pym/portage/package/ebuild/config.py:353: UserWarning: 'cache.metadata_overlay.database' is deprecated: /etc/portage/modules
  (user_auxdbmodule, modules_file))
[ebuild   R   ] net-dns/avahi-0.6.30-r2  USE="autoipd* dbus gdbm gtk introspection ipv6 mono qt4 -bookmarks -doc -gtk3 -howl-compat -mdnsresponder-compat -python -test -utils"


Code:

ottembomb@fragtastic ~ $ cat /var/tmp/portage/net-dns/avahi-0.6.30-r2/temp/build.log
 * Package:    net-dns/avahi-0.6.30-r2
 * Repository: gentoo
 * Maintainer: swegener@gentoo.org
 * USE:        amd64 autoipd dbus elibc_glibc gdbm gtk introspection ipv6 kernel_linux mono multilib qt4 userland_GNU
 * FEATURES:   sandbox
>>> Unpacking source...
>>> Unpacking avahi-0.6.30.tar.gz to /var/tmp/portage/net-dns/avahi-0.6.30-r2/work
>>> Source unpacked in /var/tmp/portage/net-dns/avahi-0.6.30-r2/work
>>> Preparing source in /var/tmp/portage/net-dns/avahi-0.6.30-r2/work/avahi-0.6.30 ...
 * Applying avahi-0.6.30-optional-gtk-utils.patch ...                          [ ok ]
 * Applying avahi-0.6.x-openrc-0.9.x-init-scripts-fixes.patch ...              [ ok ]
 * Running eautoreconf in '/var/tmp/portage/net-dns/avahi-0.6.30-r2/work/avahi-0.6.30' ...
 * Running aclocal -I common ...                                               [ ok ]
 * Running libtoolize --copy --force --install --automake ...                  [ ok ]
 * Running aclocal -I common ...                                               [ ok ]
 * Running autoconf ...                                                        [ ok ]
 * Running autoheader ...                                                      [ ok ]
 * Running automake --add-missing --copy --foreign ...                         [ !! ]

 * Failed Running automake !
 *
 * Include in your bugreport the contents of:
 *
 *   /var/tmp/portage/net-dns/avahi-0.6.30-r2/temp/automake.out

 * ERROR: net-dns/avahi-0.6.30-r2 failed (prepare phase):
 *   Failed Running automake !
 *
 * Call stack:
 *     ebuild.sh, line   85:  Called src_prepare
 *   environment, line 5798:  Called eautoreconf
 *   environment, line 1623:  Called eautomake
 *   environment, line 1592:  Called autotools_run_tool 'automake' '--add-missing' '--copy' '--foreign'
 *   environment, line 1286:  Called die
 * The specific snippet of code:
 *           die "Failed Running $1 !";
 *
 * If you need support, post the output of 'emerge --info =net-dns/avahi-0.6.30-r2',
 * the complete build log and the output of 'emerge -pqv =net-dns/avahi-0.6.30-r2'.
 * The complete build log is located at '/var/tmp/portage/net-dns/avahi-0.6.30-r2/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/net-dns/avahi-0.6.30-r2/temp/environment'.
 * S: '/var/tmp/portage/net-dns/avahi-0.6.30-r2/work/avahi-0.6.30'


/var/tmp/portage/net-dns/avahi-0.6.30-r2/temp/environment
http://pastebin.com/76h8mbGa

any help would be greatly appreciated.

*EDIT* 01/01/2012

downgrading to net-dns/avahi-0.6.29-r1 allows me to successfully emerge.
_________________
beware the temptation to imagine yourself treated unfairly
Back to top
View user's profile Send private message
potuz
Apprentice
Apprentice


Joined: 30 Jan 2010
Posts: 218

PostPosted: Fri Jan 06, 2012 10:37 pm    Post subject: Reply with quote

This seems to be the bug patched in
http://patches.openembedded.org/patch/17793/

it seems we'll have to patch ourselves, wait, or downgrade.

I wouldn't call this thread as SOLVED though
Back to top
View user's profile Send private message
Well.Heeled.Man
n00b
n00b


Joined: 25 Aug 2011
Posts: 19

PostPosted: Mon Apr 23, 2012 5:35 pm    Post subject: Reply with quote

This problem still exists if you are running ~Arch. Downgrade Automake to 1.11.2 and Avahi will install fine. The Avahi patches are a little behind the Automake version, although I have had this problem with Automake before. Seems it may be the culprit.
Back to top
View user's profile Send private message
BrainMan
n00b
n00b


Joined: 12 Nov 2007
Posts: 12
Location: Hammerfest, Norway

PostPosted: Mon Sep 24, 2012 7:03 pm    Post subject: Reply with quote

I didn't want to downgrade automake, so I tried emerging avahi-0.6.30-r3. That also did the trick. :-)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum