Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
fstab: noatime is unregarded for rootfs
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on AMD64
View previous topic :: View next topic  
Author Message
seVes
n00b
n00b


Joined: 06 Jan 2011
Posts: 42

PostPosted: Wed Dec 07, 2011 10:31 pm    Post subject: fstab: noatime is unregarded for rootfs Reply with quote

hey!

i've got some troubles with my fstab.

I have a SSD and optimized my system for using that. Everthing succeeded, except mounting my rootfs ( / ) with noatime.

My /etc/fstab:
Quote:
edge tmp # cat /etc/fstab
# /etc/fstab: static file system information.
#
# <fs> <mountpoint> <type> <opts> <dump/pass>

/dev/sda1 / ext4 data=writeback,noatime 0 0
#...


The sda1 is always mountet with relatime:
Quote:
edge tmp # mount
rootfs on / type rootfs (rw)
...
/dev/root on / type ext4 (rw,relatime,user_xattr,barrier=1,data=writeback)
edge tmp # cat /proc/mounts
rootfs / rootfs rw 0 0
/dev/root / ext4 rw,relatime,user_xattr,barrier=1,data=writeback 0 0
...


Have tried setting the "noatime" with tune2fs, but it says:
Quote:
edge tmp # tune2fs -o noatime /dev/sda1
tune2fs 1.41.14 (22-Dec-2010)
Invalid mount option set: noatime
edge tmp # tune2fs -O noatime /dev/sda1
tune2fs 1.41.14 (22-Dec-2010)
Invalid filesystem option set: noatime


Whats wrong? How can i fix this? Is it possible?

Kind regards
_________________
Alex / seVes
Back to top
View user's profile Send private message
Veldrin
Veteran
Veteran


Joined: 27 Jul 2004
Posts: 1942
Location: Zurich, Switzerland

PostPosted: Wed Dec 07, 2011 11:54 pm    Post subject: Reply with quote

yes it is:
just add rootflags=noatime to you kernel line in grub.

if you are using genkernel, use real_rootflags=noatime

V.
_________________
read the portage output!
If my answer is too concise, ask for an explanation.
Back to top
View user's profile Send private message
seVes
n00b
n00b


Joined: 06 Jan 2011
Posts: 42

PostPosted: Thu Dec 08, 2011 2:19 pm    Post subject: Reply with quote

Hey guy!

This doesn't work for me.

After adding rootflags=noatime to cmdline in menu.lst, i got a booterror on startup:
Code:
REISERFS warning (device sda1): super-6502 reiserfs_getopt: unknown mount option "noatime"
EXT4-fs (sda1): Unrecognized mount option "noatime" or missing value


Any ideas?
_________________
Alex / seVes
Back to top
View user's profile Send private message
Veldrin
Veteran
Veteran


Joined: 27 Jul 2004
Posts: 1942
Location: Zurich, Switzerland

PostPosted: Sat Dec 10, 2011 10:01 am    Post subject: Reply with quote

hmm - can you try something else.

close all not necessary programs before proceeding. this might end up in a lock up or unresponsive system.

run mount -o remount,noatime / from you running system.
This should remount root with the noatime flag.

V.
_________________
read the portage output!
If my answer is too concise, ask for an explanation.
Back to top
View user's profile Send private message
seVes
n00b
n00b


Joined: 06 Jan 2011
Posts: 42

PostPosted: Tue Dec 13, 2011 4:10 pm    Post subject: Reply with quote

Hey...

mount -o remount,noatime works, everthing else not. Run tune2fs in a live-system for /dev/sda1 or something like else doesn't work.

Other ideas? Would like to fix it...
_________________
Alex / seVes
Back to top
View user's profile Send private message
Veldrin
Veteran
Veteran


Joined: 27 Jul 2004
Posts: 1942
Location: Zurich, Switzerland

PostPosted: Wed Dec 14, 2011 1:04 am    Post subject: Reply with quote

noatime is a mount options, not fs option. therefore tune2fs will not help much.

can you post your grub config (menu.lst or grub.cfg depending on version)?
maybe rootflags=noatime is not enough, and rootfstype=ext4 needs to be added too

V.

mine for reference (though i do neither use ext4 not noatime...)
Code:
menuentry "3.1.4-gentoo-1 - Sneaky Weasel" --class gentoo --class gnu-linux --class gnu --class os {
        load_video
        insmod gzio
        insmod part_gpt
        insmod btrfs
        set root='(/dev/sdc,gpt3)'
        search --no-floppy --fs-uuid --set=root a89fc4fb-4dd8-49c3-a83e-ef9f9936df02
        linux /boot/linux-3.1.4-gentoo-1 ro real_root=/dev/sdc3 crypt_swap=/dev/sdc2 swap_key=/gentoo/root/gswap.gpg swap_keydev=/dev/sdc3 resume=/dev/mapper/swap real_rootflags=subvol=gentoo,relatime real_rootfstype=btrfs acpi=on mce vbe resume scsi_mod.scan=sync
        initrd /boot/initrd-3.1.4-gentoo-1
}

Code:
root@tijakool ~ # mount
rootfs on / type rootfs (rw)
...
/dev/sdc3 on / type btrfs (rw,relatime,nospace_cache,autodefrag)
...

_________________
read the portage output!
If my answer is too concise, ask for an explanation.
Back to top
View user's profile Send private message
seVes
n00b
n00b


Joined: 06 Jan 2011
Posts: 42

PostPosted: Wed Dec 14, 2011 9:28 pm    Post subject: Reply with quote

Here it are...

Code:
edge alex # cat /boot/grub/menu.lst
default 0
fallback 1
timeout 5
splashimage (hd0,0)/boot/grub/lenovo.xpm.gz

title Gentoo - 3.1.5-gentoo (x11)
root (hd0,0)
kernel /boot/kernel-3.1.5-gentoo root=/dev/sda1 rw init 5 elevator=noop

title Gentoo - 3.1.5-gentoo (terminal)
root (hd0,0)
kernel /boot/kernel-3.1.5-gentoo root=/dev/sda1 rw init 3 elevator=noop nousb

_________________
Alex / seVes
Back to top
View user's profile Send private message
mackrhea786
n00b
n00b


Joined: 04 Feb 2013
Posts: 1

PostPosted: Mon Feb 04, 2013 8:21 am    Post subject: Reply with quote

Veldrin wrote:
yes it is:
just add rootflags=noatime to you kernel line in grub.

if you are using genkernel, use real_rootflags=noatime

V.





yes its right answer. i am also face kernel regarding many problem but it is helpful.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on AMD64 All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum