Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problem z instalacją kde
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish) Instalacja i sprzęt
View previous topic :: View next topic  
Author Message
qdlacz
n00b
n00b


Joined: 04 Jan 2005
Posts: 63
Location: Poland Białystok

PostPosted: Wed Nov 30, 2011 9:31 am    Post subject: Problem z instalacją kde Reply with quote

Witam

mam problem z instalacją kde-meta

robię emerge -pv kde-meta

i na końcu dostaję takie coś

Code:
!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

media-libs/libpng:0

  (media-libs/libpng-1.5.6::gentoo, ebuild scheduled for merge) pulled in by
    >=media-libs/libpng-1.5:0 required by (media-libs/gd-2.0.35-r3::gentoo, ebuild scheduled for merge)

  (media-libs/libpng-1.4.5::gentoo, installed) pulled in by
    =media-libs/libpng-1.4* required by (dev-java/icedtea-bin-1.9.7::gentoo, installed)

x11-libs/gtk+:2

  (x11-libs/gtk+-2.22.1-r1::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (x11-libs/gtk+-2.24.5-r1::gentoo, ebuild scheduled for merge) pulled in by
    >=x11-libs/gtk+-2.20.1:2[introspection?] required by (app-text/poppler-0.16.7::gentoo, ebuild scheduled for merge)

x11-libs/qt-gui:4

  (x11-libs/qt-gui-4.7.2::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (x11-libs/qt-gui-4.7.2::gentoo, ebuild scheduled for merge) pulled in by
    >=x11-libs/qt-gui-4.4.0:4[mng] required by (kde-base/kopete-4.6.5::gentoo, ebuild scheduled for merge)

app-text/poppler:0

  (app-text/poppler-0.16.7::gentoo, ebuild scheduled for merge) pulled in by
    >=app-text/poppler-0.12.3-r3[lcms,qt4,-exceptions(-)] required by (kde-base/okular-4.6.5::gentoo, ebuild scheduled for merge)

  (app-text/poppler-0.14.5-r1::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.

_________________
NOBODY expects the Spanish Inquisition!
Back to top
View user's profile Send private message
lsdudi
Guru
Guru


Joined: 12 Nov 2006
Posts: 389
Location: Warsaw

PostPosted: Wed Nov 30, 2011 6:02 pm    Post subject: Reply with quote

Code:

#eselect news list
News items:
  [1]   read    2009-04-18  Generation 1 Java Setup Deprecated
  [2]   read    2009-07-02  kdeprefix and monolithic ebuilds issues
  [3]   read    2009-07-12  xorg-x11-7.4 and xorg-server-1.5 kernel support
  [4]   read    2010-03-23  New desktop subprofiles for GNOME and KDE
  [5]   read    2010-03-25  Python 3.1
  [6]   read    2010-08-01  --as-needed enabled in default profiles
  [7]   read    2010-10-22  Perl 5.12 upgrade procedure
  [8]   read    2011-05-22  Removal of kdeprefix support
  [9]   read    2011-08-28  Mesa r600 driver now defaults to gallium
  [10]  read    2011-10-15  Upgrade to libpng15

Code:

#select news read  10
2011-10-15-libpng15
  Title                     Upgrade to libpng15
  Author                    Samuli Suominen <ssuominen@gentoo.org>
  Posted                    2011-10-15
  Revision                  1

After upgrading from libpng14 to libpng15 it's important that you rebuild
cairo and gdk-pixbuf as soon as possible if they are installed.

Then you can proceed with rebuilding the rest of the software against the new
library:

# revdep-rebuild --library libpng14.so.14 -- --keep-going

Note: It might be necessary to run the previous command more than once.

If you find packages not building with the message "ld: cannot find -lpng14",
they are likely caused by broken libtool archives (.la) in your system.

You can identify those files with following one-liner:

# find /usr/ -name '*.la' -exec grep png14 {} +

Once you have identified the broken files, you can either delete them,
edit them in place and replace png14 with png15, or re-emerge the packages
they belong to.

More information and help is available at the following forum post:

http://forums.gentoo.org/viewtopic-t-894950.html



reszta to konflikty flag :)

Code:
USE=''introspection mng lcms qt4 exceptions' emerge kde-meta -vp

tylko po co ci meta?
_________________
RLU#416942
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish) Instalacja i sprzęt All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum