Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
perl: warning: Setting locale failed.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
Evilguru
Guru
Guru


Joined: 16 Aug 2005
Posts: 380
Location: England

PostPosted: Wed Nov 16, 2011 12:00 pm    Post subject: perl: warning: Setting locale failed. Reply with quote

Hello,

When running perl applications I often get a message informing me that:
Code:

perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = "",
        LC_ALL = (unset),
        LANG = "en_GB"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").


I am completely stumped by what is causing it:
Code:

fluorine ~ # locale
LANG=en_GB.UTF-8
LC_CTYPE="en_GB.UTF-8"
LC_NUMERIC="en_GB.UTF-8"
LC_TIME="en_GB.UTF-8"
LC_COLLATE="en_GB.UTF-8"
LC_MONETARY="en_GB.UTF-8"
LC_MESSAGES="en_GB.UTF-8"
LC_PAPER="en_GB.UTF-8"
LC_NAME="en_GB.UTF-8"
LC_ADDRESS="en_GB.UTF-8"
LC_TELEPHONE="en_GB.UTF-8"
LC_MEASUREMENT="en_GB.UTF-8"
LC_IDENTIFICATION="en_GB.UTF-8"
LC_ALL=

Code:

fluorine ~ # cat /etc/locale.gen
en_GB.UTF-8 UTF-8


I have re-generated the locales, been through the localization guide and still have no idea what is the matter. Can anyone help me?

Regards, Freddie.
Back to top
View user's profile Send private message
turtles
Veteran
Veteran


Joined: 31 Dec 2004
Posts: 1253

PostPosted: Thu Nov 24, 2011 7:10 am    Post subject: Reply with quote

can you post /etc/env.d/02locale ?
_________________
Donate to Gentoo
Back to top
View user's profile Send private message
drizzt
Guru
Guru


Joined: 21 Jul 2002
Posts: 337

PostPosted: Thu Nov 08, 2012 3:38 pm    Post subject: Reply with quote

Picking up this old thread since I run into the same problem today installing a new gentoo system.

My 02locale:
Code:
LANG="de_DE.UTF-8"
GDM_LANG="de_DE.UTF-8"
# For OpenOffice.org
LANGUAGE="de_DE:de"


On a second system these settings run just fine.

Update
I resolved my problem. It was caused by a typo in my locale.gen file. Locale de_DE.UTF-8 was not generated.
_________________
People don't have to earn my respect. I offer my respect to them, but be careful to lose my respect...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum