Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
app-office/libreoffice" is blocking app..libreoffice-bin ??
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
padoor
Advocate
Advocate


Joined: 30 Dec 2005
Posts: 4055
Location: india

PostPosted: Sun Nov 13, 2011 2:27 am    Post subject: app-office/libreoffice" is blocking app..libreoffice-bi Reply with quote

Code:
localtux ramaswamy # emerge -DNuav world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] sys-fs/dosfstools-3.0.12 [3.0.11] 81 kB
[ebuild  N     ] dev-perl/Archive-Zip-1.300.0  193 kB
[ebuild  N     ] dev-util/mdds-0.5.3-r1  90 kB
[ebuild     U  ] sys-apps/logwatch-7.4.0 [7.3.7_pre20100217] 288 kB
[ebuild  N     ] virtual/ooo-0  0 kB
[ebuild  N     ] app-office/libreoffice-3.4.4.2-r1  USE="branding gnome gtk vba (-aqua) -binfilter -custom-cflags -dbus -debug -eds -graphite -gstreamer -java -jemalloc -kde (-kdeenablefinal) -mysql -nsplugin -odk -opengl -pdfimport -python -templates -test -webdav" LINGUAS="-de -en_GB -en_ZA -es -fr -hu -it" 240,193 kB
[ebuild     U  ] app-office/libreoffice-l10n-3.4.4-r1 [3.4.4] USE="-offlinehelp -templates%" LINGUAS="en -af -ar -as -ast -be -bg -bn -bo -br -brx -bs -ca -ca_XV -cs -cy -da -de -dgo -dz -el -en_GB -en_ZA -eo -es -et -eu -fa -fi -fr -ga -gd -gl -gu -he -hi -hr -hu -id -is -it -ja -ka -kk -km -kn -ko -kok -ks -ku -lo -lt -lv -mai -mk -ml -mn -mni -mr -my -nb -ne -nl -nn -nr -nso -oc -om -or -pa_IN -pl -pt -pt_BR -ro -ru -rw -sa_IN -sat -sd -sh -si -sk -sl -sq -sr -ss -st -sv -sw_TZ -ta -te -tg -th -tn -tr -ts -ug -uk -uz -ve -vi -xh -zh_CN -zh_TW -zu" 0 kB
[ebuild     U  ] app-text/calibre-0.8.26 [0.8.25] 36,900 kB
[blocks B      ] app-office/libreoffice-bin ("app-office/libreoffice-bin" is blocking app-office/libreoffice-3.4.4.2-r1)
[blocks B      ] app-office/libreoffice ("app-office/libreoffice" is blocking app-office/libreoffice-bin-3.4.3.2-r1)

Total: 8 packages (4 upgrades, 4 new), Size of downloads: 277,743 kB
Conflict: 2 blocks (2 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (app-office/libreoffice-3.4.4.2-r1::gentoo, ebuild scheduled for merge) pulled in by
    >=app-office/libreoffice-3.4.4.2-r1 required by (app-office/libreoffice-l10n-3.4.4-r1::gentoo, ebuild scheduled for merge)

  (app-office/libreoffice-bin-3.4.3.2-r1::gentoo, installed) pulled in by
    app-office/libreoffice-bin required by @selected
    app-office/libreoffice-bin required by (virtual/ooo-0::gentoo, ebuild scheduled for merge)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


!!! The following installed packages are masked:
- kde-base/oxygen-icons-4.6.5::gentoo (masked by: package.mask)
- net-p2p/ktorrent-2.2.8-r2::kde-sunset (masked by: package.mask)
- app-cdr/k3b-1.0.5-r6::kde-sunset (masked by: package.mask)
- net-libs/webkit-gtk-1.4.2-r200::gentoo (masked by: package.mask)
- kde-base/kde-env-4.6.5::gentoo (masked by: package.mask)
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


when i have installed libreoffice-bin why it looks for libreoffice?
i am trying unmerging libreoffice-bin to overcome the blocks
_________________
reach out a little bit more to catch it (DON'T BELIEVE the advocate part under my user name)
Back to top
View user's profile Send private message
Chiitoo
l33t
l33t


Joined: 28 Feb 2010
Posts: 913
Location: Here and Away Again

PostPosted: Sun Nov 13, 2011 2:47 am    Post subject: Reply with quote

Did you try to simply emerge one of them at a time?

Referring to

Code:
 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

it would be what I would try first.
Ultimately, unmerging libreoffice-bin as you mention would likely work just as well. ^^


Edit:

Oh, reading it more, I noticed the app-office/libreoffice-3.4.4.2-r1 is actually new, that is being pulled in by the localisation package, app-office/libreoffice-l10n and it also wants to update the app-office/libreoffice-bin so that's where the issues arise.
_________________
Kind Regards,
~ The Noob Unlimited ~

Sore wa sore, kore wa kore.
Back to top
View user's profile Send private message
padoor
Advocate
Advocate


Joined: 30 Dec 2005
Posts: 4055
Location: india

PostPosted: Sun Nov 13, 2011 3:04 am    Post subject: Reply with quote

app-office/libreoffice-l10n and libreoffice-bin both i unmerged.
then update proceeds without any libreoffice
but
Code:
localtux ramaswamy # emerge -av libreoffice-bin

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] dev-util/mdds-0.5.3-r1  90 kB
[ebuild  N     ] dev-perl/Archive-Zip-1.300.0  193 kB
[ebuild  N     ] app-office/libreoffice-bin-3.4.3.2-r1  USE="gnome (-aqua) -java -kde (-kdeenablefinal)" 0 kB
[ebuild  N     ] virtual/ooo-0  0 kB
[ebuild  N     ] app-office/libreoffice-3.4.4.2-r1  USE="branding gnome gtk vba (-aqua) -binfilter -custom-cflags -dbus -debug -eds -graphite -gstreamer -java -jemalloc -kde (-kdeenablefinal) -mysql -nsplugin -odk -opengl -pdfimport -python -templates -test -webdav" LINGUAS="-de -en_GB -en_ZA -es -fr -hu -it" 240,193 kB
[ebuild  N     ] app-office/libreoffice-l10n-3.4.4-r1  USE="-offlinehelp -templates" LINGUAS="en -af -ar -as -ast -be -bg -bn -bo -br -brx -bs -ca -ca_XV -cs -cy -da -de -dgo -dz -el -en_GB -en_ZA -eo -es -et -eu -fa -fi -fr -ga -gd -gl -gu -he -hi -hr -hu -id -is -it -ja -ka -kk -km -kn -ko -kok -ks -ku -lo -lt -lv -mai -mk -ml -mn -mni -mr -my -nb -ne -nl -nn -nr -nso -oc -om -or -pa_IN -pl -pt -pt_BR -ro -ru -rw -sa_IN -sat -sd -sh -si -sk -sl -sq -sr -ss -st -sv -sw_TZ -ta -te -tg -th -tn -tr -ts -ug -uk -uz -ve -vi -xh -zh_CN -zh_TW -zu" 0 kB
[blocks B      ] app-office/libreoffice-bin ("app-office/libreoffice-bin" is blocking app-office/libreoffice-3.4.4.2-r1)
[blocks B      ] app-office/libreoffice ("app-office/libreoffice" is blocking app-office/libreoffice-bin-3.4.3.2-r1)

Total: 6 packages (6 new), Size of downloads: 240,476 kB
Conflict: 2 blocks (2 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (app-office/libreoffice-3.4.4.2-r1::gentoo, ebuild scheduled for merge) pulled in by
    >=app-office/libreoffice-3.4.4.2-r1 required by (app-office/libreoffice-l10n-3.4.4-r1::gentoo, ebuild scheduled for merge)

  (app-office/libreoffice-bin-3.4.3.2-r1::gentoo, ebuild scheduled for merge) pulled in by
    libreoffice-bin
    app-office/libreoffice-bin required by (virtual/ooo-0::gentoo, ebuild scheduled for merge)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked

localtux ramaswamy #                                       


now what i can block ?
_________________
reach out a little bit more to catch it (DON'T BELIEVE the advocate part under my user name)
Back to top
View user's profile Send private message
Chiitoo
l33t
l33t


Joined: 28 Feb 2010
Posts: 913
Location: Here and Away Again

PostPosted: Sun Nov 13, 2011 3:34 am    Post subject: Reply with quote

Alright, I think the version of libreoffice-bin you are trying to emerge does not play well with that version of the localisation package. I'm not sure why it wants to pull in app-office/libreoffice-3.4.4.2-r1 but either way, if you mask higher versions than app-office/libreoffice-l10n-3.4.3-r3 I think you should be fine. That, or wait until the newer version of libreoffice-bin grows into the tree.

Really not sure, but that is how it seems to me at this time.
_________________
Kind Regards,
~ The Noob Unlimited ~

Sore wa sore, kore wa kore.
Back to top
View user's profile Send private message
padoor
Advocate
Advocate


Joined: 30 Dec 2005
Posts: 4055
Location: india

PostPosted: Sun Nov 13, 2011 4:06 am    Post subject: Reply with quote

i masked the app-office/libreoffice-l10n-3.4.4-r1 and libreoffice with package.mask
then it merged libreoffice-bin and libreoffice-l10n despite the mask
Code:
[I] app-office/libreoffice-bin
     Available versions:  3.3.4!s (~)3.4.3-r2!s (~)3.4.3.2-r1!s!t {aqua elibc_FreeBSD gnome java kde kdeenablefinal linguas_af linguas_ar linguas_as linguas_ast linguas_be_BY linguas_bg linguas_bn linguas_bo linguas_br linguas_brx linguas_bs linguas_ca linguas_ca_XV linguas_cs linguas_cy linguas_da linguas_de linguas_dgo linguas_dz linguas_el linguas_en linguas_en_GB linguas_en_ZA linguas_eo linguas_es linguas_et linguas_eu linguas_fa linguas_fi linguas_fr linguas_ga linguas_gl linguas_gu linguas_he linguas_hi linguas_hr linguas_hu linguas_id linguas_is linguas_it linguas_ja linguas_ka linguas_kk linguas_km linguas_kn linguas_ko linguas_kok linguas_ks linguas_ku linguas_lo linguas_lt linguas_lv linguas_mai linguas_mk linguas_ml linguas_mn linguas_mni linguas_mr linguas_my linguas_nb linguas_ne linguas_nl linguas_nn linguas_nr linguas_ns linguas_oc linguas_om linguas_or linguas_pa_IN linguas_pl linguas_pt linguas_pt_BR linguas_ro linguas_ru linguas_rw linguas_sa_IN linguas_sat linguas_sd linguas_sh linguas_si linguas_sk linguas_sl linguas_sq linguas_sr linguas_ss linguas_st linguas_sv linguas_sw_TZ linguas_ta linguas_te linguas_tg linguas_th linguas_tn linguas_tr linguas_ts linguas_ug linguas_uk linguas_uz linguas_ve linguas_vi linguas_xh linguas_zh_CN linguas_zh_TW linguas_zu offlinehelp}
     Installed versions:  3.4.3.2-r1!s!t(09:05:21 AM 11/13/2011)(gnome -aqua -elibc_FreeBSD -java -kde -kdeenablefinal)
     Homepage:            http://www.libreoffice.org
     Description:         LibreOffice, a full office productivity suite. Binary package

[I] app-office/libreoffice-l10n
     Available versions:  (~)3.4.3-r3!s (~)3.4.4!s [m](~)3.4.4-r1!s **9999-r1!s {linguas_af linguas_ar linguas_as linguas_ast linguas_be linguas_bg linguas_bn linguas_bo linguas_br linguas_brx linguas_bs linguas_ca linguas_ca_XV linguas_cs linguas_cy linguas_da linguas_de linguas_dgo linguas_dz linguas_el linguas_en linguas_en_GB linguas_en_ZA linguas_eo linguas_es linguas_et linguas_eu linguas_fa linguas_fi linguas_fr linguas_ga linguas_gd linguas_gl linguas_gu linguas_he linguas_hi linguas_hr linguas_hu linguas_id linguas_is linguas_it linguas_ja linguas_ka linguas_kk linguas_km linguas_kn linguas_ko linguas_kok linguas_ks linguas_ku linguas_lo linguas_lt linguas_lv linguas_mai linguas_mk linguas_ml linguas_mn linguas_mni linguas_mr linguas_my linguas_nb linguas_ne linguas_nl linguas_nn linguas_nr linguas_nso linguas_oc linguas_om linguas_or linguas_pa_IN linguas_pl linguas_pt linguas_pt_BR linguas_ro linguas_ru linguas_rw linguas_sa_IN linguas_sat linguas_sd linguas_sh linguas_si linguas_sk linguas_sl linguas_sq linguas_sr linguas_ss linguas_st linguas_sv linguas_sw_TZ linguas_ta linguas_te linguas_tg linguas_th linguas_tn linguas_tr linguas_ts linguas_ug linguas_uk linguas_uz linguas_ve linguas_vi linguas_xh linguas_zh_CN linguas_zh_TW linguas_zu offlinehelp templates}
     Installed versions:  3.4.4!s(08:54:36 AM 11/13/2011)(linguas_en -linguas_af -linguas_ar -linguas_as -linguas_ast -linguas_be -linguas_bg -linguas_bn -linguas_bo -linguas_br -linguas_brx -linguas_bs -linguas_ca -linguas_ca_XV -linguas_cs -linguas_cy -linguas_da -linguas_de -linguas_dgo -linguas_dz -linguas_el -linguas_en_GB -linguas_en_ZA -linguas_eo -linguas_es -linguas_et -linguas_eu -linguas_fa -linguas_fi -linguas_fr -linguas_ga -linguas_gd -linguas_gl -linguas_gu -linguas_he -linguas_hi -linguas_hr -linguas_hu -linguas_id -linguas_is -linguas_it -linguas_ja -linguas_ka -linguas_kk -linguas_km -linguas_kn -linguas_ko -li


only for LINGUAS= en the whole language pack is installed with all -flags !
_________________
reach out a little bit more to catch it (DON'T BELIEVE the advocate part under my user name)
Back to top
View user's profile Send private message
Chiitoo
l33t
l33t


Joined: 28 Feb 2010
Posts: 913
Location: Here and Away Again

PostPosted: Sun Nov 13, 2011 4:38 am    Post subject: Reply with quote

I have never played with this package before, sorry for that, but testing it right now, it would seem to me that the -bin package comes with all the languages, but if you pull in the l10n package with that, only those that are set in your make.conf, package.use, or in the command-line are going to be used.

How did you have it before?
Perhaps in

Code:
/etc/portage/package.use

with a specific libreoffice-l10n version number and thus not use for this one?
Either way, you should be able to enable the languages that way at least, as USE flags like so:

Code:
app-office/libreoffice-l10n linguas_ja

_________________
Kind Regards,
~ The Noob Unlimited ~

Sore wa sore, kore wa kore.
Back to top
View user's profile Send private message
ulenrich
Veteran
Veteran


Joined: 10 Oct 2010
Posts: 1167

PostPosted: Sun Nov 13, 2011 4:15 pm    Post subject: Reply with quote

This should be solved now. Error was, the ebuild of libreoffice-l10n was looking for a just too high libreoffice.

That resulted in trying to install libreoffice-bin, which is wrong doing with libreoffice ....
_________________
fun2gen2
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum