Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Nieoczekiwane zakończenie pracy revdep-rebuild
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish) Polish OTW
View previous topic :: View next topic  
Author Message
nUmer_inaczej
Tux's lil' helper
Tux's lil' helper


Joined: 24 Apr 2007
Posts: 132
Location: Bydgoszcz

PostPosted: Sat Nov 05, 2011 6:04 pm    Post subject: [SOLVED] Nieoczekiwane zakończenie pracy revdep-rebuild Reply with quote

Witam serdecznie!

Najnowsza stabilna opera z portage każdorazowo podczas wyłączania jej po zakończeniu pracy wyrzuca komunikat o błędzie.
Z tego powodu próbowałem użyć revdep-rebuild. Ten jednak również kończy działanie niezgodnie z mym oczekiwaniem, co
przedstawia się jak poniżej:
Code:

gentoo numer # revdep-rebuild -i
 * Configuring search environment for revdep-rebuild

 * Checking reverse dependencies
 * Packages containing binaries and libraries broken by a package update
 * will be emerged.

 * Collecting system binaries and libraries
 * Generated new 1_files.rr
 * Collecting complete LD_LIBRARY_PATH
 * Generated new 2_ldpath.rr
 * Checking dynamic linking consistency
[ 67% ]  *   broken /usr/lib64/libgtksourceview-1.0.la (requires -lpng14)
[ 100% ]                 
 * Generated new 3_broken.rr
 * Assigning files to packages
 *   /usr/lib64/libgtksourceview-1.0.la -> x11-libs/gtksourceview
 * Generated new 4_raw.rr and 4_owners.rr
 * Cleaning list of packages to rebuild
 * Generated new 4_pkgs.rr
 * Assigning packages to ebuilds
 * Generated new 4_ebuilds.rr
 * Evaluating package order
 * Portage could not find any version of the following packages it could build:
 * x11-libs/gtksourceview:1.0
 * (Perhaps they are masked, blocked, or removed from portage.)
 * Try to emerge them manually.
 * Warning: Portage cannot rebuild any of the necessary packages.


Proszę o pomoc w rozwiązaniu mego problemu.


Last edited by nUmer_inaczej on Sun Nov 06, 2011 7:28 pm; edited 1 time in total
Back to top
View user's profile Send private message
Pryka
l33t
l33t


Joined: 08 Jun 2007
Posts: 625
Location: /dev/null

PostPosted: Sat Nov 05, 2011 6:48 pm    Post subject: Reply with quote

Sam przebuduj "x11-libs/gtksourceview" a raczej zainstaluj bo chyba go wcale nie ma.
Back to top
View user's profile Send private message
nUmer_inaczej
Tux's lil' helper
Tux's lil' helper


Joined: 24 Apr 2007
Posts: 132
Location: Bydgoszcz

PostPosted: Sat Nov 05, 2011 6:54 pm    Post subject: Reply with quote

kończy się ta operacja tym samym wynikiem niestety.
Back to top
View user's profile Send private message
Pryka
l33t
l33t


Joined: 08 Jun 2007
Posts: 625
Location: /dev/null

PostPosted: Sat Nov 05, 2011 6:56 pm    Post subject: Reply with quote

Ale jak to tym samym? przecież to niemożliwe żeby portage wywalało to co revdp-rebuild w tym logu powyżej. Wypluwa Ci, że nie ma w ogóle tej paczki w drzewie?

pokaż wynik emerge x11-libs/gtksourceview --oneshot
Back to top
View user's profile Send private message
nUmer_inaczej
Tux's lil' helper
Tux's lil' helper


Joined: 24 Apr 2007
Posts: 132
Location: Bydgoszcz

PostPosted: Sat Nov 05, 2011 7:07 pm    Post subject: Reply with quote

nie zrozumieliśmy się - emerge paczkę przebuduje, podczas gdy revdep-rebuild po tej operacji kończy pracę z tym samym komentarzem
Back to top
View user's profile Send private message
Pryka
l33t
l33t


Joined: 08 Jun 2007
Posts: 625
Location: /dev/null

PostPosted: Sat Nov 05, 2011 7:16 pm    Post subject: Reply with quote

Zainstaluj jakąś nowszą wersję o ile już nie siedzisz na ~
Back to top
View user's profile Send private message
nUmer_inaczej
Tux's lil' helper
Tux's lil' helper


Joined: 24 Apr 2007
Posts: 132
Location: Bydgoszcz

PostPosted: Sat Nov 05, 2011 8:52 pm    Post subject: Reply with quote

niestety - rezultat ten sam co poprzednio.
Back to top
View user's profile Send private message
znal
Apprentice
Apprentice


Joined: 12 Jul 2007
Posts: 177

PostPosted: Sat Nov 05, 2011 9:55 pm    Post subject: Reply with quote

Ten problem pojawił się po aktualizacji libpng-1.4 do 1.5?
Jeśli tak, to jest już o tym temat na forum: http://forums.gentoo.org/viewtopic-t-894950-postdays-0-postorder-asc-start-0.html
Back to top
View user's profile Send private message
nUmer_inaczej
Tux's lil' helper
Tux's lil' helper


Joined: 24 Apr 2007
Posts: 132
Location: Bydgoszcz

PostPosted: Sun Nov 06, 2011 7:26 pm    Post subject: Reply with quote

Dzięki skuteczności mego angielskiego ;-) zdaje się, że problem został rozwiązany. Nadto odmaskowanie i instalacja nowej wersji opery rozwiązała problemy pierwotne.

Dziękuję za uwagę i pozdrawiam
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish) Polish OTW All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum