Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
...stop udev from renaming eth0 on a live cd
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
bastibasti
Guru
Guru


Joined: 27 Nov 2006
Posts: 496

PostPosted: Fri Mar 08, 2013 2:22 pm    Post subject: ...stop udev from renaming eth0 on a live cd Reply with quote

Hi I have built a skimmed down version of gentoo. uncompressed root is about 50mb+kernel so compressed+kernel is about 20mb

however i experience that udev is renaming my eth0 to enp0s3 - whats that all about? I found out that this is a new *feature* of udev/systemd but can you switch it off?

Ok for a normal machine i could set up a mac adress based rule, but on a live cd?? and why is it s3 and not s0? my qemu only has one nic that it emulates. now iam getting confused. i thought device names ethx are given by the kernel. up to now i never had problems with that. each reboot would give me same eth numbers for my nic.
Back to top
View user's profile Send private message
XavierMiller
Moderator
Moderator


Joined: 23 Jul 2004
Posts: 5484
Location: ~Brussels - Belgique

PostPosted: Fri Mar 08, 2013 2:25 pm    Post subject: Reply with quote

Hello,

If you are unhappy with Gentoo LiveCD, use SystemRescueCD, based on Gentoo, and which is better IMHO.
_________________
Xavier Miller
(FR) Merci de respecter les règles du forum.
http://www.xaviermiller.be
Back to top
View user's profile Send private message
bastibasti
Guru
Guru


Joined: 27 Nov 2006
Posts: 496

PostPosted: Fri Mar 08, 2013 3:22 pm    Post subject: Reply with quote

I dont use any of these. Its a custom setup.
After the system is up and running I want to implement some additional scripts...

The initial question was if its possible to stop udev from renaming the eth interfaces, or not?
Back to top
View user's profile Send private message
Ant P.
Advocate
Advocate


Joined: 18 Apr 2009
Posts: 2333
Location: UK

PostPosted: Fri Mar 08, 2013 6:08 pm    Post subject: Reply with quote

There is supposedly some way to fix it by editing config files, but it'd be easier to just use eudev instead, which keeps the sane behaviour.
Back to top
View user's profile Send private message
XavierMiller
Moderator
Moderator


Joined: 23 Jul 2004
Posts: 5484
Location: ~Brussels - Belgique

PostPosted: Sun Mar 10, 2013 8:09 pm    Post subject: Reply with quote

You need to create an empty /etc/udev/rules.d/80-net-name-slot.rules
and the old naming rule will be applied
_________________
Xavier Miller
(FR) Merci de respecter les règles du forum.
http://www.xaviermiller.be
Back to top
View user's profile Send private message
ssuominen
Developer
Developer


Joined: 30 Sep 2005
Posts: 2128
Location: Finland

PostPosted: Sun Mar 10, 2013 8:17 pm    Post subject: Reply with quote

The network interface naming is documented here:

http://www.freedesktop.org/wiki/Software/systemd/PredictableNetworkInterfaceNames

In the "I don't like this, how do I disable this?" section.
Back to top
View user's profile Send private message
bastibasti
Guru
Guru


Joined: 27 Nov 2006
Posts: 496

PostPosted: Tue Mar 12, 2013 10:51 am    Post subject: Reply with quote

Thanks for the hints. I switched to eudev on all my machines :wink:
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum