Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
no active consolekit session
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
DZoom
n00b
n00b


Joined: 13 Jun 2010
Posts: 45

PostPosted: Sat Oct 22, 2011 10:27 am    Post subject: no active consolekit session Reply with quote

Hi,

i'm trying to find out why automounting of devices in my system (slim, fluxbox, thunar or pcmanfm) doesn't work.
after following several guides that all lead to (different) dead ends i'm trying to solve the problem not as a whole but piece by piece.

1. piece:
i don't have an active consolekit session.

ck-list-session printout:
Code:

dzm@hal ~ $ ck-list-sessions
Session1:
        unix-user = '1000'
        realname = '(null)'
        seat = 'Seat2'
        session-type = ''
        active = FALSE
        x11-display = ':0.0'
        x11-display-device = ''
        display-device = ''
        remote-host-name = ''
        is-local = TRUE
        on-since = '2011-10-22T10:15:50.407088Z'
        login-session-id = ''
Session2:
        unix-user = '1000'
        realname = '(null)'
        seat = 'Seat3'
        session-type = ''
        active = FALSE
        x11-display = ':0.0'
        x11-display-device = '/dev/tty7'
        display-device = ''
        remote-host-name = ''
        is-local = FALSE
        on-since = '2011-10-22T10:15:50.439213Z'
        login-session-id = ''


i use fluxbox and a graphical login manager (SLiM).
installed (relevant) software:

    - SLiM
    - fluxbox
    - thunar
    - consolekit (loaded in default runlevel)
    - polkit
    - udev (loaded in sysinit runlevel)
    - dbus (loaded in default runlevel)
    - polkit-gnome


global useflags are set as described http://forums.gentoo.org/viewtopic-t-858965.html plus did i add "-hal" in /etc/make.conf.

slim.conf login command:
Code:

login_cmd           exec /usr/bin/ck-launch-session /usr/bin/dbus-launch /bin/bash -login ~/.xinitrc


.xinitrc for my user:
Code:

thunar --daemon &

conky &

# polkit agent
/usr/libexec/polkit-gnome-authentication-agent-1 &

# finally: start fluxbox
exec startfluxbox


----------------------------------------
*EDIT*

just realized the same phenomenon (missing active consolekit session) on my macbook, which has essentially the same configuration and software installed. and followingly suffers the same issues...
but on the macbook the configuration given here definitely worked - up to the last world update which broke it
Back to top
View user's profile Send private message
netfab
Veteran
Veteran


Joined: 03 Mar 2005
Posts: 1590
Location: 127.0.0.1

PostPosted: Sat Oct 22, 2011 10:52 am    Post subject: Re: no active consolekit session Reply with quote

DZoom wrote:

slim.conf login command:
Code:

login_cmd           exec /usr/bin/ck-launch-session /usr/bin/dbus-launch /bin/bash -login ~/.xinitrc


With latest slim (1.3.2-r6) you must remove the /usr/bin/ck-launch-session call. See here.
Back to top
View user's profile Send private message
DZoom
n00b
n00b


Joined: 13 Jun 2010
Posts: 45

PostPosted: Sat Oct 22, 2011 2:07 pm    Post subject: Re: no active consolekit session Reply with quote

netfab wrote:
DZoom wrote:

slim.conf login command:
Code:

login_cmd           exec /usr/bin/ck-launch-session /usr/bin/dbus-launch /bin/bash -login ~/.xinitrc


With latest slim (1.3.2-r6) you must remove the /usr/bin/ck-launch-session call. See here.


i modified the line to:
Code:

login_cmd           exec /usr/bin/dbus-launch /bin/bash -login ~/.xinitrc


ck-list-sessions prints out only one session; but it's neither active nor does it have a login-session-id:
Code:

dzm@hal ~ $ ck-list-sessions
Session1:
        unix-user = '1000'
        realname = '(null)'
        seat = 'Seat2'
        session-type = ''
        active = FALSE
        x11-display = ':0.0'
        x11-display-device = ''
        display-device = ''
        remote-host-name = ''
        is-local = TRUE
        on-since = '2011-10-22T14:11:02.776036Z'
        login-session-id = ''
Back to top
View user's profile Send private message
netfab
Veteran
Veteran


Joined: 03 Mar 2005
Posts: 1590
Location: 127.0.0.1

PostPosted: Sun Oct 23, 2011 7:48 am    Post subject: Reply with quote

Did you check if you have the required kernel configuration ?
Please post the output of :
Code:

$ zgrep -E 'AUDITSYSCALL|PM_RUNTIME|USB_SUSPEND' /proc/config.gz
Back to top
View user's profile Send private message
DZoom
n00b
n00b


Joined: 13 Jun 2010
Posts: 45

PostPosted: Sun Oct 23, 2011 10:05 am    Post subject: Reply with quote

netfab wrote:
Did you check if you have the required kernel configuration ?
Please post the output of :
Code:

$ zgrep -E 'AUDITSYSCALL|PM_RUNTIME|USB_SUSPEND' /proc/config.gz


Code:

hal dzm # zgrep -E 'AUDITSYSCALL|PM_RUNTIME|USB_SUSPEND' /proc/config.gz
# CONFIG_PM_RUNTIME is not set


i'm recompiling my kernel right now with CONFIG_PM_RUNTIME=y

the other two options seem to be missing in the 3.06 kernel?
i'll let you know what difference the recompiled kernel does make
Back to top
View user's profile Send private message
netfab
Veteran
Veteran


Joined: 03 Mar 2005
Posts: 1590
Location: 127.0.0.1

PostPosted: Sun Oct 23, 2011 10:25 am    Post subject: Reply with quote

DZoom wrote:

the other two options seem to be missing in the 3.06 kernel?

Search them, they are there.
Back to top
View user's profile Send private message
GES
Tux's lil' helper
Tux's lil' helper


Joined: 12 Jun 2005
Posts: 107
Location: Budapest, Hungary

PostPosted: Sun Oct 23, 2011 10:50 am    Post subject: Reply with quote

Code:
# uname -r
3.0.6-gentoo

# zgrep -E 'AUDITSYSCALL|PM_RUNTIME|USB_SUSPEND' /proc/config.gz
CONFIG_AUDITSYSCALL=y
  menuconfig entry here:
  General setup  --->
    [*] Auditing support
      [*]   Enable system-call auditing support

CONFIG_PM_RUNTIME=y

CONFIG_USB_SUSPEND=y
  menuconfig entry here:
  Device Drivers  --->
    [*] USB support  --->
      {*}   Support for Host-side USB
        [*]     USB runtime power management (autosuspend) and wakeup

# ck-list-sessions
Session2:
        unix-user = '1000'
        realname = '(null)'
        seat = 'Seat1'
        session-type = ''
        active = TRUE
        x11-display = ':0.0'
        x11-display-device = '/dev/tty7'
        display-device = ''
        remote-host-name = ''
        is-local = TRUE
        on-since = '2011-10-23T07:08:33.012061Z'
        login-session-id = '1'
Session1:
        unix-user = '1000'
        realname = '(null)'
        seat = 'Seat2'
        session-type = ''
        active = FALSE
        x11-display = ':0.0'
        x11-display-device = ''
        display-device = ''
        remote-host-name = ''
        is-local = TRUE
        on-since = '2011-10-23T07:08:32.669178Z'
        login-session-id = '1'

Good works.
Back to top
View user's profile Send private message
ssuominen
Developer
Developer


Joined: 30 Sep 2005
Posts: 2117
Location: Finland

PostPosted: Sun Oct 23, 2011 11:01 am    Post subject: Reply with quote

http://forums.gentoo.org/viewtopic-t-858965.html says:

login-session-id = '1' <- If this is empty, you propably missed the CONFIG_AUDITSYSCALL=y option in kernel.

This is a duplicate thread of that sticky ...
Back to top
View user's profile Send private message
John R. Graham
Administrator
Administrator


Joined: 08 Mar 2005
Posts: 7670
Location: Somewhere over Atlanta, Georgia

PostPosted: Sun Oct 23, 2011 11:48 am    Post subject: Reply with quote

Moved from Desktop Environments to Duplicate Threads.

- John
_________________
This space intentionally left blank.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum