Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 201110-01 ] OpenSSL: Multiple vulnerabilities
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1614

PostPosted: Sun Oct 16, 2011 11:26 am    Post subject: [ GLSA 201110-01 ] OpenSSL: Multiple vulnerabilities Reply with quote

Gentoo Linux Security Advisory

Title: OpenSSL: Multiple vulnerabilities (GLSA 201110-01)
Severity: high
Exploitable: local, remote
Date: October 09, 2011
Updated: July 07, 2014
Bug(s): #303739, #308011, #322575, #332027, #345767, #347623, #354139, #382069
ID: 201110-01

Synopsis

Multiple vulnerabilities were found in OpenSSL, allowing for the
execution of arbitrary code and other attacks.


Background

OpenSSL is an Open Source toolkit implementing the Secure Sockets Layer
(SSL v2/v3) and Transport Layer Security (TLS v1) as well as a general
purpose cryptography library.


Affected Packages

Package: dev-libs/openssl
Vulnerable: < 1.0.0e
Unaffected: >= 1.0.0e
Unaffected: >= 0.9.8r < 0.9.9
Unaffected: >= 0.9.8s < 0.9.9
Unaffected: >= 0.9.8t < 0.9.9
Unaffected: >= 0.9.8u < 0.9.9
Unaffected: >= 0.9.8v < 0.9.9
Unaffected: >= 0.9.8w < 0.9.9
Unaffected: >= 0.9.8x < 0.9.9
Unaffected: >= 0.9.8y < 0.9.9
Unaffected: >= 0.9.8z_p1 < 0.9.9
Unaffected: >= 0.9.8z_p2 < 0.9.9
Unaffected: >= 0.9.8z_p3 < 0.9.9
Unaffected: >= 0.9.8z_p4 < 0.9.9
Unaffected: >= 0.9.8z_p5 < 0.9.9
Architectures: All supported architectures


Description

Multiple vulnerabilities have been discovered in OpenSSL. Please review
the CVE identifiers referenced below for details.


Impact

A context-dependent attacker could cause a Denial of Service, possibly
execute arbitrary code, bypass intended key requirements, force the
downgrade to unintended ciphers, bypass the need for knowledge of shared
secrets and successfully authenticate, bypass CRL validation, or obtain
sensitive information in applications that use OpenSSL.


Workaround

There is no known workaround at this time.

Resolution

All OpenSSL users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-libs/openssl-1.0.0e"
   
NOTE: This is a legacy GLSA. Updates for all affected architectures are
available since September 17, 2011. It is likely that your system is
already no longer affected by most of these issues.


References

CVE-2009-3245
CVE-2009-4355
CVE-2010-0433
CVE-2010-0740
CVE-2010-0742
CVE-2010-1633
CVE-2010-2939
CVE-2010-3864
CVE-2010-4180
CVE-2010-4252
CVE-2011-0014
CVE-2011-3207
CVE-2011-3210


Last edited by GLSA on Tue Jul 08, 2014 4:28 am; edited 8 times in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum