Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
layman: add an overlay error!
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
arnk
n00b
n00b


Joined: 25 Jul 2011
Posts: 18

PostPosted: Sun Oct 09, 2011 1:50 pm    Post subject: layman: add an overlay error! Reply with quote

$ sudo layman -a sunrise
* Adding overlay,...
* Adding repository "sunrise" failed!

* CLI: Errors occured processing action add
* Adding repository "sunrise" failed!

googled, find nothing.
Has anyone encontered this problem before?
Back to top
View user's profile Send private message
dol-sen
Developer
Developer


Joined: 30 Jun 2002
Posts: 2540
Location: Richmond, BC, Canada

PostPosted: Sun Oct 09, 2011 2:20 pm    Post subject: Reply with quote

arnk It happens occasionally. Usually the server is too busy or something like that. Try again after a few minutes, it should be fine.

That is Layman's error which does not know the reason why git, svn, etc. failed, just that it did. For the real reason, you need to look through the output by git, svn, etc.
_________________
Brian
Porthole, the Portage GUI frontend irc@freenode: #gentoo-guis, #porthole, Blog
layman, gentoolkit, CoreBuilder, esearch...
Back to top
View user's profile Send private message
arnk
n00b
n00b


Joined: 25 Jul 2011
Posts: 18

PostPosted: Mon Oct 10, 2011 4:07 am    Post subject: Reply with quote

dol-sen wrote:
arnk It happens occasionally. Usually the server is too busy or something like that. Try again after a few minutes, it should be fine.

That is Layman's error which does not know the reason why git, svn, etc. failed, just that it did. For the real reason, you need to look through the output by git, svn, etc.

I have try many times these day. :cry:
Back to top
View user's profile Send private message
dol-sen
Developer
Developer


Joined: 30 Jun 2002
Posts: 2540
Location: Richmond, BC, Canada

PostPosted: Mon Oct 10, 2011 8:17 am    Post subject: Reply with quote

OK, I've done some more testing... It looks like you don't have dev-vcs/subversion installed. That seems to be what is causing the failure. At least for my testing.

Does it list the sunrise overlay when you do a
Code:
layman -L
If not then it is hiding it because it could not find the svn command.
If it does, but with a red star to the left of it, then it is the same as above except that you have the nocheck option in layman.cfg set to yes.

Either way emerge subversion to fix it.

I will work on improving the the error handling to report that it failed to find the command it was looking for.
_________________
Brian
Porthole, the Portage GUI frontend irc@freenode: #gentoo-guis, #porthole, Blog
layman, gentoolkit, CoreBuilder, esearch...
Back to top
View user's profile Send private message
arnk
n00b
n00b


Joined: 25 Jul 2011
Posts: 18

PostPosted: Wed Oct 19, 2011 7:31 am    Post subject: Reply with quote

dol-sen wrote:
OK, I've done some more testing... It looks like you don't have dev-vcs/subversion installed. That seems to be what is causing the failure. At least for my testing.

Does it list the sunrise overlay when you do a
Code:
layman -L
If not then it is hiding it because it could not find the svn command.
If it does, but with a red star to the left of it, then it is the same as above except that you have the nocheck option in layman.cfg set to yes.

Either way emerge subversion to fix it.

I will work on improving the the error handling to report that it failed to find the command it was looking for.

Thx, It works for me. I didn't install the subversion, and some overlay which need it show a red star before it(I just know the means of the red star.).

I think we should add some infomation to make it looks more friendly, like the Xorg.0.log
(--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum