Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
libpng-1.5.x entered stable - upgrade tips
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4, 5, 6, 7  Next  
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
queen
Veteran
Veteran


Joined: 19 Jul 2005
Posts: 1512

PostPosted: Mon Mar 05, 2012 12:06 pm    Post subject: Reply with quote

WvR wrote:
queen, note that your revdep-rebuild does not rebuild anything. There is an error related to one of the USE-flags on one of your packages. Unless you fix that USE-flag revdep-rebuild will not rebuild the necessary packages.


Yes, I am aware of that. It wants USE plasma to install marble which then installs new kde version. Actually, 4.7 instead of 4.6. I wanted to avoid that because it takes a long time.
Back to top
View user's profile Send private message
ssuominen
Developer
Developer


Joined: 30 Sep 2005
Posts: 2000
Location: Finland

PostPosted: Mon Mar 05, 2012 12:11 pm    Post subject: Re: ><)))°€ Reply with quote

queen wrote:
BTW, I have other system that still has libpng14 and I intend to copy it to the broken system. Is there anything else I should do?


That would be 1.4.8 or version before that. Known to be vulnerable. Everyone should delete that one as soon as possible. Copying it over certainly isn't good idea.
Back to top
View user's profile Send private message
queen
Veteran
Veteran


Joined: 19 Jul 2005
Posts: 1512

PostPosted: Mon Mar 05, 2012 1:09 pm    Post subject: Re: ><)))°€ Reply with quote

ssuominen wrote:
queen wrote:
BTW, I have other system that still has libpng14 and I intend to copy it to the broken system. Is there anything else I should do?


That would be 1.4.8 or version before that. Known to be vulnerable. Everyone should delete that one as soon as possible. Copying it over certainly isn't good idea.


Then I am left without options. Just to upgrade everything. Hopefully, things will work better. It's just lots of packages.

Weird, but lots of packages still want libpng14. starting with kde packages, firefox, vlc.
Back to top
View user's profile Send private message
ssuominen
Developer
Developer


Joined: 30 Sep 2005
Posts: 2000
Location: Finland

PostPosted: Mon Mar 05, 2012 1:28 pm    Post subject: Re: ><)))°€ Reply with quote

queen wrote:
ssuominen wrote:
queen wrote:
BTW, I have other system that still has libpng14 and I intend to copy it to the broken system. Is there anything else I should do?


That would be 1.4.8 or version before that. Known to be vulnerable. Everyone should delete that one as soon as possible. Copying it over certainly isn't good idea.


Then I am left without options. Just to upgrade everything. Hopefully, things will work better. It's just lots of packages.

Weird, but lots of packages still want libpng14. starting with kde packages, firefox, vlc.


Yeah, there are really no shortcuts to take and you should really upgrade/rebuild everything using libpng.

The libpng upgrade thread mentioned earlier is the way to go.

And remember that nothing in Portage needs or wants libpng14, so any errors related to "Missing libpng14" is really coming from your own system, from one of the installed packages. This usually just means you need to rebuild some other package before that one. In big upgrades like this, it's easy to get Portage or revdep-rebuild confused on the order in which packages are supposed to be rebuilt.
Back to top
View user's profile Send private message
queen
Veteran
Veteran


Joined: 19 Jul 2005
Posts: 1512

PostPosted: Mon Mar 05, 2012 1:43 pm    Post subject: Re: ><)))°€ Reply with quote

ssuominen wrote:
queen wrote:
ssuominen wrote:
queen wrote:
BTW, I have other system that still has libpng14 and I intend to copy it to the broken system. Is there anything else I should do?


That would be 1.4.8 or version before that. Known to be vulnerable. Everyone should delete that one as soon as possible. Copying it over certainly isn't good idea.


Then I am left without options. Just to upgrade everything. Hopefully, things will work better. It's just lots of packages.

Weird, but lots of packages still want libpng14. starting with kde packages, firefox, vlc.


Yeah, there are really no shortcuts to take and you should really upgrade/rebuild everything using libpng.

The libpng upgrade thread mentioned earlier is the way to go.

And remember that nothing in Portage needs or wants libpng14, so any errors related to "Missing libpng14" is really coming from your own system, from one of the installed packages. This usually just means you need to rebuild some other package before that one. In big upgrades like this, it's easy to get Portage or revdep-rebuild confused on the order in which packages are supposed to be rebuilt.


I wish I knew this before that. I would have waited one/two weeks more. Anyway, will start upgrading today. Are there special commands that I need to run after I migrate kde from 4.6.5 to 4.7? Or just simply emerge?

I also have to upgrade qt related packages. Any special commands that I have to run there too?
Back to top
View user's profile Send private message
Trog Dog
Apprentice
Apprentice


Joined: 04 Aug 2007
Posts: 282

PostPosted: Mon Mar 05, 2012 2:57 pm    Post subject: Reply with quote

there was also a news item with instructions

Quote:
2011-10-15-libpng15
Title Upgrade to libpng15
Author Samuli Suominen <ssuominen@gentoo.org>
Posted 2011-10-15
Revision 1

After upgrading from libpng14 to libpng15 it's important that you rebuild
cairo and gdk-pixbuf as soon as possible if they are installed.

Then you can proceed with rebuilding the rest of the software against the new
library:

# revdep-rebuild --library libpng14.so.14 -- --keep-going

Note: It might be necessary to run the previous command more than once.

If you find packages not building with the message "ld: cannot find -lpng14",
they are likely caused by broken libtool archives (.la) in your system.

You can identify those files with following one-liner:

# find /usr/ -name '*.la' -exec grep png14 {} +

Once you have identified the broken files, you can either delete them,
edit them in place and replace png14 with png15, or re-emerge the packages
they belong to.

More information and help is available at the following forum post:

http://forums.gentoo.org/viewtopic-t-894950.html


Code:
eselect news list

_________________
CIC1=CC=C(C2=N[C@@H](CC(OC(C)(C)C)=O)C3=NN=C(C)N3C4=C2C(C)=C(C)S4)C=C1
Back to top
View user's profile Send private message
queen
Veteran
Veteran


Joined: 19 Jul 2005
Posts: 1512

PostPosted: Mon Mar 05, 2012 4:18 pm    Post subject: Reply with quote

Trog Dog wrote:
there was also a news item with instructions

Quote:
2011-10-15-libpng15
Title Upgrade to libpng15
Author Samuli Suominen <ssuominen@gentoo.org>
Posted 2011-10-15
Revision 1

After upgrading from libpng14 to libpng15 it's important that you rebuild
cairo and gdk-pixbuf as soon as possible if they are installed.

Then you can proceed with rebuilding the rest of the software against the new
library:

# revdep-rebuild --library libpng14.so.14 -- --keep-going

Note: It might be necessary to run the previous command more than once.

If you find packages not building with the message "ld: cannot find -lpng14",
they are likely caused by broken libtool archives (.la) in your system.

You can identify those files with following one-liner:

# find /usr/ -name '*.la' -exec grep png14 {} +

Once you have identified the broken files, you can either delete them,
edit them in place and replace png14 with png15, or re-emerge the packages
they belong to.

More information and help is available at the following forum post:

http://forums.gentoo.org/viewtopic-t-894950.html


Code:
eselect news list


I ran the revdep-rebuild as suggested. I don't have libpng14 on the system. My main problem is that the programs still want libpng14. All kde applications, kdeinit4, etc.
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5270

PostPosted: Mon Mar 05, 2012 4:36 pm    Post subject: Reply with quote

If you did it with '--keep-going', chances are something got skiped.
Run revdep-rebuild again to check if it detects anything, if not - post the exact errors.
Back to top
View user's profile Send private message
queen
Veteran
Veteran


Joined: 19 Jul 2005
Posts: 1512

PostPosted: Mon Mar 05, 2012 6:01 pm    Post subject: Reply with quote

VoidMage wrote:
If you did it with '--keep-going', chances are something got skiped.
Run revdep-rebuild again to check if it detects anything, if not - post the exact errors.


Yes, I recall i used --keep-going. Right now I have a borked system, cause kdeinit4 doesn't launch. I will run again just from terminal
Back to top
View user's profile Send private message
Trog Dog
Apprentice
Apprentice


Joined: 04 Aug 2007
Posts: 282

PostPosted: Mon Mar 05, 2012 10:29 pm    Post subject: Reply with quote

news item wrote:
Note: It might be necessary to run the previous command more than once.

If you find packages not building with the message "ld: cannot find -lpng14",
they are likely caused by broken libtool archives (.la) in your system.

You can identify those files with following one-liner:

# find /usr/ -name '*.la' -exec grep png14 {} +

Once you have identified the broken files, you can either delete them,
edit them in place and replace png14 with png15, or re-emerge the packages
they belong to.

_________________
CIC1=CC=C(C2=N[C@@H](CC(OC(C)(C)C)=O)C3=NN=C(C)N3C4=C2C(C)=C(C)S4)C=C1
Back to top
View user's profile Send private message
tomk
Administrator
Administrator


Joined: 23 Sep 2003
Posts: 7219
Location: Sat in front of my computer

PostPosted: Tue Mar 06, 2012 10:16 am    Post subject: Reply with quote

Merged from here.
_________________
Search | Read | Answer | Report | Strip
Back to top
View user's profile Send private message
queen
Veteran
Veteran


Joined: 19 Jul 2005
Posts: 1512

PostPosted: Tue Mar 06, 2012 9:00 pm    Post subject: Reply with quote

Code:

revdep-rebuild --library libpng14.so.14 -- --keep-going
 * Configuring search environment for revdep-rebuild
 * Environment mismatch from previous run, deleting temporary files...

 * Checking reverse dependencies
 * Packages containing binaries and libraries using libpng14.so.14
 * will be emerged.

 * Collecting system binaries and libraries
 * Generated new 1_files.rr
 * Checking dynamic linking
[ 21% ]  *   found /usr/bin/pbm2png
[ 44% ]  *   found /usr/lib/gtk-2.0/modules/libcanberra-gtk-module.so
[ 54% ]  *   found /usr/lib/libXm.so.4.0.3
[ 56% ]  *   found /usr/lib/libcairomm-1.0.so.1.4.0
 *   found /usr/lib/libcanberra-gtk.so.0.1.7
[ 57% ]  *   found /usr/lib/libdigikamcore.so.1.0.0
[ 62% ]  *   found /usr/lib/libkhtml.so.5.6.0
 *   found /usr/lib/libkipiplugins.so.1.0.0
[ 68% ]  *   found /usr/lib/libreoffice/program/oosplash.bin
[ 82% ]  *   found /usr/lib/qt4/libQtGui.so.4.7.2
[ 100% ]                 
 * Generated new 3_broken.rr
 * Assigning files to packages
 *   /usr/bin/pbm2png -> app-text/pdf2html
 *   /usr/lib/gtk-2.0/modules/libcanberra-gtk-module.so -> media-libs/libcanberra
 *   /usr/lib/libXm.so.4.0.3 -> x11-libs/openmotif
 *   /usr/lib/libcairomm-1.0.so.1.4.0 -> dev-cpp/cairomm
 *   /usr/lib/libcanberra-gtk.so.0.1.7 -> media-libs/libcanberra
 *   /usr/lib/libdigikamcore.so.1.0.0 -> media-gfx/digikam
 *   /usr/lib/libkhtml.so.5.6.0 -> kde-base/kdelibs
 *   /usr/lib/libkipiplugins.so.1.0.0 -> media-plugins/kipi-plugins
 *   /usr/lib/libreoffice/program/oosplash.bin -> app-office/libreoffice
 *   /usr/lib/qt4/libQtGui.so.4.7.2 -> x11-libs/qt-gui
 * Generated new 4_raw.rr and 4_owners.rr
 * Cleaning list of packages to rebuild
 * Generated new 4_pkgs.rr
 * Assigning packages to ebuilds
 * Generated new 4_ebuilds.rr
 * Evaluating package order
 * Generated new 5_order.rr
 * All prepared. Starting rebuild
emerge --complete-graph=y --oneshot --autounmask=n --keep-going app-office/libreoffice:0 app-text/pdf2html:0 dev-cpp/cairomm:0 kde-base/kdelibs:4 media-gfx/digikam:4 media-libs/libcanberra:0 media-plugins/kipi-plugins:4 x11-libs/openmotif:0 x11-libs/qt-gui:4
..........
Calculating dependencies... done!

emerge: there are no ebuilds built with USE flags to satisfy ">=kde-base/marble-4.7:4[aqua=,plasma]".
!!! One of the following packages is required to complete your request:
- kde-base/marble-4.7.4::gentoo (Change USE: +plasma)
(dependency required by "media-gfx/digikam-2.4.1" [ebuild])
(dependency required by "media-gfx/digikam:4" [argument])
 * Build finished correctly. Removing temporary files...
 * You can re-run revdep-rebuild to verify that all libraries and binaries
 * are fixed. Possible reasons for remaining inconsistencies include:
 *   orphaned files
 *   deep dependencies
 *   packages installed outside of portage's control
 *   specially-evaluated libraries

Back to top
View user's profile Send private message
ssuominen
Developer
Developer


Joined: 30 Sep 2005
Posts: 2000
Location: Finland

PostPosted: Tue Mar 06, 2012 10:10 pm    Post subject: Reply with quote

queen wrote:
Code:

revdep-rebuild --library libpng14.so.14 -- --keep-going
 * Configuring search environment for revdep-rebuild
 * Environment mismatch from previous run, deleting temporary files...

 * Checking reverse dependencies
 * Packages containing binaries and libraries using libpng14.so.14
 * will be emerged.

 * Collecting system binaries and libraries
 * Generated new 1_files.rr
 * Checking dynamic linking
[ 21% ]  *   found /usr/bin/pbm2png
[ 44% ]  *   found /usr/lib/gtk-2.0/modules/libcanberra-gtk-module.so
[ 54% ]  *   found /usr/lib/libXm.so.4.0.3
[ 56% ]  *   found /usr/lib/libcairomm-1.0.so.1.4.0
 *   found /usr/lib/libcanberra-gtk.so.0.1.7
[ 57% ]  *   found /usr/lib/libdigikamcore.so.1.0.0
[ 62% ]  *   found /usr/lib/libkhtml.so.5.6.0
 *   found /usr/lib/libkipiplugins.so.1.0.0
[ 68% ]  *   found /usr/lib/libreoffice/program/oosplash.bin
[ 82% ]  *   found /usr/lib/qt4/libQtGui.so.4.7.2
[ 100% ]                 
 * Generated new 3_broken.rr
 * Assigning files to packages
 *   /usr/bin/pbm2png -> app-text/pdf2html
 *   /usr/lib/gtk-2.0/modules/libcanberra-gtk-module.so -> media-libs/libcanberra
 *   /usr/lib/libXm.so.4.0.3 -> x11-libs/openmotif
 *   /usr/lib/libcairomm-1.0.so.1.4.0 -> dev-cpp/cairomm
 *   /usr/lib/libcanberra-gtk.so.0.1.7 -> media-libs/libcanberra
 *   /usr/lib/libdigikamcore.so.1.0.0 -> media-gfx/digikam
 *   /usr/lib/libkhtml.so.5.6.0 -> kde-base/kdelibs
 *   /usr/lib/libkipiplugins.so.1.0.0 -> media-plugins/kipi-plugins
 *   /usr/lib/libreoffice/program/oosplash.bin -> app-office/libreoffice
 *   /usr/lib/qt4/libQtGui.so.4.7.2 -> x11-libs/qt-gui
 * Generated new 4_raw.rr and 4_owners.rr
 * Cleaning list of packages to rebuild
 * Generated new 4_pkgs.rr
 * Assigning packages to ebuilds
 * Generated new 4_ebuilds.rr
 * Evaluating package order
 * Generated new 5_order.rr
 * All prepared. Starting rebuild
emerge --complete-graph=y --oneshot --autounmask=n --keep-going app-office/libreoffice:0 app-text/pdf2html:0 dev-cpp/cairomm:0 kde-base/kdelibs:4 media-gfx/digikam:4 media-libs/libcanberra:0 media-plugins/kipi-plugins:4 x11-libs/openmotif:0 x11-libs/qt-gui:4
..........
Calculating dependencies... done!

emerge: there are no ebuilds built with USE flags to satisfy ">=kde-base/marble-4.7:4[aqua=,plasma]".
!!! One of the following packages is required to complete your request:
- kde-base/marble-4.7.4::gentoo (Change USE: +plasma)
(dependency required by "media-gfx/digikam-2.4.1" [ebuild])
(dependency required by "media-gfx/digikam:4" [argument])
 * Build finished correctly. Removing temporary files...
 * You can re-run revdep-rebuild to verify that all libraries and binaries
 * are fixed. Possible reasons for remaining inconsistencies include:
 *   orphaned files
 *   deep dependencies
 *   packages installed outside of portage's control
 *   specially-evaluated libraries



Yes, everyone has been waiting for you to enable that USE="plasma" for marble, otherwise that revdep-rebuild won't proceed and we won't get anywhere.
Back to top
View user's profile Send private message
queen
Veteran
Veteran


Joined: 19 Jul 2005
Posts: 1512

PostPosted: Wed Mar 07, 2012 11:59 pm    Post subject: Reply with quote

I enabled plasma USE flag and emerged marble. Although libpng 1.5 was installed with USE apng I emerged again and got the message to
Code:
revdep-rebuild --library '/usr/lib/libpng14.so.14'


Things went quite ok, until it failed with libreoffice. libreoffice was the last packaged to be emerged in the revdep-rebuild. It looks like there is a bug with libreoffice and it fails. See here:

[url] http://forums.gentoo.org/viewtopic-t-914264-highlight-libreoffice.html[/url]

I also try to run update-world (after revdep-rebuild), but it doesn't build the emergelist due to this:

Code:

Total: 200 packages (175 upgrades, 5 new, 2 in new slots, 18 reinstalls), Size of downloads: 271,192 kB

The following USE changes are necessary to proceed:
#required by www-client/firefox-10.0.1, required by @selected, required by @world (argument)
>=media-libs/libpng-1.5.9 apng
#required by media-libs/libkgeomap-2.4.1, required by media-gfx/digikam-2.4.1, required by @selected, required by @world (argument)
=kde-base/marble-4.7.4 plasma



marble is installed, libpng too. digikam upgraded.

Code:

[I] kde-base/marble
     Available versions:  (4) 4.7.4!t ~4.8.0 ~4.8.0-r1
        {aqua debug designer-plugin gps +handbook (+)kde plasma python test}
     Installed versions:  4.7.4(4)!t(21:28:19 03/07/12)(handbook kde plasma python -aqua -debug -designer-plugin -gps -test)
     Homepage:            http://www.kde.org/
     Description:         Generic geographical map widget

[I] media-libs/libpng
     Available versions: 
        (1.2)   1.2.47
        (0)     1.5.8 1.5.9
        {apng neon static-libs}
     Installed versions:  1.2.47(1.2)(00:15:32 03/05/12) 1.5.9(21:35:16 03/07/12)(apng -neon -static-libs)
     Homepage:            http://www.libpng.org/
     Description:         Portable Network Graphics library

[I] www-client/firefox
     Available versions:  3.6.20 ~3.6.22 8.0 9.0 ~10.0 10.0.1 ~10.0.1-r1 {+alsa bindist +crashreporter custom-cflags custom-optimization +dbus debug elibc_FreeBSD gnome +ipc java libnotify+minimal pgo selinux startup-notification system-sqlite +webm wifi}                                               
    [b] Installed versions:  10.0.1[/b] (20:38:25 02/25/12)(alsa crashreporter dbus ipc minimal webm -bindist


Code:

equery d libpng
 * These packages depend on libpng:
app-office/libreoffice-3.3.1 (media-libs/libpng)
app-text/ghostscript-gpl-9.04-r4 (media-libs/libpng:0)
app-text/htmldoc-1.8.27-r3 (>=media-libs/libpng-1.4)
app-text/pdf2html-1.4 (>=media-libs/libpng-1.4)
app-text/poppler-0.16.7 (png ? >=media-libs/libpng-1.4:0)
dev-java/icedtea-bin-6.1.11.1 (>=media-libs/libpng-1.5)
dev-python/wxpython-2.8.12.1 (media-libs/libpng:0)
kde-base/kdelibs-4.7.4 (>=media-libs/libpng-1.4)
kde-base/ksplash-4.6.5 (media-libs/libpng)
media-gfx/digikam-2.4.1 (media-libs/libpng)
media-gfx/imagemagick-6.7.1.0 (png ? >=media-libs/libpng-1.4:0)
media-gfx/xv-3.10a-r16 (png ? >=media-libs/libpng-1.4)
media-libs/jbig2dec-0.11 (>=media-libs/libpng-1.4)
media-libs/lensfun-0.2.5-r2 (>=media-libs/libpng-1.2)
media-libs/libtheora-1.1.1 (examples ? media-libs/libpng)
media-libs/netpbm-10.51.00-r2 (png ? >=media-libs/libpng-1.4:0)
media-libs/opencv-2.3.0 (png ? media-libs/libpng)
media-libs/openjpeg-1.4-r1 (media-libs/libpng:0)
media-libs/vigra-1.7.1 (png ? media-libs/libpng)
media-plugins/kipi-plugins-2.4.1 (media-libs/libpng)
media-sound/sox-14.3.2-r1 (png ? media-libs/libpng)
media-video/mplayer-1.0_rc4_p20110322-r1 (png ? media-libs/libpng)
media-video/vlc-1.1.13 (png ? media-libs/libpng)
net-libs/webkit-gtk-1.4.3-r200 (>=media-libs/libpng-1.4:0)
net-p2p/amule-2.2.6 (remote ? >=media-libs/libpng-1.2.0)
net-print/cups-1.4.8-r1 (png ? >=media-libs/libpng-1.4.3:0)
www-client/firefox-10.0.1 (media-libs/libpng[apng])
x11-libs/cairo-1.10.2-r1 (media-libs/libpng:0)
x11-libs/gdk-pixbuf-2.24.0-r1 (>=media-libs/libpng-1.4:0)
x11-libs/openmotif-2.3.3-r1 (png ? >=media-libs/libpng-1.4)
x11-libs/qt-gui-4.7.4-r1 (media-libs/libpng:0)
x11-libs/wxGTK-2.8.12.1 (X ? media-libs/libpng:0)



So to sum it up, packages still want libpng 1.4. Also amule wants 1.2. Is it really need 1.2 or it's yet another artifact?

Code:


[I] net-p2p/amule
     Available versions:  2.2.6 ~2.3.1 {+X daemon debug geoip gtk nls remote stats unicode upnp}
     Installed versions:  2.2.6(22:23:54 12/16/11)(gtk nls unicode -daemon -debug -geoip -remote -stats -upnp)
     Homepage:            http://www.amule.org/
     Description:         aMule, the all-platform eMule p2p client

[I] x11-libs/cairo
     Available versions:  1.8.10!t 1.10.2-r1!t ~1.10.2-r2!t [M]~9999!t {X aqua cleartype debug directfb doc drm gallium +glib lcdfilter opengl openvg qt4 static-libs +svg xcb}                                                                         
     Installed versions:  1.10.2-r1!t(21:38:53 02/24/12)(X glib opengl svg -aqua -debug -directfb -doc -drm -gallium -openvg -qt4 -static-libs -xcb)
     Homepage:            http://cairographics.org/
     Description:         A vector graphics library with cross-device output support

[I] x11-libs/gdk-pixbuf
     Available versions:  (2) 2.24.0-r1 ~2.24.1
        {+X debug doc +introspection jpeg jpeg2k test tiff}
     Installed versions:  2.24.0-r1(2)(00:44:46 03/05/12)(X introspection jpeg -debug -doc -jpeg2k -test -tiff)
     Homepage:            http://www.gtk.org/
     Description:         Image loading library for GTK+


So where do I get from here regarding libpng?
Unmerge libreoffice and emerge koffice in order to finish revdep-rebuild?

I don't understand the last lines of update-world. It insists on those use flags while it has everything.

BTW, kdelibs are upgraded to 4.7.4. Also qt packages are updated.
Back to top
View user's profile Send private message
ssuominen
Developer
Developer


Joined: 30 Sep 2005
Posts: 2000
Location: Finland

PostPosted: Thu Mar 08, 2012 5:50 am    Post subject: Reply with quote

queen wrote:
Code:

Total: 200 packages (175 upgrades, 5 new, 2 in new slots, 18 reinstalls), Size of downloads: 271,192 kB

The following USE changes are necessary to proceed:
#required by www-client/firefox-10.0.1, required by @selected, required by @world (argument)
>=media-libs/libpng-1.5.9 apng
#required by media-libs/libkgeomap-2.4.1, required by media-gfx/digikam-2.4.1, required by @selected, required by @world (argument)
=kde-base/marble-4.7.4 plasma



I don't understand the last lines of update-world. It insists on those use flags while it has everything.


I don't see any progress from your last post. You need to use USE in make.conf, or /etc/portage/package.use to make these USE flags stick.

I suggest you revert to the handbook to learn about USE flags:

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?part=2&chap=2
Back to top
View user's profile Send private message
queen
Veteran
Veteran


Joined: 19 Jul 2005
Posts: 1512

PostPosted: Sat Mar 10, 2012 11:10 am    Post subject: Reply with quote

I managed to revdep-rebuild and update-world. The only thing that fails is libreoffice due to the bug mentioned above.

I also ran
Code:
revdep-rebuild --library libpng14.so
and it didn't find anything depending on this. So this looks fine. But if I run

Code:
equery d libpng
, still it finds a lot of packages that depend on libpng 1.4 some on 1.5 and 1.2. I don't know why. Others it depends on libpng without mentioning version.


Currently, I have few problems:

1. I found in /etc/portage/package.unmask libpng 1.4. I assume that it's there a long time. The file is from 25 March 2011. I guess I added it back then. Definitely, I didn't do it in the last month. Right now, I put a comment on this line.

2. Due to upgrade, it updated xorg-server 1.11 and it doesn't detect the screen. So I can't launch yet the new kde to test if things work.
Back to top
View user's profile Send private message
ssuominen
Developer
Developer


Joined: 30 Sep 2005
Posts: 2000
Location: Finland

PostPosted: Sat Mar 10, 2012 12:28 pm    Post subject: Reply with quote

queen wrote:
I managed to revdep-rebuild and update-world. The only thing that fails is libreoffice due to the bug mentioned above.

I also ran
Code:
revdep-rebuild --library libpng14.so
and it didn't find anything depending on this. So this looks fine. But if I run

Code:
equery d libpng
, still it finds a lot of packages that depend on libpng 1.4 some on 1.5 and 1.2. I don't know why. Others it depends on libpng without mentioning version.


Currently, I have few problems:

1. I found in /etc/portage/package.unmask libpng 1.4. I assume that it's there a long time. The file is from 25 March 2011. I guess I added it back then. Definitely, I didn't do it in the last month. Right now, I put a comment on this line.

2. Due to upgrade, it updated xorg-server 1.11 and it doesn't detect the screen. So I can't launch yet the new kde to test if things work.


You used wrong revdep-rebuild command then. Need to be accurate and use `revdep-rebuild --library libpng14.so.14` with the ending .14.

That unmask entry is irrelevant, just remove it.

And rest of the issues are not related to this thread so not commenting on them.
Back to top
View user's profile Send private message
queen
Veteran
Veteran


Joined: 19 Jul 2005
Posts: 1512

PostPosted: Sun Mar 11, 2012 3:18 pm    Post subject: Reply with quote

I ran again with
Code:
revdep-rebuild --library libpng14.so.14


The only broken part was of libreoffice. And as mentioned earlier libreoffice-3.4.3.2-r1 fails to emerge.

The error that I get is with build bridge. I also had a warning that it requires at least 1gb ram and more than 9gb space in /var. Otherwise it will fail. The max ram I have on the system is 1gb. I am not sure if the error of build bridge is related to the previous warning or not. I tried to change the requirements in the ebuild to less than 1gb, but it fails due to checksum.

Should I remove libreoffice and install libreoffice-bin or leave the old version as is?

How come libreoffice became such a beast? Before, 1gb was more than enough to install.
Back to top
View user's profile Send private message
hmag
n00b
n00b


Joined: 30 Aug 2010
Posts: 19

PostPosted: Sun Mar 25, 2012 9:36 am    Post subject: Re: libpng-1.5.x entered stable - upgrade tips Reply with quote

Polynomial-C wrote:
Hi folks,

now that libpng-1.5.x was unmasked I found my systems being unable to do a straightforward upgrade to that new version.
In my case this was caused by some .la files still containing -lpng14 so here's a small hint how to get rid of errors like:
Code:
... cannot find -lpng14...

First make sure you already did the upgrade steps the libpng-1.5.x ebuilds are suggesting. If you want to have as much fixed as possible with the first run, modify the command suggested by the ebuild as follows:
Code:
revdep-rebuild --library '/usr/lib64/libpng14.so.14' -- --keep-going

When this command has finished you should already have most of the packages being fixed and linked against libpng-1.5.x. Now to the -lpng14 problem. Run the following command to get rid of those:
Code:
emerge -1av --keep-going $(find /usr \( -name "*.la" -o -name "*.pc" -o -name "*-config" -o -name "*.pm" \) -exec grep -H png14 {} \; | cut -d : -f 1 | xargs qfile -CSq | sort | uniq)
(qfile belongs to app-portage/portage-utils package so make sure to have it installed before running this command).
2011-Oct-18: IMPORTANT! The combination of find and grep in our stable tree seems to have trouble with multiple filename patterns finding files containing a specific string[1]. I modified the command to circumvent this problem. All stable users are encouraged to repeat the search with the modified command.
Simply run the revdep-rebuild command again and all should be settled. If no more compile errors occur you may remove the old /usr/lib64/libpng14.so.14 from your system.
If you still have compile errors try to run the above command several times until all errors are gone.
In case emerge prints some error message like "emerge: error: no such option: -," the find command didn't find anything containing png14 and thus emerge got called with an invalid parameter. This doesn't hurt your system and should just be considered some "cosmetic disadvantage" of the above command ;)

[edit]
UPDATE1! Package slots should now be taken into account as well. Added "--keep-going" option to last one-liner.
UPDATE2! Added some more files to the find search. Now .la files and *-config files are taken into account, too.
UPDATE3! Adjusted summary to reflect png15 being in stable now.
UPDATE4! Added a comment about emerge printing an error message when the find command doesn't find anything containing png14.
UPDATE5! Added perl modules to the find search.
UPDATE6! Modified the find command to circumvent a problem with stable find/grep combination.
[/edit]

[1] Thanks mephinet for giving the correct hints.

[mod]"Sticking" thread - Jorge (jmbsvicetto)[/mod]


Hi, developer,

For your information, I also had to fix dependencies to libpng14 in some '.so', though it might be useful to include a '-o -name *.so' in the grep args.

Thanks & regards
Back to top
View user's profile Send private message
calavicci
n00b
n00b


Joined: 28 Mar 2006
Posts: 39

PostPosted: Thu Jun 21, 2012 11:36 pm    Post subject: Reply with quote

libgnomecanvas really seems intent on using 1.4:

Code:

libtool: link: x86_64-pc-linux-gnu-gcc -shared  -fPIC -DPIC  .libs/gnome-canvas-shape.o .libs/gnome-canvas-bpath.o .libs/gnome-canvas-path-def.o .libs/gnome-canvas-clipgroup.o .libs/gnome-canvas-line.o .libs/gnome-canvas-pixbuf.o .libs/gnome-canvas-polygon.o .libs/gnome-canvas-rect-ellipse.o .libs/gnome-canvas-text.o .libs/gnome-canvas-rich-text.o .libs/gnome-canvas-util.o .libs/gnome-canvas-widget.o .libs/gnome-canvas.o .libs/libgnomecanvastypes.o .libs/gailcanvas.o .libs/gailcanvasitem.o .libs/gailcanvasgroup.o .libs/gailcanvaswidget.o .libs/gailcanvastext.o .libs/gailcanvasitemfactory.o .libs/gailcanvasgroupfactory.o .libs/gailcanvaswidgetfactory.o .libs/gailcanvastextfactory.o   -Wl,--as-needed /usr/lib64/libgailutil.so -L/usr/lib64 -lXext -lXinerama -lXrandr /usr/lib64/libXcursor.so -lXcomposite -lXdamage -lXfixes /usr/lib64/libpixman-1.so -lpng14 -lXrender -lX11 -lxcb -lXau -lXdmcp -lGL -lresolv -ldl -lpthread /usr/lib64/libgtk-x11-2.0.so /usr/lib64/libgdk-x11-2.0.so -latk-1.0 -lgio-2.0 -lpangocairo-1.0 -lgdk_pixbuf-2.0 -lcairo /usr/lib64/libart_lgpl_2.so -lpangoft2-1.0 -lpango-1.0 /usr/lib64/libfontconfig.so -lfreetype -lz -lexpat -lgobject-2.0 -lgmodule-2.0 -lgthread-2.0 -lrt -lglib-2.0 -lm  -march=core2 -O2 -msse3 -Wl,-O1 -pthread   -pthread -Wl,-soname -Wl,libgnomecanvas-2.so.0 -o .libs/libgnomecanvas-2.so.0.3000.3
/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.3/../../../../x86_64-pc-linux-gnu/bin/ld: cannot find -lpng14
collect2: ld returned 1 exit status
make[3]: *** [libgnomecanvas-2.la] Error 1
make[3]: Leaving directory `/var/tmp/portage/gnome-base/libgnomecanvas-2.30.3/work/libgnomecanvas-2.30.3/libgnomecanvas'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/var/tmp/portage/gnome-base/libgnomecanvas-2.30.3/work/libgnomecanvas-2.30.3/libgnomecanvas'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/gnome-base/libgnomecanvas-2.30.3/work/libgnomecanvas-2.30.3'
make: *** [all] Error 2


Code:

Portage 2.1.10.49 (default/linux/amd64/10.0, gcc-4.4.3, glibc-2.11.2, 2.6.37-gentoo-r4-61 x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-2.6.37-gentoo-r4-61-x86_64-Intel-R-_Core-TM-2_Quad_CPU_Q6600_@_2.40GHz-with-gentoo-1.12.14
Timestamp of tree: Thu, 21 Jun 2012 18:45:01 +0000
app-shells/bash:          4.0_p28
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.4.6, 2.5.4-r4, 2.6.8, 2.7.3-r2, 3.1.5
dev-util/cmake:           2.8.4-r1
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      1.12.14-r1
sys-apps/sandbox:         2.4
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.4_p6, 1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2, 1.11.1
sys-devel/binutils:       2.20.1-r1
sys-devel/gcc:            3.4.6-r2, 4.1.2, 4.4.3-r2, 4.5.3-r2
sys-devel/gcc-config:     1.6
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 2.6.30-r1 (virtual/os-headers)
sys-libs/glibc:           2.11.2
Repositories: gentoo x-layman
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -O2 -pipe -msse3"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=core2 -O2 -pipe -msse3"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="rsync://mirror.mcs.anl.gov/gentoo/"
LANG="en_US"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman"
SYNC="rsync://rsync.namerica.gentoo.org/gentoo-portage"
USE="X acl alsa amd64 berkdb bzip2 clamav cli cracklib crypt cups cxx dri dvd fortran gdbm gpm iconv ipv6 mmexext mmx modules mudflap multilib ncurses nls nptl openmp pam pcre pppd readline session sse sse2 sse3 ssl ssse3 tcpd threads unicode xorg zlib" ALSA_CARDS="hda_intel hpet hrtimer rtctimer" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" PHP_TARGETS="php5-4" PYTHON_TARGETS="python3_2 python2_7" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="nvidia vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON


Seems hardcoded into the .la file. The given command seems to find it, but correction doesn't do much. Am I doing something wrong, or is something else broken?
Back to top
View user's profile Send private message
krinn
Advocate
Advocate


Joined: 02 May 2003
Posts: 3907

PostPosted: Thu Jun 21, 2012 11:44 pm    Post subject: Reply with quote

Obviously you've done something wrong :)
Code:
Calculating dependencies... done!
[ebuild   R    ] gnome-base/libgnomecanvas-2.30.3  USE="-doc -glade -test" 0 kB
[ebuild   R    ] media-libs/libpng-1.5.10  USE="apng (-neon) -static-libs" 0 kB
Back to top
View user's profile Send private message
calavicci
n00b
n00b


Joined: 28 Mar 2006
Posts: 39

PostPosted: Fri Jun 22, 2012 4:17 pm    Post subject: Reply with quote

Edit: Finally found the borked .la and fixed it by hand. Thanks anyway.
Back to top
View user's profile Send private message
Randy Andy
Veteran
Veteran


Joined: 19 Jun 2007
Posts: 1009
Location: /dev/koelsch

PostPosted: Wed Apr 10, 2013 6:09 pm    Post subject: The story goes on, cause libpng-1.6.1 hit the tree Reply with quote

The next round is open and the media-libs/libpng trouble strikes back.

I guess it would be a great help, if one of the well experienced devs/guys would open a new thread,
as we had last time: http://forums.gentoo.org/viewtopic-t-894950-postdays-0-postorder-asc-highlight-libpng-start-0.html

One example for the upcoming problems I got on two different archs:

On the ~x86_64 for world update:
Code:

Calculating dependencies... done!
[ebuild     U  ] dev-libs/oniguruma-5.9.4 [5.9.3] USE="-combination-explosion-check -crnl-as-line-terminator -static-libs" 555 kB
[ebuild     U  ] media-libs/libpng-1.6.1:0/16 [1.5.15:0/0] USE="apng (-neon) -static-libs" 826 kB
[ebuild  NS    ] media-libs/libpng-1.5.15-r15:1.5 [1.5.15:0] USE="apng (-neon)" 0 kB
[ebuild     U  ] dev-python/sip-4.14.5:0/9 [4.14.4:0/9] USE="-debug -doc" PYTHON_TARGETS="python2_7 python3_2 -python2_5 -python2_6 -python3_1 (-python3_3)" 733 kB
[ebuild     U  ] app-misc/pax-utils-0.7 [0.6] USE="python -caps" 89 kB
[ebuild     U  ] sys-apps/kmod-13 [12-r1] USE="lzma tools zlib -debug -doc -static-libs" 1,403 kB
[ebuild     U  ] media-libs/libcdr-0.0.12 [0.0.11] USE="-doc -static-libs" 553 kB
[ebuild     U  ] sys-fs/udev-201 [200] USE="acl firmware-loader gudev hwdb introspection keymap kmod openrc -doc (-selinux) -static-libs" 2,081 kB
[ebuild     U  ] dev-db/libiodbc-3.52.8-r1 [3.52.8] USE="gtk (-static-libs%)" 0 kB
[ebuild     U  ] app-text/poppler-0.22.2-r2:0/35 [0.20.5:0/0] USE="cairo cjk cxx introspection jpeg lcms png qt4 tiff utils -curl -debug -doc -jpeg2k" 0 kB
[ebuild     U  ] dev-python/twisted-13.0.0 [12.3.0] USE="crypt gtk -serial" 1,461 kB
[ebuild     U  ] dev-cpp/gtkmm-2.24.3:2.4 [2.24.2:2.4] USE="-doc -examples {-test}" 10,231 kB
[ebuild     U  ] app-crypt/gnupg-2.0.19-r2 [2.0.19-r1] USE="bzip2 ldap nls readline usb -adns -doc -mta (-selinux) -smartcard -static" 0 kB
[ebuild     U  ] net-misc/whois-5.0.22 [5.0.20] USE="iconv nls -idn" 69 kB
[ebuild     U  ] app-text/recode-3.6_p20 [3.6_p17-r2] USE="nls -static-libs" 334 kB
[ebuild     U  ] gnome-base/gconf-3.2.6-r1:2 [3.2.6:2] USE="gtk introspection ldap (policykit) -debug -orbit" PYTHON_TARGETS="python2_7%* -python2_5% -python2_6%" 0 kB
[ebuild     U  ] media-video/mjpegtools-2.0.1_rc1-r1:1 [2.0.1_rc1:1] USE="dga dv gtk mmx png quicktime sdl v4l -sdlgfx -static-libs" 0 kB
[ebuild     U  ] www-client/firefox-20.0 [19.0.2] USE="alsa dbus gstreamer jit libnotify minimal startup-notification -bindist -custom-cflags -custom-optimization -debug (-pgo) (-selinux) -system-jpeg -system-sqlite -wifi" LINGUAS="de -af -ak -ar -as -ast -be -bg -bn_BD -bn_IN -br -bs -ca -cs -csb -cy -da -el -en_GB -en_ZA -eo -es_AR -es_CL -es_ES -es_MX -et -eu -fa -fi -fr -fy_NL -ga_IE -gd -gl -gu_IN -he -hi_IN -hr -hu -hy_AM -id -is -it -ja -kk -km -kn -ko -ku -lg -lt -lv -mai -mk -ml -mr -nb_NO -nl -nn_NO -nso -or -pa_IN -pl -pt_BR -pt_PT -rm -ro -ru -si -sk -sl -son -sq -sr -sv_SE -ta -ta_LK -te -th -tr -uk -vi -zh_CN -zh_TW -zu" 0 kB
[blocks B      ] =media-libs/libpng-1.5*:0 ("=media-libs/libpng-1.5*:0" is blocking media-libs/libpng-1.5.15-r15)

Total: 18 packages (17 upgrades, 1 in new slot), Size of downloads: 18,328 kB
Conflict: 1 block (1 unsatisfied)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

app-text/poppler:0

  (app-text/poppler-0.22.2-r2::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (app-text/poppler-0.20.5::gentoo, installed) pulled in by
    app-text/poppler:0/0=[qt4] required by (app-text/diffpdf-2.1.1::gentoo, installed)
    app-text/poppler:0/0=[cxx,jpeg,lcms,tiff,xpdf-headers(+)] required by (net-print/cups-filters-1.0.30::gentoo, installed)
    >=app-text/poppler-0.16:0/0=[xpdf-headers(+),cxx] required by (app-office/libreoffice-4.0.2.2::gentoo, installed)
    (and 1 more with the same problems)

media-libs/libpng:0

  (media-libs/libpng-1.5.15::gentoo, installed) pulled in by
    media-libs/libpng:0/0= required by (kde-base/kdelibs-4.10.2::gentoo, installed)
    media-libs/libpng:0/0= required by (kde-base/ksplash-4.10.2::gentoo, installed)
    >=media-libs/libpng-1.4:0/0= required by (x11-libs/gdk-pixbuf-2.26.5::gentoo, installed)
    (and 1 more with the same problems)

  (media-libs/libpng-1.6.1::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)


On the ~x86 to reduce the output, so if I'm trying to update only media-libs/libpng:
Code:

Calculating dependencies... done!
[ebuild     U  ] media-libs/libpng-1.6.1 [1.5.15]

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

media-libs/libpng:0

  (media-libs/libpng-1.5.15::gentoo, installed) pulled in by
    media-libs/libpng:0/0= required by (kde-base/kdelibs-4.10.2::gentoo, installed)
    media-libs/libpng:0/0= required by (app-emulation/wine-1.5.27::gentoo, installed)
    media-libs/libpng:0/0= required by (media-libs/opencv-2.4.4a::gentoo, installed)
    media-libs/libpng:0/0= required by (media-libs/openjpeg-1.5.0::gentoo, installed)
    media-libs/libpng:0/0= required by (media-gfx/digikam-3.1.0::gentoo, installed)
    media-libs/libpng:0/0= required by (kde-base/ksplash-4.10.2::gentoo, installed)
    media-libs/libpng:0/0= required by (media-libs/libwebp-0.2.1-r1::gentoo, installed)
    >=media-libs/libpng-1.4:0/0= required by (x11-libs/gdk-pixbuf-2.26.5::gentoo, installed)
    =media-libs/libpng-1.5* required by (dev-java/icedtea-bin-7.2.3.8::gentoo, installed)
    media-libs/libpng:0/0= required by (media-video/mjpegtools-2.0.1_rc1-r1::gentoo, installed)

  (media-libs/libpng-1.6.1::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)


This time I don't want to go on with experiments, like deleting older libpngs or masking newer ones.
There must be a smoother solution, come on :wink:

Best, Andy.
_________________
If you want to see a Distro done right, compile it yourself!
Back to top
View user's profile Send private message
Kollin
Veteran
Veteran


Joined: 25 Feb 2006
Posts: 1092
Location: Sofia/Bulgaria

PostPosted: Wed Apr 10, 2013 8:24 pm    Post subject: Reply with quote

For me icedtea-bin is the mfer:

equery d "=media-libs/libpng-1.5*:0"
Quote:

* These packages depend on media-libs/libpng-1.5:
app-emulation/virtualbox-bin-4.2.10 (!headless ? media-libs/libpng)
app-emulation/wine-1.5.27 (png ? media-libs/libpng:0)
app-text/ghostscript-gpl-9.06 (media-libs/libpng:0)
app-text/poppler-0.22.2-r2 (png ? >=media-libs/libpng-1.4:0)
dev-java/icedtea-bin-7.2.3.8 (=media-libs/libpng-1.5*)
dev-lang/R-3.0.0 (png ? media-libs/libpng)
dev-python/wxpython-2.8.12.1-r1 (media-libs/libpng:0)
dev-qt/qtgui-4.8.4-r1 (media-libs/libpng:0)
kde-base/kdelibs-4.10.2 (media-libs/libpng:0)
kde-base/ksplash-4.10.2 (media-libs/libpng:0)
media-gfx/darktable-1.2-r1 (media-libs/libpng:0)
media-gfx/gimp-2.8.4 (png ? >=media-libs/libpng-1.2.37:0)
media-gfx/graphicsmagick-1.3.18 (png ? media-libs/libpng:0)
media-gfx/graphviz-2.28.0 (>=media-libs/libpng-1.2:0)
media-gfx/pstoedit-3.61 (>=media-libs/libpng-1.4.3)
media-gfx/qrencode-3.4.2 (media-libs/libpng)
media-libs/gd-2.0.35-r3 (png ? >=media-libs/libpng-1.2:0)
media-libs/gegl-0.2.0-r1 (png ? media-libs/libpng)
media-libs/imlib2-1.4.5 (png ? media-libs/libpng:0)
media-libs/jbig2dec-0.11-r1 (png ? >=media-libs/libpng-1.2:0)
media-libs/lensfun-0.2.7 (media-libs/libpng:0)
media-libs/libkate-0.4.1 (media-libs/libpng)
media-libs/libquicktime-1.2.4 (png ? media-libs/libpng:0)
media-libs/libtheora-1.1.1 (examples ? media-libs/libpng)
media-libs/libwebp-0.2.1-r1 (media-libs/libpng:0)
media-libs/libwmf-0.2.8.4-r4 (>=media-libs/libpng-1.4)
media-libs/ming-0.4.4 (media-libs/libpng)
media-libs/netpbm-10.61.00 (png ? >=media-libs/libpng-1.4:0)
media-libs/sdl-image-1.2.12 (png ? >=media-libs/libpng-1.4)
media-sound/sox-14.4.1 (png ? media-libs/libpng)
media-video/gpac-0.5.0 (png ? >=media-libs/libpng-1.4)
media-video/mjpegtools-2.0.1_rc1-r1 (png ? media-libs/libpng:0)
media-video/mplayer-1.1-r1 (png ? media-libs/libpng)
media-video/mplayer2-2.0_p20130126 (png ? media-libs/libpng)
media-video/ogmrip-0.13.8 (media-libs/libpng)
media-video/vlc-2.0.5 (png ? media-libs/libpng)
media-video/xine-ui-0.99.7 (media-libs/libpng:0)
net-libs/libvncserver-0.9.9-r1 (png ? media-libs/libpng:0)
net-p2p/amule-2.3.1 (remote ? >=media-libs/libpng-1.2.0)
net-print/cups-filters-1.0.30 (png ? media-libs/libpng:0)
sys-libs/slang-2.2.4 (png ? >=media-libs/libpng-1.2:0)
www-client/chromium-27.0.1453.12 (media-libs/libpng:0)
www-client/firefox-20.0 (>=media-libs/libpng-1.5.11[apng])
x11-libs/cairo-1.12.12-r1 (media-libs/libpng:0)
x11-libs/gdk-pixbuf-2.26.5 (>=media-libs/libpng-1.4:0)
x11-libs/gl2ps-1.3.8 (png ? media-libs/libpng)
x11-libs/wxGTK-2.8.12.1 (X ? media-libs/libpng:0)
x11-libs/wxGTK-2.9.4.1 (X ? media-libs/libpng:0)

_________________
"Dear Enemy: may the Lord hate you and all your kind, may you be turned orange in hue, and may your head fall off at an awkward moment."
"Linux is like a wigwam - no windows, no gates, apache inside..."
Back to top
View user's profile Send private message
rorgoroth
Apprentice
Apprentice


Joined: 06 Aug 2012
Posts: 221
Location: England, UK

PostPosted: Wed Apr 10, 2013 8:30 pm    Post subject: Reply with quote

^^ Owch 8)
I was rather lucky with it, normal update plus 2 rounds of @preserved-rebuild and it was over.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Goto page Previous  1, 2, 3, 4, 5, 6, 7  Next
Page 6 of 7

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum