Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Java applets do no longer run in Firefox
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
suprafluid
n00b
n00b


Joined: 07 Jan 2011
Posts: 22
Location: Deep in the Bavarian Forrest, Germany

PostPosted: Fri Sep 02, 2011 8:29 am    Post subject: Java applets do no longer run in Firefox Reply with quote

Hello all,

Sorry, I am bit a newbie to all this gentoo stuff. So far I had a stable system and no problems getting installed all that I needed.

Now recently I did a "emerge -avDNut world" and after that, Firefox (3.6.17) does no longer run java applets. There just a gray box where the applet should run... Now I remerged java and firefox again.. but nothing changed.

java-check-environment ends with "* Java environment is sane. Congratulations!"

Active jre (java-config -f) is "sun-jre-bin-1.6"

Any ideas waht I could do here?

Kind regards,
tobias
[/code]
Back to top
View user's profile Send private message
massimo
Veteran
Veteran


Joined: 22 Jun 2003
Posts: 1133
Location: Austria

PostPosted: Fri Sep 02, 2011 8:39 am    Post subject: Reply with quote

When you enter 'about:plugins' in Firefox' address bar you get a list of installed plugins - can you find java there?
_________________
Hello 911? How are you?
Back to top
View user's profile Send private message
suprafluid
n00b
n00b


Joined: 07 Jan 2011
Posts: 22
Location: Deep in the Bavarian Forrest, Germany

PostPosted: Fri Sep 02, 2011 8:56 am    Post subject: Reply with quote

Hi! This gives me:

application/x-java-vm IcedTea class,jar Yes
application/x-java-applet IcedTea class,jar Yes

IcedTea ist also installed

The following VMs are available for generation-2:
1) IcedTea6-bin 1.10.3 [icedtea6-bin]
2) Sun JDK 1.6.0.26 [sun-jdk-1.6]
*) Sun JRE 1.6.0.26 [sun-jre-bin-1.6]
Back to top
View user's profile Send private message
suprafluid
n00b
n00b


Joined: 07 Jan 2011
Posts: 22
Location: Deep in the Bavarian Forrest, Germany

PostPosted: Sat Sep 03, 2011 8:55 pm    Post subject: Reply with quote

Hi all,

Seems Firefox runs into the follwong problem, as soon as a java applet starts...

Code:

Gtk-ERROR **: GTK+ 2.x symbols detected. Using GTK+ 2.x and GTK+ 3 in the same process is not supported
aborting...


But installed is only gtk 2 on this system.

x11-libs/gtk+-2.24.4

what can I do here?
Back to top
View user's profile Send private message
Elv13
Guru
Guru


Joined: 13 Nov 2005
Posts: 382
Location: Socialist land of North America

PostPosted: Sun Sep 04, 2011 7:51 am    Post subject: Reply with quote

Remove the icedtea plugin (.so) from the netscape/mozilla//firefox plugin directory (usually in /usr/lib/{netscape,mozilla,firefox} directory
Back to top
View user's profile Send private message
suprafluid
n00b
n00b


Joined: 07 Jan 2011
Posts: 22
Location: Deep in the Bavarian Forrest, Germany

PostPosted: Sun Sep 04, 2011 8:15 am    Post subject: Reply with quote

Hi!

In the firefox plugin directory, there's only a symlink to:

/usr/share/java-config-2/nsplugin/icedtea6-javaplugin.so

and this is also just a link pointing to:

/opt/icedtea6-web-bin/lib/IcedTeaPlugin.so

I deleted that link and now the browser says that it does not find a plugin for java applets. What should the deletion of this do?

I will re-emerge firefox now and see what it does.
Back to top
View user's profile Send private message
charles17
Tux's lil' helper
Tux's lil' helper


Joined: 02 Mar 2008
Posts: 98

PostPosted: Sun Sep 04, 2011 12:03 pm    Post subject: Reply with quote

Did you set java-nsplugin in eselect?
Code:
eselect java-nsplugin set icedtea6
eselect java-nsplugin list
Back to top
View user's profile Send private message
suprafluid
n00b
n00b


Joined: 07 Jan 2011
Posts: 22
Location: Deep in the Bavarian Forrest, Germany

PostPosted: Sun Sep 04, 2011 3:40 pm    Post subject: Reply with quote

hi
yes that is set. I get this error message when starting an applet:

Code:

OpenJDK Runtime Environment (IcedTea6 1.10.3) (Gentoo build 1.6.0_22-b22)
OpenJDK Client VM (build 20.0-b11, mixed mode)

Gtk-ERROR **: GTK+ 2.x symbols detected. Using GTK+ 2.x and GTK+ 3 in the same process is not supported
aborting...

Back to top
View user's profile Send private message
suprafluid
n00b
n00b


Joined: 07 Jan 2011
Posts: 22
Location: Deep in the Bavarian Forrest, Germany

PostPosted: Sun Sep 04, 2011 9:29 pm    Post subject: got it Reply with quote

got it: icedtea6 does not work properly because it messes up with gtk+ 2 and 3 (3 is not installed on my system)

I changed the default java browser plugin to sun-jdk-1.6

Code:

eselect java-nsplugin set sun-jdk-1.6


and now java applets are working again...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum