Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] MPD Hell
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
F_
Tux's lil' helper
Tux's lil' helper


Joined: 31 Dec 2006
Posts: 102

PostPosted: Thu Aug 25, 2011 7:21 am    Post subject: [solved] MPD Hell Reply with quote

I can't seem to configure mpd so that I can play music on my computer. I can play the .mp3 files just fine if I use something like mplayer. But using mpc or ncmpc just won't work. I can load the .mp3 files to playlists just fine in ncmpc, but I get no sound. What could be wrong?

/etc/mpd.conf
Code:


music_directory         "/usr/local/mp3"
playlist_directory      "/usr/local/mp3/,playlists"
db_file         "/var/lib/mpd/database"
log_file         "/var/lib/mpd/log"
state_file         "/var/lib/mpd/state"


user            "f"
group            "f"
bind_to_address      "127.0.0.1"
bind_to_address      "/var/lib/mpd/socket"
port            "6600"

input {
        plugin "curl"
}

audio_output {
   type      "alsa"
   name      "My ALSA Device"
}

audio_output {
        type    "fifo"
        name    "MPD FIFO Output"
        path    "~/var/run/mpd.fifo"
        format  "44100:16:1"
}

filesystem_charset "UTF-8"


I have tried changing the "user" and "group" to "'mpd" and "audio" but with no avail.

when I run "mpc play" i get the following error:
Code:

$ mpc play
El-P - Tuned Mass Damper
[paused]  #2/2   0:00/4:06 (0%)
volume: n/a   repeat: off   random: off   single: off   consume: off
ERROR: problems opening audio device


That same error happens if i run 'mpc play' as root or as a user.' Also, both root and my user are in the audio group.



I'm at a loss for what to do. Any ideas?
Thanks.


Last edited by F_ on Thu Aug 25, 2011 1:34 pm; edited 1 time in total
Back to top
View user's profile Send private message
avx
Advocate
Advocate


Joined: 21 Jun 2004
Posts: 2108

PostPosted: Thu Aug 25, 2011 10:07 am    Post subject: Reply with quote

Seems to be the same problem I once had -> http://forums.gentoo.org/viewtopic-t-875403-start-0.html
_________________
++++++++++[>+++++++>++++++++++>+++>+<<<<-]>++.>+.+++++++..+++.>++.<<+++++++++++++++.>.+++.------.--------.>+.>.
Back to top
View user's profile Send private message
F_
Tux's lil' helper
Tux's lil' helper


Joined: 31 Dec 2006
Posts: 102

PostPosted: Thu Aug 25, 2011 1:34 pm    Post subject: Reply with quote

Fixed the problem.

The problem was my edits to mpd.conf weren't taking any effect because there was a previously running mpd instance from when I ran "mpd --verbose" trying to figure out how to get sound. Apparently it didn't close. Had to kill it, and once I did that my mpd.conf settings came into effect when I reran "/etc/init.d/mpd start".
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum