Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Solaris 10: binutils does not include the RPATH by default
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on Alternative Architectures
View previous topic :: View next topic  
Author Message
keymon
n00b
n00b


Joined: 02 Aug 2011
Posts: 7

PostPosted: Tue Aug 16, 2011 7:05 pm    Post subject: Solaris 10: binutils does not include the RPATH by default Reply with quote

I do not know what happened in my prefix, but now I am unable to emerge binaries that include the RPATH variable.

I bootstraped the system with binutils 2.19, but by accident I tried to compile 2.20. 2.20 failed and I couldn't compile anymore, so I recompiled the 2.19 version using the bootstraped binaries. After that I got binutils 2.19

But now all the packages that I compile does not include the RPATH variable, forcing me to set LD_LIBRARY_PATH.

For instance:

Code:
0x0000000f (RPATH)                      Library rpath: [/eprefix/SunOS-i386/gentoo/usr/lib:/eprefix/SunOS-i386/gentoo/lib:/eprefix/SunOS-i386/gentoo/tmp/usr/lib:/eprefix/SunOS-i386/gentoo/usr/i386-pc-solaris2.10/lib/gcc:/eprefix/SunOS-i386/gentoo/usr/i386-pc-solaris2.10/lib:/eprefix/SunOS-i386/gentoo/lib:/eprefix/SunOS-i386/gentoo/usr/lib]
 0x0000001d (RUNPATH)                    Library runpath: [/eprefix/SunOS-i386/gentoo/usr/lib:/eprefix/SunOS-i386/gentoo/lib:/eprefix/SunOS-i386/gentoo/tmp/usr/lib:/eprefix/SunOS-i386/gentoo/usr/i386-pc-solaris2.10/lib/gcc:/eprefix/SunOS-i386/gentoo/usr/i386-pc-solaris2.10/lib:/eprefix/SunOS-i386/gentoo/lib:/eprefix/SunOS-i386/gentoo/usr/lib]


If I do this:

Code:
LD_RUN_PATH=/eprefix/SunOS-i386/gentoo/usr/lib:/eprefix/SunOS-i386/gentoo/lib:/eprefix/SunOS-i386/gentoo/tmp/usr/lib:/eprefix/SunOS-i386/gentoo/usr/i386-pc-solaris2.10/lib/gcc:/eprefix/SunOS-i386/gentoo/usr/i386-pc-solaris2.10/lib:/eprefix/SunOS-i386/gentoo/lib:/eprefix/SunOS-i386/gentoo/usr/lib emerge less


it works

What I am doing wrong? What should I touch to fix it?
Back to top
View user's profile Send private message
keymon
n00b
n00b


Joined: 02 Aug 2011
Posts: 7

PostPosted: Tue Aug 16, 2011 9:12 pm    Post subject: Just recompile all Reply with quote

I do not know what I did, but recompiling all the packages again with a properly initialized environment solved the problem.

I just had to set LD_LIBRARY_PATH to allow the binutils work, but after rebuild them, I was ok.

I still do not know where this default rpath is defined.
Back to top
View user's profile Send private message
grobian
Developer
Developer


Joined: 31 May 2006
Posts: 63

PostPosted: Sun Dec 04, 2011 7:39 pm    Post subject: Reply with quote

rpaths are added by the ld wrapper (binutils-config)

You may have not used the prefix gcc somehow.
_________________
Gentoo on a different level
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on Alternative Architectures All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum