Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[RISOLTO]Gentoo trasferita sul disco usb
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) Forum di discussione italiano
View previous topic :: View next topic  
Author Message
saverik1967
n00b
n00b


Joined: 21 Jul 2011
Posts: 27

PostPosted: Wed Aug 03, 2011 10:03 am    Post subject: [RISOLTO]Gentoo trasferita sul disco usb Reply with quote

Allora...
ho smontato il mio disco sata dal mio notebook e ne ho messo u 'altro con il suo sistema operativo e tutto..(purtroppo devo usarci wzzz perche non lo uso da solo).
Visto che per metterci las mia gentoo ci h impiegato 3 sett(sono veramente alle prime armi)per renderla funzionante, ho messo il sata nel usb e volevo far partire la mia gentoo da usb!!!!
Con mio disappunto(qualcunio dira' normale)mi ha dato un kernel panic etc..allora ho riconfigurato il fstab e il lilo.conf sodtituendo sda con sdb etc... ma mi vs lo stesso in panic..
qualcuno che mi illumuna...?
Ho giaprovato con goole etc, ma dopo la millesima guida mi sono arreso.. e vi chiedo aiuto!!!
come faccio a farla partire da usb e sopratutto a farla funzionare da usb senza rovinare il resto?
Spero di essere stato chiaro.. :oops:
grazie
_________________
Notebook 13,3"Hpdm310 core2 1,3ghz 4gbram nvidia105m(512Mb) hd500gb GentooAmd2.6.39-r3


Last edited by saverik1967 on Wed Aug 17, 2011 9:40 am; edited 1 time in total
Back to top
View user's profile Send private message
k01
Arch/Herd Tester
Arch/Herd Tester


Joined: 13 Feb 2008
Posts: 617
Location: Milano

PostPosted: Wed Aug 03, 2011 12:49 pm    Post subject: Reply with quote

postare anche gli errori specifici sarebbe di grande aiuto per risolvere il problema, in ogni caso il problema più generale dell'avere la partizione di root su usb è che al momento del boot le periferiche usb non sono ancora pronte, quindi si deve aggiungere l'opzione rootdelay da passare all'avvio

in ogni caso prova a seguire questo topic: http://forums.gentoo.org/viewtopic-t-887336.html

se ancora c'è qualcosa che non va riporta l'errore specifico
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4728
Location: not so far from an evil, world famous volcano. Under dictatorship, idiocracy, property of banks...

PostPosted: Fri Aug 05, 2011 12:07 pm    Post subject: Reply with quote

Se hai usato genkernel con la sua initrd ti basta impostare real_root= e dovrebbe andare tutto bene ma farei attenzione al contenuto di /etc/mtab cancellerei (da live) /etc/mtab.*.
Non mi sono mai chiesto se sia stato risolto ma c'era una volta un problemino con le periferiche "statiche" quindi in /etc/udev/rules.d potrebbe esserci una ulteriore causa di problemi.
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
saverik1967
n00b
n00b


Joined: 21 Jul 2011
Posts: 27

PostPosted: Wed Aug 17, 2011 9:39 am    Post subject: Reply with quote

ho spostato il tutto sul disco interno in dual boot...
mooolto piu' comodo smanettarci...
grazie di tutto
_________________
Notebook 13,3"Hpdm310 core2 1,3ghz 4gbram nvidia105m(512Mb) hd500gb GentooAmd2.6.39-r3
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) Forum di discussione italiano All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum