Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Can't install crosscompiler
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
phoenix_me
Apprentice
Apprentice


Joined: 24 Dec 2003
Posts: 281
Location: Lubliniec

PostPosted: Mon Aug 15, 2011 10:47 am    Post subject: [SOLVED] Can't install crosscompiler Reply with quote

I am trying to install crosscompiler but so far without success. I am stuck on first step.
After:
Code:
crossdev --b 2.19 --g 3.4.4 --k 2.6.12.6 --l 2.6 armv5tel-softfloat-linux-gnueabi

I have error
Code:
* glibc failed :(
 * If you file a bug, please attach the following logfiles:
 * /var/log/portage/cross-armv5tel-softfloat-linux-gnueabi-info.log
 * /var/log/portage/cross-armv5tel-softfloat-linux-gnueabi-glibc-headers.log

and log is showing
Code:
checking sysdep dirs... configure: error: The armv5tel is not supported.


What's wrong?
_________________
phoenix
___
myslenie ma przyszlosc
___


Last edited by phoenix_me on Mon Aug 15, 2011 6:36 pm; edited 1 time in total
Back to top
View user's profile Send private message
DaggyStyle
Advocate
Advocate


Joined: 22 Mar 2006
Posts: 4941

PostPosted: Mon Aug 15, 2011 10:59 am    Post subject: Reply with quote

are you sure that the glibc you choose is compatible with this arch?
_________________
Only two things are infinite, the universe and human stupidity and I'm not sure about the former - Albert Einstein
ProjectFootball
Back to top
View user's profile Send private message
phoenix_me
Apprentice
Apprentice


Joined: 24 Dec 2003
Posts: 281
Location: Lubliniec

PostPosted: Mon Aug 15, 2011 12:29 pm    Post subject: Reply with quote

DaggyStyle wrote:
are you sure that the glibc you choose is compatible with this arch?


I was already trying 3 different version of glibc and always have the same error.
_________________
phoenix
___
myslenie ma przyszlosc
___
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5622

PostPosted: Mon Aug 15, 2011 12:38 pm    Post subject: Reply with quote

phoenix_me wrote:
DaggyStyle wrote:
are you sure that the glibc you choose is compatible with this arch?


I was already trying 3 different version of glibc and always have the same error.


Seems to me you've answered a different question then the one asked.

But anyway, that seems to be a configure message, so was there anything interesting in the relevant config.log ?
Back to top
View user's profile Send private message
phoenix_me
Apprentice
Apprentice


Joined: 24 Dec 2003
Posts: 281
Location: Lubliniec

PostPosted: Mon Aug 15, 2011 12:57 pm    Post subject: Reply with quote

VoidMage wrote:
phoenix_me wrote:
DaggyStyle wrote:
are you sure that the glibc you choose is compatible with this arch?


I was already trying 3 different version of glibc and always have the same error.


Seems to me you've answered a different question then the one asked.

But anyway, that seems to be a configure message, so was there anything interesting in the relevant config.log ?


I think I answered the right question. What I mean is that I was trying a three different versions of glibc to compile using crossdev. So it is nearly impossibly that none of this version in not supporting my arch.

What I found is that a glibc-ports is missing and this is a problem. But how can I force glibc to to use glibc-ports as a part of glibc installation? It should be a task for crossdev to select appriopriate architecture based on the TARGET parameter.

Code:
crossdev --b 2.19 --g 3.4.4 --k 2.6.12.6 --l 2.6 -t armv5tel-softfloat-linux-gnueabi
------------------------------------------------------------------------------------------------------------------------------
 * crossdev version:      20110705
 * Host Portage ARCH:     amd64
 * Target Portage ARCH:   arm
 * Target System:         armv5tel-softfloat-linux-gnueabi
 * Stage:                 4 (C/C++ compiler)
 * ABIs:                  default

 * binutils:              binutils-2.19
 * gcc:                   gcc-3.4.4
 * headers:               linux-headers-2.6.12.6
 * libc:                  glibc-2.6

 * PORTDIR_OVERLAY:       /usr/local/portage
 * PORT_LOGDIR:           /var/log/portage
 * PORTAGE_CONFIGROOT:

_________________
phoenix
___
myslenie ma przyszlosc
___
Back to top
View user's profile Send private message
DaggyStyle
Advocate
Advocate


Joined: 22 Mar 2006
Posts: 4941

PostPosted: Mon Aug 15, 2011 4:07 pm    Post subject: Reply with quote

phoenix_me wrote:
VoidMage wrote:
phoenix_me wrote:
DaggyStyle wrote:
are you sure that the glibc you choose is compatible with this arch?


I was already trying 3 different version of glibc and always have the same error.


Seems to me you've answered a different question then the one asked.

But anyway, that seems to be a configure message, so was there anything interesting in the relevant config.log ?


I think I answered the right question. What I mean is that I was trying a three different versions of glibc to compile using crossdev. So it is nearly impossibly that none of this version in not supporting my arch.

What I found is that a glibc-ports is missing and this is a problem. But how can I force glibc to to use glibc-ports as a part of glibc installation? It should be a task for crossdev to select appriopriate architecture based on the TARGET parameter.

Code:
crossdev --b 2.19 --g 3.4.4 --k 2.6.12.6 --l 2.6 -t armv5tel-softfloat-linux-gnueabi
------------------------------------------------------------------------------------------------------------------------------
 * crossdev version:      20110705
 * Host Portage ARCH:     amd64
 * Target Portage ARCH:   arm
 * Target System:         armv5tel-softfloat-linux-gnueabi
 * Stage:                 4 (C/C++ compiler)
 * ABIs:                  default

 * binutils:              binutils-2.19
 * gcc:                   gcc-3.4.4
 * headers:               linux-headers-2.6.12.6
 * libc:                  glibc-2.6

 * PORTDIR_OVERLAY:       /usr/local/portage
 * PORT_LOGDIR:           /var/log/portage
 * PORTAGE_CONFIGROOT:


no, you did not answered my question, I asked if the version you tried is compatible with arch for which you are trying to create the crosscompiler too.
_________________
Only two things are infinite, the universe and human stupidity and I'm not sure about the former - Albert Einstein
ProjectFootball
Back to top
View user's profile Send private message
phoenix_me
Apprentice
Apprentice


Joined: 24 Dec 2003
Posts: 281
Location: Lubliniec

PostPosted: Mon Aug 15, 2011 6:35 pm    Post subject: Reply with quote

I deleted whole configuration. Using crossdev -C arch and I created it using latest glibc gcc kernel binutils and it is working right now. Seems like crossdev have some issue with older version of glibc (i.e. 2.6).
Thanks for helping me.
_________________
phoenix
___
myslenie ma przyszlosc
___
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum