Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Wireless] Realtek no me permite inyectar paquetes
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
Diabliyo
Guru
Guru


Joined: 12 May 2008
Posts: 383
Location: Mexico

PostPosted: Thu Feb 23, 2012 8:59 pm    Post subject: [Wireless] Realtek no me permite inyectar paquetes Reply with quote

Buenas...

Tengo una lap con chipset inalámbrico Realtek, carga el modulo r8192ce_pci, es reconocida como wlan0:

# lspci -vv
Code:
Network controller: Realtek Semiconductor Co., Ltd. Device 8176 (rev 01)
   Subsystem: Hewlett-Packard Company Device 1629
   Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
   Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
   Latency: 0, Cache Line Size: 64 bytes
   Interrupt: pin A routed to IRQ 17
   Region 0: I/O ports at 3000 [size=256]
   Region 2: Memory at f0200000 (64-bit, non-prefetchable) [size=16K]
   Capabilities: [40] Power Management version 3
      Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=375mA PME(D0+,D1+,D2+,D3hot+,D3cold+)
      Status: D0 PME-Enable- DSel=0 DScale=0 PME-
   Capabilities: [50] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-
      Address: 0000000000000000  Data: 0000
   Capabilities: [70] Express (v2) Endpoint, MSI 00
      DevCap:   MaxPayload 128 bytes, PhantFunc 0, Latency L0s <512ns, L1 <64us
         ExtTag- AttnBtn- AttnInd- PwrInd- RBE+ FLReset-
      DevCtl:   Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
         RlxdOrd+ ExtTag- PhantFunc- AuxPwr- NoSnoop-
         MaxPayload 128 bytes, MaxReadReq 512 bytes
      DevSta:   CorrErr+ UncorrErr- FatalErr- UnsuppReq+ AuxPwr+ TransPend-
      LnkCap:   Port #0, Speed 2.5GT/s, Width x1, ASPM L0s L1, Latency L0 <512ns, L1 <64us
         ClockPM+ Suprise- LLActRep- BwNot-
      LnkCtl:   ASPM L0s L1 Enabled; RCB 64 bytes Disabled- Retrain- CommClk+
         ExtSynch- ClockPM+ AutWidDis- BWInt- AutBWInt-
      LnkSta:   Speed 2.5GT/s, Width x1, TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
   Capabilities: [100] Advanced Error Reporting <?>
   Capabilities: [140] Virtual Channel <?>
   Capabilities: [160] Device Serial Number xx-xx-xx-xx-xx-xx-xx-xx
   Kernel driver in use: rtl8192CE
   Kernel modules: r8192ce_pci


Cuando pongo la inalámbrica en modo Monior, ya sea manualmente o con airmon-ng start wlan0 y despues invocar la captura con airodump-ng simplemente no consigo Paquetes #DATA, ademas tras ejecutar algun ataque con aireplay-ng (con -3 -1) no me inyecta los paquetes :(.

Y ya comprobé que no sea problema de que los APs se esten protegiendo o no respondan, porque si conecto una USB Wireless con chipset atheros, rápidamente puedo ver como la inyección en repetición arp's (ataque -3), empieza a generar paquetes inyectados y los #DATA incrementan rápidamente.

Otro detalle es que el airmon-ng no me crea la interface mon0.

Saludos !
Back to top
View user's profile Send private message
esteban_conde
Veteran
Veteran


Joined: 04 Jun 2003
Posts: 1509

PostPosted: Fri Feb 24, 2012 10:26 am    Post subject: Reply with quote

Prueba con otro kernel aunque no consigas la misma eficacia que con una tarjeta atheros en parte debido a la antena deberia crearte mon0 correctamente o wlan0-mon0.
Mi antena es mucho más vieja que la tuya
Quote:
RaLink RT2500 802.11g Cardbus/mini-PCI (rev 01)
y con un kernel 2.6.32-gentoo-r7 me crea perfectamente mon0 con otros recuerdo que me creaba ra0-mon0.
Aunque no inyecte me parece recordar que se obtenian resultados.
_________________
Saludos a tod@s, Esteban.
Back to top
View user's profile Send private message
Diabliyo
Guru
Guru


Joined: 12 May 2008
Posts: 383
Location: Mexico

PostPosted: Fri Feb 24, 2012 2:57 pm    Post subject: Reply with quote

Voy a checar cambiando el kernel, gracias por el dato.....
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum