Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
help installing odesk team application version 3.2.13
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
tyrinslys
n00b
n00b


Joined: 10 Aug 2011
Posts: 3

PostPosted: Wed Aug 10, 2011 7:13 pm    Post subject: help installing odesk team application version 3.2.13 Reply with quote

Has anyone had luck with installing odesk 3.2.13 on their gentoo system?

if I do an 'ldd odeskteam-qt4" I get:

Code:

odeskteam-qt4: /usr/lib/libcrypto.so.0.9.8: no version information available (required by odeskteam-qt4)
        linux-gate.so.1 =>  (0xb770b000)
        libgstvideo-0.10.so.0 => /usr/lib/libgstvideo-0.10.so.0 (0xb76fe000)
        libgstinterfaces-0.10.so.0 => /usr/lib/libgstinterfaces-0.10.so.0 (0xb76ee000)
        libgstreamer-0.10.so.0 => /usr/lib/libgstreamer-0.10.so.0 (0xb762b000)
        libXss.so.1 => /usr/lib/libXss.so.1 (0xb7627000)
        libxml2.so.2 => /usr/lib/libxml2.so.2 (0xb750b000)
        libbz2.so.1.0 => not found
        libtar.so.0 => /usr/lib/libtar.so.0 (0xb74e9000)
        libX11.so.6 => /usr/lib/libX11.so.6 (0xb73cf000)
        libXext.so.6 => /usr/lib/libXext.so.6 (0xb73c0000)
        libgtk-x11-2.0.so.0 => /usr/lib/libgtk-x11-2.0.so.0 (0xb7020000)
        libgdk-x11-2.0.so.0 => /usr/lib/libgdk-x11-2.0.so.0 (0xb6f8d000)
        libatk-1.0.so.0 => /usr/lib/libatk-1.0.so.0 (0xb6f72000)
        libgio-2.0.so.0 => /usr/lib/libgio-2.0.so.0 (0xb6e94000)
        libpangoft2-1.0.so.0 => /usr/lib/libpangoft2-1.0.so.0 (0xb6e6e000)
        libpangocairo-1.0.so.0 => /usr/lib/libpangocairo-1.0.so.0 (0xb6e61000)
        libgdk_pixbuf-2.0.so.0 => /usr/lib/libgdk_pixbuf-2.0.so.0 (0xb6e47000)
        libcairo.so.2 => /usr/lib/libcairo.so.2 (0xb6da3000)
        libpango-1.0.so.0 => /usr/lib/libpango-1.0.so.0 (0xb6d61000)
        libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0xb6cdd000)
        libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0xb6cae000)
        libgobject-2.0.so.0 => /usr/lib/libgobject-2.0.so.0 (0xb6c6e000)
        libgmodule-2.0.so.0 => /usr/lib/libgmodule-2.0.so.0 (0xb6c69000)
        libgthread-2.0.so.0 => /usr/lib/libgthread-2.0.so.0 (0xb6c64000)
        librt.so.1 => /lib/librt.so.1 (0xb6c5b000)
        libglib-2.0.so.0 => /usr/lib/libglib-2.0.so.0 (0xb6b72000)
        libcrypto.so.0.9.8 => /usr/lib/libcrypto.so.0.9.8 (0xb6a30000)
        libnotify.so.1 => not found
        libdbus-glib-1.so.2 => /usr/lib/libdbus-glib-1.so.2 (0xb6a0e000)
        libm.so.6 => /lib/libm.so.6 (0xb69e8000)
        libdbus-1.so.3 => /usr/lib/libdbus-1.so.3 (0xb69ad000)
        libQtDBus.so.4 => /usr/lib/qt4/libQtDBus.so.4 (0xb6936000)
        libQtXml.so.4 => /usr/lib/qt4/libQtXml.so.4 (0xb68f1000)
        libQtGui.so.4 => /usr/lib/qt4/libQtGui.so.4 (0xb5e9e000)
        libQtNetwork.so.4 => /usr/lib/qt4/libQtNetwork.so.4 (0xb5d75000)
        libQtCore.so.4 => /usr/lib/qt4/libQtCore.so.4 (0xb5afc000)
        libpthread.so.0 => /lib/libpthread.so.0 (0xb5ae3000)
        libstdc++.so.6 => /usr/lib/gcc/i686-pc-linux-gnu/4.4.5/libstdc++.so.6 (0xb59ef000)
        libgcc_s.so.1 => /lib/libgcc_s.so.1 (0xb59d3000)
        libc.so.6 => /lib/libc.so.6 (0xb588d000)
        libgstbase-0.10.so.0 => /usr/lib/libgstbase-0.10.so.0 (0xb584a000)
        libdl.so.2 => /lib/libdl.so.2 (0xb5846000)
        libicuuc.so.46 => /usr/lib/libicuuc.so.46 (0xb570d000)
        libz.so.1 => /lib/libz.so.1 (0xb56f8000)
        libxcb.so.1 => /usr/lib/libxcb.so.1 (0xb56dd000)
        libXfixes.so.3 => /usr/lib/libXfixes.so.3 (0xb56d6000)
        libXi.so.6 => /usr/lib/libXi.so.6 (0xb56c8000)
        libXrandr.so.2 => /usr/lib/libXrandr.so.2 (0xb56c0000)
        libXcursor.so.1 => /usr/lib/libXcursor.so.1 (0xb56b6000)
        libXcomposite.so.1 => /usr/lib/libXcomposite.so.1 (0xb56b2000)
        libXdamage.so.1 => /usr/lib/libXdamage.so.1 (0xb56ad000)
        libXrender.so.1 => /usr/lib/libXrender.so.1 (0xb56a3000)
        libresolv.so.2 => /lib/libresolv.so.2 (0xb568f000)
        libexpat.so.1 => /usr/lib/libexpat.so.1 (0xb5669000)
        libpixman-1.so.0 => /usr/lib/libpixman-1.so.0 (0xb560d000)
        libpng14.so.14 => /usr/lib/libpng14.so.14 (0xb55e8000)
        libXau.so.6 => /usr/lib/libXau.so.6 (0xb55e4000)
        libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0xb55de000)
        /lib/ld-linux.so.2 (0xb770c000)
        libEGL.so.1 => /usr/lib/libEGL.so.1 (0xb55cf000)
        libSM.so.6 => /usr/lib/libSM.so.6 (0xb55c5000)
        libICE.so.6 => /usr/lib/libICE.so.6 (0xb55ad000)
        libicudata.so.46 => /usr/lib/libicudata.so.46 (0xb4739000)
        libuuid.so.1 => /lib/libuuid.so.1 (0xb4734000)


I have already had to emerge gstreamer, gst-plugin-xvideo, libtar, and libnotify to get this far[/code].

I don't know what do do about "/usr/lib/libcrypto.so.0.9.8: no version information available" or "libbz2.so.1.0 => not found" or "libnotify.so.1 => not found"

I installed libnotify, but that didn't satisfy the ldd tool.

any suggestions?
Back to top
View user's profile Send private message
tyrinslys
n00b
n00b


Joined: 10 Aug 2011
Posts: 3

PostPosted: Thu Aug 11, 2011 12:52 am    Post subject: Reply with quote

In case anyone is wondering the software can be downloaded from this link

https://www.odesk.com/downloads
Back to top
View user's profile Send private message
tyrinslys
n00b
n00b


Joined: 10 Aug 2011
Posts: 3

PostPosted: Tue Aug 16, 2011 4:43 pm    Post subject: Reply with quote

I figured this one out, and am answering it for others...
I had to install gstreamer, gst-plugins-base, libtar, libnotify

then, I had to make a symbolic link to the libbz2

Code:
ln -s /lib/libbz2.so.1 /usr/lib/libbz2.so.1.0


this gives "undefined symbol: _ZN9QListData11detach_growEPii" if you don't have qt-core-4.7.xx installed.

after installing the new qt-core it works.

Note: not sure if it is good/bad to create a manual symbolic link the the bz2 library. If anyone has a better suggestion then let me know.
Back to top
View user's profile Send private message
titanofold
Developer
Developer


Joined: 30 Dec 2003
Posts: 228
Location: Bryson City, NC USA

PostPosted: Fri Apr 12, 2013 3:17 pm    Post subject: Reply with quote

odeskteam is actually in Portage now.

Code:
# emerge odeskteam

_________________
The best things in life are free.
Guy-1: Surely, you will fold with me...
Guy-2: Alright, but don't call me Shirley
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum