Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Minecraft won't start, GTK+ 2.x symbols detected
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gamers & Players
View previous topic :: View next topic  
Author Message
linuxpyro
Apprentice
Apprentice


Joined: 08 Sep 2004
Posts: 255

PostPosted: Thu Aug 04, 2011 2:59 am    Post subject: [SOLVED] Minecraft won't start, GTK+ 2.x symbols detected Reply with quote

I have installed Minecraft via the java-overlay (http://forums.gentoo.org/viewtopic-t-857083-start-0.html). However, when I try to start it, I get an error like this:

Code:

Gtk-ERROR **: GTK+ 2.x symbols detected. Using GTK+ 2.x and GTK+ 3 in the same process is not supported
aborting...
Aborted


Interestingly, it starts up fine as root. I have also added my user to the games group. Has anyone seen this before?


Last edited by linuxpyro on Sun Aug 21, 2011 2:26 am; edited 1 time in total
Back to top
View user's profile Send private message
hip2theehop
n00b
n00b


Joined: 25 Jul 2011
Posts: 1
Location: USA

PostPosted: Mon Aug 15, 2011 9:52 pm    Post subject: Reply with quote

There is a linux port on the minecraft web page now. I just noticed this like 2 days ago and it runs very smooth.
Back to top
View user's profile Send private message
linuxpyro
Apprentice
Apprentice


Joined: 08 Sep 2004
Posts: 255

PostPosted: Sun Aug 21, 2011 2:25 am    Post subject: Reply with quote

Alright, I fixed it by using the Sun JDK. I just emerged sun-jdk, and then did eselect java-vm set system 2. I'm not sure what caused it exactly, but that seemed to fix it. I had been having the same problem even after downloading the jar from the Minecraft site.
Back to top
View user's profile Send private message
azp
Guru
Guru


Joined: 16 Nov 2003
Posts: 354
Location: Stockholm, Sweden

PostPosted: Sun Sep 18, 2011 9:20 am    Post subject: GTK+ 2.x symbols detected. Using GTK+ 2.x and GTK+ 3 in the Reply with quote

I have some issues with some programs and games, I'm not quite sure when in started. It complains about GTK2 and GTK3 clashing, for instance when starting Minecraft:

Code:
peter@skare$ ./minecraft.sh
peter@skare$
Gtk-ERROR **: GTK+ 2.x symbols detected. Using GTK+ 2.x and GTK+ 3 in the same process is not supported
aborting...


Since Minecraft is Java based I assume it's not directly related to Minecraft using GTK, but more likely java creating a GTK window automatically, or something like it. Does anybody recognize this error?

I'm on ~amd64, and recently updated my system. I also updated sun-java by fetching it by hand, etc.
_________________
Weeks of coding can save you hours of planning.


Last edited by azp on Sun Sep 18, 2011 9:30 am; edited 1 time in total
Back to top
View user's profile Send private message
azp
Guru
Guru


Joined: 16 Nov 2003
Posts: 354
Location: Stockholm, Sweden

PostPosted: Sun Sep 18, 2011 9:29 am    Post subject: Reply with quote

BTW, I've run revdep-rebuild, dispatch-conf and all those utilities =)

The problem remains if I change my java-vm to icedtea-bin as well.
_________________
Weeks of coding can save you hours of planning.
Back to top
View user's profile Send private message
azp
Guru
Guru


Joined: 16 Nov 2003
Posts: 354
Location: Stockholm, Sweden

PostPosted: Sun Sep 18, 2011 9:33 am    Post subject: Reply with quote

Just found an answer at http://forums.gentoo.org/viewtopic-p-6774446.html

I'm really annoyed by how badly the search function is working in the forum...
_________________
Weeks of coding can save you hours of planning.
Back to top
View user's profile Send private message
azp
Guru
Guru


Joined: 16 Nov 2003
Posts: 354
Location: Stockholm, Sweden

PostPosted: Sun Sep 18, 2011 9:40 am    Post subject: Reply with quote

I have the same issue, but I'm already using the sun-jdk. I will try installing icedtea from source instead of the -bin package I was using, perhaps that will fix it.
_________________
Weeks of coding can save you hours of planning.
Back to top
View user's profile Send private message
azp
Guru
Guru


Joined: 16 Nov 2003
Posts: 354
Location: Stockholm, Sweden

PostPosted: Sun Sep 18, 2011 9:47 am    Post subject: Reply with quote

I fixed the issue be resetting the 'user' vm as well, seems like the system-vm change didn't really catch on.

$ eselect java-vm set user 1

$ eselect java-vm list
Available Java Virtual Machines:
[1] sun-jdk-1.6 system-vm user-vm

Now it works!
_________________
Weeks of coding can save you hours of planning.
Back to top
View user's profile Send private message
tomk
Administrator
Administrator


Joined: 23 Sep 2003
Posts: 7219
Location: Sat in front of my computer

PostPosted: Tue Sep 20, 2011 12:36 pm    Post subject: Reply with quote

Merged from here.
_________________
Search | Read | Answer | Report | Strip
Back to top
View user's profile Send private message
Chewi
l33t
l33t


Joined: 01 Sep 2003
Posts: 789
Location: Edinburgh, Scotland

PostPosted: Sun Sep 25, 2011 1:02 pm    Post subject: Reply with quote

A better workaround is to install cairo with the qt4 USE flag disabled. It's a very strange problem that's catching more and more people out. I first noticed it when trying to use Flash in Opera.
Back to top
View user's profile Send private message
aceFruchtsaft
Guru
Guru


Joined: 16 May 2004
Posts: 438
Location: Vienna, Austria

PostPosted: Sun Oct 23, 2011 9:33 am    Post subject: Reply with quote

Chewi wrote:
A better workaround is to install cairo with the qt4 USE flag disabled. It's a very strange problem that's catching more and more people out. I first noticed it when trying to use Flash in Opera.

Thanks, that actually worked to get jabref running with icedtea.
Back to top
View user's profile Send private message
lyallp
Veteran
Veteran


Joined: 15 Jul 2004
Posts: 1263
Location: Adelaide/Australia

PostPosted: Sat Dec 10, 2011 12:17 am    Post subject: Reply with quote

Strange, cairo is installed with -qt4 and it still fails.
My problem is that the Iced Tea VM complains that the
Code:
Exception in thread "Minecraft main thread" java.lang.UnsatisfiedLinkError: /home/lyall/.minecraft/bin/natives/liblwjgl.so: /home/lyall/.minecraft/bin/natives/liblwjgl.so: wrong ELF class: ELFCLASS32 (Possible cause: architecture word width mismatch)
        at java.lang.ClassLoader$NativeLibrary.load(Native Method)

which, appears to be a more fundamental problem than simply removing qt4 from cairo.

I would prefer to use IcedTea but even the Minecraft web site says 'Please use Sun Java'.
_________________
...Lyall
Back to top
View user's profile Send private message
Chewi
l33t
l33t


Joined: 01 Sep 2003
Posts: 789
Location: Edinburgh, Scotland

PostPosted: Sat Dec 10, 2011 12:25 am    Post subject: Reply with quote

lyallp wrote:
Strange, cairo is installed with -qt4 and it still fails.
My problem is that the Iced Tea VM complains that the
Code:
Exception in thread "Minecraft main thread" java.lang.UnsatisfiedLinkError: /home/lyall/.minecraft/bin/natives/liblwjgl.so: /home/lyall/.minecraft/bin/natives/liblwjgl.so: wrong ELF class: ELFCLASS32 (Possible cause: architecture word width mismatch)
        at java.lang.ClassLoader$NativeLibrary.load(Native Method)

which, appears to be a more fundamental problem than simply removing qt4 from cairo.

I would prefer to use IcedTea but even the Minecraft web site says 'Please use Sun Java'.

That is very different. Are you using my ebuild? If not, please try it. You can use IcedTea, even version 7.

http://forums.gentoo.org/viewtopic-t-857083-start-0.html
Back to top
View user's profile Send private message
bigbangnet
Apprentice
Apprentice


Joined: 11 Jun 2007
Posts: 174

PostPosted: Sat Apr 21, 2012 8:33 pm    Post subject: Reply with quote

Chewi wrote:
A better workaround is to install cairo with the qt4 USE flag disabled. It's a very strange problem that's catching more and more people out. I first noticed it when trying to use Flash in Opera.


This might be a necro thread but Cairo was already installed but I reinstalled it using the qt4 use flag disabled and it actually worked. That fixed my problem.


thank you
_________________
I'm a noob, be gentle with me. TEACH ME
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gamers & Players All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum