Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] XDM (or xorg ?) keyboard layout bug
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
alex6
Tux's lil' helper
Tux's lil' helper


Joined: 18 Jul 2011
Posts: 140

PostPosted: Thu Jul 21, 2011 1:18 am    Post subject: [SOLVED] XDM (or xorg ?) keyboard layout bug Reply with quote

I tried to set my keyboard to the layout "fr" like this :

Quote:
Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
# Option "XkbModel" "pc105"
Option "XkbLayout" "fr"
# Option "XkbVariant" ",multi"
EndSection


...But when I login with gdm or any other logging manager my keyboard is in qwerty...My other tty don't have this problem...
My locales are set to "fr_FR ISO-8859-1"

Does someone understand what's happening ?


Last edited by alex6 on Sat Jul 23, 2011 12:22 am; edited 1 time in total
Back to top
View user's profile Send private message
krinn
Advocate
Advocate


Joined: 02 May 2003
Posts: 4294

PostPosted: Thu Jul 21, 2011 10:10 am    Post subject: Reply with quote

oui

you're using old style xorg.conf to configure your keyboard, this won't work, you need use the new style explain here : http://www.gentoo.org/proj/en/desktop/x/x11/ (lookout for xorg server version you use upgrade guide)

or add this file to your system & it should work (as /etc/X11/xorg.conf.d/97-evdev.conf)
Code:
Section "InputClass"
   Identifier "mouse-all"
        MatchIsPointer "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
        Option "AutoServerLayout" "on"
EndSection

Section "InputClass"
        Identifier "keyboard-all"
        MatchIsKeyboard "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
        Option "XkbLayout" "fr"
        Option "XkbRules"  "xorg"
        Option "XkbModel"  "pc105"
        Option "AutoServerLayout" "on"
EndSection
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5621

PostPosted: Thu Jul 21, 2011 10:40 am    Post subject: Reply with quote

:roll: Once again, setting XkbRules has no point as evdev driver hardcodes it to 'evdev' anyway.
Back to top
View user's profile Send private message
alex6
Tux's lil' helper
Tux's lil' helper


Joined: 18 Jul 2011
Posts: 140

PostPosted: Thu Jul 21, 2011 1:14 pm    Post subject: Reply with quote

Thanks, your config file works :)
I had to create the directory xorg.conf and create the config file which didn't exist...

I love xorg new way : no config file, you have to create it and create several in hidden places that doesn't exist with a new syntax !

I'm a bit melancholic when I remember some years ago when we only had to use a single xorg.conf file which DID exist :D
Back to top
View user's profile Send private message
krinn
Advocate
Advocate


Joined: 02 May 2003
Posts: 4294

PostPosted: Thu Jul 21, 2011 3:10 pm    Post subject: Reply with quote

VoidMage wrote:
:roll: Once again, setting XkbRules has no point as evdev driver hardcodes it to 'evdev' anyway.


well, it work, and no bad effect, you're too perfectionist VoidMage :)
Back to top
View user's profile Send private message
cazort
Guru
Guru


Joined: 19 Sep 2004
Posts: 340
Location: Lancaster, PA

PostPosted: Sat Dec 08, 2012 5:03 pm    Post subject: Reply with quote

I just found this solution and it also worked for me (I was trying to change to dvorak), but I agree with alex6's comment (incidentally, my name is also Alex). It seems a bit counter-intuitive to have to create a new config file in a directory that does not exist, to do something as basic as changing the keyboard layout for xdm.

While I like the new configuration-free xorg overall, the old setup had the advantage that if you needed to change something that required manual configuration, there were examples to work from!
_________________
Alex Zorach | Teacology | RateTea | Why This Way
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum