Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] Missing dependencies in the kernel
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
Le Farfadet Spatial
n00b
n00b


Joined: 03 Jan 2011
Posts: 70

PostPosted: Sat Jul 16, 2011 12:02 pm    Post subject: [Solved] Missing dependencies in the kernel Reply with quote

Hello everybody out there!

After more than ten years using Linux, it is the first time I compile a kernel! Well, as it is the first time, I have some troubles. Not that many, in fact.

I have done "emerge gentoo-sources". After leaving "make menuconfig", I get the following warnings:

Code:

warning: (SCHED_AUTOGROUP) selects CGROUP_SCHED which has unmet direct dependencies (CGROUPS && EXPERIMENTAL)
warning: (ACPI_HOTPLUG_CPU) selects ACPI_CONTAINER which has unmet direct dependencies (ACPI && EXPERIMENTAL)
warning: (MEDIA_TUNER) selects MEDIA_TUNER_TEA5761 which has unmet direct dependencies (MEDIA_SUPPORT && VIDEO_MEDIA && I2C && EXPERIMENTAL)


All the hardware is a brand new one, and I do not want anything experimental in this kernel. Therefore, I do not want to enable "EXPERIMENTAL", and I need to deselect those options. The trouble is, I do not want to directly change ".config" (comments explicitly tell not to do so anyway), and I have some trouble to find out the options into "menuconfig".

After a long while, I have finally found out that "SCHED_AUTOGROUP" stands for "General setup --> Automatic process group scheduling," and I have disabled it. But, after long searching, I have not been able to find out what "ACPI_HOTPLUG_CPU" and "MEDIA_TUNER" stand for. Can somebody help me?

Best regards.

The Spacial Sprite


Last edited by Le Farfadet Spatial on Mon Jul 18, 2011 6:33 pm; edited 2 times in total
Back to top
View user's profile Send private message
Aquous
l33t
l33t


Joined: 08 Jan 2011
Posts: 647

PostPosted: Sat Jul 16, 2011 12:31 pm    Post subject: Reply with quote

Press / in menuconfig to enter search mode.
Back to top
View user's profile Send private message
Le Farfadet Spatial
n00b
n00b


Joined: 03 Jan 2011
Posts: 70

PostPosted: Sat Jul 16, 2011 4:22 pm    Post subject: Reply with quote

Hello everybody out there!

Aquous wrote:
Press / in menuconfig to enter search mode.


Thank you. Indeed, pressing "/," I can make some search for configure string. Anyway, I still have some trouble localising either "ACPI_HOTPLUG_CPU" or "MEDIA_TUNER". The search result does not give any location for them, as if they are located in the main menu (Kernel Configuration). Though, I cannot find any corresponding option in the main menu. It seems like these options are hidden until you select an option, but I do not know what option will make them appear. I have tried to enable "Prompt for development and/or incomplete code/drivers" (EXPERIMENTAL), but it did not make them appear.

Best regards.

The Spacial Sprite
Back to top
View user's profile Send private message
Hu
Watchman
Watchman


Joined: 06 Mar 2007
Posts: 9125

PostPosted: Sat Jul 16, 2011 4:51 pm    Post subject: Reply with quote

Some options are not directly available to the user, and are instead used to aggregate other settings. You did not specify the kernel version you are using, but I can point you in the general direction.
drivers/acpi/Kconfig:
config ACPI_HOTPLUG_CPU
   bool
   depends on ACPI_PROCESSOR && HOTPLUG_CPU
   select ACPI_CONTAINER
   default y
drivers/media/common/tuners/Kconfig:
config MEDIA_TUNER
   tristate
   default VIDEO_MEDIA && I2C
   depends on VIDEO_MEDIA && I2C
   select MEDIA_TUNER_XC2028 if !MEDIA_TUNER_CUSTOMISE
   select MEDIA_TUNER_XC5000 if !MEDIA_TUNER_CUSTOMISE
   select MEDIA_TUNER_MT20XX if !MEDIA_TUNER_CUSTOMISE
   select MEDIA_TUNER_TDA8290 if !MEDIA_TUNER_CUSTOMISE
   select MEDIA_TUNER_TEA5761 if !MEDIA_TUNER_CUSTOMISE
   select MEDIA_TUNER_TEA5767 if !MEDIA_TUNER_CUSTOMISE
   select MEDIA_TUNER_SIMPLE if !MEDIA_TUNER_CUSTOMISE
   select MEDIA_TUNER_TDA9887 if !MEDIA_TUNER_CUSTOMISE
   select MEDIA_TUNER_MC44S803 if !MEDIA_TUNER_CUSTOMISE
Back to top
View user's profile Send private message
Le Farfadet Spatial
n00b
n00b


Joined: 03 Jan 2011
Posts: 70

PostPosted: Sat Jul 16, 2011 7:33 pm    Post subject: Reply with quote

Hello everybody out there.

Hu wrote:

Some options are not directly available to the user, and are instead used to aggregate other settings.


If I understand well, it means that I need to deselect "ACPI_PROCESSOR," "HOTPLUG_CPU," "VIDEO_MEDIA" and "I2C," needn’t I? Well, actually I want to only deselect experimental stuff. I guess there is a way to know what is experimental and what is not experimental. The question is: what is that way?

Quote:

You did not specify the kernel version you are using


2.6.38

Regards.

The Spacial Sprite
Back to top
View user's profile Send private message
Le Farfadet Spatial
n00b
n00b


Joined: 03 Jan 2011
Posts: 70

PostPosted: Sat Jul 16, 2011 10:46 pm    Post subject: Reply with quote

Hello everybody out there!

When "EXPERIMENTAL" is not enable, I cannot find "ACPI_CONTAINER." When "EXPERIMENTAL" is enable, then I can find "ACPI_CONTAINER", but I can only either build it in or modularised it, I cannot disable it. Tell me if I am mistaken, as it seems that I have to choose between some experimental support of ACPI or no ACPI at all. Some ACPI support can be useful, so I have enabled "EXPERIMENTAL" and modularised "ACPI_CONTAINER." At least, I can hope being able to unload the module if I get some trouble with it.

Anyway, with this configuration, I have no more missing dependencies, I can boot this kernel with no error message and I do not have any trouble while running it. So far …

Before I turn this thread as resolved, is it possible to confirm with you that my understanding is correct?

Regards.

The Spacial Sprite
Back to top
View user's profile Send private message
Le Farfadet Spatial
n00b
n00b


Joined: 03 Jan 2011
Posts: 70

PostPosted: Mon Jul 18, 2011 6:32 pm    Post subject: Reply with quote

Hello everybody out there!

I guess that nobody giving any answer either means that I have understood well or nobody can give me any more information. I set this thread as solved, thank you.

Best regards.

The Spacial Sprite
Back to top
View user's profile Send private message
Punchcutter
Apprentice
Apprentice


Joined: 11 Feb 2007
Posts: 233

PostPosted: Sun Sep 25, 2011 11:37 pm    Post subject: Reply with quote

I'm just compiling gentoo-sources 2.6.39-r3, and running into these troubles. Thanks to those on this thread for helping me find my way around. What I found regarding the MEDIA_TUNER stuff was that I had to enable Customize analog and hybrid tuner modules to build, then go into the tuners subscreen, where everything was turned on (as modules). If I turned them all off, then went up a level and turned off the aforementioned customization category, after I exited menuconfig, everything would be returned to the original state (with all the device modules turned on). So what I did was turn off all the individual device modules but left Customize analog and hybrid tuner modules to build activated. In this way, the device modules appear to remain turned off.

As for the CPU hotplugging problem, I found (similarly), that if I turn on EXPERIMENTAL in order to modularize the CONTAINER (change to M), and then try to turn off EXPERIMENTAL again, the CONTAINER is reverted to Y. I have decided to accept this state of affairs, rather than leave EXPERIMENTAL turned on.

I hope these problems are temporary quirks in this particular kernel version, or series, and that they will go away in later versions.
Back to top
View user's profile Send private message
genterminl
Guru
Guru


Joined: 12 Feb 2005
Posts: 341
Location: Connecticut, USA

PostPosted: Mon Nov 14, 2011 8:14 pm    Post subject: Reply with quote

I'm still seeing the same issue trying to configure MEDIA_TUNER in 3.0.6. I do not remember seeing these issues previously, and I'm now running 2.6.39-r3 (gentoo-sources)
Back to top
View user's profile Send private message
robinmarlow
Apprentice
Apprentice


Joined: 10 Mar 2004
Posts: 164

PostPosted: Tue Oct 09, 2012 9:28 pm    Post subject: Reply with quote

In case anyone else finds this through google, I just met a similar issue with kernel 3.6.1

had the error:
warning: (VIDEO_EM28XX && VIDEO_PVRUSB2 && VIDEO_TLG2300 && VIDEO_CX231XX && VIDEO_TM6000 && VIDEO_USBVISION && VIDEO_BT848 && VIDEO_CX18 && VIDEO_CX23885 && VIDEO_CX88 && VIDEO_IVTV && VIDEO_MXB && VIDEO_SAA7134 && VIDEO_SAA7164 && VIDEO_GO7007) selects VIDEO_TUNER which has unmet direct dependencies (MEDIA_SUPPORT && MEDIA_TUNER)

but couldn't understand how to enable MEDIA_TUNER

I eventually found that even though I'm just using DVB cards I needed to enable

CONFIG_MEDIA_ANALOG_TV_SUPPORT

as hidden within the notes were:
"Note: There are several DVB cards that are based on chips that support both analog and digital TV. Disabling this option will disable support for them."

Robin
Back to top
View user's profile Send private message
tld
l33t
l33t


Joined: 09 Dec 2003
Posts: 863

PostPosted: Thu Dec 05, 2013 2:59 pm    Post subject: Reply with quote

Wow...thanks for this one. For reasons I can't imagine, I just ran into this for the first time upgrading from linux-3.10.7-gentoo to linux-3.10.17-gentoo. I'm sure it never came up before. Not a clue why it didn't come up earlier.

In my case it's on a system using CX88 (pcHDTV HD-5500) cards. I just checked my old (3.10.7) .config and it's definitely disabled:

Code:
# CONFIG_MEDIA_ANALOG_TV_SUPPORT is not set


I only use digital TV, but I clearly recall something I had to enable around analog in order to support the card at all, but it clearly wasn't this. Strange one.

Tom
Back to top
View user's profile Send private message
robinmarlow
Apprentice
Apprentice


Joined: 10 Mar 2004
Posts: 164

PostPosted: Thu Dec 05, 2013 3:00 pm    Post subject: Reply with quote

Glad to help!

Robin
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum