Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Conky Not Showing On XFCE4 Desktop
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
sq1rl
n00b
n00b


Joined: 09 Apr 2014
Posts: 6
Location: US

PostPosted: Wed Apr 09, 2014 6:43 am    Post subject: Conky Not Showing On XFCE4 Desktop Reply with quote

shows only in terminal:
http://i.imgur.com/KunnAKe.png
before it loads one of the errors i get is:
Conky: not implemented obj type 15
then same error with different numbers...
here's the conky:
Code:
#========================================================================
#
# original author: Salem-Tunisia
# edited by: sq1rl/04.08.14
# emerge conky, lm-sensors
# sensors-detect (choose YES to all)
# service module-init-tools start
# conky
# possible tweakz to get transparency ok:
# “own_window_type normal”
# “own_window_type override”
# "own_window_type desktop"
# "own_window_argb_visual"
# you may have to change your root background
# i copied new background made the size same
# changed it to originalz format rebooted
# this is the startup script, place it in /etc/conky/
#-------------------
# #! /bin/sh -e
#sleep 5
#conky
#exit 0
#-------------------
# you may have to add it to startupz -command: /etc/conky/conky-startup.sh
# or just "conky" for the command ;)
#=========================================================================

background yes
update_interval 1
total_run_times 0

cpu_avg_samples 1
net_avg_samples 2
temperature_unit celsius

double_buffer yes
no_buffers yes
text_buffer_size 2048

gap_x 1340
gap_y 30
minimum_size 200 600
maximum_width 320
own_window yes
own_window_argb_visual
own_window_transparent yes
own_window_hints undecorate,sticky,skip_taskbar,skip_pager,below
border_inner_margin 0
border_outer_margin 0
#alignment tr

draw_shades yes
draw_outline yes
draw_borders no
draw_graph_borders yes

override_utf8_locale yes
use_xft yes
xftfont monospace:size=8
xftalpha 0.5
uppercase no
temperature_unit celsius

default_color 00EBFF
color0 00EBFF   
color1 BEBEBE   
color2 00EBFF   
color3 00EBFF
color4 00EBFF   
color5 BEBEBE
color6 BEBEBE
color7 BEBEBE
color8 BEBEBE
color9 BEBEBE

TEXT
${color1}Gen ${color}Too ${hr 3}
${color1}${font :Bold:size=9} $alignc ${time %H}:${time %M}
${color1}${font :Bold:size=8} $alignc ${time %h} ${time %e} - ${time %Y}${font :Bold:size=08}
$alignc${time %A}
${color1}$alignc Uptime: $uptime
$alignc${color1}$sysname  $nodename  $machine
${color0} $hr:
${color}CPUz   ${color7}Temp:${color7}$alignc${hwmon 0 temp 1}°C${color9}$alignr${color1}$cpu%@${freq_g cpu}GHz
${color0}${cpugraph 15,320 000000 BEBEBE}

${color}RAM ${alignr}${color1}$mem / $memmax $memperc%
${color0}${membar 8}
#${color}SWAP ${alignr}${color1}$swap / $swapmax $swapperc%
#${color0}${swapbar 8}

${color}SERVICES $alignr ${color1}CPU% MEM%
${color1}${top name 1}$alignr${top cpu 1} ${top mem 1}
${color1}${top name 2}$alignr${top cpu 2} ${top mem 2}
${color1}${top name 3}$alignr${top cpu 3} ${top mem 3}
${color1}${top name 4}$alignr${top cpu 4} ${top mem 4}
${color1}${top name 5}$alignr${top cpu 4} ${top mem 5}
${color1}${top name 6}$alignr${top cpu 4} ${top mem 6}
${color1}${top name 7}$alignr${top cpu 4} ${top mem 7}
${color1}${top name 8}$alignr${top cpu 4} ${top mem 8}
${color1}${top name 9}$alignr${top cpu 4} ${top mem 9}

${color4}HDD $hr:
${color5}Size${fs_size /}${alignr}${color1}Used${fs_used /}

${color0}N3TW0RX $hr:
${color7}Public IP: ${alignr}${color7}${execi 60 curl ifconfig.me}
${color7}Local-IP:${color} ${alignr}${color7} ${addr }
${color7}Downz: ${color7}${downspeed } k/s ${alignr} $alignr${color7}Upz: ${color7} ${upspeed } k/s
#${color}${downspeedgraph 15,150} ${alignr}${color}${upspeedgraph 15,150}
${color7}eth0${alignr}${color7}IP ${addr eth0}
${color7}wlan0${alignr}${color7}IP ${addr wlan0}
${color7}wlan1${alignr}${color7}IP ${addr wlan1}
${color7}mon0${alignr}${color7}IP ${addr mon0}
${color7}ESSID:  ${alignr}${color1}${wireless_essid wlan0}

${color0}P0RTz $hr:
${color7}URL${alignr}${color7}PORT
${color7}${tcp_portmon 1 65535 rhost 0}${alignr}${color7}${tcp_portmon 1 65535 rport 0}
${color7}${tcp_portmon 1 65535 rhost 1}${alignr}${color7}${tcp_portmon 1 65535 rport 1}
${color7}${tcp_portmon 1 65535 rhost 2}${alignr}${color7}${tcp_portmon 1 65535 rport 2}
${color7}${tcp_portmon 1 65535 rhost 3}${alignr}${color7}${tcp_portmon 1 65535 rport 3}
${color7}${tcp_portmon 1 65535 rhost 4}${alignr}${color7}${tcp_portmon 1 65535 rport 4}
${color7}${tcp_portmon 1 65535 rhost 5}${alignr}${color7}${tcp_portmon 1 65535 rport 5}
${color7}${tcp_portmon 1 65535 rhost 6}${alignr}${color7}${tcp_portmon 1 65535 rport 6}
${color7}${tcp_portmon 1 65535 rhost 7}${alignr}${color7}${tcp_portmon 1 65535 rport 7}
${color7}${tcp_portmon 1 65535 rhost 8}${alignr}${color7}${tcp_portmon 1 65535 rport 8}
${color7}${tcp_portmon 1 65535 rhost 9}${alignr}${color7}${tcp_portmon 1 65535 rport 9}
   
${color}${hr 3}


tried a couple of the suggestions from the forum to get it to display on the desktop
on the irc channel also, i iuse this to keep an eye on the cpu temp, traffic,
once i figure it out i'll post the fix on here just in case someone else has trouble
can't believe i'm epically failing with a conky of all things
brainfart day i guess, grab coffee...
_________________
just hit enter, things will be fine...
Back to top
View user's profile Send private message
Anon-E-moose
Advocate
Advocate


Joined: 23 May 2008
Posts: 2501
Location: Dallas area

PostPosted: Wed Apr 09, 2014 9:57 am    Post subject: Reply with quote

# WINDOW
own_window yes
own_window_type desktop
own_window_transparent yes
own_window_hints undecorated,below,sticky,skip_taskbar,skip_pager,below
_________________
Asus m5a99fx, FX 8320 - amd64-multilib, 3.15.9-zen, glibc-2.17, gcc-4.7.3-r1, eudev
xorg-server-1.16, openbox w/lxpanel, nouveau, oss4(2010)
Back to top
View user's profile Send private message
sq1rl
n00b
n00b


Joined: 09 Apr 2014
Posts: 6
Location: US

PostPosted: Wed Apr 09, 2014 1:22 pm    Post subject: Reply with quote

i tried that and all the other options, override, desktop, normal etc. have no idea why in the world i can not get this to show on the desktop
appreciate your trying, any other ideas i'm all in, can't believe i'm not getting this to work, i pulled an i5 out of my laptop put an i7 in
well, kinda a good move, had to tone down the i7 to two cores and i use the conky for monitoring traffic and temps
sq1rl
_________________
just hit enter, things will be fine...
Back to top
View user's profile Send private message
Anon-E-moose
Advocate
Advocate


Joined: 23 May 2008
Posts: 2501
Location: Dallas area

PostPosted: Wed Apr 09, 2014 1:32 pm    Post subject: Reply with quote

what does "emerge -pv conky" show?
_________________
Asus m5a99fx, FX 8320 - amd64-multilib, 3.15.9-zen, glibc-2.17, gcc-4.7.3-r1, eudev
xorg-server-1.16, openbox w/lxpanel, nouveau, oss4(2010)
Back to top
View user's profile Send private message
sq1rl
n00b
n00b


Joined: 09 Apr 2014
Posts: 6
Location: US

PostPosted: Wed Apr 09, 2014 1:53 pm    Post subject: Reply with quote

Code:
Calculating dependencies... done!
[ebuild   R    ] app-admin/conky-1.9.0-r3  USE="ncurses portmon -X -apcupsd -audacious -curl -debug -eve -hddtemp -imlib -iostats -lua -lua-cairo -lua-imlib -math -moc -mpd -nano-syntax (-nvidia) -rss -thinkpad -truetype -vim-syntax -weather-metar -weather-xoap -wifi -xmms2" 0 kB

_________________
just hit enter, things will be fine...
Back to top
View user's profile Send private message
ppurka
Advocate
Advocate


Joined: 26 Dec 2004
Posts: 3209

PostPosted: Wed Apr 09, 2014 2:08 pm    Post subject: Reply with quote

Why do you have -X in conky?
_________________
emerge --quiet redefined | E17 vids: I, II | Now using kde4 :-/
Back to top
View user's profile Send private message
sq1rl
n00b
n00b


Joined: 09 Apr 2014
Posts: 6
Location: US

PostPosted: Wed Apr 09, 2014 2:17 pm    Post subject: Reply with quote

i removed it that's what the output was, not sure why
appreciate you helping, been on linux couple years
and well, getting "settled in" to the gentoo way
love this software but wow, lots of coffee and couple hours of sleep ;)
moose, thank you for the replies, means a lot

sincerely, sq1rl
_________________
just hit enter, things will be fine...
Back to top
View user's profile Send private message
Anon-E-moose
Advocate
Advocate


Joined: 23 May 2008
Posts: 2501
Location: Dallas area

PostPosted: Wed Apr 09, 2014 2:29 pm    Post subject: Reply with quote

Code:
equery u conky
[ Legend : U - final flag setting for installation]
[        : I - package is installed with flag     ]
[ Colors : set, unset                             ]
 * Found these USE flags for app-admin/conky-1.9.0-r3:
 U I
 + + X             : Add support for X11
 - - apcupsd       : enable support for sys-power/apcupsd
 - - audacious     : enable monitoring of music played by media-sound/audacious
 - - curl          : Add support for client-side URL transfer library
 - - debug         : Enable extra debug codepaths, like asserts and extra output. If you want to get meaningful
                     backtraces see http://www.gentoo.org/proj/en/qa/backtraces.xml
 - - eve           : enable support for the eve-online skill monitor
 + + hddtemp       : Enable monitoring of hdd temperature (app-admin/hddtemp)
 + + imlib         : Add support for imlib, an image loading and rendering library
 + + iostats       : enable support for per-task I/O statistics
 - - lua           : enable if you want Lua scripting support
 + + lua-cairo     : enable if you want Lua Cairo bindings for Conky (also enables lua support)
 + + lua-imlib     : enable if you want Lua Imlib2 bindings for Conky (also enables lua and imlib support)
 - - math          : enable support for glibc's libm math library
 - - moc           : enable monitoring of music played by media-sound/moc
 - - mpd           : enable monitoring of music controlled by media-sound/mpd
 - - nano-syntax   : enable syntax highlighting for app-editors/nano
 + + ncurses       : Add ncurses support (console display library)
 - - nvidia        : enable reading of nvidia card temperature sensors via media-video/nvidia-settings
 + + portmon       : enable support for tcp (ip4) port monitoring
 - - rss           : Enable support for RSS feeds
 - - thinkpad      : enable support for IBM/Lenovo notebooks
 + + truetype      : Add support for FreeType and/or FreeType2 fonts
 - - vim-syntax    : Pulls in related vim syntax scripts
 - - weather-metar : enable support for metar weather service
 + + weather-xoap  : enable support for metar and xoap weather service
 - - wifi          : Enable wireless network functions
 - - xmms2         : enable monitoring of music played by media-sound/xmms2


Good luck
_________________
Asus m5a99fx, FX 8320 - amd64-multilib, 3.15.9-zen, glibc-2.17, gcc-4.7.3-r1, eudev
xorg-server-1.16, openbox w/lxpanel, nouveau, oss4(2010)
Back to top
View user's profile Send private message
sq1rl
n00b
n00b


Joined: 09 Apr 2014
Posts: 6
Location: US

PostPosted: Wed Apr 09, 2014 2:38 pm    Post subject: Reply with quote

this is what i got now in package.use

ncurses portmon -apcupsd -curl -hddtemp -imlib -iostats -lua -lua-cairo -lua-imlib -moc -mpd -truetype -vim-syntax -wifi -xmms2

am i supposed to have something else installed for the conky graph bars etc?

04.10.14 here's the fix:
add this to your /etc/portage/make.conf file...
Code:
USE="a52 aac acpi alsa branding cairo cdr dbus dts dvd dvdr emboss encode exif
fam firefox flac gif gpm gtk hal jpeg lcms ldap libnotify mad mikmod mng mp3
mp4 mpeg ogg opengl pango pdf png ppds qt3support qt4 sdl spell
startup-notification svg tiff truetype vorbis unicode usb X xcb x264 xml xv
xvid"


not sure which one exactly did it
maybe not needed but i added this to the package.use:
x11-base/xorg-server udev

thanx again to moose for taking the time to help
and also to #conky on freenode especially Tucos
dude hung in there with me n00ben on gentoo
_________________
just hit enter, things will be fine...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum