Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED]interface net.eth0 not found, the module is loaded
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
thegloriousninth
n00b
n00b


Joined: 03 Feb 2013
Posts: 7

PostPosted: Sun Feb 03, 2013 8:34 am    Post subject: [SOLVED]interface net.eth0 not found, the module is loaded Reply with quote

Ok so i'm noob on gentoo, this is my first time installing and i already did some search on the following problem, and excuse me for my english, not my first language.
So the problem is : after successfully doing a fresh install, then reboot, the net.eth0 interface is not found. Did some google search, and from the error, i conclude the problem is the responsible module is not loaded.

My laptop uses Atheros AR8152 v1.1 fast ethernet. I'm booting again the live cd and type : lspci -k. The output states that the module used is
Code:
atl1c
. I tried to load the module, but that module can't be found. So i did
Code:

cd /usr/src/linux
make menuconfig


and then i checklist the atheros blah blah blah, the one responsible for the module, and then i issue:

Code:

make && make modules_install


then i can do
Code:

modprobe atl1c


issuing
Code:
ifconfig -a
, my net.eth0 still not found, also tried:
Code:
/etc/init.d/net.eth0 restart


still the same.


Last edited by thegloriousninth on Thu Feb 07, 2013 5:18 am; edited 1 time in total
Back to top
View user's profile Send private message
ssuominen
Developer
Developer


Joined: 30 Sep 2005
Posts: 2128
Location: Finland

PostPosted: Sun Feb 03, 2013 8:43 am    Post subject: Reply with quote

Are you using sys-fs/udev-197 or higher? Use `emerge -pv sys-fs/udev` to check.

If so, do you have /etc/udev/rules.d/80-net-name-slot.rules file in place to enable the old network naming scheme (eth*)? You can create a symlink from /etc/udev/rules.d/80-net-name-slot.rules to /dev/null to get the old naming back, see this link for more information:

http://www.freedesktop.org/wiki/Software/systemd/PredictableNetworkInterfaceNames
Back to top
View user's profile Send private message
thegloriousninth
n00b
n00b


Joined: 03 Feb 2013
Posts: 7

PostPosted: Sun Feb 03, 2013 9:06 am    Post subject: Reply with quote

ssuominen wrote:
Are you using sys-fs/udev-197 or higher? Use `emerge -pv sys-fs/udev` to check.

If so, do you have /etc/udev/rules.d/80-net-name-slot.rules file in place to enable the old network naming scheme (eth*)? You can create a symlink from /etc/udev/rules.d/80-net-name-slot.rules to /dev/null to get the old naming back, see this link for more information:

http://www.freedesktop.org/wiki/Software/systemd/PredictableNetworkInterfaceNames


Ok i cannot use emerge since i dont have any internet connection (this one's using different machine), but i tried booting from livecd then chroot, but when i do that, the eth0 is not found, but if don't chroot,
Code:
emerge
is not found.

Then i just skip that part and try to symlink /etc/udev/rules.d/80-net-name-slot.rules to /dev/null. I issue
Code:
ln -s  /etc/udev/rules.d/80-net-name-slot.rules  /dev/null


but it says : failed to create symbolic links, file exists
Back to top
View user's profile Send private message
ssuominen
Developer
Developer


Joined: 30 Sep 2005
Posts: 2128
Location: Finland

PostPosted: Sun Feb 03, 2013 11:08 am    Post subject: Reply with quote

thegloriousninth wrote:
ssuominen wrote:
Are you using sys-fs/udev-197 or higher? Use `emerge -pv sys-fs/udev` to check.

If so, do you have /etc/udev/rules.d/80-net-name-slot.rules file in place to enable the old network naming scheme (eth*)? You can create a symlink from /etc/udev/rules.d/80-net-name-slot.rules to /dev/null to get the old naming back, see this link for more information:

http://www.freedesktop.org/wiki/Software/systemd/PredictableNetworkInterfaceNames


Ok i cannot use emerge since i dont have any internet connection (this one's using different machine), but i tried booting from livecd then chroot, but when i do that, the eth0 is not found, but if don't chroot,
Code:
emerge
is not found.

Then i just skip that part and try to symlink /etc/udev/rules.d/80-net-name-slot.rules to /dev/null. I issue
Code:
ln -s  /etc/udev/rules.d/80-net-name-slot.rules  /dev/null


but it says : failed to create symbolic links, file exists


OK, being more explicit then.

If you don't see a file with the following command:

Code:

# ls -ld /etc/udev/rules.d/80-net-name-slot.rules


Then you can create the file yourself, or just symlink it, to restore the old /dev/eth* naming scheme:

Code:

# ln -nfs /dev/null /etc/udev/rules.d/80-net-name-slot.rules


Or you can just read the link I gave you and adapt to the new scheme.
Back to top
View user's profile Send private message
krinn
Advocate
Advocate


Joined: 02 May 2003
Posts: 4243

PostPosted: Sun Feb 03, 2013 11:17 am    Post subject: Reply with quote

For my information, you have stabilize udev-197 with that new scheme per default ?
Back to top
View user's profile Send private message
ssuominen
Developer
Developer


Joined: 30 Sep 2005
Posts: 2128
Location: Finland

PostPosted: Sun Feb 03, 2013 11:29 am    Post subject: Reply with quote

krinn wrote:
For my information, you have stabilize udev-197 with that new scheme per default ?


No, the stable udev, 197-r4, always installs a dummy file in place to keep the old scheme.

But in ~arch, using 197-r6, the new users of udev will get the new scheme by default. The ebuild will also assume you are a new udev user if you first emerge -C udev and then emerge it back.
Back to top
View user's profile Send private message
krinn
Advocate
Advocate


Joined: 02 May 2003
Posts: 4243

PostPosted: Sun Feb 03, 2013 11:37 am    Post subject: Reply with quote

oh and for a more topic answer:

ifconfig -a should display device, even if not start and/or not configure.

So you should check your dmesg after modprobe your card to see what is going on.
Back to top
View user's profile Send private message
thegloriousninth
n00b
n00b


Joined: 03 Feb 2013
Posts: 7

PostPosted: Thu Feb 07, 2013 5:17 am    Post subject: Reply with quote

Thank you, for all of your help, it turns out the interface name is not the usual eth0. Once i configured it with the new interface, the connection good to go. Thanks.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum