Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
USB control queue full w/ APC power supply
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
Cicero
Apprentice
Apprentice


Joined: 21 Jul 2003
Posts: 220

PostPosted: Tue Sep 23, 2003 5:52 am    Post subject: USB control queue full w/ APC power supply Reply with quote

While my USB APC UPS (try saying THAT) is plugged in, my logs fill with:

Code:
drivers/usb/input/hid-core.c: control queue full


Using 2.6.0-test5-mm4
Back to top
View user's profile Send private message
Cicero
Apprentice
Apprentice


Joined: 21 Jul 2003
Posts: 220

PostPosted: Wed Nov 12, 2003 11:13 pm    Post subject: Reply with quote

test9 and counting.
Back to top
View user's profile Send private message
Moofed
Apprentice
Apprentice


Joined: 22 Oct 2002
Posts: 158
Location: Bloomington, IN

PostPosted: Thu Nov 13, 2003 1:33 am    Post subject: Reply with quote

Just wanted to chime in and say this happens to my APC BackUPS CS 350.
Back to top
View user's profile Send private message
Cicero
Apprentice
Apprentice


Joined: 21 Jul 2003
Posts: 220

PostPosted: Thu Nov 13, 2003 2:01 am    Post subject: Reply with quote

That would be the same model I have, but I'm fairly certain that the issue lies either with apcupsd or with the small fixed queue size in 2.6.0
Back to top
View user's profile Send private message
gitarretyp
n00b
n00b


Joined: 22 Oct 2002
Posts: 36

PostPosted: Fri Dec 05, 2003 8:44 am    Post subject: Reply with quote

I have had this problem as well since test3, but with the Back-UPS ES 725. I just wanted to bump this to see if anyone has resolved this problem, yet.
Back to top
View user's profile Send private message
Cicero
Apprentice
Apprentice


Joined: 21 Jul 2003
Posts: 220

PostPosted: Sun Dec 07, 2003 6:15 am    Post subject: Reply with quote

I still haven't . . .
Back to top
View user's profile Send private message
jack_mort
Apprentice
Apprentice


Joined: 30 Jan 2003
Posts: 166

PostPosted: Thu Dec 18, 2003 8:16 pm    Post subject: Reply with quote

Well, I get the same errors here with a BackUPS 500. Something strange is thaht the damon seems to work well even with these errors... But it makes my computer eating all its little CPU power (celeron 400 ^^) by all this flood logging...

Any help, suggestion or whatever would be apprecated :roll:

Edit : after googling since yesterday about this annoying problem without finding a solution, I may have found a patch... at linux-usb mailing lists :D

Look at here :

http://marc.theaimsgroup.com/?l=linux-usb-devel&m=107172403531243&w=2

The guy gives a patch, which I applied (in fact I edited manually the file, but hey, it's a way to apply a patch, no ? :P). For now, I have not seen any "drivers/usb/input/hid-core.c: control queue full"...
Back to top
View user's profile Send private message
CharlieS
Tux's lil' helper
Tux's lil' helper


Joined: 06 Nov 2003
Posts: 146
Location: Texas, USA

PostPosted: Sat Jan 03, 2004 4:53 am    Post subject: Reply with quote

guys i'm having the same problem.. could somebody be more specific as to what i can do? i dont know how to patch anything... is this safe???
Back to top
View user's profile Send private message
CharlieS
Tux's lil' helper
Tux's lil' helper


Joined: 06 Nov 2003
Posts: 146
Location: Texas, USA

PostPosted: Sun Jan 04, 2004 8:44 am    Post subject: Reply with quote

Ok guys.. i've figured out the problem. i contacted the people who keep up the apcupsd project and they said that we need to upgrade.. i have done so and removed patch from kernel and it works like a charm.. just use the masked version.. it has done well for me..
Back to top
View user's profile Send private message
pwnell
n00b
n00b


Joined: 02 Mar 2003
Posts: 29
Location: South Africa

PostPosted: Wed Jan 14, 2004 2:20 pm    Post subject: Reply with quote

CharlieS wrote:
Ok guys.. i've figured out the problem. i contacted the people who keep up the apcupsd project and they said that we need to upgrade.. i have done so and removed patch from kernel and it works like a charm.. just use the masked version.. it has done well for me..


What version of apcupsd are you running? I have the same issue with my SmartUPS 1000 on USB. I am running 2.6.1 (release) as well as 3.10.8 - the latest version of apcupsd in portage.

Furthermore, does anyone know when 3.10.9 will be available in portage as it has been out since 31 Dec 2003 I think???

Waldo
Back to top
View user's profile Send private message
CharlieS
Tux's lil' helper
Tux's lil' helper


Joined: 06 Nov 2003
Posts: 146
Location: Texas, USA

PostPosted: Thu Jan 15, 2004 4:41 pm    Post subject: Reply with quote

i'm actually running 3.10.8 .. it is what cleared up my problem.. it was just added to portage tree..
Back to top
View user's profile Send private message
cadu
n00b
n00b


Joined: 22 Dec 2004
Posts: 34

PostPosted: Sun Jul 24, 2005 8:16 pm    Post subject: I have this problem, too Reply with quote

My logs are full of "drivers/usb/input/hid-core.c: control queue full". I'm using gentoo-sources 2.6.12-r4 with apcupsd 3.10.17

Which versions are known to work well together (gentoo-sources and apcupsd)?

Thank you!
Back to top
View user's profile Send private message
cadu
n00b
n00b


Joined: 22 Dec 2004
Posts: 34

PostPosted: Sat Aug 13, 2005 9:07 am    Post subject: Fixed Reply with quote

I've had no more "control queue" messages since I had upgraded to apcupsd 3.10.18-r1. My kernel is 2.6.12-gentoo-r6 (gentoo-sources).
Back to top
View user's profile Send private message
VinzC
Advocate
Advocate


Joined: 17 Apr 2004
Posts: 4681
Location: Theux (Belgium)

PostPosted: Mon Oct 24, 2005 1:24 pm    Post subject: Reply with quote

Well, 2 months after the last post in this thread, I'm obesrving the same problem on an IBM xSeries 226 with gentoo sources 2.6.13-r3 (the patch is already applied in the sources) and apcupsd-3.10.18-r1. It looks like the patch should be reversed, is that correct? Is it gonna get better some day? :roll:
_________________
Gentoo addict: tomorrow I quit, I promise!... Just one more emerge...
GNU/Linux user #369763
“Wow! I feel root”
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum