Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[XORG] xorg-server dépend de gentoo-source
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
zerros
Apprentice
Apprentice


Joined: 02 Jun 2010
Posts: 150

PostPosted: Thu Apr 12, 2012 3:40 pm    Post subject: [XORG] xorg-server dépend de gentoo-source Reply with quote

Bonjour,

Je ne comprends pas pourquoi xorg-server dépend de gentoo-source. J'ai compiler mon kernel à la main ne souhaitant pas utiliser gentoo-source ou genkernel,
et il m'est impossible d'installer mon serveur X sans installer gentoo-source !!

Existe-t-il une parade ?
_________________
- zerros -
Back to top
View user's profile Send private message
chris972
Tux's lil' helper
Tux's lil' helper


Joined: 02 Mar 2012
Posts: 97

PostPosted: Thu Apr 12, 2012 4:35 pm    Post subject: Reply with quote

Je sais que ça ne répond pas purement à ta question, mais compiler à la main n'est en rien incompatible avec l'installation de sources d'un noyau par emerge, que ce soit gentoo-sources ou vanilla-sources...
Back to top
View user's profile Send private message
boozo
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3149

PostPosted: Thu Apr 12, 2012 5:21 pm    Post subject: Re: [XORG] xorg-server dépend de gentoo-source Reply with quote

zerros wrote:
Bonjour,

Je ne comprends pas pourquoi xorg-server dépend de gentoo-source. J'ai compiler mon kernel à la main ne souhaitant pas utiliser gentoo-source ou genkernel,
et il m'est impossible d'installer mon serveur X sans installer gentoo-source !!

Existe-t-il une parade ?

Oui, on appelle cela les packages gérés hors portage cf. ©handbook :wink:
n.b. au fait, attention au path... va pas au même endroit que les autres fichiers package.*

/!\ Mise en garde (quand même) /!\
    (°) l'usage de cette fonctionnalité reste très ciblé et faut vraiment faire gaffe à ce qu'on met dedans si on joue avec, notamment aux dépendences car c'est surtout là que les pb peuvent se poser avec les update ^^ donc pour rappel :
    man portage wrote:
    package.provided
    [...]
    Portage will not attempt to update a package that is listed here unless another package explicitly requires a version that is newer than what has been listed.

_________________
" Un psychotique, c'est quelqu'un qui croit dur comme fer que 2 et 2 font 5, et qui en est pleinement satisfait.
Un névrosé, c'est quelqu'un qui sait pertinemment que 2 et 2 font 4, et ça le rend malade ! "
Back to top
View user's profile Send private message
zerros
Apprentice
Apprentice


Joined: 02 Jun 2010
Posts: 150

PostPosted: Fri Apr 13, 2012 8:16 pm    Post subject: Reply with quote

ok, j'ai compris, je vais rester sur gentoo-source et genkernel :)

Merci :)
_________________
- zerros -
Back to top
View user's profile Send private message
boozo
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3149

PostPosted: Fri Apr 13, 2012 8:49 pm    Post subject: Reply with quote

heu, vu la réponse, suis pas sur qu'on se soit compris : comme signalé plus haut il n'y a aucune obligation a avoir les gentoo sources (même simplement installé) cf. la méthode indiquée - d'autant plus si tu gères un vanilla ou autre à la main mais à toi de gérer les updates de sécurité également :wink:

Edit: un p'tit (résolu) à la fin du titre stp ? ^^
_________________
" Un psychotique, c'est quelqu'un qui croit dur comme fer que 2 et 2 font 5, et qui en est pleinement satisfait.
Un névrosé, c'est quelqu'un qui sait pertinemment que 2 et 2 font 4, et ça le rend malade ! "
Back to top
View user's profile Send private message
kopp
Advocate
Advocate


Joined: 09 Apr 2004
Posts: 2869
Location: Grenoble, France

PostPosted: Mon Apr 16, 2012 8:16 pm    Post subject: Reply with quote

LE problèmes de package.provided, c'est si tu n'as pas l'équivalent du paquet réellement installé, ou autre.
La, tu as toujours ton noyau, probablement à l'endroit classique / la config accessible pour que Xorg puisse faire ses vérifications s'il y en a.

Le seul soucis restant possible, c'est si tu utilises en fait uniquement un vieux noyau alors qu'Xorg en réclame un plus récent.


A noter aussi que l'utilisation d'emerge pour la gestion des sources ne t'impose pas d'utiliser genkernel.
Et si tu ne veux pas le patchset gentoo, il y a le paquet vanilla-sources (je pense qu'xorg dépend seulement d'une classe qui correspond aux paquets *sources et que par défaut, emerge y répond avec les gentoo-sources)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum