Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge autogen fails (~amd64 problem, SOLVED)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
Crono81
Tux's lil' helper
Tux's lil' helper


Joined: 07 Nov 2006
Posts: 86

PostPosted: Tue Jan 30, 2007 1:35 pm    Post subject: emerge autogen fails (~amd64 problem, SOLVED) Reply with quote

Hi, i get errors when, during updates, portage tries to emerge autogen.

With the latest version of guile, "emerge autogen" gives this error:
Quote:
* You need to build dev-scheme/guile with USE='deprecated discouraged threads'

Same problem using guile 1.6.7, 1.6.8 and 1.8.1-r1.

Why i have to use such flags? I mean, if it's deprecated, discouraged, then why i need it in an emerge --update world? I don't even know what's this libguile. I don't want to install things that need those "deprecated" or "discouraged" use flags.



If i try to emerge previous versions of autogen, i get this:
Quote:
configure: error: Cannot find working libguile

!!! Please attach the following file when filing a report to bugs.gentoo.org:
!!! /var/tmp/portage/sys-devel/autogen-5.7.1/work/autogen-5.7.1/config.log

!!! ERROR: sys-devel/autogen-5.7.1 failed.
Call stack:
ebuild.sh, line 1611: Called dyn_compile
ebuild.sh, line 968: Called qa_call 'src_compile'
environment, line 1274: Called src_compile
autogen-5.7.1.ebuild, line 32: Called econf
ebuild.sh, line 574: Called die


Last edited by Crono81 on Tue Jan 30, 2007 4:31 pm; edited 1 time in total
Back to top
View user's profile Send private message
Dan
Veteran
Veteran


Joined: 25 Oct 2005
Posts: 1301

PostPosted: Tue Jan 30, 2007 2:20 pm    Post subject: Reply with quote

weird, I do not see anything like this in either the guile ebuild or the autogen ebuild
do you have an overlay that contains either of these? When was the last time you emerge --sync ?
both guile and autogen build without any flags.
_________________
- Failure is not an option. It's bundled with your software.
Back to top
View user's profile Send private message
Crono81
Tux's lil' helper
Tux's lil' helper


Joined: 07 Nov 2006
Posts: 86

PostPosted: Tue Jan 30, 2007 2:36 pm    Post subject: Reply with quote

no overlay, and just synced, but i forgot to mention that i'm using ~amd64.

Additional info:
Quote:
emerge guile autogen -pv

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild R ] dev-scheme/guile-1.8.1-r1 USE="nls -debug -debug-freelist -debug-malloc -deprecated -discouraged -elisp -networking -regex -threads" 0 kB
[ebuild U ] sys-devel/autogen-5.8.8 [5.8.3] 0 kB
Back to top
View user's profile Send private message
Dan
Veteran
Veteran


Joined: 25 Oct 2005
Posts: 1301

PostPosted: Tue Jan 30, 2007 3:10 pm    Post subject: Reply with quote

well then build it the way its required.
Code:
echo dev-scheme/guile deprecated discouraged threads >> /etc/portage/package.use && emerge -uDN world

_________________
- Failure is not an option. It's bundled with your software.
Back to top
View user's profile Send private message
Crono81
Tux's lil' helper
Tux's lil' helper


Joined: 07 Nov 2006
Posts: 86

PostPosted: Tue Jan 30, 2007 4:30 pm    Post subject: Reply with quote

ok, now it's obviously working. Probably it was for the ~arch.
Back to top
View user's profile Send private message
dylan38
n00b
n00b


Joined: 14 Oct 2005
Posts: 7

PostPosted: Wed Jan 31, 2007 5:17 pm    Post subject: Reply with quote

I'm having this same problem on ~x86 trying to compile guile 1.6.8, but adding the use flags suggested and re-emerging doesn't solve it.

Any thoughts?

Thanks,
Curtis.
_________________
Help preserve history a page at a time - visit Distributed Proofreaders
Back to top
View user's profile Send private message
Dan
Veteran
Veteran


Joined: 25 Oct 2005
Posts: 1301

PostPosted: Wed Jan 31, 2007 6:05 pm    Post subject: Reply with quote

ok paste what you get.. If you added the use flags then you can't be having the same problem.
_________________
- Failure is not an option. It's bundled with your software.
Back to top
View user's profile Send private message
antiflag1980
n00b
n00b


Joined: 01 Nov 2004
Posts: 65
Location: cincinnati usa

PostPosted: Wed Feb 14, 2007 5:47 am    Post subject: Reply with quote

dylan38 wrote:
I'm having this same problem on ~x86 trying to compile guile 1.6.8, but adding the use flags suggested and re-emerging doesn't solve it.

Any thoughts?

Thanks,
Curtis.

Me too. It just gives the exact same error about guile needing to be built with the flags I just built it with.
Back to top
View user's profile Send private message
fidel
Guru
Guru


Joined: 16 Jul 2004
Posts: 390
Location: CH

PostPosted: Thu Oct 11, 2007 8:23 am    Post subject: Reply with quote

Thanks for the tipp! Using the proposed useflags of the failure of the build makes autogen compile. Still this doesn't make me really happy, those useflags sound no good to me... So know I am concerned about having a misconfigured system... Just to make sure: is it only autogen that uses those "features" of guile? Useflags like "discouraged" or "deprecated" make me doubt...
Greets!
Back to top
View user's profile Send private message
frankjr
n00b
n00b


Joined: 13 Sep 2002
Posts: 55

PostPosted: Wed Nov 07, 2007 3:46 am    Post subject: Reply with quote

I'm having the same problems on x86, it'd be nice if I knew just exactly what I was enabling and if it could possibly b0rk my system down the line.
Back to top
View user's profile Send private message
Sadako
Advocate
Advocate


Joined: 05 Aug 2004
Posts: 3753
Location: sleeping in the bathtub

PostPosted: Wed Nov 07, 2007 8:12 pm    Post subject: Reply with quote

I just ran into the exat same issue, also on amd64.

I built guile with USE="discouraged threads -deprecated", however it wouldn't get passed the error encountered here until I enabled the "deprecated" USE flag also.

According to this bug on the subject, the deprecated use flag was actually removed from the requirements of autogen, but it appears autogen needs more than what's enabled by "discouraged".

I have a feeling it's the requirement on the discouraged use flag which was supposed to be removed rather than deprecated.
_________________
"You have to invite me in"
Back to top
View user's profile Send private message
OneOfMany
Tux's lil' helper
Tux's lil' helper


Joined: 19 Nov 2003
Posts: 108
Location: Portland, OR USA

PostPosted: Thu Nov 08, 2007 1:13 am    Post subject: Reply with quote

No the bug says to remove the discouraged dependency. If you run "equery uses dev-scheme/guile" you'll see a list of the use flags the ebuild might reference and their description. For me I get a list that includes...
Code:
 + + deprecated     : enable deprecated features
 - - discouraged    : (implied by deprecated) enable merely discouraged features

So the bug was the fact that the description claims if you already have deprecated, you shouldn't need discouraged. The fix doesn't say what they did, but I assumed they removed the code looking for the use flag "discouraged". I wasn't sure if by being in CVS that the fix made it into the portage tree yet, but I'll take a peek in a second (gotta reboot into my Linux partition).

[update]They did mess up on the fix. I updated the bug.
Back to top
View user's profile Send private message
Akkara
Administrator
Administrator


Joined: 28 Mar 2006
Posts: 5237
Location: &akkara

PostPosted: Thu Nov 29, 2007 5:54 am    Post subject: Reply with quote

Hi! I just ran into this one. Rebuilding guile with the asked-for useflags fixed it.

I find it curious and that a new version of a package would suddenly require another package be rebuilt with ominous-sounding use-flags.

If at some point in the future this requirement is lifted, is there a way to find out, and know it is again safe to (re-)re-build guile without these flags?
Back to top
View user's profile Send private message
antiflag1980
n00b
n00b


Joined: 01 Nov 2004
Posts: 65
Location: cincinnati usa

PostPosted: Sat Dec 15, 2007 12:49 am    Post subject: Reply with quote

Yeah, it worked for me also, but I forgot to report back. It wasn't working for me before when compiling with those use flags because I misspelled the deprecated use flag.
Back to top
View user's profile Send private message
bcsthsc
n00b
n00b


Joined: 14 Mar 2005
Posts: 19

PostPosted: Tue Jul 15, 2014 8:35 am    Post subject: Re: emerge autogen fails (~amd64 problem, SOLVED) Reply with quote

I'm on x86 stable.

Switching from gcc 4.6.3 to gcc-4.7.3 did the trick for me.
Back to top
View user's profile Send private message
dahoste
Tux's lil' helper
Tux's lil' helper


Joined: 01 Dec 2005
Posts: 138
Location: Maryland, USA

PostPosted: Mon Aug 04, 2014 6:31 pm    Post subject: Re: emerge autogen fails (~amd64 problem, SOLVED) Reply with quote

bcsthsc, you're a saint!

Don't let anyone tell you not to resurrect an ancient thread, if you've got something constructive to add.

Switching from gcc 4.6.3 to gcc-4.7.3 was precisely the fix for me as well. I'm wading through a (shamefully overdue) world update and this autogen thing was a total showstopper for me.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum