Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
blender 2.5 vs python 3.3
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
KAMIKAZE_
Apprentice
Apprentice


Joined: 09 Oct 2003
Posts: 291
Location: Riga, Latvia

PostPosted: Fri May 27, 2011 11:24 am    Post subject: blender 2.5 vs python 3.3 Reply with quote

hello. emerge -Dupv world says to me:
Code:
!!! The following update has been skipped due to unsatisfied dependencies:

media-gfx/blender:2.5

emerge: there are no ebuilds to satisfy "=dev-lang/python-3.3*".
(dependency required by "media-gfx/blender-2.57-r1" [ebuild])


But I can't find such python package in portage at all... even in blender ebuild there is nothing about 3.3 :?
_________________
-=[powered by Gentoo]=-
Back to top
View user's profile Send private message
KAMIKAZE_
Apprentice
Apprentice


Joined: 09 Oct 2003
Posts: 291
Location: Riga, Latvia

PostPosted: Fri May 27, 2011 8:57 pm    Post subject: Reply with quote

ok, found it in cache/metadata/blender-2.57-r1
but why it's there if there is no such package at all?
_________________
-=[powered by Gentoo]=-
Back to top
View user's profile Send private message
KAMIKAZE_
Apprentice
Apprentice


Joined: 09 Oct 2003
Posts: 291
Location: Riga, Latvia

PostPosted: Fri Jun 03, 2011 3:19 pm    Post subject: Reply with quote

Anyone has blender 2.57-r1 installed successfully?
:roll:
_________________
-=[powered by Gentoo]=-
Back to top
View user's profile Send private message
melinux
n00b
n00b


Joined: 25 May 2006
Posts: 58
Location: Malta

PostPosted: Sat Jun 04, 2011 11:06 am    Post subject: Reply with quote

It's a bug in blender...
Back to top
View user's profile Send private message
Xtroce
n00b
n00b


Joined: 27 Apr 2004
Posts: 12

PostPosted: Sun Jun 05, 2011 2:10 pm    Post subject: Reply with quote

can't be a bug in blender since the error occurs even before the ebuild starts to unpack.
+blender surely doesn't know about the portage structure to warn about dev-lang/python
the point is that it needs python-3.2 or bigger and because 3.2 is still masked with keyword it searches
for the next higher number which would be 3.3 which obviously doesn't exist.
if you install dev-lang/python-3.2 after setting the keyword, it compiles fine
_________________
In the land of the blind, the one eyed man is king!
Back to top
View user's profile Send private message
Xenocrates
n00b
n00b


Joined: 20 Sep 2004
Posts: 26
Location: Texas, USA

PostPosted: Tue Jun 21, 2011 8:27 am    Post subject: Reply with quote

Has anyone found a solution/cause for this? I'm experiencing the exact same predicament.
Back to top
View user's profile Send private message
lexington
n00b
n00b


Joined: 10 Apr 2005
Posts: 25
Location: Cambridge, MA

PostPosted: Wed Jun 22, 2011 7:49 pm    Post subject: Reply with quote

Xenocrates wrote:
Has anyone found a solution/cause for this? I'm experiencing the exact same predicament.

Xtroce already explained why and the solution but basically you need to unmask (via keyword) python3.2. You can do this in /etc/portage/package.keywords:

Code:

dev-lang/python:3.2


With that said this error message from portage is confusing and requires the user to dig around a bit to figure out the issue. The error leads you to believe that python 3.3 is required when in fact it's >=python-3.2 that's required. IMO portage should detect this situation where no unmasked version (or greater) exists in a required slot and communicate this better in the error message.

Looking (very briefly) at the blender-2.57-r1 ebuild it looks like this dependency happens because of the following:

Code:

PYTHON_DEPEND="3:3.2"


From the docs this means it depends on any version of Python 3 which is at least 3.2.*. Given that this a relatively easy use case to detect (basically any ebuild containing PYTHON_DEPEND with slot:version requirement...) it would be nice to instead have an error message somewhere along the lines of:

Code:

!!! The following update has been skipped due to unsatisfied dependencies:

media-gfx/blender:2.5

emerge: all ebuilds in dev-lang/python:3 greater than or equal to version 3.2 are masked
(dependency required by "media-gfx/blender-2.57-r1" [ebuild])


Maybe even better would be to have the traditional "package media-gfx/blender-2.57-r1 requires >=dev-lang/python-3.2 which is masked by (keyword)"....?
Back to top
View user's profile Send private message
platojones
Veteran
Veteran


Joined: 23 Oct 2002
Posts: 1533
Location: Just over the horizon

PostPosted: Sun Jul 03, 2011 7:26 pm    Post subject: Reply with quote

This is late, but....

python-3.3 is in the python overlay...built fine on my system. Still haven't gotten blender-2.57-r1 to build though. Still trying.

[UPDATE: Nevermind...python 3.3 in the overlay doesn't work with much else].
Back to top
View user's profile Send private message
koan
Apprentice
Apprentice


Joined: 01 May 2006
Posts: 160

PostPosted: Mon Aug 15, 2011 10:23 am    Post subject: Reply with quote

I got it to build with -ffmpeg

There seems to be a fix for the ffmpeg_property_add
Code:
error: incompatible types when assigning to type 'int' from type'const union <anonymous>
available.

http://comments.gmane.org/gmane.comp.video.blender.devel/31042
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum