Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
chromium" is blocking www-plugins/gecko-mediaplayer ?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
cwc
l33t
l33t


Joined: 20 Mar 2006
Posts: 804
Location: Tri-Cities, WA USA

PostPosted: Thu May 19, 2011 11:39 am    Post subject: chromium" is blocking www-plugins/gecko-mediaplayer ? Reply with quote

www-client/chromium ("www-client/chromium" is blocking www-plugins/gecko-mediaplayer-1.0.3-r1)

I've got gecko-mediaplayer Latest version installed: 1.0.3-r1

I do believe Firefox need gecko and I'd like to keep firefox and chromium.

I need a bit of advice here. Do I need to one shot gecko?
Remove gecko then emerge chromium or visa-vera?

Code:

azzerare ~ # more /etc/make.conf
# These settings were set by the catalyst build script that automatically
# built this stage.
# Please consult /usr/share/portage/config/make.conf.example for a more
# detailed example.
CFLAGS="-O2 -pipe"
CXXFLAGS="${CFLAGS}"
# WARNING: Changing your CHOST is not something that should be done lightly.
# Please consult http://www.gentoo.org/doc/en/change-chost.xml before changing.
CHOST="x86_64-pc-linux-gnu"
# These are the USE flags that were used in addition to what is provided by the
# profile used for building.
#cwc
#VIDEO_CARDS="openchrome via"   
VIDEO_CARDS="nvidia"
VIDEO_CARDS="radeon"
MAKEOPTS="-j1"
PHP_TARGETS="php5-3"
#virtual/ffmpeg="threads"
#media-video/ffmpeg="threads"
USE= "X dbus gnome gtk hal mmx sqlite sse sse2 threads tk -doc -kde -qt4"
#USE_PYTHON="3"
GENTOO_MIRRORS="http://gentoo.osuosl.org/ "

SYNC="rsync://rsync.gentoo.org/gentoo-portage"
ACCEPT_LICENSE="*"
PORTDIR_OVERLAY="/usr/local/portage"

azzerare ~ # more /etc/portage/package.keywords
www-plugins/adobe-flash 32bit 64bit (multilib) -nspluginwrapper
<media-video/gnome-mplayer-9999
<www-plugins/gecko-mediaplayer-9999
<www-client/chromium-9999 cups gecko-mediaplayer gnome gnome-keyring -test ~amd64
<dev-util/chromium-tools-9999  -subversion
#<media-gfx/blender-9999
<dev-java/sun-jdk-9999
<media-video/ogmrip-9999
<dev-lang/v8-9999
<gnome-extra/nautilus-dropbox-9999
<x11-misc/xnviewmp-9999
<media-libs/libwebp-9999
<media-libs/vo-aacenc-9999
#<virtual/ffmpeg-9999 threads ~amd64 X encode mp3 sdl x264 -jpeg2k -theora -vaapi -vdpau
<virtual/ffmpeg-9999  ~amd64
<media-video/ffmpeg-9999  ~amd64

_________________
Without diversity there can be no evolution:)
Back to top
View user's profile Send private message
Jaglover
Advocate
Advocate


Joined: 29 May 2005
Posts: 4611
Location: Saint Amant, Acadiana

PostPosted: Thu May 19, 2011 11:44 am    Post subject: Reply with quote

Firefox works with mozplugger.
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
cwc
l33t
l33t


Joined: 20 Mar 2006
Posts: 804
Location: Tri-Cities, WA USA

PostPosted: Thu May 19, 2011 11:54 am    Post subject: Reply with quote

Jaglover wrote:
Firefox works with mozplugger.


I removed gecko and am emerging chromium 12.
I'll see how things works!

thanks!
_________________
Without diversity there can be no evolution:)
Back to top
View user's profile Send private message
cwc
l33t
l33t


Joined: 20 Mar 2006
Posts: 804
Location: Tri-Cities, WA USA

PostPosted: Fri May 20, 2011 12:12 pm    Post subject: Reply with quote

Jaglover wrote:
Firefox works with mozplugger.


http://forums.gentoo.org/viewtopic-t-879031-highlight-.html
_________________
Without diversity there can be no evolution:)
Back to top
View user's profile Send private message
ghutzl
Tux's lil' helper
Tux's lil' helper


Joined: 29 May 2005
Posts: 117
Location: Germany

PostPosted: Fri May 20, 2011 2:13 pm    Post subject: Reply with quote

Today I have installed www-client/chromium-12.0.742.60 with no problems and I have these installed, too:

Code:
[I] www-plugins/gecko-mediaplayer
     Available versions:  1.0.0 ~1.0.3-r1 {curl gnome}
     Installed versions:  1.0.0(10:58:31 AM 04/20/2011)(gnome)
     Homepage:            http://code.google.com/p/gecko-mediaplayer/
     Description:         A browser plugin that uses GNOME MPlayer

[I] www-plugins/mozplugger
     Available versions:  (~)1.13.2 (~)1.14.0-r1 (~)1.14.2
     Installed versions:  1.14.2(03:04:43 PM 04/01/2011)
     Homepage:            http://mozplugger.mozdev.org/
     Description:         Configurable browser plugin to launch streaming media players.


So obviously it is possible to install chromium-12 alongside gecko-mediaplayer and mozplugger. Maybe you can try the stable 1.0.0 version of gecko-mediaplayer which I have installed.
Back to top
View user's profile Send private message
cwc
l33t
l33t


Joined: 20 Mar 2006
Posts: 804
Location: Tri-Cities, WA USA

PostPosted: Sun May 22, 2011 1:53 pm    Post subject: Reply with quote

ghutzl wrote:
Today I have installed www-client/chromium-12.0.742.60 with no problems and I have these installed, too:

Code:
[I] www-plugins/gecko-mediaplayer
     Available versions:  1.0.0 ~1.0.3-r1 {curl gnome}
     Installed versions:  1.0.0(10:58:31 AM 04/20/2011)(gnome)
     Homepage:            http://code.google.com/p/gecko-mediaplayer/
     Description:         A browser plugin that uses GNOME MPlayer

[I] www-plugins/mozplugger
     Available versions:  (~)1.13.2 (~)1.14.0-r1 (~)1.14.2
     Installed versions:  1.14.2(03:04:43 PM 04/01/2011)
     Homepage:            http://mozplugger.mozdev.org/
     Description:         Configurable browser plugin to launch streaming media players.


So obviously it is possible to install chromium-12 alongside gecko-mediaplayer and mozplugger. Maybe you can try the stable 1.0.0 version of gecko-mediaplayer which I have installed.


www-plugins/gecko-mediaplayer will not emerge.

here is my package.keywords list:

www-plugins/adobe-flash 32bit 64bit (multilib) -nspluginwrapper
<media-video/gnome-mplayer-9999
<www-plugins/gecko-mediaplayer-9999 -curl
<www-client/chromium-9999 cups gecko-mediaplayer gnome gnome-keyring -test ~amd64
<dev-util/chromium-tools-9999 -subversion
<dev-java/sun-jdk-9999
<media-video/ogmrip-9999
<dev-lang/v8-9999
<gnome-extra/nautilus-dropbox-9999
<x11-misc/xnviewmp-9999
<media-libs/libwebp-9999
<media-libs/vo-aacenc-9999
#<virtual/ffmpeg-9999 threads ~amd64 X encode mp3 sdl x264 -jpeg2k -theora -vaapi -vdpau
<virtual/ffmpeg-9999 ~amd64
<media-video/ffmpeg-9999 ~amd64
<www-plugins/mozplugger-9999


Code:

azzerare ~ # emerge www-plugins/gecko-mediaplayer
Calculating dependencies... done!
[ebuild  N    ] www-plugins/gecko-mediaplayer-1.0.3-r1  USE="-curl"
[blocks B     ] www-client/chromium ("www-client/chromium" is blocking www-plugins/gecko-mediaplayer-1.0.3-r1)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (www-plugins/gecko-mediaplayer-1.0.3-r1, ebuild scheduled for merge) pulled in by
    www-plugins/gecko-mediaplayer

  (www-client/chromium-12.0.742.60, installed) pulled in by
    www-client/chromium required by @selected


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked




_________________
Without diversity there can be no evolution:)
Back to top
View user's profile Send private message
ghutzl
Tux's lil' helper
Tux's lil' helper


Joined: 29 May 2005
Posts: 117
Location: Germany

PostPosted: Sun May 22, 2011 2:56 pm    Post subject: Reply with quote

I digged a little deeper into this and I think I found the reason for your problem:

The gecko-mediaplayer-1.0.3-r1.ebuild contains this:

Code:
RDEPEND=">=dev-libs/dbus-glib-0.92
        >=dev-libs/glib-2.26:2
        dev-libs/nspr
        >=media-video/gnome-mplayer-1.0.3-r2[dbus]
        >=net-libs/xulrunner-1.9.2:1.9
        curl? ( net-misc/curl )
        !www-client/chromium"


The last line says all: You cannot install gecko-mediaplayer-1.0.3-r1 when chromium is installed. Obviously there must be some incompatibility which the package maintainer has found and therefore is blocking chromium. This is not true for the gecko-mediaplayer-1.0.0.ebuild. So that is the reason why you cannot install the two packages at the same time. And I am pretty sure that you can install chromium and gecko-mediaplayer-1.0.0 at the same time because this is what I have done.

So looking at your package.keywords I think you should just remove this line:

Code:
<www-plugins/gecko-mediaplayer-9999 -curl


and the problem should be gone (as long as you can live with gecko-mediaplayer-1.0.0).
Back to top
View user's profile Send private message
cwc
l33t
l33t


Joined: 20 Mar 2006
Posts: 804
Location: Tri-Cities, WA USA

PostPosted: Sun May 22, 2011 5:30 pm    Post subject: Reply with quote

Ahh. I need to read! 1.0.0 not 1.0.3.

I'll try 1.0.9

ghutzl wrote:
Today I have installed www-client/chromium-12.0.742.60 with no problems and I have these installed, too:

Code:
[I] www-plugins/gecko-mediaplayer
     Available versions:  1.0.0 ~1.0.3-r1 {curl gnome}
     Installed versions:  1.0.0(10:58:31 AM 04/20/2011)(gnome)
     Homepage:            http://code.google.com/p/gecko-mediaplayer/
     Description:         A browser plugin that uses GNOME MPlayer

[I] www-plugins/mozplugger
     Available versions:  (~)1.13.2 (~)1.14.0-r1 (~)1.14.2
     Installed versions:  1.14.2(03:04:43 PM 04/01/2011)
     Homepage:            http://mozplugger.mozdev.org/
     Description:         Configurable browser plugin to launch streaming media players.


So obviously it is possible to install chromium-12 alongside gecko-mediaplayer and mozplugger. Maybe you can try the stable 1.0.0 version of gecko-mediaplayer which I have installed.

_________________
Without diversity there can be no evolution:)
Back to top
View user's profile Send private message
cwc
l33t
l33t


Joined: 20 Mar 2006
Posts: 804
Location: Tri-Cities, WA USA

PostPosted: Mon May 23, 2011 3:49 am    Post subject: Reply with quote

emerged gecko-mediaplayer.10.0

I'll wait for mozplugger 1.14.3

http://craigcoleman.com/movies/io/jump.mov

Thanks for the help!
_________________
Without diversity there can be no evolution:)
Back to top
View user's profile Send private message
ilborg
n00b
n00b


Joined: 02 Mar 2008
Posts: 42
Location: Finland

PostPosted: Tue Jun 21, 2011 5:03 pm    Post subject: Reply with quote

This is again bothering us as new version of gecko-mediaplayer doesn't have mask.

I was just wondering that firstly shouldn't the mask be other way around as I have understood that the bug is on chromium side? And could chromium be patched to so that it doesn't even try to use this plug-in? There was some kind of blacklist on chromium side, so if it compiles, but doesn't use the plug-in then everything should be okay also.

At the moment this means that I'll have remove one of the programs, and as I'm using mostly firefox and opera, it will be chromium (chromium takes anyway quite long to compile).
Back to top
View user's profile Send private message
cwc
l33t
l33t


Joined: 20 Mar 2006
Posts: 804
Location: Tri-Cities, WA USA

PostPosted: Wed Jun 22, 2011 3:09 am    Post subject: Reply with quote

ilborg wrote:
This is again bothering us as new version of gecko-mediaplayer doesn't have mask.

I was just wondering that firstly shouldn't the mask be other way around as I have understood that the bug is on chromium side? And could chromium be patched to so that it doesn't even try to use this plug-in? There was some kind of blacklist on chromium side, so if it compiles, but doesn't use the plug-in then everything should be okay also.

At the moment this means that I'll have remove one of the programs, and as I'm using mostly firefox and opera, it will be chromium (chromium takes anyway quite long to compile).


I just enjoy watching the development of chromium especially the video.
http://craigcoleman.com/vision/
I'm using the <video> tag on this page along with a ogv file.
I have no problem removing gecko then moving it back after an update world. Here's my update script.

azzerare ~ # more azzerare-sync-emerge-world-script.sh
eselect python set 1;
emerge --sync;
emerge -C gecko-mediaplayer;
emerge -uDva world;
emerge ="gecko-mediaplayer-1.0.0"
eselect python set 2;
azzerare ~ #
_________________
Without diversity there can be no evolution:)
Back to top
View user's profile Send private message
cwc
l33t
l33t


Joined: 20 Mar 2006
Posts: 804
Location: Tri-Cities, WA USA

PostPosted: Wed Jun 22, 2011 3:10 am    Post subject: Reply with quote

ilborg wrote:
This is again bothering us as new version of gecko-mediaplayer doesn't have mask.

I was just wondering that firstly shouldn't the mask be other way around as I have understood that the bug is on chromium side? And could chromium be patched to so that it doesn't even try to use this plug-in? There was some kind of blacklist on chromium side, so if it compiles, but doesn't use the plug-in then everything should be okay also.

At the moment this means that I'll have remove one of the programs, and as I'm using mostly firefox and opera, it will be chromium (chromium takes anyway quite long to compile).


I just enjoy watching the development of chromium especially the video.
http://craigcoleman.com/vision/
I'm using the <video> tag on this page along with a ogv file.
I have no problem removing gecko then moving it back after an update world. Here's my update script.

azzerare ~ # more azzerare-sync-emerge-world-script.sh
eselect python set 1;
emerge --sync;
emerge -C gecko-mediaplayer;
emerge -uDva world;
emerge ="gecko-mediaplayer-1.0.0"
eselect python set 2;
azzerare ~ #
_________________
Without diversity there can be no evolution:)
Back to top
View user's profile Send private message
Punchcutter
Apprentice
Apprentice


Joined: 11 Feb 2007
Posts: 213

PostPosted: Thu Sep 15, 2011 6:48 am    Post subject: Reply with quote

I just tried to install gecko-mediaplayer, having chromium (13.0.782.215) installed, and was told there's a block. I don't quite understand what has been discussed in this thread (except that there's a block and it must be for a good reason), or if there are any hints here for me (I looked into mozplugger, but it's masked, as I try to run stable).

Is there any news on this issue?

Thanks.
Back to top
View user's profile Send private message
cwc
l33t
l33t


Joined: 20 Mar 2006
Posts: 804
Location: Tri-Cities, WA USA

PostPosted: Thu Sep 15, 2011 1:58 pm    Post subject: Reply with quote

Punchcutter wrote:
I just tried to install gecko-mediaplayer, having chromium (13.0.782.215) installed, and was told there's a block. I don't quite understand what has been discussed in this thread (except that there's a block and it must be for a good reason), or if there are any hints here for me (I looked into mozplugger, but it's masked, as I try to run stable).

Is there any news on this issue?

Thanks.


Here is how I work around the issue:

azzerare ~ # more azzerare-sync-emerge-world-script.sh
eselect python set 1;
emerge --sync;
emerge -C gecko-mediaplayer;
emerge -uDva world;
emerge ="gecko-mediaplayer-1.0.0"
eselect python set 2;



azzerare ~ # more /etc/portage/package.keywords
#www-plugins/adobe-flash 32bit 64bit (multilib) -nspluginwrapper
www-plugins/adobe-flash 32bit 64bit (multilib) -bindist -kde -vdpau -nspluginwra
pper
<media-video/gnome-mplayer-9999
#<www-plugins/gecko-mediaplayer-9999 -curl
<www-client/chromium-9999 ~amd64 cups gnome gnome-keyring -kerberos -test -xiner
ama
<dev-util/chromium-tools-9999 -subversion
#<media-gfx/blender-9999
<dev-java/sun-jdk-9999
<media-video/ogmrip-9999
<dev-lang/v8-9999
<gnome-extra/nautilus-dropbox-9999
<x11-misc/xnviewmp-9999
<media-libs/libwebp-9999
<media-libs/vo-aacenc-9999
#<virtual/ffmpeg-9999 threads ~amd64 X encode mp3 sdl x264 -jpeg2k -theora -vaap
i -vdpau
<virtual/ffmpeg-9999 ~amd64
<media-video/ffmpeg-9999 ~amd64 3dnow 3dnowext X aac alsa bzip2 encode hardcode
d-tables mmx mmxext mp3 sdl ssse3 threads truetype vorbis x264 xvid zlib -altive
c -amr -avx -bindist -celt -cpudetection -custom-cflags -debug -dirac -doc -faac
-frei0r -gsm -ieee1394 -jack -jpeg2k -network -oss -pic -qt-faststart -rtmp -sc
hroedinger -speex -static-libs -test -theora -v4l -v4l2 -vaapi -vdpau -vpx
<www-plugins/mozplugger-9999 ~amd64
<media-libs/x264-9999 ~amd64 threads -debug -pic
<mail-client/evolution-9999 crypt gstreamer ldap python ssl (-clutter) -doc -kerberos -networkmanager
x11-libs/gtk+ ~amd64 cups introspection (-aqua) -debug -doc -examples -test -vim-syntax -xinerama
_________________
Without diversity there can be no evolution:)
Back to top
View user's profile Send private message
Punchcutter
Apprentice
Apprentice


Joined: 11 Feb 2007
Posts: 213

PostPosted: Sun Sep 18, 2011 9:43 pm    Post subject: Reply with quote

Thanks...... it seems you work around the problem by installing 1.0.0, but I would like to find a way to run latest (1.0.3) if possible.
Back to top
View user's profile Send private message
cwc
l33t
l33t


Joined: 20 Mar 2006
Posts: 804
Location: Tri-Cities, WA USA

PostPosted: Mon Sep 19, 2011 2:15 am    Post subject: Reply with quote

Punchcutter wrote:
Thanks...... it seems you work around the problem by installing 1.0.0, but I would like to find a way to run latest (1.0.3) if possible.


good luck. I like testing Chromium. So I'll stick with 1.0.0 until Chromium is fully developed.
If you really want 1.0.3 emerge -C chromium. do a emerge -pv chromium first though
_________________
Without diversity there can be no evolution:)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum