Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Realtek ALC880 not recognised any more by alsa
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
corrosif
Apprentice
Apprentice


Joined: 21 Dec 2003
Posts: 177
Location: France

PostPosted: Mon May 16, 2011 10:52 pm    Post subject: Realtek ALC880 not recognised any more by alsa Reply with quote

Hi,

Back when using Gentoo with kernel 2.6.32 and baselayout-1, the soundcard in my laptop (an Amilo M3438G 75001) was recognized and working perfectly.

Now, I'm trying to make it work with kernel linux-2.6.37-gentoo-r4 and baselayout-2 (not sure if baselayout has anything to do with the problem, but well...). But alsaconf cannot find it!

Here is the output of lspci:

Code:
00:1b.0 Audio device: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller (rev 04)


In the kernel config, I have following options:

Code:
CONFIG_SOUND=m
CONFIG_SOUND_OSS_CORE=y
CONFIG_SOUND_OSS_CORE_PRECLAIM=y
CONFIG_SND=m
CONFIG_SND_TIMER=m
CONFIG_SND_PCM=m
CONFIG_SND_SEQUENCER=m
CONFIG_SND_OSSEMUL=y
CONFIG_SND_MIXER_OSS=m
CONFIG_SND_PCM_OSS=m
CONFIG_SND_PCM_OSS_PLUGINS=y
CONFIG_SND_SEQUENCER_OSS=y
CONFIG_SND_DYNAMIC_MINORS=y
CONFIG_SND_SUPPORT_OLD_API=y
CONFIG_SND_VERBOSE_PROCFS=y
CONFIG_SND_VMASTER=y
CONFIG_SND_DMA_SGBUF=y
CONFIG_SND_PCI=y
CONFIG_SND_HDA_INTEL=m
CONFIG_SND_HDA_CODEC_REALTEK=y
CONFIG_SND_HDA_GENERIC=y


In /etc/modprobe.d/alsa.conf, I have:

Code:
alias /dev/mixer snd-mixer-oss
alias /dev/dsp snd-pcm-oss
alias /dev/midi snd-seq-oss

alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel


After compiling the kernel, and restarting the system, I have re-emerged the following packages:

Code:
media-sound/alsa-headers
media-libs/alsa-lib
media-libs/alsa-oss
media-sound/alsa-firmware
media-sound/alsa-tools
media-sound/alsa-utils


Then, I rebooted.

Here is the output of dmesg:

Code:
HDA Intel 0000:00:1b.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
HDA Intel 0000:00:1b.0: setting latency timer to 64


Then, I launched alsaconf... which is reporting me that no soundcard can be found!

However, if I launch the following command:
Code:
alsamixer -V all


I get:

Code:
Card: HDA Intel
Chip: Realtek ALC880


So far, I can't get any sound at all... do you have any idea where my problem may come from?
_________________
S'il n'y a pas de solution, alors il n'y a pas de problème (logique Shadok).
Back to top
View user's profile Send private message
corrosif
Apprentice
Apprentice


Joined: 21 Dec 2003
Posts: 177
Location: France

PostPosted: Tue May 17, 2011 3:44 pm    Post subject: Reply with quote

Strange... rebooted my laptop today, and sound is now working!

More strange, if I launch alsaconf, my soundcard is still not detected... although it works!
_________________
S'il n'y a pas de solution, alors il n'y a pas de problème (logique Shadok).
Back to top
View user's profile Send private message
dmpogo
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2289
Location: Canada

PostPosted: Tue May 17, 2011 4:24 pm    Post subject: Reply with quote

You have both OSS and ALSA stacks defined in the kernel and compiled as modules. Could it be that they conflict if loaded both, or OSS was loaded in the first try ?
Back to top
View user's profile Send private message
corrosif
Apprentice
Apprentice


Joined: 21 Dec 2003
Posts: 177
Location: France

PostPosted: Tue May 17, 2011 4:57 pm    Post subject: Reply with quote

I noticed another funny thing: sound is working, although alsasound deamon is stopped:

Code:
# /etc/init.d/alsasound status
 * status: stopped


... How can that even be possible?!?

The only thing about OSS I have activated in my kernel is this option (which is recommended in the text):

Code:
CONFIG_SOUND_OSS_CORE_PRECLAIM:

With this option enabled, the kernel will claim all OSS device
numbers if any OSS support (native or emulation) is enabled
whether the respective module is loaded or not and try to load the
appropriate module using sound-slot/service-* and char-major-*
module aliases when one of the device numbers is opened.  With
this option disabled, kernel will only claim actually in-use
device numbers and opening a missing device will generate only the
standard char-major-* aliases.

The only visible difference is use of additional module aliases
and whether OSS sound devices appear multiple times in
/proc/devices.  sound-slot/service-* module aliases are scheduled
to be removed (ie. PRECLAIM won't be available) and this option is
to make the transition easier.  This option can be overridden
during boot using the kernel parameter soundcore.preclaim_oss.

Disabling this allows alternative OSS implementations.

Please read Documentation/feature-removal-schedule.txt for
details.

If unsure, say Y.

Symbol: SOUND_OSS_CORE_PRECLAIM [=y]
Type  : boolean
Prompt: Preclaim OSS device numbers
  Defined at sound/Kconfig:32
  Depends on: SOUND [=m] && SOUND_OSS_CORE [=y]
  Location:
    -> Device Drivers
      -> Sound card support (SOUND [=m])


In the "Sound card support" page of the kernel menu configuration, I have the following:

Code:
--- Sound card support
[*]   Preclaim OSS device numbers
<M>   Advanced Linux Sound Architecture  --->
< >   Open Sound System (DEPRECATED)  --->


I have emerged following ebuilds related to alsa:

Code:
media-sound/alsa-headers-1.0.23
media-libs/alsa-lib-1.0.23
media-libs/alsa-oss-1.0.17
media-sound/alsa-firmware-1.0.23
media-sound/alsa-tools-1.0.23
media-sound/alsa-utils-1.0.23-r1


Notice that I have emerged alsa-oss... I thought it was the good way to have oss compatibility alongside alsa (for Id Software games for instance, which recommend oss).
_________________
S'il n'y a pas de solution, alors il n'y a pas de problème (logique Shadok).
Back to top
View user's profile Send private message
dmpogo
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2289
Location: Canada

PostPosted: Tue May 17, 2011 11:12 pm    Post subject: Reply with quote

corrosif wrote:
I noticed another funny thing: sound is working, although alsasound deamon is stopped:

Code:
# /etc/init.d/alsasound status
 * status: stopped




alsasound is not launching any daemon. It is just a script which loads alsa modules and perhaps restores mixer settings. Once it's done, it's done.
You can as well load modules by hand, if you wish.
Back to top
View user's profile Send private message
corrosif
Apprentice
Apprentice


Joined: 21 Dec 2003
Posts: 177
Location: France

PostPosted: Fri May 20, 2011 4:43 pm    Post subject: Reply with quote

Sigh... After many other test reboots, the fact is that sometimes I have sound (during the whole uptime), sometimes not...

And it is hard to find where the problem lies, as my soundcard is not detected by alsaconf anymore (which is a thing I can't understand, as it worked well on prior installations with older software versions), and the other dumps I mentionned stay the same.

... or am I missing something?
_________________
S'il n'y a pas de solution, alors il n'y a pas de problème (logique Shadok).
Back to top
View user's profile Send private message
krinn
Advocate
Advocate


Joined: 02 May 2003
Posts: 4294

PostPosted: Fri May 20, 2011 4:53 pm    Post subject: Reply with quote

i would bet on a bad made kernel with too few irq avaiable.
so boot -> irq for the card -> working
irq shared with some device -> card not working.
check your apic choices you've made in your new kernel or cat /proc/interrupt should gave you a good fast hint
Back to top
View user's profile Send private message
corrosif
Apprentice
Apprentice


Joined: 21 Dec 2003
Posts: 177
Location: France

PostPosted: Fri May 20, 2011 6:49 pm    Post subject: Reply with quote

Here is my interrupts state when the card is not working (I outlined the interresting part about the soundcard, which is refered by hda_intel):

Code:
$ cat /proc/interrupts
           CPU0       
  0:    2899990   IO-APIC-edge      timer
  1:       3389   IO-APIC-edge      i8042
  9:          0   IO-APIC-fasteoi   acpi
 12:         13   IO-APIC-edge      i8042
 14:      70129   IO-APIC-edge      ide0
 15:          0   IO-APIC-edge      ide1

 16:      65968   IO-APIC-fasteoi   sata_via, uhci_hcd:usb5, hda_intel, nvidia

 18:      17134   IO-APIC-fasteoi   firewire_ohci, uhci_hcd:usb4
 19:      36177   IO-APIC-fasteoi   uhci_hcd:usb3, ipw2200, eth0
 23:          2   IO-APIC-fasteoi   ehci_hcd:usb1, uhci_hcd:usb2
NMI:          0   Non-maskable interrupts
LOC:     128668   Local timer interrupts
SPU:          0   Spurious interrupts
PMI:          0   Performance monitoring interrupts
IWI:          0   IRQ work interrupts
TRM:          0   Thermal event interrupts
THR:          0   Threshold APIC interrupts
MCE:          0   Machine check exceptions
MCP:         27   Machine check polls
ERR:          0
MIS:          0


In my kernel config, I have following options related to APIC:

Code:
CONFIG_X86_UP_APIC=y
CONFIG_X86_UP_IOAPIC=y
CONFIG_X86_LOCAL_APIC=y
CONFIG_X86_IO_APIC=y
# CONFIG_X86_REROUTE_FOR_BROKEN_BOOT_IRQS is not set
CONFIG_PCI_IOAPIC=y

_________________
S'il n'y a pas de solution, alors il n'y a pas de problème (logique Shadok).
Back to top
View user's profile Send private message
krinn
Advocate
Advocate


Joined: 02 May 2003
Posts: 4294

PostPosted: Fri May 20, 2011 7:29 pm    Post subject: Reply with quote

if you can enable (it's arch dependent) enable MSI interrupt to get more irq and a better handling.
else battle with your bios or remove some unused devices (the ide0 and ide1 should belong to old crappy ide driver, where you should only have one taken by ahci)

options you might check that could help you:
CONFIG_ARCH_SUPPORTS_MSI=y : you can't set this one yourself, but will answer if you can use it or not
CONFIG_PCI_MSI=y
and INTR_REMAP

with that you will get real more irq (and will be less bug by irq sharing hell)
Code:
           CPU0       CPU1       CPU2       CPU3       CPU4       CPU5       CPU6       CPU7       
   0:        128          0          0    1068189          0          0          0          0   IO-APIC-edge      timer
   1:          0          0          0          2          0          0          0          0   IO-APIC-edge      i8042
   8:          0          0          0         59          0          0          0          0   IO-APIC-edge      rtc0
   9:          0          0          0          0          0          0          0          0   IO-APIC-fasteoi   acpi
  12:          0          0          0          4          0          0          0          0   IO-APIC-edge      i8042
  16:          0          0          0          0          0          0          0          0   IO-APIC-fasteoi   uhci_hcd:usb3
  18:          0          0          0          0          0          0          0          0   IO-APIC-fasteoi   ehci_hcd:usb1, uhci_hcd:usb8
  19:          0          0          0          0          0          0          0      37987   IO-APIC-fasteoi   uhci_hcd:usb5, uhci_hcd:usb7
  21:          0          0          0          0          0          0          0          0   IO-APIC-fasteoi   uhci_hcd:usb4
  23:          0          0          0          0          0          0       5471          0   IO-APIC-fasteoi   ehci_hcd:usb2, uhci_hcd:usb6
  24:          0     325984          0          0          0          0          0          0   IO-APIC-fasteoi   nvidia
  28:          0          0          0          0      40532          0          0          0   IO-APIC-fasteoi   aacraid
  64:          0          0          0          0          0      13299          0          0   PCI-MSI-edge      ahci
  65:      11037          0          0          0          0          0          0          0   PCI-MSI-edge      eth0
  66:          0        290          0          0          0          0          0          0   PCI-MSI-edge      hda_intel
 NMI:          0          0          0          0          0          0          0          0   Non-maskable interrupts
 LOC:     230171     320912     159898     134708     259988     262744     186090     267856   Local timer interrupts
 SPU:          0          0          0          0          0          0          0          0   Spurious interrupts
 PMI:          0          0          0          0          0          0          0          0   Performance monitoring interrupts
 PND:          0          0          0          0          0          0          0          0   Performance pending work
 RES:       1277       1333       1020       2003       1280       1269       1191       3316   Rescheduling interrupts
 CAL:      16343      14913      14823      15969      14418      10531      12617      11154   Function call interrupts
 TLB:       2720      35870       2777       3982       2898       3095       3536       4560   TLB shootdowns
 TRM:          0          0          0          0          0          0          0          0   Thermal event interrupts
 THR:          0          0          0          0          0          0          0          0   Threshold APIC interrupts
 MCE:          0          0          0          0          0          0          0          0   Machine check exceptions
 MCP:         15         15         15         15         15         15         15         15   Machine check polls
 ERR:          7
 MIS:          0
Back to top
View user's profile Send private message
corrosif
Apprentice
Apprentice


Joined: 21 Dec 2003
Posts: 177
Location: France

PostPosted: Fri May 20, 2011 9:22 pm    Post subject: Reply with quote

I have activated following options in my kernel config, as you suggested:

Code:
CONFIG_ARCH_SUPPORTS_MSI=y
CONFIG_PCI_MSI=y


I can't set INTR_REMAP because it prerequisites another options which needs 64bit architecture... and I have a pure 32bit processor (pentium-m 750).

Now the soundcard has its own irq, and things looks nicer:

Code:
$ cat /proc/interrupts
           CPU0       
  0:      70083   IO-APIC-edge      timer
  1:        514   IO-APIC-edge      i8042
  9:          0   IO-APIC-fasteoi   acpi
 12:         13   IO-APIC-edge      i8042
 14:       2035   IO-APIC-edge      ide0
 15:          0   IO-APIC-edge      ide1
 16:      18582   IO-APIC-fasteoi   sata_via, uhci_hcd:usb5, nvidia
 18:       4069   IO-APIC-fasteoi   firewire_ohci, uhci_hcd:usb4
 19:       4730   IO-APIC-fasteoi   uhci_hcd:usb3, ipw2200, eth0
 23:          2   IO-APIC-fasteoi   ehci_hcd:usb1, uhci_hcd:usb2

 40:       1148   PCI-MSI-edge      hda_intel

NMI:          0   Non-maskable interrupts
LOC:      34287   Local timer interrupts
SPU:          0   Spurious interrupts
PMI:          0   Performance monitoring interrupts
IWI:          0   IRQ work interrupts
TRM:          0   Thermal event interrupts
THR:          0   Threshold APIC interrupts
MCE:          0   Machine check exceptions
MCP:          1   Machine check polls
ERR:          0
MIS:          0


Unfortunately, I still can't hear sound, and alsaconf cannot detect my soundcard...
_________________
S'il n'y a pas de solution, alors il n'y a pas de problème (logique Shadok).
Back to top
View user's profile Send private message
krinn
Advocate
Advocate


Joined: 02 May 2003
Posts: 4294

PostPosted: Fri May 20, 2011 10:37 pm    Post subject: Reply with quote

well, it's not bad anyway to get more irq :p

just try your previous kernel: if card is detect and works 100% time : then easy, your new kernel have an option the card doesn't really like.
Back to top
View user's profile Send private message
dmpogo
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2289
Location: Canada

PostPosted: Fri May 20, 2011 11:54 pm    Post subject: Reply with quote

Actually, nvidia chips can also probably use MSI interrups. Try adding

options nvidia NVreg_EnableMSI=1

to your /etc/modprobe.d/nvidia.conf


regrading sound, what does aplay -l ( and then aplay -L ) show ?
Back to top
View user's profile Send private message
corrosif
Apprentice
Apprentice


Joined: 21 Dec 2003
Posts: 177
Location: France

PostPosted: Sat May 21, 2011 10:59 am    Post subject: Reply with quote

With your nvidia NVreg_EnableMSI=1 option, things are even nicer now :)

Code:
$ cat /proc/interrupts
           CPU0       
  0:     117586   IO-APIC-edge      timer
  1:        651   IO-APIC-edge      i8042
  9:          0   IO-APIC-fasteoi   acpi
 12:         13   IO-APIC-edge      i8042
 14:       2683   IO-APIC-edge      ide0
 15:          0   IO-APIC-edge      ide1
 16:      17428   IO-APIC-fasteoi   sata_via, uhci_hcd:usb5
 18:       5983   IO-APIC-fasteoi   firewire_ohci, uhci_hcd:usb4
 19:       6423   IO-APIC-fasteoi   uhci_hcd:usb3, ipw2200, eth0
 23:          2   IO-APIC-fasteoi   ehci_hcd:usb1, uhci_hcd:usb2

 40:       1273   PCI-MSI-edge      hda_intel
 41:       1027   PCI-MSI-edge      nvidia

NMI:          0   Non-maskable interrupts
LOC:      23738   Local timer interrupts
SPU:          0   Spurious interrupts
PMI:          0   Performance monitoring interrupts
IWI:          0   IRQ work interrupts
TRM:          0   Thermal event interrupts
THR:          0   Threshold APIC interrupts
MCE:          0   Machine check exceptions
MCP:          2   Machine check polls
ERR:          0
MIS:          0


But still no sound, and no detection from alsaconf...

Here are the outputs from aplay:

Code:
$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC880 Analog [ALC880 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0


Code:
$ aplay -L
null
    Discard all samples (playback) or generate zero samples (capture)
default:CARD=Intel
    HDA Intel, ALC880 Analog
    Default Audio Device
front:CARD=Intel,DEV=0
    HDA Intel, ALC880 Analog
    Front speakers
surround40:CARD=Intel,DEV=0
    HDA Intel, ALC880 Analog
    4.0 Surround output to Front and Rear speakers
surround41:CARD=Intel,DEV=0
    HDA Intel, ALC880 Analog
    4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=Intel,DEV=0
    HDA Intel, ALC880 Analog
    5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=Intel,DEV=0
    HDA Intel, ALC880 Analog
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=Intel,DEV=0
    HDA Intel, ALC880 Analog
    7.1 Surround output to Front, Center, Side, Rear and Woofer speakers

_________________
S'il n'y a pas de solution, alors il n'y a pas de problème (logique Shadok).
Back to top
View user's profile Send private message
dmpogo
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2289
Location: Canada

PostPosted: Sat May 21, 2011 6:23 pm    Post subject: Reply with quote

OK, so your sound card is known to the system (I often do not trust alsaconf).

what does 'amixer' show ?

you can also run alsamixer and see graphically whether it sees a card and whether any channels are muted (this is a frequent issue, and I suspect is the case here)
Back to top
View user's profile Send private message
corrosif
Apprentice
Apprentice


Joined: 21 Dec 2003
Posts: 177
Location: France

PostPosted: Sat May 21, 2011 11:18 pm    Post subject: Reply with quote

I checked alsamixer when sound is not working... my card is shown, and the interesting channels are not muted:

Code:
lqqqqqqqqqqqqqqqqqqqqqqqqqqqqq AlsaMixer v1.0.23 qqqqqqqqqqqqqqqqqqqqqqqqqqqqqqk
x Card: HDA Intel                                      F1:  Help               x
x Chip: Realtek ALC880                                 F2:  System information x
x View: F3:[Playback] F4: Capture  F5: All             F6:  Select sound card  x
x Item: Master [dB gain: 0,00]                         Esc: Exit               x
x                                                                              x
x         lqqk       lqqk       lqqk       lqqk       lqqk       lqqk          x
x         xaax       xaax       xaax       xaax       x  x       x  x          x
x         xaax       xaax       xaax       xaax       x  x       x  x          x
x         xaax       xaax       xaax       xaax       x  x       x  x          x
x         xaax       xaax       xaax       xaax       x  x       x  x          x
x         xaax       xaax       xaax       xaax       x  x       x  x          x
x         xaax       xaax       xaax       xaax       x  x       x  x          x
x         xaax       xaax       xaax       xaax       x  x       x  x          x
x         xaax       xaax       xaax       xaax       x  x       x  x          x
x         xaax       xaax       xaax       xaax       x  x       x  x          x
x         xaax       xaax       xaax       xaax       x  x       x  x          x
x         xaax       xaax       xaax       xaax       x  x       x  x          x
x         tqqu       tqqu       tqqu       mqqj       tqqu       tqqu          x
x         xOOx       xOOx       xOOx                  xMMx       xMMx          x
x         mqqj       mqqj       mqqj                  mqqj       mqqj          x
x         100       98<>98    100<>100   100<>100     0<>0       0<>0          x
x     <  Master  >Headphone   Speaker      PCM         CD        Mic           x
mqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqj


Here is the output of amixer:

Code:
$ amixer
Simple mixer control 'Master',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined penum
  Playback channels: Mono
  Limits: Playback 0 - 64
  Mono: Playback 64 [100%] [0.00dB] [on]
Simple mixer control 'Headphone',0
  Capabilities: pvolume pswitch penum
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 64
  Mono:
  Front Left: Playback 63 [98%] [-1.00dB] [on]
  Front Right: Playback 63 [98%] [-1.00dB] [on]
Simple mixer control 'Speaker',0
  Capabilities: pvolume pswitch penum
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 64
  Mono:
  Front Left: Playback 64 [100%] [0.00dB] [on]
  Front Right: Playback 64 [100%] [0.00dB] [on]
Simple mixer control 'PCM',0
  Capabilities: pvolume penum
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 255
  Mono:
  Front Left: Playback 255 [100%] [0.00dB]
  Front Right: Playback 255 [100%] [0.00dB]
Simple mixer control 'CD',0
  Capabilities: pvolume pswitch penum
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 65
  Mono:
  Front Left: Playback 0 [0%] [-35.00dB] [off]
  Front Right: Playback 0 [0%] [-35.00dB] [off]
Simple mixer control 'Mic',0
  Capabilities: pvolume pswitch penum
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 65
  Mono:
  Front Left: Playback 0 [0%] [-35.00dB] [off]
  Front Right: Playback 0 [0%] [-35.00dB] [off]
Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch penum
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 35
  Front Left: Capture 0 [0%] [0.00dB] [on]
  Front Right: Capture 0 [0%] [0.00dB] [on]
Simple mixer control 'Capture',1
  Capabilities: cvolume cswitch penum
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 35
  Front Left: Capture 0 [0%] [0.00dB] [on]
  Front Right: Capture 0 [0%] [0.00dB] [on]
Simple mixer control 'Capture',2
  Capabilities: cvolume cswitch penum
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 35
  Front Left: Capture 0 [0%] [0.00dB] [on]
  Front Right: Capture 0 [0%] [0.00dB] [on]
Simple mixer control 'Digital',0
  Capabilities: cvolume penum
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 120
  Front Left: Capture 60 [50%] [0.00dB]
  Front Right: Capture 60 [50%] [0.00dB]
Simple mixer control 'Input Source',0
  Capabilities: cenum
  Items: 'Mic' 'CD'
  Item0: 'Mic'
Simple mixer control 'Input Source',1
  Capabilities: cenum
  Items: 'Mic' 'CD'
  Item0: 'Mic'
Simple mixer control 'Input Source',2
  Capabilities: cenum
  Items: 'Mic' 'CD'
  Item0: 'Mic'

_________________
S'il n'y a pas de solution, alors il n'y a pas de problème (logique Shadok).
Back to top
View user's profile Send private message
dmpogo
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2289
Location: Canada

PostPosted: Sun May 22, 2011 1:23 am    Post subject: Reply with quote

Ok, they look fine. Do you have any .wav file ? Find one and try

aplay file.wav

would you hear anything ?


BTW, what version of alsa-utils do you have ?
Back to top
View user's profile Send private message
corrosif
Apprentice
Apprentice


Joined: 21 Dec 2003
Posts: 177
Location: France

PostPosted: Sun May 22, 2011 8:29 am    Post subject: Reply with quote

No, I can't hear anything through aplay, nor with any other application.

Here are the sound-related packages I have installed:

Code:
sys-kernel/gentoo-sources-2.6.37-r4  USE="-build -deblob -symlink"

media-sound/alsa-headers-1.0.23

media-sound/alsa-firmware-1.0.23  ALSA_CARDS="-aica -asihpi -darla20 -darla24 -echo3g -emi26 -emu10k1 -emu1212 -emu1616 -emu1820 -gina20 -gina24 -hdsp -hdspm -indigo -indigoio -korg1212 -layla20 -layla24 -maestro3 -mia -mixart -mona -msnd-pinnacle -pcxhr -sb16 -usb-usx2y -vx222 -wavefront -ymfpci"

media-libs/alsa-lib-1.0.23  USE="python -alisp -debug -doc" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol"

media-libs/alsa-oss-1.0.17

media-sound/alsa-tools-1.0.23  USE="gtk -fltk" ALSA_CARDS="-darla20 -darla24 -echo3g -emu10k1 -emu10k1x -gina20 -gina24 -hdsp -hdspm -ice1712 -indigo -indigoio -layla20 -layla24 -mia -mixart -mona -pcxhr -rme32 -rme96 -sb16 -sbawe -sscape -usb-usx2y -vx222"

media-sound/alsa-utils-1.0.23-r1  USE="nls -doc -minimal"


But... Now I recall that I had this variable set since a long time in my make.conf (which was fine by the time, but who knows, namings may have changed recently about my card):

Code:
ALSA_CARDS="hda-intel"


I will try to reemerge these ebuilds without this variable (to ensure the compilation of ALL sound drivers), to see if it helps the recognition.
_________________
S'il n'y a pas de solution, alors il n'y a pas de problème (logique Shadok).
Back to top
View user's profile Send private message
corrosif
Apprentice
Apprentice


Joined: 21 Dec 2003
Posts: 177
Location: France

PostPosted: Sun May 22, 2011 9:58 am    Post subject: Reply with quote

After recompiling everything (kernel included) without the variable ALSA_CARDS, nothing has changed.
Still no sound and no card recognition within alsaconf...
_________________
S'il n'y a pas de solution, alors il n'y a pas de problème (logique Shadok).
Back to top
View user's profile Send private message
dmpogo
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2289
Location: Canada

PostPosted: Sun May 22, 2011 4:59 pm    Post subject: Reply with quote

What if you plug in headphones ?
Back to top
View user's profile Send private message
corrosif
Apprentice
Apprentice


Joined: 21 Dec 2003
Posts: 177
Location: France

PostPosted: Sun May 22, 2011 6:01 pm    Post subject: Reply with quote

Sound is working through the headphones!
Does that mean that the main speakers are muted in an invisible way?
_________________
S'il n'y a pas de solution, alors il n'y a pas de problème (logique Shadok).
Back to top
View user's profile Send private message
duryodhana
n00b
n00b


Joined: 13 Jan 2008
Posts: 65

PostPosted: Sun May 22, 2011 7:02 pm    Post subject: Reply with quote

Code:
CONFIG_SND_HDA_INTEL=m
CONFIG_SND_HDA_HWDEP=y
CONFIG_SND_HDA_RECONFIG=y
CONFIG_SND_HDA_INPUT_BEEP=y
CONFIG_SND_HDA_INPUT_BEEP_MODE=1
CONFIG_SND_HDA_INPUT_JACK=y
CONFIG_SND_HDA_PATCH_LOADER=y
CONFIG_SND_HDA_CODEC_REALTEK=y
CONFIG_SND_HDA_CODEC_ANALOG=y
CONFIG_SND_HDA_CODEC_SIGMATEL=y
CONFIG_SND_HDA_CODEC_VIA=y
CONFIG_SND_HDA_CODEC_HDMI=y
CONFIG_SND_HDA_CODEC_CIRRUS=y
CONFIG_SND_HDA_CODEC_CONEXANT=y
CONFIG_SND_HDA_CODEC_CA0110=y
CONFIG_SND_HDA_CODEC_CMEDIA=y
CONFIG_SND_HDA_CODEC_SI3054=y
CONFIG_SND_HDA_GENERIC=y


are all these enabled in your kernel configuration?
Back to top
View user's profile Send private message
dmpogo
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2289
Location: Canada

PostPosted: Sun May 22, 2011 9:32 pm    Post subject: Reply with quote

corrosif wrote:
Sound is working through the headphones!
Does that mean that the main speakers are muted in an invisible way?


Try to mute Headphones in the mixer (although it should not be required).
And play with muting on/off other elements in the mixer then
Back to top
View user's profile Send private message
corrosif
Apprentice
Apprentice


Joined: 21 Dec 2003
Posts: 177
Location: France

PostPosted: Sun May 22, 2011 10:10 pm    Post subject: Reply with quote

I tried activating all other sound drivers, as duryodhana suggested... but results are the same.
It's not surprising though, as I am sure that my driver is the realtek one.

When muting headphones in the mixer, music is not played anywhere (headphones & main speakers).
I have tried almost all combinations of muting/unmuting for all available channels... music is never played through the main speakers.
_________________
S'il n'y a pas de solution, alors il n'y a pas de problème (logique Shadok).
Back to top
View user's profile Send private message
dmpogo
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2289
Location: Canada

PostPosted: Sun May 22, 2011 11:33 pm    Post subject: Reply with quote

corrosif wrote:
I tried activating all other sound drivers, as duryodhana suggested... but results are the same.
It's not surprising though, as I am sure that my driver is the realtek one.


Yep, that should not be an issue

Quote:


When muting headphones in the mixer, music is not played anywhere (headphones & main speakers).
I have tried almost all combinations of muting/unmuting for all available channels... music is never played through the main speakers.


Were you saying that speakers work on some boots ? You don't have an old kernel around to check if it still works ?

Hm I am a bit worried that mixer controls show nothing related to surround sound (aplay -L seems to indicate capability)[/quote]
Back to top
View user's profile Send private message
corrosif
Apprentice
Apprentice


Joined: 21 Dec 2003
Posts: 177
Location: France

PostPosted: Sun May 22, 2011 11:54 pm    Post subject: Reply with quote

My previous analysis was wrong... the fact is that the result is always the same, at each boot.
Simply, I moved my computer from place to place during the first tests, sometimes with external speakers (connected to the headphones), sometimes without.
I did not notice that when it was not working, it was always when using the internal speakers without headphones :)

On my laptop, there is no physical hardware for surround control (there are only two native speakers, and a stereo headphone output).

I kept the sources of my old kernel (2.6.32-gentoo-r7)... I could try to compile it again to see if detection still works OK on that old kernel.
_________________
S'il n'y a pas de solution, alors il n'y a pas de problème (logique Shadok).
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum