Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED]samba installation - Internal error: Killed
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish) Instalacja i sprzęt
View previous topic :: View next topic  
Author Message
professor1234
n00b
n00b


Joined: 27 Mar 2005
Posts: 41
Location: Kraków, Poland

PostPosted: Sat Apr 30, 2011 1:22 pm    Post subject: [SOLVED]samba installation - Internal error: Killed Reply with quote

Witam ponownie,

Mam problem z zainstalowaniem samby. Zanim instaluje się samba, emerge ściąga 'towarzyszące pakiety' między innymi dev-lang/php-5.3.6 i ten pakiet jest problemowy.
Poniżej log z tego co się dzieję. Jak ktoś już to przerobił i mógłby dać kilka wskazówek będę wdzięczny.

Code:

  -I/usr/include -O2 -march=i486  -c /var/tmp/portage/dev-lang/php-5.3.6/work/sapis-build/cli/ext/fileinfo/libmagic/compress.c -o ext/fileinfo/libmagic/compress.lo
i486-pc-linux-gnu-gcc: Internal error: Killed (program cc1)
Please submit a full bug report.
See <http://bugs.gentoo.org/> for instructions.
make: *** [ext/fileinfo/libmagic/apprentice.lo] Error 1
make: *** Waiting for unfinished jobs....
emake failed
 * ERROR: dev-lang/php-5.3.6 failed (compile phase):
 *   emake failed
 *
 * Call stack:
 *              ebuild.sh, line   56:  Called src_compile
 *            environment, line 4626:  Called eblit-run 'src_compile' 'v1'
 *            environment, line 1803:  Called eblit-php-src_compile
 *   src_compile-v1.eblit, line   14:  Called php_sapi_build 'cli'
 *   src_compile-v1.eblit, line   23:  Called die
 * The specific snippet of code:
 *   emake || die "emake failed"
 *
 * If you need support, post the output of 'emerge --info =dev-lang/php-5.3.6',
 * the complete build log and the output of 'emerge -pqv =dev-lang/php-5.3.6'.
 * The complete build log is located at '/var/tmp/portage/dev-lang/php-5.3.6/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-lang/php-5.3.6/temp/environment'.
 * S: '/var/tmp/portage/dev-lang/php-5.3.6/work/php-5.3.6'

>>> Failed to emerge dev-lang/php-5.3.6, Log file:

>>>  '/var/tmp/portage/dev-lang/php-5.3.6/temp/build.log'

 * Messages for package dev-lang/php-5.3.6:

 * Please note that this version of PHP does not yet come with a suhosin patch
 * ERROR: dev-lang/php-5.3.6 failed (compile phase):
 *   emake failed
 *
 * Call stack:
 *              ebuild.sh, line   56:  Called src_compile
 *            environment, line 4626:  Called eblit-run 'src_compile' 'v1'
 *            environment, line 1803:  Called eblit-php-src_compile
 *   src_compile-v1.eblit, line   14:  Called php_sapi_build 'cli'
 *   src_compile-v1.eblit, line   23:  Called die
 * The specific snippet of code:
 *   emake || die "emake failed"
 *
 * If you need support, post the output of 'emerge --info =dev-lang/php-5.3.6',
 * the complete build log and the output of 'emerge -pqv =dev-lang/php-5.3.6'.
 * The complete build log is located at '/var/tmp/portage/dev-lang/php-5.3.6/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-lang/php-5.3.6/temp/environment'.
 * S: '/var/tmp/portage/dev-lang/php-5.3.6/work/php-5.3.6'

 * IMPORTANT: 3 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


Last edited by professor1234 on Mon May 02, 2011 8:05 pm; edited 1 time in total
Back to top
View user's profile Send private message
Crenshaw
Guru
Guru


Joined: 23 Jun 2004
Posts: 474
Location: Poland

PostPosted: Sun May 01, 2011 8:58 pm    Post subject: Reply with quote

Code:
-march=i486


pokaz emerge --info

z tego co mi sie wydaje to samba nie ma wprost zaleznosci od php wiec moze nie jest Ci to potrzebne? pogrzeb we flagach use zeby zobaczyc co wyciaga php do instalacji
pomocna moze byc opcja --tree do emerge ktora powoduje wypisywanie zaleznosci w ladnym drzewku
Back to top
View user's profile Send private message
professor1234
n00b
n00b


Joined: 27 Mar 2005
Posts: 41
Location: Kraków, Poland

PostPosted: Mon May 02, 2011 8:04 pm    Post subject: Reply with quote

Kolego Crenshaw,

Problem polega na ilości pamięci - tak przynajmniej stwierdzam po tym jak już udało mi się to zainstalować - mam 256Mb i nie robiłem swapa - uważałem że nie potrzeba.
Po tym jak go zrobiłem wszystko się skompilowało - szkoda tylko że nie pokazało że przyczyną jest brak pamięci...

However poniżej linijki, które się mogą przydać jak ktoś nie przeznaczył m-ca na dysku na swap.
Na podstawie:
http://www.linux.rk.edu.pl/w/p/system-plikw-w-pliku/

Code:

dd if=/dev/zero of=disk-image count=100000
mkswap disk-image
swapon
Back to top
View user's profile Send private message
Pryka
l33t
l33t


Joined: 08 Jun 2007
Posts: 625
Location: /dev/null

PostPosted: Tue May 03, 2011 2:02 pm    Post subject: Reply with quote

przy 256mb ramu stwierdziłeś, że Ci SWAP Niepotrzebny? O_o

Ja przy 4GB nadal go mam.

Poza tym kompilacja kodu to nie zwykła instalacja, samemu trzeba interpretować problemy.
Back to top
View user's profile Send private message
professor1234
n00b
n00b


Joined: 27 Mar 2005
Posts: 41
Location: Kraków, Poland

PostPosted: Wed May 04, 2011 7:13 pm    Post subject: Reply with quote

Dysk mam mały, a w związku z tym że to pod serwer/router, to kilka aplikacji mi chodzi cały czas i nie są one pamięciożerne, więc zasadniczo na co dzień wystarcza, tylko przy kompilacji czasami problemy - jak widac.

Niemniej było by miło jakby kompilator wywalał błąd że pamięci brakuje...

Dzięki za zainteresowanie
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish) Instalacja i sprzęt All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum