Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Xfce4 & ConsoleKit Help
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
SDNick484
Tux's lil' helper
Tux's lil' helper


Joined: 05 Dec 2005
Posts: 138

PostPosted: Sat Apr 12, 2014 6:30 am    Post subject: Xfce4 & ConsoleKit Help Reply with quote

An update has somehow broken my consolekit settings so that now I can't execute suspend or shutdown from Xfce as a non-privileged user anymore. I know this is a consolekit issue however I'm not sure how to correct it. It was working previously, and a major pain to get it right in the first place. I have tried re-following the steps in this thread however it doesn't seem to help.

So far I have the following:
[ebuild R ] sys-auth/pambase-20140313 USE="cracklib sha512 (-consolekit) -debug -gnome-keyring -minimal -mktemp -pam_krb5 -pam_ssh -passwdqc (-selinux) -systemd" 0 kB
[ebuild R ] dev-libs/glib-2.38.2-r1:2 USE="-debug (-fam) (-selinux) -static-libs -systemtap {-test} -utils -xattr" ABI_X86="32 (64) (-x32)" PYTHON_TARGETS="python2_7 -python2_6" 0 kB
[ebuild R ] sys-apps/shadow-4.1.5.1-r1 USE="acl cracklib nls pam -audit (-selinux) -skey -xattr" 0 kB
[ebuild R ] dev-libs/dbus-glib-0.102 USE="-debug -doc -static-libs {-test}" ABI_X86="32 (64) (-x32)" 0 kB
[ebuild R ] sys-fs/udisks-2.1.3:2 USE="gptfdisk introspection -cryptsetup -debug (-selinux) -systemd" 0 kB
[ebuild R ] gnome-extra/polkit-gnome-0.105-r1 304 kB
[ebuild R ] gnome-base/gvfs-1.18.3 USE="archive avahi bluetooth cdda fuse gdu gnome-online-accounts gphoto2 gtk http libsecret udev udisks -afp -bluray -ios -mtp -samba -systemd {-test}" 0 kB
[ebuild R ] sys-power/upower-0.9.23-r2 USE="introspection -doc -ios -systemd" 0 kB
[ebuild R ] sys-auth/consolekit-0.4.6 USE="acl pam policykit -debug -doc (-selinux) -systemd-units {-test}" 0 kB

I am running ~amd64 and have absolutely no interest in running systemd unless I absolutely have to.

My ~/.xinitrc looks like: exec ck-launch-session startxfce4

When I do a ck-list-sessions, I see only one session and [/url]both active & is-local are listed as FALSE (I recall they need to be TRUE, I just don't know what I need to do to fix them.

This is a single user laptop so I'm open to insecure polkit entries if that's an easier way to fix this problem.

Any help would be greatly appreciated.
Back to top
View user's profile Send private message
TomWij
Developer
Developer


Joined: 04 Jul 2012
Posts: 1345

PostPosted: Sat Apr 12, 2014 9:03 am    Post subject: Reply with quote

Can you please follow along this duplicate thread? The Gentoo maintainer of XFCE has already been send to it, it's only a matter of time before there will be a response.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum