Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
E17 has landed! Was: E17 is coming? (Part 7)
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 12, 13, 14  
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Skippy204
Apprentice
Apprentice


Joined: 09 May 2008
Posts: 187
Location: Fort Collins, Colorado, USA

PostPosted: Mon Feb 03, 2014 10:59 pm    Post subject: Reply with quote

Thank you - I was *assuming* those packages were related to e16. My mistake.

I will remove e17 and proceed from there. Thanks very much for the kick in the butt.
Back to top
View user's profile Send private message
Aonoa
Guru
Guru


Joined: 23 May 2002
Posts: 585
Location: Oslo, Norway

PostPosted: Sun Mar 23, 2014 2:29 am    Post subject: Reply with quote

I'm curious about the Enlightenment ebuilds in portage which seem to be a bit outdated? Is there a reason?

There is no E18 and Terminology is on 0.4 instead of 0.5.

There is no emotion-generic-players-1.9.0 ebuild at all, unless it is supposed to be media-libs/emotion-1.7.9 and EFL is at 1.9.0 instead of 1.9.1.

I used an ebuild for Enlightenment 0.18.5 from an overlay and it worked perfectly as an upgrade from 0.17.6 in the official gentoo repo. Seems to me that there should be no problems updating the Enlightenment ebuilds in the official tree?
_________________
Dive into Gentoo Linux and emerge into a new world
Back to top
View user's profile Send private message
Holysword
l33t
l33t


Joined: 19 Nov 2006
Posts: 808
Location: Greece

PostPosted: Wed Mar 26, 2014 6:56 pm    Post subject: Reply with quote

Aonoa wrote:
I'm curious about the Enlightenment ebuilds in portage which seem to be a bit outdated? Is there a reason?

There is no E18 and Terminology is on 0.4 instead of 0.5.

There is no emotion-generic-players-1.9.0 ebuild at all, unless it is supposed to be media-libs/emotion-1.7.9 and EFL is at 1.9.0 instead of 1.9.1.

I used an ebuild for Enlightenment 0.18.5 from an overlay and it worked perfectly as an upgrade from 0.17.6 in the official gentoo repo. Seems to me that there should be no problems updating the Enlightenment ebuilds in the official tree?


Now I am also curious, which overlay is it?

About shelves and shortcut... I have been using this shortcut to hide/show a shelf, but I am wondering if there is any trick (perhaps with enlightenment_remote?) to use the same shortcut to hide/show two shelves? Also, the shortcut shows the shelf for as long as you hold it, is there any trick to get it to "toggle" the state instead?
_________________
"Nolite arbitrari quia venerim mittere pacem in terram non veni pacem mittere sed gladium" (Yeshua Ha Mashiach)
Who will save us from pulseaudio and systemd?
Back to top
View user's profile Send private message
ruta
n00b
n00b


Joined: 01 Oct 2004
Posts: 60
Location: Canada

PostPosted: Thu Apr 10, 2014 8:55 pm    Post subject: Reply with quote

I have a problem with e17 that I've had since e17 was put on portage. I used to use layman before that, but switched to portage's when it became available. Sorry if this problem has come up, but it's kind of hard to explain, so I also find it hard to search for a way to solve it.

Anyway, it's basically a problem where my minimised windows reappear when I don't want them to. It happens when I minimise or close a window around the area where I minimised another window. So, say I minimise a window on Desktop 1 that's full screen. Then I open another window on Desktop 1, and then close it. When it closes, the first window will just reappear. If I open a window on Desktop 2 and then close it, the first window will remain minimised. I wonder if this is some sort of strange preference or something? Anyway, it is driving me crazy and I can't stand waiting for it to go away anymore. I've gotten in the habit of just moving all the things I want to minimise to another virtual desktop. Does anyone have any idea what this is?
Back to top
View user's profile Send private message
ppurka
Advocate
Advocate


Joined: 26 Dec 2004
Posts: 3209

PostPosted: Fri Apr 11, 2014 5:32 am    Post subject: Reply with quote

@ruta: Can not reproduce this behavior with e-0.17.6.
_________________
emerge --quiet redefined | E17 vids: I, II | Now using kde4 :-/
Back to top
View user's profile Send private message
ruta
n00b
n00b


Joined: 01 Oct 2004
Posts: 60
Location: Canada

PostPosted: Fri Apr 11, 2014 7:11 pm    Post subject: Reply with quote

Yeah, I've never heard anyone else talk about the problem. I don't know how I managed to get this kind of bug, but I've had the problem long before e-0.17.6, and before the efl merge. It happened as soon as e17 "landed" and was moved to portage. There must be some remnant of some old e17 build hanging around in my system from when I went from the layman overlay to portage. I just don't know how or where to find it. Of course, when I moved to e17 from portage from layman, I unmerged everything to do with e17 first, but I assume something must be hanging around causing this problem. I just don't know what I should even begin looking for.

As an aside, I don't know if it's related, but at some point, some of the graphical effects from the composite module also broke. Specifically, windows in applications that should be transparent are no longer transparent. It seems unlikely that these two things are related, though. The first problem begun well before the second one. I usually don't enable composite, so I don't really care, but it's tiring to always tip-toe around all the ways my enlightenment is broken.

Edit: I hate to say it, but I was playing around with focus, and this only happens when focus is Pointer. I switched to Sloppy and the problem went away. I had issues with sloppy in the past, but maybe it's better now. I have to wonder if this is desired behaviour, though?
Back to top
View user's profile Send private message
ppurka
Advocate
Advocate


Joined: 26 Dec 2004
Posts: 3209

PostPosted: Sat Apr 12, 2014 7:04 am    Post subject: Reply with quote

ruta wrote:
Edit: I hate to say it, but I was playing around with focus, and this only happens when focus is Pointer. I switched to Sloppy and the problem went away. I had issues with sloppy in the past, but maybe it's better now. I have to wonder if this is desired behaviour, though?
There are two possibilities:
1. You might have some old library lying around.
2. Your configuration might be broken in some way.

I don't have problems with composite or focus with e17. Now, e19 is a different beast.
_________________
emerge --quiet redefined | E17 vids: I, II | Now using kde4 :-/
Back to top
View user's profile Send private message
Aonoa
Guru
Guru


Joined: 23 May 2002
Posts: 585
Location: Oslo, Norway

PostPosted: Sat Apr 12, 2014 9:08 am    Post subject: Reply with quote

Holysword wrote:
Now I am also curious, which overlay is it?


Sorry for the late reply, I have been busy and am now using e19 from git instead, but it was this overlay:

http://gpo.zugaina.org/Overlays/sera/x11-wm/enlightenment
_________________
Dive into Gentoo Linux and emerge into a new world
Back to top
View user's profile Send private message
Holysword
l33t
l33t


Joined: 19 Nov 2006
Posts: 808
Location: Greece

PostPosted: Sat May 10, 2014 1:04 am    Post subject: Reply with quote

Aonoa wrote:
Holysword wrote:
Now I am also curious, which overlay is it?


Sorry for the late reply, I have been busy and am now using e19 from git instead, but it was this overlay:

http://gpo.zugaina.org/Overlays/sera/x11-wm/enlightenment

Thanks for pointing out. I will try it out... eventually... xD

I am on e18 now and it looks really nice. What really, really, really, desperately, absurdly annoys me now (and always have) is the fact that the systray module seems to be so horribly abandoned. The thing comes up invisible, and making it impossible to click on it to find its settings. Once you open something that goes in the systray it becomes kind of visible, but clicking on it doesn't actually give you the menu for the systray settings, but for the application's settings instead. It takes loads of patience for you to find that exact pixel that is recognized as a right click ON THE TRAY that finally gives you the settings menu. Also, as a gadget it is a true challenge. Try adding it as a gadget on your desktop or on the overlay: ♪ oh where, oh where, can my systray be ♫ ??
_________________
"Nolite arbitrari quia venerim mittere pacem in terram non veni pacem mittere sed gladium" (Yeshua Ha Mashiach)
Who will save us from pulseaudio and systemd?
Back to top
View user's profile Send private message
Ant P.
Advocate
Advocate


Joined: 18 Apr 2009
Posts: 2512
Location: UK

PostPosted: Sun May 11, 2014 2:10 am    Post subject: Reply with quote

The systray in e17 has always been that broken, fyi.

I tend to just put up with it, since there's usually only 1-2 icons needing it at most.
Back to top
View user's profile Send private message
ppurka
Advocate
Advocate


Joined: 26 Dec 2004
Posts: 3209

PostPosted: Sun May 11, 2014 7:15 am    Post subject: Reply with quote

systray in e18 and e19 are much worse than in e17. Make sure that you enable the xembed option in the systray. For e19, I opened the following ticket, but the dev is unable to reproduce my problems (I can reproduce in two completely separate installations):
https://phab.enlightenment.org/T1242
_________________
emerge --quiet redefined | E17 vids: I, II | Now using kde4 :-/
Back to top
View user's profile Send private message
Holysword
l33t
l33t


Joined: 19 Nov 2006
Posts: 808
Location: Greece

PostPosted: Mon May 12, 2014 2:54 pm    Post subject: Reply with quote

ppurka wrote:
systray in e18 and e19 are much worse than in e17. Make sure that you enable the xembed option in the systray. For e19, I opened the following ticket, but the dev is unable to reproduce my problems (I can reproduce in two completely separate installations):
https://phab.enlightenment.org/T1242

I can relate to that. There are 4 icons in mine: SpiderOak, wicd, Skype and Audacious. You can identify them. Sort of. The bar is invisible but making it visible shows that the icons are actually oversized and misplaced. It is a mess. I am using the overlay, is there any chance to check which commit I am in?

http://oi58.tinypic.com/2upqn8g.jpg
http://oi58.tinypic.com/2ij6wrt.jpg

EDIT#1: Also, e18 is giving me annoying problems with focus when I change desktop. It gives me the cursor blinking in the window under the mouse, but then I type and it goes to another window. It is quite weird.
_________________
"Nolite arbitrari quia venerim mittere pacem in terram non veni pacem mittere sed gladium" (Yeshua Ha Mashiach)
Who will save us from pulseaudio and systemd?
Back to top
View user's profile Send private message
ppurka
Advocate
Advocate


Joined: 26 Dec 2004
Posts: 3209

PostPosted: Tue May 13, 2014 1:31 pm    Post subject: Reply with quote

Please reply to the ticket if you are also having issues with systray. I doubt the dev zmike uses systray, otherwise he should have noticed this erratic behavior within 5 min of using it.

To get the revision you can simply look at the first commit of
Code:
git log
when you are in the enlightenment source directory. If you are using portage then unpack the ebuild and then check what revision it reports
Code:
ebuild $(equery which enlightenment) unpack


I reported focus problems like that long ago with both e18 and e19. There has been a recent release of e18 (or maybe its development version). You can try that out.
_________________
emerge --quiet redefined | E17 vids: I, II | Now using kde4 :-/
Back to top
View user's profile Send private message
Holysword
l33t
l33t


Joined: 19 Nov 2006
Posts: 808
Location: Greece

PostPosted: Tue May 13, 2014 5:13 pm    Post subject: Reply with quote

ppurka wrote:
Please reply to the ticket if you are also having issues with systray. I doubt the dev zmike uses systray, otherwise he should have noticed this erratic behavior within 5 min of using it.

To get the revision you can simply look at the first commit of
Code:
git log
when you are in the enlightenment source directory. If you are using portage then unpack the ebuild and then check what revision it reports
Code:
ebuild $(equery which enlightenment) unpack


I reported focus problems like that long ago with both e18 and e19. There has been a recent release of e18 (or maybe its development version). You can try that out.

I was using the overlay, but now I am using 0.18.7 from official Gentoo repository. Systray problem persists. I will post it on Phabricator.
_________________
"Nolite arbitrari quia venerim mittere pacem in terram non veni pacem mittere sed gladium" (Yeshua Ha Mashiach)
Who will save us from pulseaudio and systemd?
Back to top
View user's profile Send private message
ppurka
Advocate
Advocate


Joined: 26 Dec 2004
Posts: 3209

PostPosted: Wed May 14, 2014 4:54 am    Post subject: Reply with quote

Holysword wrote:
I was using the overlay, but now I am using 0.18.7 from official Gentoo repository. Systray problem persists. I will post it on Phabricator.
Does the systray problem persist in enlightenment 0.18.8? It does in enlightenment-git (e19):

https://phab.enlightenment.org/phame/live/3/post/efl_elementary_and_friends_1_10_beta2_plus_enlightenment_0_18_8/

Thanks for reporting in the ticket.
_________________
emerge --quiet redefined | E17 vids: I, II | Now using kde4 :-/
Back to top
View user's profile Send private message
Holysword
l33t
l33t


Joined: 19 Nov 2006
Posts: 808
Location: Greece

PostPosted: Thu May 15, 2014 3:34 pm    Post subject: Reply with quote

ppurka wrote:
Does the systray problem persist in enlightenment 0.18.8? It does in enlightenment-git (e19):

https://phab.enlightenment.org/phame/live/3/post/efl_elementary_and_friends_1_10_beta2_plus_enlightenment_0_18_8/

Thanks for reporting in the ticket.

I will test that when I have the opportunity, I'll let you know!
_________________
"Nolite arbitrari quia venerim mittere pacem in terram non veni pacem mittere sed gladium" (Yeshua Ha Mashiach)
Who will save us from pulseaudio and systemd?
Back to top
View user's profile Send private message
Holysword
l33t
l33t


Joined: 19 Nov 2006
Posts: 808
Location: Greece

PostPosted: Fri May 16, 2014 6:56 pm    Post subject: Reply with quote

ppurka wrote:
Holysword wrote:
I was using the overlay, but now I am using 0.18.7 from official Gentoo repository. Systray problem persists. I will post it on Phabricator.
Does the systray problem persist in enlightenment 0.18.8? It does in enlightenment-git (e19):

https://phab.enlightenment.org/phame/live/3/post/efl_elementary_and_friends_1_10_beta2_plus_enlightenment_0_18_8/

Thanks for reporting in the ticket.

Btw, is there a git repository to fetch these things from? Downloading tarballs for every update doesn't sound like a very sexy approach.
_________________
"Nolite arbitrari quia venerim mittere pacem in terram non veni pacem mittere sed gladium" (Yeshua Ha Mashiach)
Who will save us from pulseaudio and systemd?
Back to top
View user's profile Send private message
ppurka
Advocate
Advocate


Joined: 26 Dec 2004
Posts: 3209

PostPosted: Sat May 17, 2014 9:14 am    Post subject: Reply with quote

Holysword wrote:
Btw, is there a git repository to fetch these things from? Downloading tarballs for every update doesn't sound like a very sexy approach.
Yes, there is. It is all at git.enlightenment.org

To install you will have to use either of

1. the -9999 ebuilds: maybe from some overlay - I use my own that I adapted from either the portage ebuilds or enlightenment overlay
use

2. easy_efl.sh from morlenxus: http://omicron.homeip.net/projects/#easy_efl_sh

3. easy_efl.sh from my github (it is a modified version of above): https://github.com/ppurka/easy_efl
_________________
emerge --quiet redefined | E17 vids: I, II | Now using kde4 :-/
Back to top
View user's profile Send private message
Holysword
l33t
l33t


Joined: 19 Nov 2006
Posts: 808
Location: Greece

PostPosted: Sat Jun 28, 2014 6:53 pm    Post subject: Reply with quote

Does anybody here have experience with dualhead on E18? I am having a serious headache.
_________________
"Nolite arbitrari quia venerim mittere pacem in terram non veni pacem mittere sed gladium" (Yeshua Ha Mashiach)
Who will save us from pulseaudio and systemd?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Goto page Previous  1, 2, 3 ... 12, 13, 14
Page 14 of 14

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum