Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
E17 has landed! Was: E17 is coming? (Part 7)
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 6, 7, 8 ... 12, 13, 14  Next  
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Yminus
Apprentice
Apprentice


Joined: 06 Jan 2008
Posts: 167

PostPosted: Wed Oct 24, 2012 9:25 am    Post subject: Reply with quote

ppurka wrote:
Set an icon theme in e. Can't remember, but it's there in settings.


It's in 'Application Theme' -> 'Icons'

...and it works. Thank you!
_________________
Göögle is evil!
To protect your privacy search the net with
https://www.ixquick.com
Back to top
View user's profile Send private message
Clad in Sky
l33t
l33t


Joined: 04 May 2007
Posts: 750
Location: Germany

PostPosted: Mon Oct 29, 2012 8:35 pm    Post subject: Reply with quote

So, updating e17 suddenly stopped working. Specifically, enlightenment dies in configure phase because of this:
Code:
checking for E... no
configure: error: Package requirements (
  evas >= 1.7.0
  ecore >= 1.7.0
  ecore-x >= 1.7.0
  ecore-evas >= 1.7.0
  ecore-input >= 1.7.0
  ecore-input-evas >= 1.7.0
  ecore-con >= 1.7.0
  ecore-ipc >= 1.7.0
  ecore-file >= 1.7.0
  eet >= 1.7.0
  edje >= 1.7.0
  efreet >= 1.7.0
  efreet-mime >= 1.7.0
  efreet-trash >= 1.7.0
  eina >= 1.7.0
  dbus-1
  edbus >= 1.7.0
  eio >= 1.7.0
 
 
  eukit >= 1.2.0
  eeze
) were not met:

Requested 'eio >= 1.7.0' but version of eio is 1.6.99.0

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables E_CFLAGS
and E_LIBS to avoid the need to call pkg-config.

Unfortunately I have no idea if adjusting the PKG_CONFIG_PATH does anything. Moreover, I don't know how to do it.
Any hints?
_________________
Kali Ma
Now it's autumn of the aeons
Dance with your sword
Now it's time for the harvest
Back to top
View user's profile Send private message
ppurka
Advocate
Advocate


Joined: 26 Dec 2004
Posts: 3181

PostPosted: Tue Oct 30, 2012 12:40 am    Post subject: Reply with quote

You can't just update e17. You have to update the whole stack, right from eina.
_________________
emerge --quiet redefined | E17 vids: I, II
Back to top
View user's profile Send private message
Clad in Sky
l33t
l33t


Joined: 04 May 2007
Posts: 750
Location: Germany

PostPosted: Tue Oct 30, 2012 7:52 am    Post subject: Reply with quote

I'm doing it like the e17 howto in Gentoo-Wiki describes. More or less. I made a script, that goes:
Code:

emerge -av --keep-going eina eet evas ecore efreet embryo edje eeze e_dbus enlightenment $(qlist -I -C x11-plugins/e_modules)

All packages emerge just fine, only enlightenment dies (and some module, but that is not too bad), probably because it expects eio and some others to be > 1.7 and not 1.6.9999. Where do I go wrong?

SOLVED:
Emerged eio, afterwards enlightenment didn't fail anymore.
_________________
Kali Ma
Now it's autumn of the aeons
Dance with your sword
Now it's time for the harvest
Back to top
View user's profile Send private message
rpil
Apprentice
Apprentice


Joined: 23 May 2008
Posts: 288

PostPosted: Tue Oct 30, 2012 10:12 am    Post subject: Reply with quote

I found some very beautiful E17 themes that I like to use, but they are too old and they don't function in the new Enlightenment versions. How can I update those themes, as edje_convert is dropped from E17 maintainers?
Is there any other way? :?
Back to top
View user's profile Send private message
ppurka
Advocate
Advocate


Joined: 26 Dec 2004
Posts: 3181

PostPosted: Tue Oct 30, 2012 1:21 pm    Post subject: Reply with quote

Unfortunately, no. A lot of good themes haven't been updated for years. :-(
_________________
emerge --quiet redefined | E17 vids: I, II
Back to top
View user's profile Send private message
rpil
Apprentice
Apprentice


Joined: 23 May 2008
Posts: 288

PostPosted: Tue Oct 30, 2012 7:58 pm    Post subject: Reply with quote

Oh, good Lord, no! :cry:
Back to top
View user's profile Send private message
rpil
Apprentice
Apprentice


Joined: 23 May 2008
Posts: 288

PostPosted: Thu Nov 01, 2012 11:51 am    Post subject: Reply with quote

There is a package named editje that can edit .edj files. But when I typed "eix editje" I receive "no matches found"! I saw it here: http://gpo.zugaina.org/dev-util/editje
Why isn't in the enlightenment overlay or official portage?
Back to top
View user's profile Send private message
Clad in Sky
l33t
l33t


Joined: 04 May 2007
Posts: 750
Location: Germany

PostPosted: Thu Nov 01, 2012 1:10 pm    Post subject: Reply with quote

You can build it manually:
svn co http://svn.enlightenment.org/svn/e/trunk/editje
cd editje
./autogen.sh
make
(as root) make install

Builds for me, but crashes when I start it. Perhaps you're luckier.
_________________
Kali Ma
Now it's autumn of the aeons
Dance with your sword
Now it's time for the harvest
Back to top
View user's profile Send private message
ppurka
Advocate
Advocate


Joined: 26 Dec 2004
Posts: 3181

PostPosted: Thu Nov 01, 2012 2:20 pm    Post subject: Reply with quote

I think it needs the python-efl components. But it has gone unmaintained for the past year.
_________________
emerge --quiet redefined | E17 vids: I, II
Back to top
View user's profile Send private message
avx
Advocate
Advocate


Joined: 21 Jun 2004
Posts: 2070

PostPosted: Mon Nov 05, 2012 4:45 pm    Post subject: Reply with quote

http://www.enlightenment.org/p.php?p=news/show&l=en&news_id=62 - there we have it, e17 finally being alpha :twisted:
_________________
++++++++++[>+++++++>++++++++++>+++>+<<<<-]>++.>+.+++++++..+++.>++.<<+++++++++++++++.>.+++.------.--------.>+.>.
Back to top
View user's profile Send private message
Clad in Sky
l33t
l33t


Joined: 04 May 2007
Posts: 750
Location: Germany

PostPosted: Mon Nov 05, 2012 6:42 pm    Post subject: Reply with quote

Huzzah!
_________________
Kali Ma
Now it's autumn of the aeons
Dance with your sword
Now it's time for the harvest
Back to top
View user's profile Send private message
Holysword
l33t
l33t


Joined: 19 Nov 2006
Posts: 754
Location: Greece

PostPosted: Mon Nov 12, 2012 1:47 pm    Post subject: Reply with quote

avx wrote:
http://www.enlightenment.org/p.php?p=news/show&l=en&news_id=62 - there we have it, e17 finally being alpha :twisted:

This is BEAUTIFUL! :o Thanks for sharing!

Now, one question. Is there any way to force a specific window to have a specific title? I mean, I can do that with kwrite and kate, for instance, but these commands provide an option --title. If I want to do for mplayer instead, would that be possible?
_________________
"Nolite arbitrari quia venerim mittere pacem in terram non veni pacem mittere sed gladium" (Yeshua Ha Mashiach)
Back to top
View user's profile Send private message
avx
Advocate
Advocate


Joined: 21 Jun 2004
Posts: 2070

PostPosted: Mon Nov 12, 2012 2:41 pm    Post subject: Reply with quote

Holysword wrote:
avx wrote:
http://www.enlightenment.org/p.php?p=news/show&l=en&news_id=62 - there we have it, e17 finally being alpha :twisted:

This is BEAUTIFUL! :o Thanks for sharing!
Just to make sure you didn't miss it, the final is set to be released on Dec. 21st 2012 - be sure to have a fast machine so you can compile it before the world ends :twisted:

As for your question, I'm not sure there is a general and easy way. Question is, for what do you need it? You could try `xprop -id $window-id -set $property $value`.
_________________
++++++++++[>+++++++>++++++++++>+++>+<<<<-]>++.>+.+++++++..+++.>++.<<+++++++++++++++.>.+++.------.--------.>+.>.
Back to top
View user's profile Send private message
Holysword
l33t
l33t


Joined: 19 Nov 2006
Posts: 754
Location: Greece

PostPosted: Mon Nov 12, 2012 3:49 pm    Post subject: Reply with quote

avx wrote:
Just to make sure you didn't miss it, the final is set to be released on Dec. 21st 2012 - be sure to have a fast machine so you can compile it before the world ends :twisted:

Hahah, I'll do so. I got an i7, it should do the trick.

avx wrote:
As for your question, I'm not sure there is a general and easy way. Question is, for what do you need it? You could try `xprop -id $window-id -set $property $value`.

I don't formally NEED it, it is more of a tool. I have some scripts that launch some applications, open some files and etc, and they sometimes look very alike (mplayer was just an example) so I lose some time trying to identify who is who. If I set the window name things would be way easier.

This is what I get:
Code:
† perjanus † ~ $  xprop -name MPlayer
__E_ATOM_DESKTOP_FILE(UTF8_STRING) = "/home/holysword/.local/share/applications/mplayer.desktop"
__E_WINDOW_MAPPED(CARDINAL) = 1
WM_STATE(WM_STATE):
                window state: Normal
                icon window: 0x0
_E_FRAME_SIZE(CARDINAL) = 0, 0, 22, 4
_NET_FRAME_EXTENTS(CARDINAL) = 0, 0, 22, 4
__E_WINDOW_DESK(CARDINAL) = 1, 0
E_ZONE_GEOMETRY(CARDINAL) = 0, 0, 2100, 900
__E_WINDOW_ZONE(CARDINAL) = 0
__E_WINDOW_CONTAINER(CARDINAL) = 0
__E_WINDOW_MANAGED(CARDINAL) = 1
WM_NORMAL_HINTS(WM_SIZE_HINTS):
                program specified location: 1439, 22
                program specified size: 640 by 480
                program specified minimum size: 4 by 4
                program specified minimum aspect ratio: 640/480
                program specified maximum aspect ratio: 640/480
                program specified base size: 0 by 0
                window gravity: Static
WM_ICON_NAME(STRING) = "MPlayer"
_NET_WM_PID(CARDINAL) = 29860
WM_CLASS(STRING) = "xv", "MPlayer"
_NET_WM_NAME(UTF8_STRING) = "MPlayer"
WM_NAME(STRING) = "MPlayer"
WM_PROTOCOLS(ATOM): protocols  WM_DELETE_WINDOW
† perjanus † ~ $

There is no title property (it appears in the ICCCM properties window, but it is gray-ish as in "disabled"). Setting WM_NAME won't change the title either (it changes the WM_NAME indeed, but the title remains the same). _NET_WM_NAME property won't change at all ("xprop: error: unsupported conversion for _NET_WM_NAME" error). I found out that there exists a property _NET_WM_VISIBLE_NAME but that won't change either.
_________________
"Nolite arbitrari quia venerim mittere pacem in terram non veni pacem mittere sed gladium" (Yeshua Ha Mashiach)
Back to top
View user's profile Send private message
avx
Advocate
Advocate


Joined: 21 Jun 2004
Posts: 2070

PostPosted: Mon Nov 12, 2012 4:01 pm    Post subject: Reply with quote

Currently not on an e17 machine so I might be wrong here, but I remember trying some wm lately which offered renaming windows via a menu reached by the top-left button. If I remember that correctly, I'm pretty sure there would be a way to do it via some sort of script, only need to find out how.
_________________
++++++++++[>+++++++>++++++++++>+++>+<<<<-]>++.>+.+++++++..+++.>++.<<+++++++++++++++.>.+++.------.--------.>+.>.
Back to top
View user's profile Send private message
genstorm
Advocate
Advocate


Joined: 05 Apr 2007
Posts: 2350
Location: Austria

PostPosted: Sun Nov 18, 2012 9:46 pm    Post subject: Reply with quote

The end must really be near. :) Currently enjoying my usual excursion to e17.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
avx
Advocate
Advocate


Joined: 21 Jun 2004
Posts: 2070

PostPosted: Mon Nov 19, 2012 3:43 am    Post subject: Reply with quote

Is an Intel HD3000 not capable of running the GL-effects? Just merged the alpha3 on my Macbook, clicked through the wizard changing nothing but language/keyboard and all I got was a seemingly blank screen with cursor. Moving and clicking the cursor animated it, so I guess there should be windows, but I can't see them.

Deleting the config, starting over again and this time deselecting everything GL works, but I'm not really motivated to try all options so is this hardware not capable or did I miss some setting, f.e. in X.org?
_________________
++++++++++[>+++++++>++++++++++>+++>+<<<<-]>++.>+.+++++++..+++.>++.<<+++++++++++++++.>.+++.------.--------.>+.>.
Back to top
View user's profile Send private message
genstorm
Advocate
Advocate


Joined: 05 Apr 2007
Posts: 2350
Location: Austria

PostPosted: Mon Nov 19, 2012 2:24 pm    Post subject: Reply with quote

All fine here with an old GMA 4500HD.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
avx
Advocate
Advocate


Joined: 21 Jun 2004
Posts: 2070

PostPosted: Mon Nov 19, 2012 4:10 pm    Post subject: Reply with quote

Meh that sucks, not in the mood to investigate much :(
_________________
++++++++++[>+++++++>++++++++++>+++>+<<<<-]>++.>+.+++++++..+++.>++.<<+++++++++++++++.>.+++.------.--------.>+.>.
Back to top
View user's profile Send private message
Yminus
Apprentice
Apprentice


Joined: 06 Jan 2008
Posts: 167

PostPosted: Mon Nov 19, 2012 10:55 pm    Post subject: Reply with quote

What's wrong with the e17-svn ebuilds?

I can't emerge dev-libs/eina-9999:

Code:
cat /var/tmp/portage/dev-libs/eina-9999/temp/build.log
 * Package:    dev-libs/eina-9999
 * Repository: enlightenment
 * Maintainer: enlightenment@gentoo.org
 * USE:        amd64 elibc_glibc kernel_linux mempool-chained mempool-pass-through mmx multilib nls sse sse2 userland_GNU
 * FEATURES:   ccache distcc sandbox userpriv usersandbox
>>> Unpacking source...
 * subversion check out start -->
 *      repository: http://svn.enlightenment.org/svn/e/trunk//eina
svn: URL 'http://svn.enlightenment.org/svn/e/trunk/eina' doesn't exist
 * ERROR: dev-libs/eina-9999 failed (unpack phase):
 *   subversion: can't fetch to /usr/portage/distfiles/svn-src/enlightenment//eina from http://svn.enlightenment.org/svn/e/trunk//eina.
 *
 * Call stack:
 *     ebuild.sh, line   93:  Called src_unpack
 *   environment, line 3033:  Called enlightenment_src_unpack
 *   environment, line 1615:  Called subversion_src_unpack
 *   environment, line 3316:  Called subversion_fetch
 *   environment, line 3211:  Called die
 * The specific snippet of code:
 *               ${ESVN_FETCH_CMD} ${options} "${repo_uri}" || die "${ESVN}: can't fetch to ${wc_path} from ${repo_uri}.";
 *
 * If you need support, post the output of `emerge --info '=dev-libs/eina-9999'`,
 * the complete build log and the output of `emerge -pqv '=dev-libs/eina-9999'`.
 * This ebuild is from an overlay named 'enlightenment': '/var/lib/layman/enlightenment/'
 * The complete build log is located at '/var/tmp/portage/dev-libs/eina-9999/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-libs/eina-9999/temp/environment'.
 * Working directory: '/usr/portage/distfiles/svn-src/enlightenment'
 * S: '/var/tmp/portage/dev-libs/eina-9999/work/eina'


[EDIT]
The same applies to:
  • dev-libs/eet-9999
  • dev-libs/embryo-9999
  • dev-libs/eob
  • ...

_________________
Göögle is evil!
To protect your privacy search the net with
https://www.ixquick.com
Back to top
View user's profile Send private message
Prenj
n00b
n00b


Joined: 20 Nov 2011
Posts: 10

PostPosted: Mon Nov 19, 2012 11:44 pm    Post subject: Reply with quote

Let's hope there will be some clean and innovative themes once it hits release, themes that do NOT try to look like OSX, windows, etc etc.
Back to top
View user's profile Send private message
ppurka
Advocate
Advocate


Joined: 26 Dec 2004
Posts: 3181

PostPosted: Tue Nov 20, 2012 12:13 am    Post subject: Reply with quote

Yminus wrote:
What's wrong with the e17-svn ebuilds?

I can't emerge dev-libs/eina-9999:
http://comments.gmane.org/gmane.comp.window-managers.enlightenment.user/17845
_________________
emerge --quiet redefined | E17 vids: I, II
Back to top
View user's profile Send private message
Yminus
Apprentice
Apprentice


Joined: 06 Jan 2008
Posts: 167

PostPosted: Tue Nov 20, 2012 12:39 am    Post subject: Reply with quote

ppurka wrote:
Yminus wrote:
What's wrong with the e17-svn ebuilds?

I can't emerge dev-libs/eina-9999:
http://comments.gmane.org/gmane.comp.window-managers.enlightenment.user/17845


Pfff, this is hitting me in the midst of on
Code:
emerge -aveuND world
and ~1200 of my ~1800 packages are already re-emerged. Now emerge fails as soon as it hits an e17-svn package, which for sure will happen again as soon as I am going to bed and leave the computer compiling over night :(

But thank you for the fast answer, ppurka! And that E17 is alpha now is really good news!
_________________
Göögle is evil!
To protect your privacy search the net with
https://www.ixquick.com
Back to top
View user's profile Send private message
avx
Advocate
Advocate


Joined: 21 Jun 2004
Posts: 2070

PostPosted: Tue Nov 20, 2012 1:05 am    Post subject: Reply with quote

Yminus wrote:
Pfff, this is hitting me in the midst of on
Code:
emerge -aveuND world
and ~1200 of my ~1800 packages are already re-emerged. Now emerge fails as soon as it hits an e17-svn package, which for sure will happen again as soon as I am going to bed and leave the computer compiling over night :(
Use `emerge --keep-going $args`
_________________
++++++++++[>+++++++>++++++++++>+++>+<<<<-]>++.>+.+++++++..+++.>++.<<+++++++++++++++.>.+++.------.--------.>+.>.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Goto page Previous  1, 2, 3 ... 6, 7, 8 ... 12, 13, 14  Next
Page 7 of 14

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum