Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Atheros AR9285
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish) Instalacja i sprzęt
View previous topic :: View next topic  
Author Message
cabana
n00b
n00b


Joined: 29 Mar 2011
Posts: 23
Location: Wrocław

PostPosted: Sun Apr 03, 2011 10:54 am    Post subject: Atheros AR9285 Reply with quote

Witajcie, mam kartę WiFi w laptopie opartą na tym. No i niestety nie działa mi.
Gentoo widzi interfejs wlan0, ale po wydaniu iwconfig otrzymuje

Code:
wlan0     Interface doesn't support scanning.


Chcę używać szyfrowania WPA2, no ale nie działa mi WiFi, nie wiem co podać mogę


dmesg | grep -C 3 ath9k
Code:

[   25.346735] type=1400 audit(1301827487.058:4): apparmor="STATUS" operation="profile_load" name="/usr/lib/connman/scripts/dhclient-script" pid=866 comm="apparmor_parser"
[   25.356649] Linux video capture interface: v2.00
[   25.370870] uvcvideo: Found UVC 1.00 device USB 2.0 Camera (13d3:5130)
[   25.375886] ath9k 0000:04:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[   25.375896] ath9k 0000:04:00.0: setting latency timer to 64
[   25.378216] [fglrx] Maximum main memory to use for locked dma buffers: 1883 MBytes.
[   25.378483] [fglrx]   vendor: 1002 device: 68e0 count: 1
[   25.378967] [fglrx] ioport: bar 4, base 0xe000, size: 0x100
--
[   25.427517] ath: Country alpha2 being used: 00
[   25.427519] ath: Regpair used: 0x60
[   25.436557] psmouse serio4: ID: 10 00 64
[   25.452645] phy0: Selected rate control algorithm 'ath9k_rate_control'
[   25.453247] Registered led device: ath9k-phy0::radio
[   25.453261] Registered led device: ath9k-phy0::assoc
[   25.453275] Registered led device: ath9k-phy0::tx
[   25.453289] Registered led device: ath9k-phy0::rx
[   25.453296] phy0: Atheros AR9285 Rev:2 mem=0xf8ae0000, irq=16
[   25.470921]   alloc irq_desc for 44 on node -1
[   25.470927]   alloc kstat_irqs on node -1
--
[   25.534974] elantech: assuming hardware version 2, firmware version 4.1.2
[   25.571035] elantech: Synaptics capabilities query result 0x78, 0x16, 0x0d.
[   25.671546] input: ETPS/2 Elantech Touchpad as /devices/platform/i8042/serio4/input/input9
[   25.961485] usb 1-1: ath9k_htc: Transferred FW: ar9271.fw, size: 51280
[   26.682312] EXT4-fs (sda5): re-mounted. Opts: errors=remount-ro
[   26.784142] type=1400 audit(1301827488.498:5): apparmor="STATUS" operation="profile_replace" name="/sbin/dhclient3" pid=1187 comm="apparmor_parser"
[   26.784415] type=1400 audit(1301827488.498:6): apparmor="STATUS" operation="profile_load" name="/usr/share/gdm/guest-session/Xsession" pid=1186 comm="apparmor_parser"
--
[   26.990249] ath: Country alpha2 being used: CN
[   26.990251] ath: Regpair used: 0x52
[   26.991843] cfg80211: Calling CRDA for country: CN
[   26.994032] Registered led device: ath9k-phy1::radio
[   26.994052] Registered led device: ath9k-phy1::assoc
[   26.994068] Registered led device: ath9k-phy1::tx
[   26.994086] Registered led device: ath9k-phy1::rx
[   26.994089] usb 1-1: ath9k_htc: USB layer initialized
[   26.994111] usbcore: registered new interface driver ath9k_hif_usb
[   26.998717] cfg80211: Regulatory domain changed to country: CN
[   26.998721]     (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[   26.998724]     (2402000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm)
--
[   52.922762] lo: Disabled Privacy Extensions
[   90.108396] usb 1-1: USB disconnect, address 2
[   90.132642] wlan1: deauthenticating from 4c:54:99:15:8b:75 by local choice (reason=3)
[   90.240948] usb 1-1: ath9k_htc: USB reboot failed
[   90.240957] usb 1-1: ath9k_htc: USB layer deinitialized
[  408.685951] EXT3-fs: barriers not enabled
[  408.698705] kjournald starting.  Commit interval 5 seconds
[  408.699511] EXT3-fs (sda2): using internal journal




lsmod | grep ath
Code:
ath5k                 130083  0
ath9k_htc              40706  0
ath9k                  88884  0
ath9k_common            5982  2 ath9k,ath9k_htc
ath9k_hw              292329  3 ath9k_htc,ath9k,ath9k_common
mac80211              231959  5 ath5k,ath9k_htc,ath9k,ath9k_common,ar9170usb
ath                     8153  5 ath5k,ath9k,ath9k_htc,ar9170usb,ath9k_hw
cfg80211              144694  7 ath5k,ath9k,ath9k_htc,ath9k_common,ar9170usb,ath,mac80211
led_class               2633  6 ath5k,ath9k,ath9k_htc,ar9170usb,asus_laptop,sdhci



Config kernela

http://wklej.org/id/505099/

emege --info

http://wklej.org/id/505100/

lspci

http://wklej.org/id/505102/
Back to top
View user's profile Send private message
Kurt Steiner
Moderator
Moderator


Joined: 01 Apr 2005
Posts: 1051
Location: Ostroleka, Polska

PostPosted: Sun Apr 03, 2011 12:45 pm    Post subject: Reply with quote

Moved from Polskie forum (Polish) to Instalacja i sprzęt.
_________________
Proszę, pamiętaj o regulaminie, a jeśli zauważysz, że został on złamany, zgłoś to. :)

LRU:431698
Back to top
View user's profile Send private message
Odinist
Apprentice
Apprentice


Joined: 09 Aug 2006
Posts: 176
Location: Silesia, Poland

PostPosted: Fri Apr 08, 2011 6:37 am    Post subject: Reply with quote

A spróbuj najpierw włączyć interfejs:
Code:
# ifconfig wlan0 up


Ogólnie do sieci bezprzewodowej polecam net-misc/wicd.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish) Instalacja i sprzęt All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum