Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[НЕ АКТУАЛЬНО] не хочет работать emerge -e world
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Russian
View previous topic :: View next topic  
Author Message
aledz
n00b
n00b


Joined: 21 Aug 2009
Posts: 7

PostPosted: Sat May 14, 2011 11:15 am    Post subject: [НЕ АКТУАЛЬНО] не хочет работать emerge -e world Reply with quote

Ставлю дженту на новый ноут. После обновления gcc запускаю #emerge -e world и получаю следующее:
# emerge -e world
These are the packages that would be merged, in order:
Calculating dependencies... done!

На этом все останавливается и может стоять сутки. При этом отдельные пакеты ставятся нормально. Подскажите что я делаю не так?

P.S:
#emerge --info
#emerge -e --debug world

# gcc-config -l
[1] i686-pc-linux-gnu-4.4.5
[2] i686-pc-linux-gnu-4.5.2 *

# eselect python list
Available Python interpreters:
[1] python2.7 *
[2] python3.1


Last edited by aledz on Tue May 24, 2011 1:03 am; edited 1 time in total
Back to top
View user's profile Send private message
cord
Apprentice
Apprentice


Joined: 28 Apr 2007
Posts: 204

PostPosted: Sun May 15, 2011 6:36 am    Post subject: Reply with quote

Похоже на кривое обновление питона (эмердж написан на питоне), python-updater запускали?
Попробуйте переключить питон на 3 версию.
Выполните revdep-rebuild


Есть еще мысли что виновато обновление портежей, попробуйте сделать 'emerge --sync' с буржуйского зеркала, например http://distfiles.gentoo.org/
Back to top
View user's profile Send private message
aledz
n00b
n00b


Joined: 21 Aug 2009
Posts: 7

PostPosted: Sun May 15, 2011 8:23 am    Post subject: Reply with quote

#emerge --sync делается с http://distfiles.gentoo.org/ выполнялось вчера и сегодня

#python-updater
* Starting Python Updater...
* Main active version of Python: 2.7
* Active version of Python 2: 2.7
* Active version of Python 3: 3.1
* No packages need to be reinstalled.

revdep-rebuild делал не помогло

Переключаться на питон3 пробовал. python-updater говорит что надо пересобрать 1 пакет и опять зависает как при emerge -e world
python-updater
* Starting Python Updater...
* Main active version of Python: 3.1
* Active version of Python 2: 2.7
* Active version of Python 3: 3.1
* Adding to list: dev-vcs/git:0
* emerge -Dv1 --keep-going dev-vcs/git:0

These are the packages that would be merged, in order:

Calculating dependencies... done!
Back to top
View user's profile Send private message
cord
Apprentice
Apprentice


Joined: 28 Apr 2007
Posts: 204

PostPosted: Sun May 15, 2011 12:40 pm    Post subject: Reply with quote

ну пересоберите этот пакет отдельно
Back to top
View user's profile Send private message
aledz
n00b
n00b


Joined: 21 Aug 2009
Posts: 7

PostPosted: Sun May 15, 2011 1:25 pm    Post subject: Reply with quote

cord wrote:
ну пересоберите этот пакет отдельно


Пробовал ... зависает emerge
Back to top
View user's profile Send private message
dmpogo
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2286
Location: Canada

PostPosted: Mon May 23, 2011 12:12 am    Post subject: Reply with quote

Такое ощущение что ему не нравится сам портаж переустанавливать
Попробуйте отдельно emerge -u portage.

Кстати portage-2.1.9.49 еще ведь не в stable ?, может какие зависимости не keyworded ?
Back to top
View user's profile Send private message
aledz
n00b
n00b


Joined: 21 Aug 2009
Posts: 7

PostPosted: Tue May 24, 2011 1:02 am    Post subject: Reply with quote

dmpogo wrote:
Такое ощущение что ему не нравится сам портаж переустанавливать
Попробуйте отдельно emerge -u portage.

Кстати portage-2.1.9.49 еще ведь не в stable ?, может какие зависимости не keyworded ?


У меня ACCEPT_KEYWORDS="~x86"
Back to top
View user's profile Send private message
aledz
n00b
n00b


Joined: 21 Aug 2009
Posts: 7

PostPosted: Tue May 24, 2011 1:03 am    Post subject: Reply with quote

В итоге поставил систему с нуля используя ACCEPT_KEYWORDS="x86" /в make.conf/
Затем изменил ACCEPT_KEYWORDS="~x86" /в make.conf/
Обновился. Обновление прошло почти хорошо. Мелкие недочеты но все поправимо :)

Всем спасбо за помощь
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Russian All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum