Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Xorg - No device to configure [SOLVED]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish) Instalacja i sprzęt
View previous topic :: View next topic  
Author Message
rysic
n00b
n00b


Joined: 08 Apr 2011
Posts: 13

PostPosted: Fri Apr 08, 2011 9:37 am    Post subject: Xorg - No device to configure [SOLVED] Reply with quote

Witam!

Postanowiłem sobie na próbę zainstalować gentoo w Virtualbox-ie, ale mam problem podczas instalacji X-ów.

Postępując według instrukcji: http://www.gentoo.org/doc/pl/xorg-config.xml
ustawiłem w make.conf

Code:
VIDEO_CARDS="intel"


zainstalowałem X-y

a potem doszedłem do kofiguracji, w której uruchomiłem:

Code:
Xorg -configure


i dostaję komunikat

Code:
No device to configure. Configuration failed.


Last edited by rysic on Tue Apr 19, 2011 9:28 am; edited 2 times in total
Back to top
View user's profile Send private message
SlashBeast
Moderator
Moderator


Joined: 23 May 2006
Posts: 2836

PostPosted: Fri Apr 08, 2011 10:13 am    Post subject: Reply with quote

Tobie raczej potrzeba x11-drivers/xf86-video-virtualbox a nie intel.
_________________
BitBucket -- better-initramfs
Back to top
View user's profile Send private message
rysic
n00b
n00b


Joined: 08 Apr 2011
Posts: 13

PostPosted: Fri Apr 08, 2011 12:12 pm    Post subject: Reply with quote

Jak spojrzałem na lspci, to okazało się, że VB mapuje tylko kartę sieciową jako Intel, więc źle spojrzałem na grafikę.
Mam tego użyć przy kompilacji jądra, czy gdzieś w make.conf?
Back to top
View user's profile Send private message
Bastian82
n00b
n00b


Joined: 07 Feb 2011
Posts: 45
Location: Poznań

PostPosted: Wed Apr 13, 2011 10:50 am    Post subject: Reply with quote

Wystarczy w make.conf ustawić:

Code:
VIDEO_CARDS="Virtualbox"
o ile dobrze pamiętam (wybacz nie mam gentoo pod ręką)

i następnie rekompilować (--newuse). U mnie chodzi, i chodzi dobrze. Chociaż nie próbowałem akceleracji 3D (teoretycznie powinno ruszyć, jeśli zaznaczyć w opcji maszyny)

Ewentualnie można na sterowniku vesa. [/code]
Back to top
View user's profile Send private message
rysic
n00b
n00b


Joined: 08 Apr 2011
Posts: 13

PostPosted: Thu Apr 14, 2011 12:18 pm    Post subject: Reply with quote

Znalazłem jeszcze coś takiego:

http://en.gentoo-wiki.com/wiki/Virtualbox_Guest

w kernelu mam pozaznaczane tamte opcje a w pliku make.conf zamieniłem te opcje na virtualbox-owe.

potem:

Code:

emerge --unmerge xorg-server
emerge --unmerge xorg-x11

emerge -pv xorg-server
emerge xorg-x11
env-update
source /etc/profile


niestety przy Xorg -configure nadal jest komunikat:

Code:

...
List of video drives:
   instel
No devices to configure. Configuration failed.
Back to top
View user's profile Send private message
Bastian82
n00b
n00b


Joined: 07 Feb 2011
Posts: 45
Location: Poznań

PostPosted: Thu Apr 14, 2011 12:24 pm    Post subject: Reply with quote

A sterownik do karty graficzniej zainstalowałeś?
Back to top
View user's profile Send private message
rysic
n00b
n00b


Joined: 08 Apr 2011
Posts: 13

PostPosted: Thu Apr 14, 2011 12:34 pm    Post subject: Reply with quote

Bastian82 wrote:
A sterownik do karty graficzniej zainstalowałeś?

Mów mi jeszcze ;)
Co przez to rozumiesz? Zaznaczyłem odpowiednie pola podczas konfiguracji kernela - pola z wiki, które wkleiłem w poście wcześniej.

Code:

Graphics support --->
        <*> Direct Rendering Manager (XFree86 4.1.0 and higher DRI support)  --->
Back to top
View user's profile Send private message
Bastian82
n00b
n00b


Joined: 07 Feb 2011
Posts: 45
Location: Poznań

PostPosted: Thu Apr 14, 2011 12:35 pm    Post subject: Reply with quote

Code:
emerge -pv 11-drivers/xf86-video-virtualbox
[/code]
Back to top
View user's profile Send private message
rysic
n00b
n00b


Joined: 08 Apr 2011
Posts: 13

PostPosted: Thu Apr 14, 2011 1:11 pm    Post subject: Reply with quote

Bastian82 wrote:
Code:
emerge -pv 11-drivers/xf86-video-virtualbox
[/code]

Instaluje się... tylko poco wśród paczek jest np openldap, to nie wiem... :/
Back to top
View user's profile Send private message
Bastian82
n00b
n00b


Joined: 07 Feb 2011
Posts: 45
Location: Poznań

PostPosted: Thu Apr 14, 2011 1:11 pm    Post subject: Reply with quote

Pamietaj potem o przekompilowaniu xorg'a.

Quote:
tylko poco wśród paczek jest np openldap, to nie wiem... :/


Zgaduje. Kwestia ustawień flag USE?
Back to top
View user's profile Send private message
rysic
n00b
n00b


Joined: 08 Apr 2011
Posts: 13

PostPosted: Fri Apr 15, 2011 6:27 am    Post subject: Reply with quote

Gentoo fajna dystrybucja, bo się człowiek dużo uczy, ale przez te kompilacje wszystko trwa i trwa i trwaaaa.... :?

Dzięki za pomoc! Teraz działa :)

Wprawdzie nie widać myszki, ale może coś wymyślę ;)
Back to top
View user's profile Send private message
rysic
n00b
n00b


Joined: 08 Apr 2011
Posts: 13

PostPosted: Fri Apr 15, 2011 11:41 am    Post subject: Reply with quote

Chyba za szybko pochwaliłem :(

Po uruchomieniu

Code:

X -config /root/xorg.conf.net


ekran jest cały czarny, nie widać myszki a kombinacja Ctrl + Alt + Backspace nie działa...

Po zabiciu go za pomocą killall X, wypisuje:

Code:

(EE) VBox Video(0): Failed to initialize the VirtualBox device (rc=-102) - make sure that the VirtualBox guest additions are properly installed. If you are not sure, try reinstalling them. The X Windows graphics drivers will run in compatibliliy mode.
FATAL: Module vboxvideo not foind.
(EE) [drm] drmOpen failed.
(EE) VBoxVideo(0): DRIScreenInit failed, disabling DRI.
(EE) VirtualBox USB Tablet: failed to initialize for relative axes


Próbowałem:
Code:

emerge xf86-video-virtualbox xf86-input-virtualbox virtualbox-guest-additions
rc-update add virtualbox-guest-additions default
/etc/init.d/virtualbox-guest-additions start


ale to nic nie daje :(

EDIT:

Zauważyłem, że jeszcze pare drobiazgów po zainstalowaniu virtualboxowych addonów się zmieniło:
http://www.picshot.pl/public/view/full/27467
Back to top
View user's profile Send private message
Bastian82
n00b
n00b


Joined: 07 Feb 2011
Posts: 45
Location: Poznań

PostPosted: Sat Apr 16, 2011 5:46 am    Post subject: Reply with quote

A sterownik da się recznie załadować?[/code]

Code:
modprobe vboxvideo
Back to top
View user's profile Send private message
rysic
n00b
n00b


Joined: 08 Apr 2011
Posts: 13

PostPosted: Tue Apr 19, 2011 8:06 am    Post subject: Reply with quote

To polecenie nic nie zwraca... więc chyba się ładuje?

EDIT:
Chyba już wiem jak sprawdzić, czy się załadował :)

Code:

modprobe -l
...
/lib/modules/2.6.36-gentoo-r8/misc/vboxvideo.ko
....
Back to top
View user's profile Send private message
Bastian82
n00b
n00b


Joined: 07 Feb 2011
Posts: 45
Location: Poznań

PostPosted: Tue Apr 19, 2011 8:31 am    Post subject: Reply with quote

X'y wstają?
Back to top
View user's profile Send private message
rysic
n00b
n00b


Joined: 08 Apr 2011
Posts: 13

PostPosted: Tue Apr 19, 2011 8:45 am    Post subject: Reply with quote

Bez myszki, bez niczego... czarny ekran... Ciemność widzę ciemność! :)
Back to top
View user's profile Send private message
Bastian82
n00b
n00b


Joined: 07 Feb 2011
Posts: 45
Location: Poznań

PostPosted: Tue Apr 19, 2011 8:50 am    Post subject: Reply with quote

No to znaczy, że X'y wstają. Teraz instaluj ulubione środowisko graficzne.
Back to top
View user's profile Send private message
Aktyn
l33t
l33t


Joined: 25 Dec 2005
Posts: 619

PostPosted: Tue Apr 19, 2011 8:54 am    Post subject: Reply with quote

rysic wrote:
Chyba już wiem jak sprawdzić, czy się załadował :)

man modprobe
man lsmod
_________________
Aktyn Pages
są ludzie inteligentni, są nad wyraz inteligentni i błyskotliwi, są jasnowidze, są wszechwiedzący bogowie, oraz ludzie piszący kompilatory
Back to top
View user's profile Send private message
rysic
n00b
n00b


Joined: 08 Apr 2011
Posts: 13

PostPosted: Tue Apr 19, 2011 8:57 am    Post subject: Reply with quote

Bastian82 wrote:
No to znaczy, że X'y wstają. Teraz instaluj ulubione środowisko graficzne.

Tylko po instalacji np. KDE będę miał problemy z myszakiem... :/
Back to top
View user's profile Send private message
rysic
n00b
n00b


Joined: 08 Apr 2011
Posts: 13

PostPosted: Tue Apr 19, 2011 9:12 am    Post subject: Reply with quote

Jednak nie do końca jest tak pięknie z tym startowaniem X-ów, bo jak przekopiuję konfigurację do /etc/X11 i zrobię startx, to dostaję coś takiego:

http://zapisz.net/images/563_ggg.png

EDIT:
No tak... trzeba było doinstalować xterm, ale o tym w tutorialu nie było :)

Dzięki za pomoc!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish) Instalacja i sprzęt All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum