Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
valgrind und glibc
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
pablo_supertux
Advocate
Advocate


Joined: 25 Jan 2004
Posts: 2585
Location: Somewhere between reality and Middle-Earth and in Freiburg (Germany)

PostPosted: Sat Sep 29, 2012 2:51 pm    Post subject: valgrind und glibc Reply with quote

Ich hab valgrind eine schöne lange Weile nicht mehr verwendet (da ich zur Zeit hauptsächlich mit ruby und python programmiere). Ich hatte schon ein Paar world updates seitdem ich zuletzt valgrind verwendet habe. Nun bekomme ich

Code:

valgrind:  Fatal error at startup: a function redirection
valgrind:  which is mandatory for this platform-tool combination
valgrind:  cannot be set up.  Details of the redirection are:
valgrind: 
valgrind:  A must-be-redirected function
valgrind:  whose name matches the pattern:      index
valgrind:  in an object with soname matching:   ld-linux.so.2
valgrind:  was not found whilst processing
valgrind:  symbols from the object with soname: ld-linux.so.2
valgrind: 
valgrind:  Possible fixes: (1, short term): install glibc's debuginfo
valgrind:  package on this machine.  (2, longer term): ask the packagers
valgrind:  for your Linux distribution to please in future ship a non-
valgrind:  stripped ld.so (or whatever the dynamic linker .so is called)
valgrind:  that exports the above-named function using the standard
valgrind:  calling conventions for this platform.  The package you need
valgrind:  to install for fix (1) is called
valgrind: 
valgrind:    On Debian, Ubuntu:                 libc6-dbg
valgrind:    On SuSE, openSuSE, Fedora, RHEL:   glibc-debuginfo
valgrind: 
valgrind:  Cannot continue -- exiting now.  Sorry.


wtf? Muss ich sys-libs/glibc mit USE=debug neu installieren, oder was? Bevor ich glibc neu installiere, möchte ich wissen, ob ich vielleicht ein anderes Paket installieren muss. Hat schon jemand diese Fehlermeldung bekommen?

Danke
_________________
A! Elbereth Gilthoniel!
silivren penna míriel
o menel aglar elenath,
Gilthoniel, A! Elbereth!
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 3839
Location: Irgendwo im Nirgendwo

PostPosted: Sat Sep 29, 2012 3:03 pm    Post subject: Reply with quote

AFAIK macht USE="debug" nur einige Laufzeitprüfungen (assert &co) und wird dir bei deinem Problem wenig helfen.
Das was valgrind will ist ein "-ggdb" in den CFLAGS. Pass auf dass du "splitdebug" in deinen FEATURES hast (man make.conf).
_________________
"der mac dennoch wesen geil"
Wolfram von Eschenbach, Parzival (Buch 1, Z. 7).
Ein frühes Statement gegen Windows.

My overlay
Back to top
View user's profile Send private message
pablo_supertux
Advocate
Advocate


Joined: 25 Jan 2004
Posts: 2585
Location: Somewhere between reality and Middle-Earth and in Freiburg (Germany)

PostPosted: Sat Sep 29, 2012 3:48 pm    Post subject: Reply with quote

danke für die Info
_________________
A! Elbereth Gilthoniel!
silivren penna míriel
o menel aglar elenath,
Gilthoniel, A! Elbereth!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum