Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge --depclean removed python, what now?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
dashko
n00b
n00b


Joined: 13 Jul 2010
Posts: 22
Location: Slovakia

PostPosted: Thu Mar 31, 2011 2:03 pm    Post subject: emerge --depclean removed python, what now? Reply with quote

Hi,
today i updated my system with classical list of commands:

emerge --sync; emerge portage; emerge --update --newuse --deep world; emerge --depclean; revdep-rebuild

but emerge --depclean removed python (omfg). And i can't run emerge now. This never happened to me.
How this can happen? Shouldn't be there at least 2 big warnings with confirmation from user?
Is correct way to run emerge --depclean after emerge --update --newuse --deep world?
How can i avoid this kind of fatal errors? And what can i do now, what's correct way to fix this?
I manually recompiled, and reemerged python which partially solve problem.

Thanks for answers.
Back to top
View user's profile Send private message
Aquous
l33t
l33t


Joined: 08 Jan 2011
Posts: 646

PostPosted: Thu Mar 31, 2011 2:58 pm    Post subject: Reply with quote

Post output of eselect python list
Back to top
View user's profile Send private message
Etal
Veteran
Veteran


Joined: 15 Jul 2005
Posts: 1641

PostPosted: Thu Mar 31, 2011 3:02 pm    Post subject: Reply with quote

... and then set python 2.7. After that, run python-updater.
_________________
“And even in authoritarian countries, information networks are helping people discover new facts and making governments more accountable.”– Hillary Clinton, Jan. 21, 2010
Back to top
View user's profile Send private message
rh1
Guru
Guru


Joined: 10 Apr 2010
Posts: 501

PostPosted: Thu Mar 31, 2011 5:00 pm    Post subject: Reply with quote

And in the future, always run depclean with the "--pretend" or "--ask" flag so you can see what it's going to remove ahead of time. Allowing it to blindly remove packages is a recipe for disaster.
Back to top
View user's profile Send private message
dashko
n00b
n00b


Joined: 13 Jul 2010
Posts: 22
Location: Slovakia

PostPosted: Fri Apr 01, 2011 7:12 am    Post subject: Reply with quote

Etal wrote:
... and then set python 2.7. After that, run python-updater.


Thanks, i tried Python 3.1, but 7 packages in my system i couldn't compile.
Python 2.7 = 3 packages i couldn't compile.
And python 2.6 = was everything all right.

I am using stable packages.
Back to top
View user's profile Send private message
aCOSwt
Moderator
Moderator


Joined: 19 Oct 2007
Posts: 2537
Location: Hilbert space

PostPosted: Fri Apr 01, 2011 7:20 am    Post subject: Reply with quote

dashko wrote:
Python 3.1, but 7 packages in my system i couldn't compile.

Normal ! There are still many packages not compatible with python 3. You should not eselect python set it.
dashko wrote:
Python 2.7 = 3 packages i couldn't compile.

Can be normal and not Python's fault. If among those packages you have let's say... openoffice... :roll: Its rebuild might be broken for... other sombre reasons ! :roll: :roll:
Which are the packages you cannot rebuild with Python 2.7 eselected ?
Back to top
View user's profile Send private message
dashko
n00b
n00b


Joined: 13 Jul 2010
Posts: 22
Location: Slovakia

PostPosted: Wed Apr 13, 2011 10:10 pm    Post subject: Reply with quote

aCOSwt wrote:
Which are the packages you cannot rebuild with Python 2.7 eselected ?

app-office/dia-0.97.1
/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.5/../../../../x86_64-pc-linux-gnu/bin/ld: /usr/lib64/python2.7/config/libpython2.7.a(exceptions.o): relocation R_X86_64_32 against `_Py_NoneStruct' can not be used when making a shared object; recompile with -fPIC
/usr/lib64/python2.7/config/libpython2.7.a: could not read symbols: Bad value
collect2: ld returned 1 exit status
make[3]: *** [libpython_plugin.la] Error 1

net-im/pidgin-2.7.11
/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.5/../../../../x86_64-pc-linux-gnu/bin/ld: /usr/lib/python2.7/config/libpython2.7.a(listobject.o): relocation R_X86_64_32 against `_Py_NoneStruct' can not be used when making a shared object; recompile with -fPIC
/usr/lib/python2.7/config/libpython2.7.a: could not read symbols: Bad value
collect2: ld returned 1 exit status
make[5]: *** [libgnt.la] Error 1

media-libs/lcms-1.19
/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.5/../../../../x86_64-pc-linux-gnu/bin/ld: /usr/lib64/python2.7/config/libpython2.7.a(abstract.o): relocation R_X86_64_32 against `.rodata.str1.8' can not be used when making a shared object; recompile with -fPIC
/usr/lib64/python2.7/config/libpython2.7.a: could not read symbols: Bad value
collect2: ld returned 1 exit status
make: *** [_lcms.la] Error 1
emake failed

How can i fix this? Thanks!
Back to top
View user's profile Send private message
vincent-
Developer
Developer


Joined: 13 Jan 2007
Posts: 415
Location: Valencia (Spain)

PostPosted: Wed Apr 13, 2011 10:31 pm    Post subject: Reply with quote

Run "lafilefixer --justfixit" and try "python-updater" again.
Back to top
View user's profile Send private message
dashko
n00b
n00b


Joined: 13 Jul 2010
Posts: 22
Location: Slovakia

PostPosted: Thu Apr 14, 2011 6:32 am    Post subject: Reply with quote

peratu wrote:
Run "lafilefixer --justfixit" and try "python-updater" again.

Don't work, still same error :(
Back to top
View user's profile Send private message
sera
Developer
Developer


Joined: 29 Feb 2008
Posts: 993
Location: CET

PostPosted: Thu Apr 14, 2011 7:44 am    Post subject: Reply with quote

dashko,

looking at those errors I wonder which profile you are using and what flags you set in your make.conf.

Please post emerge --info.
Back to top
View user's profile Send private message
dashko
n00b
n00b


Joined: 13 Jul 2010
Posts: 22
Location: Slovakia

PostPosted: Thu Apr 14, 2011 8:45 am    Post subject: Reply with quote

sera wrote:
Please post emerge --info.


Code:
# emerge --info
Portage 2.1.9.42 (default/linux/amd64/10.0, gcc-4.4.5, glibc-2.11.3-r0, 2.6.37-gentoo-r4 x86_64)
=================================================================
System uname: Linux-2.6.37-gentoo-r4-x86_64-Intel-R-_Core-TM-2_Duo_CPU_T5670_@_1.80GHz-with-gentoo-1.12.14
Timestamp of tree: Wed, 13 Apr 2011 19:00:01 +0000
app-shells/bash:     4.1_p9
dev-java/java-config: 2.1.11-r3
dev-lang/python:     2.6.6-r2, 2.7.1-r1, 3.1.3-r1
dev-util/cmake:      2.8.1-r2
sys-apps/baselayout: 1.12.14-r1
sys-apps/sandbox:    2.4
sys-devel/autoconf:  2.13, 2.65-r1
sys-devel/automake:  1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.4.5
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.10
sys-devel/make:      3.81-r2
virtual/os-headers:  2.6.36.1 (sys-kernel/linux-headers)
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -mtune=generic -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=core2 -mtune=generic -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs distlocks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://de-mirror.org/distro/gentoo/ http://ftp.fi.muni.cz/pub/linux/gentoo/ rsync://ftp6.linux.cz/pub/linux/gentoo/ rsync://ftp.fi.muni.cz/pub/linux/gentoo/ http://gentoo.wheel.sk/ ftp://gentoo.wheel.sk/pub/linux/gentoo/ ftp://mirror.ynet.sk/pub/gentoo/ http://mirror.ynet.sk/pub/gentoo/"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/java-overlay /var/lib/layman/zugaina"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X aalib acl acpi alsa amd64 apache2 apm atm bash-completion berkdb bzip2 cli cracklib crypt ctype cups curl cxx dbus device-mapper dri dv dvb dvd dvdr encode esd exif extras fbcon ffmpeg firefox flac fortran ftp gd gdbm gif gimp glut gnutls gpm gstreamer gtk gzip iconv icu imagemagick imap imlib ipv6 java java6 javascript jpeg jpeg2k lame latex libwww lm_sensors maildir matroska matrox mime mmx modules motif mozilla mp3 mp4 mpeg mplayer mtp mudflap multilib mysql mysqli ncurses networkmanager nls nptl nptlonly ogg openmp pam pcre perl php png policykit pppd python qt4 quicktime raw rdesktop readline rss samba sasl session simplexml smp sockets socks5 spell sse sse2 ssl svg symlink sysfs syslog taglib tcl tcpd threads tiff tk truetype udev unicode usb v4l v4l2 vhosts vorbis wavpack wifi x264 xine xinerama xml xmlrunner xorg xpm xscreensaver xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

What do you think about that?
Back to top
View user's profile Send private message
rh1
Guru
Guru


Joined: 10 Apr 2010
Posts: 501

PostPosted: Thu Apr 14, 2011 2:09 pm    Post subject: Reply with quote

@dashko Here is a bug report for dia: http://bugs.gentoo.org/show_bug.cgi?format=multiple&id=361231

You should post there that you have the same issue since gentoo-dev commented that he can't reproduce the issue. That way they will know it's a not an isolated case.
Back to top
View user's profile Send private message
Erdie
Veteran
Veteran


Joined: 20 May 2004
Posts: 1698
Location: Heidelberg - Germany

PostPosted: Fri Apr 15, 2011 7:59 am    Post subject: Reply with quote

I had the same issue and fixed it in the same way. My question is:

Since portage deletes its own bottom layer while deleting python, it shows a lot of error messages. How can I be sure that everything from python 2.6 was removed cleanly? Do i have to cleanup some files afterwards?

-Erdie
Back to top
View user's profile Send private message
dol-sen
Developer
Developer


Joined: 30 Jun 2002
Posts: 2559
Location: Richmond, BC, Canada

PostPosted: Fri Apr 15, 2011 8:17 am    Post subject: Reply with quote

the simplest way is
Code:
equery belongs python2.6

If anything shows up other than python2.6 itself. re-emerge those pkgs so they are updated into python2.7. Anything else left over in python2.6/site-packages will be orphaned files and can be deleted manually.
Quote:
Since portage deletes its own bottom layer while deleting python
??????
Portage does not install to python at all. It installs to it's own directory and installs that path into the PYTHONPATH environment variable. So whichever python is the active one it will find it's modules.
_________________
Brian
Porthole, the Portage GUI frontend irc@freenode: #gentoo-guis, #porthole, Blog
layman, gentoolkit, CoreBuilder, esearch...
Back to top
View user's profile Send private message
tomk
Administrator
Administrator


Joined: 23 Sep 2003
Posts: 7219
Location: Sat in front of my computer

PostPosted: Wed Apr 20, 2011 8:49 am    Post subject: Reply with quote

Moved from Portage & Programming to Duplicate Threads, please see Python 2.7 upgrade?
_________________
Search | Read | Answer | Report | Strip
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum