Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Write protecting the kernel read-only
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish) Instalacja i sprzęt
View previous topic :: View next topic  
Author Message
josel
n00b
n00b


Joined: 30 Mar 2011
Posts: 10
Location: z laptopa

PostPosted: Wed Mar 30, 2011 2:32 pm    Post subject: [SOLVED] Write protecting the kernel read-only Reply with quote

Witam,

W świecie linuxa jestem w sumie mocno początkujący, trochę siedziałem na ubuntu, dawno temu postawiłem slackware'a i skompilowałem w nim jądro, że działało, tyle moich doświadczeń, ale wrócę do sprawy.

Instalowałem gentoo z minimal cd (zamontowanej na pendrive'ie) według polskiego handbooka dostępnego na gentoo.org, robiłem wszystko zgodnie z poleceniami i powinno było się udać. Jednak po wybraniu w GRUB'ie "Gentoo" (mam jeszcze windowsa, z którego piszę tego posta) odbywa się wyszukiwanie sprzętu itp. (nie wiem jak zdobyć logi z tego startu, choć guglałem, jeśli wiecie, chętnie się nimi podzielę) i bootowanie kończy się na:

Code:
Ext3 - fs(sda3): mounted filesystem with writeback data mode
VFS: Mounted root (ext3 filesystem) readonly on device 8:3
Freeing unused kernel memory: 408k fred
Write protecting the kernel text: 4340k
Write protecting the kernel read-only data: 1692k
/ #:


i czego nie wpiszę po znaku zachęty pojawia się:

Code:
<to co wpiszę> used greatest stack depth. 6223 bytes left


a potem już nic się nie pojawia, niezależnie od tego co napiszę.

Zawsze dopiero w ostateczności proszę jakąś społeczność linuksową o radę, ale tutaj załamuję ręce, bo nawet google niewiele wie o tym problemie.
Nie wiem sam, może coś w kernelu namieszałem...
Jak będzie trzeba jakichś informacji, to najlepiej podajcie proszę instrukcje jak je zdobyć, a na pewno je wkleję.

Z góry dzięki za zainteresowanie.
Pozdrawiam.
_________________
learning linux all day long.


Last edited by josel on Wed Mar 30, 2011 7:54 pm; edited 1 time in total
Back to top
View user's profile Send private message
joi_
Apprentice
Apprentice


Joined: 28 Mar 2005
Posts: 171

PostPosted: Wed Mar 30, 2011 7:23 pm    Post subject: Reply with quote

nie zostawiłeś czasem init=/bin/sh w konfiguracji gruba?
Back to top
View user's profile Send private message
josel
n00b
n00b


Joined: 30 Mar 2011
Posts: 10
Location: z laptopa

PostPosted: Wed Mar 30, 2011 7:45 pm    Post subject: Reply with quote

Nie mam pojęcia jakim sposobem się tam znalazł, bo sam ręcznie wpisywałem to, co powinno być w pliku konfiguracyjnym, w każdym razie dzięki :)
_________________
learning linux all day long.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish) Instalacja i sprzęt All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum