Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
python, update problem, emerge not working [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
while true
Guru
Guru


Joined: 07 Apr 2010
Posts: 346
Location: Ljubljana, Slovenia

PostPosted: Fri Mar 25, 2011 2:39 pm    Post subject: python, update problem, emerge not working [SOLVED] Reply with quote

Ola, newbie at the wheel, so hold on at curves...

Updating again and among other stuff there was python.
At the end of emerge I got notified that I should run python-update $options.
revdep-rebuild was ok.
I than run python-update --help, but could not find anything useful, so I just ran
Code:
# python-update

which took a while and found virtulabox-bin, openoffice-bin and (sys?)/boost.
After that it started emerging, and pretty soon it failed...


I proceeded with --depclean which foud these outdated packages:
Code:
>>> These are the packages that would be unmerged:

 sys-kernel/gentoo-sources
    selected: 2.6.36-r5
   protected: none
     omitted: 2.6.32-r7 2.6.36-r8

 dev-lang/python
    selected: 2.6.6-r2
   protected: none
     omitted: 2.7.1-r1 3.1.3-r1

 sys-libs/db
    selected: 4.7.25_p4
   protected: none
     omitted: 4.8.30

I have 2.6.32 kernel and same gentoo-sources, so for gentoo-sources I was sure it is ok to let it go.
Also, since I have new python (omitted: 2.7.1-r1 3.1.3-r1 ) it is also ok for selected: 2.6.6-r2 to go...
and db I guessed has connection for selected: 2.6.6-r2 python...
I deleted those files.

revdep-rebuild gave me scare, it ended like so:
Code:
 Portage could not find any version of the following packages it could build:
 * app-admin/apache-tools:0 app-editors/gedit:0 app-editors/vim:0 dev-lang/yasm:0 dev-libs/libxslt:0 dev-python/cython:0 dev-python/imaging:0 dev-python/lxml:0 dev-python/numpy:0 dev-python/pycairo:0 dev-python/pysqlite:2 dev-python/pyxml:0 media-libs/alsa-lib:0 media-libs/lcms:0 net-analyzer/wireshark:0 sys-libs/cracklib:0 www-servers/apache:2
 *
 * (Perhaps they are masked, blocked, or removed from portage.)
 * Try to emerge them manually.
 *
 * Warning: Portage cannot rebuild any of the necessary packages.

I tried than to emerge what depclean removed, but it seems that emerge is not working no more:
Code:
C6820s grom # emerge -pv dev-lang/python
C6820s grom # 

Code:
C6820s grom # emerge -pv firefox
C6820s grom # 

Code:
C6820s grom # eix dev-lang/python
[I] dev-lang/python
     Available versions: 
        (2.4)   2.4.6
        (2.5)   2.5.4-r4
        (2.6)   2.6.5-r3 2.6.6-r1 2.6.6-r2
        (2.7)   2.7.1-r1
        (3.1)   3.1.2-r4 3.1.3-r1
        (3.2)   [M]~3.2
        {-berkdb bootstrap build +cxx doc elibc_uclibc examples gdbm ipv6 +ncurses +readline sqlite +ssl +threads tk +wide-unicode wininst +xml}
     Installed versions:  2.7.1-r1(2.7)(00:39:56 03/25/11)(berkdb gdbm ipv6 ncurses readline ssl threads wide-unicode xml -build -doc -elibc_uclibc -examples -sqlite -tk -wininst) 3.1.3-r1(3.1)(10:16:56 02/28/11)(gdbm ipv6 ncurses readline ssl threads wide-unicode xml -build -doc -elibc_uclibc -examples -sqlite -tk -wininst)
     Homepage:            http://www.python.org/
     Description:         Python is an interpreted, interactive, object-oriented programming language.

C6820s grom #



# make menuconfig works fine (at least it brings up the kernel options to modify)
man emerge works, but not these commands:
Code:
C6820s linux # emerge --help
C6820s linux # emerge --info
C6820s linux #



At which curve did I slip?

Thank you.

EDIT:

Code:
C6820s grom # eselect python list
Available Python interpreters:
  [1]   python2.7
  [2]   python3.1
C6820s grom # eselect python set 2

this made emerge worked, now let see if revdep-rebuild goes fine...
_________________
Kind regards, Goran Mitic

alive
while true
kick ass


Last edited by while true on Sun Mar 27, 2011 10:04 pm; edited 1 time in total
Back to top
View user's profile Send private message
jodel
Tux's lil' helper
Tux's lil' helper


Joined: 28 Sep 2004
Posts: 113

PostPosted: Fri Mar 25, 2011 3:50 pm    Post subject: Reply with quote

I have the exact same problem after todays update. Please help.
Back to top
View user's profile Send private message
astor84
Tux's lil' helper
Tux's lil' helper


Joined: 06 Feb 2007
Posts: 96
Location: Dallas, Tx

PostPosted: Fri Mar 25, 2011 5:08 pm    Post subject: Reply with quote

I have essentially the same problem.

After I upgraded python to 2.7, ran python-updater, and then emerge --depclean, portage no longer works.

As a stop-gap solution, I have symlinked /usr/bin/python2.6 to /usr/bin/python2.7, which at least gets portage working again.

EDIT: It looks like you need to run
Code:
eselect python set 2


This assumes that python2.7 is the the second python listed by
Code:
eselect python list


I have never had this problem when updating python before, so I assume that the ebuild should have automatically done this.

It looks like you need to run python-updater again after you manually fix this too.
Back to top
View user's profile Send private message
astor84
Tux's lil' helper
Tux's lil' helper


Joined: 06 Feb 2007
Posts: 96
Location: Dallas, Tx

PostPosted: Fri Mar 25, 2011 5:14 pm    Post subject: Reply with quote

Currently rebuilding about a million packages due to the 2.7 upgrade ... will report back when I'm sure it all works.
Back to top
View user's profile Send private message
Anon-E-moose
Advocate
Advocate


Joined: 23 May 2008
Posts: 2245
Location: Dallas area

PostPosted: Fri Mar 25, 2011 5:16 pm    Post subject: Reply with quote

I was surprised at the lack of info when python 2.7 got installed

It simply said "run python-updater" which I did, saw that it did nothing,
then I did the eselect of 2.7 and when I went to run equery, it complained,
so I re-emerged gentoolkit (emerge itself was fine but I had not uninstalled 2.6)
then I ran python-updater again and it reinstalled 59 packages.

then I ran depclean and it removed python 2.6.

If you have already removed python 2.6 and things don't work, as astor84 said you can symlink the executable,

I would re-emerge portage and gentoolkit (if you have that installed), remove the symlink you created, then run python-updater
depending on what is going on on your system, you might have to symlink the /usr/lib/python2.7 library too.
_________________
Asus m5a99fx, FX 8320 - amd64-multilib, 3.9.1-zen, glibc-2.17, gcc-4.7.3-r1, eudev
xorg-server-1.16, openbox w/lxpanel, nouveau, oss4
Back to top
View user's profile Send private message
ferreirafm
Guru
Guru


Joined: 28 Jul 2005
Posts: 449
Location: Sao Paulo, Brazil

PostPosted: Fri Mar 25, 2011 6:10 pm    Post subject: Reply with quote

Hi there,
After my full upgrade a I have eselected the new python module before running python-updater.
That's the right track.
Code:
> emerge -av python
> eselect python list
> eselect python set X
where X is the new python version 2.7
> python-updater

Exactly 59 packages have been re-emerged.
G'Luck
Back to top
View user's profile Send private message
wlchase
Tux's lil' helper
Tux's lil' helper


Joined: 04 Jul 2003
Posts: 81
Location: Texas

PostPosted: Fri Mar 25, 2011 6:22 pm    Post subject: Reply with quote

ferreirafm wrote:
Hi there,
After my full upgrade a I have eselected the new python module before running python-updater.
That's the right track.
Code:
> emerge -av python
> eselect python list
> eselect python set X
where X is the new python version 2.7
> python-updater

Exactly 59 packages have been re-emerged.
G'Luck


That did the trick!
Back to top
View user's profile Send private message
while true
Guru
Guru


Joined: 07 Apr 2010
Posts: 346
Location: Ljubljana, Slovenia

PostPosted: Fri Mar 25, 2011 7:27 pm    Post subject: Reply with quote

After several revdep-rebuilds I came down to this:

Code:
* Checking dynamic linking consistency
[ 55% ]  *   broken /usr/lib64/gedit-2/plugin-loaders/libpythonloader.so (requires libpython2.6.so.1.0)
[ 79% ]  *   broken /usr/lib64/python2.6/site-packages/_cracklibmodule.so (requires libpython2.6.so.1.0)
[ 100% ] 

...
...
...

 * revdep-rebuild failed to emerge all packages.

So I need python 2.6?
I will emerge it, eselect it and run revdep-rebuild once again...
Code:
emerge =dev-lang/python-2.6.6-r2
eselect python list
Available Python interpreters:
  [1]   python2.6
  [2]   python2.7
  [3]   python3.1 *
eselect python set 1
python-updater
revdep-rebuild
emerge -pv --depclean #nothing to remove
eclean-dist -d


This took about 2 hours...
but now it is working...

So basicly I downgraded python...

I do not know what I will do next update
since gedit is my favourite editor,
but it does not use python 2.7 or higher,
and also cracklib does not use python 2.7 or higher,
which is needed for ssh and several other stuff...


I will go ferreirafm way next update on sunday,
for the time being I will keep my settings as they are.

Will not mark as solved until sunday when I will have time to (hopefuly) update again,
now it is friday night and I am going out !!!

Thank you all for input and thanks ferreirafm for providing the path for the rest of us!
_________________
Kind regards, Goran Mitic

alive
while true
kick ass
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4723
Location: not so far from an evil, world famous volcano. Under dictatorship, idiocracy, property of banks...

PostPosted: Sat Mar 26, 2011 2:13 pm    Post subject: Reply with quote

same as Anon-E-moose after installed python 2.7 started python-updater and eselect no problem but now it insist to rebuild emul-linux-x86-baselibs ( /usr/lib32/python2.6/site-packages/libxml2mod.so ).

The only good thing is than emerge --depclean has not uninstalled the current python default as in past times.
Its normal for me run directly emerge @world ; emerge --deplean ; revdep-rebuild
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
while true
Guru
Guru


Joined: 07 Apr 2010
Posts: 346
Location: Ljubljana, Slovenia

PostPosted: Sun Mar 27, 2011 10:04 pm    Post subject: Reply with quote

Oi,

so, I updated today gentoo, and than I eselected python 3.1 and ran python-updater...
It updated just 12 packages.. wow I thought..

That I ran revdep-rebuild and I got message like so: Syntax error ...
but it went on nicely...

Then I ran eclean-dist -d and I got same error, but command did not do what it is supposed to do.

Searching this board I found out that I have to choose earlier version of python...?!?
So I eselected python 2.7 and ran python-updater which rebuild 53 packages.

from here on it is smooth sailing, no syntax error message, all works well.

Thank you all for helping me out!
_________________
Kind regards, Goran Mitic

alive
while true
kick ass
Back to top
View user's profile Send private message
tomk
Administrator
Administrator


Joined: 23 Sep 2003
Posts: 7219
Location: Sat in front of my computer

PostPosted: Wed Apr 20, 2011 8:51 am    Post subject: Reply with quote

Moved from Portage & Programming to Duplicate Threads, please see Python 2.7 upgrade?
_________________
Search | Read | Answer | Report | Strip
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum