Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] python update problems
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
childc2
n00b
n00b


Joined: 17 Nov 2010
Posts: 33

PostPosted: Tue Mar 29, 2011 4:36 am    Post subject: [solved] python update problems Reply with quote

Hey everyone,
I seem to have caused myself a little bit of trouble with python recently. I installed python 2.7 when the update became available. When I did I unmerged python 2.6 before I realized I should have run eselect to set the new version of python and run python-updater.
This left me with no python to use emerge with so I followed the fix here.
That fix got python working again, and I can run emerge and so on with almost no problems. The problem is now I have python 2.6 installed from having unpacked it and compiled it manually and a few packages like sys-libs/tdb will fail to compile with the python use flag now. Python 2.6 is also listed again in the eselect list.

Does anyone know a good way for me to remove Python 2.6 now that I have 2.7 running?

Thanks for the help

Edit: title - childc2 03/30/2011


Last edited by childc2 on Wed Mar 30, 2011 2:45 pm; edited 1 time in total
Back to top
View user's profile Send private message
dol-sen
Developer
Developer


Joined: 30 Jun 2002
Posts: 2523
Location: Richmond, BC, Canada

PostPosted: Tue Mar 29, 2011 5:56 am    Post subject: Reply with quote

Actually you didn't have to manually compile python. You could have run eselect python list ,... and set to set it to 2.7.

You could have run python updater then too.

Check to see if it installs to the same locations as portage would. Unfortunately, not using the package manager, means you have to track it's files manualy, for uninstall.

You could try re-emerging python-2.6 with collision-protect turned off so that it overwrites the files by your manual install. That should allow you to unmerge it and get most of the files cleaned out. The remaining ones you'll have to hunt on your own.
_________________
Brian
Porthole, the Portage GUI frontend irc@freenode: #gentoo-guis, #porthole, Blog
layman, gentoolkit, CoreBuilder, esearch...
Back to top
View user's profile Send private message
childc2
n00b
n00b


Joined: 17 Nov 2010
Posts: 33

PostPosted: Wed Mar 30, 2011 2:44 pm    Post subject: Reply with quote

Thank you.
Emerging Python 2.6 with collision-protect off worked. I ended up having to pull /usr/bin/python2.6-config out of that directory to get tdb to compile too.
Back to top
View user's profile Send private message
tomk
Administrator
Administrator


Joined: 23 Sep 2003
Posts: 7219
Location: Sat in front of my computer

PostPosted: Wed Apr 20, 2011 8:50 am    Post subject: Reply with quote

Moved from Portage & Programming to Duplicate Threads, please see Python 2.7 upgrade?
_________________
Search | Read | Answer | Report | Strip
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum