Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
HELP! Shutdown / restart buttons don't work in KDE
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
MarcusXP
Apprentice
Apprentice


Joined: 18 Apr 2007
Posts: 184
Location: Toronto, ON, Canada

PostPosted: Sun Mar 20, 2011 4:22 am    Post subject: HELP! Shutdown / restart buttons don't work in KDE Reply with quote

Hey there,

While logged in KDE I can't restart or shutdown the machine from the graphical interface. I press the "Shutdown" or "Restart" button but nothing happens.
I can type "reboot" or "shutdown" from the console, though. But all my settings in KDE do not get saved when I do that.. so I want to be able to shut it down nicely.
I have this problem on all 3 of my Gentoo systems. I must probably be using same/similar configuration on all of them...
Can you guys please help me fix it?

thanks a lot,


Last edited by MarcusXP on Tue Mar 22, 2011 4:45 pm; edited 1 time in total
Back to top
View user's profile Send private message
MarcusXP
Apprentice
Apprentice


Joined: 18 Apr 2007
Posts: 184
Location: Toronto, ON, Canada

PostPosted: Sun Mar 20, 2011 4:24 am    Post subject: Reply with quote

emerge --info

Portage 2.1.9.43 (default/linux/amd64/10.0/server, gcc-4.5.2, glibc-2.11.3-r0, 2.6.38-gentoo x86_64)
=================================================================
System uname: Linux-2.6.38-gentoo-x86_64-Intel-R-_Xeon-R-_CPU_L5520_@_2.27GHz-with-gentoo-2.0.1
Timestamp of tree: Fri, 18 Mar 2011 17:00:01 +0000
ccache version 2.4 [enabled]
app-shells/bash: 4.1_p9
dev-java/java-config: 2.1.11-r3
dev-lang/python: 2.6.6-r2, 3.1.3-r1
dev-util/ccache: 2.4-r9
dev-util/cmake: 2.8.4
sys-apps/baselayout: 2.0.1-r1
sys-apps/openrc: 0.7.0
sys-apps/sandbox: 2.4
sys-devel/autoconf: 2.13, 2.65-r1
sys-devel/automake: 1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils: 2.20.1-r1
sys-devel/gcc: 4.5.2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool: 2.2.10
sys-devel/make: 3.81-r2
virtual/os-headers: 2.6.36.1 (sys-kernel/linux-headers)
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs ccache distlocks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/vmware"
SYNC="rsync://10.10.10.11/gentoo-portage"
USE="X acl acpi amd64 apm bash-completion berkdb bzip2 cli consolekit cracklib crypt cxx dbus dri fortran gdbm git gpm iconv java javascript kde mmx modules mudflap multilib mysql ncurses nfs nls nptl nptlonly opengl openmp pam pcre perl php policykit pppd python python3 qt3support qt4 readline rtc samba semantic-desktop session smp snmp sql sqlite sqlite3 sse sse2 sse3 ssl ssse3 startup-notification svg symlink sysfs tcpd truetype udev unicode xml xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="vmware" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset: CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Back to top
View user's profile Send private message
MarcusXP
Apprentice
Apprentice


Joined: 18 Apr 2007
Posts: 184
Location: Toronto, ON, Canada

PostPosted: Sun Mar 20, 2011 4:25 am    Post subject: Reply with quote

This problem persists from quite some time, I had it with older KDE version (4.4.5) and older kernels as well.
It just didn't bother me so much.. until recently.
Back to top
View user's profile Send private message
The Doctor
Veteran
Veteran


Joined: 27 Jul 2010
Posts: 1493

PostPosted: Sun Mar 20, 2011 4:30 am    Post subject: Reply with quote

I think you can set consolekit to allow shutdowns. I am not sure how.
If you log in from kdm, shutdown should work, unless there is something going on with kdm.

I would start by look at consolekit. I am not sure how to approch this, but I think that this is related http://forums.gentoo.org/viewtopic-t-869349-highlight-.html, just in gnome.
_________________
First things first, but not necessarily in that order.
Back to top
View user's profile Send private message
MarcusXP
Apprentice
Apprentice


Joined: 18 Apr 2007
Posts: 184
Location: Toronto, ON, Canada

PostPosted: Sun Mar 20, 2011 5:05 am    Post subject: Reply with quote

Found this topic:

http://forums.gentoo.org/viewtopic-t-866921-highlight-kde+restart.html

I've done what it was said there about consolekit, policykit. I ran emerge DavuN world, emerge --depclean, rebooted. Still the problem persists...
Back to top
View user's profile Send private message
MarcusXP
Apprentice
Apprentice


Joined: 18 Apr 2007
Posts: 184
Location: Toronto, ON, Canada

PostPosted: Sun Mar 20, 2011 2:15 pm    Post subject: Reply with quote

bump.. please help!
Back to top
View user's profile Send private message
toralf
Advocate
Advocate


Joined: 01 Feb 2004
Posts: 2713
Location: Hamburg/Germany

PostPosted: Sun Mar 20, 2011 4:23 pm    Post subject: Reply with quote

When I upgraded from 4.4.5 to 4.6.1 I experienced a similar issue. The problem went away after removing and adding that button to the task bar. (but probably the only - and ugly way is to remove the .kde4 HOME folder).
Back to top
View user's profile Send private message
MarcusXP
Apprentice
Apprentice


Joined: 18 Apr 2007
Posts: 184
Location: Toronto, ON, Canada

PostPosted: Sun Mar 20, 2011 5:47 pm    Post subject: Reply with quote

toralf wrote:
When I upgraded from 4.4.5 to 4.6.1 I experienced a similar issue. The problem went away after removing and adding that button to the task bar. (but probably the only - and ugly way is to remove the .kde4 HOME folder).


I have this problem in both, 4.4.5 and 4.6.1
I actually upgraded to 4.6.1 thinking the problem will go away, which didn't happen.
I will try your suggestion with removing the .kde4 folder.

thanks,
Marcus
Back to top
View user's profile Send private message
MarcusXP
Apprentice
Apprentice


Joined: 18 Apr 2007
Posts: 184
Location: Toronto, ON, Canada

PostPosted: Sun Mar 20, 2011 6:28 pm    Post subject: Reply with quote

I removed all .kde* folders from /root and /home/myuser folders .. and still didn't help.
I think it has something to do with the USE flags.. but I have no idea what could be the problem.
Back to top
View user's profile Send private message
MarcusXP
Apprentice
Apprentice


Joined: 18 Apr 2007
Posts: 184
Location: Toronto, ON, Canada

PostPosted: Mon Mar 21, 2011 2:18 am    Post subject: Reply with quote

Any other suggestions, please?
I have 3 systems with the same problem.. what did I do wrong? It must be some configuration issue.. :(
Back to top
View user's profile Send private message
Goverp
Guru
Guru


Joined: 07 Mar 2007
Posts: 346

PostPosted: Mon Mar 21, 2011 11:03 am    Post subject: Reply with quote

Unlikely, but have you checked the Shutdown tab on KDE's System Settings -> Advanced -> Login Manager dialog? You need "Allow Shutdown=Everyone".
_________________
Greybeard
Back to top
View user's profile Send private message
MarcusXP
Apprentice
Apprentice


Joined: 18 Apr 2007
Posts: 184
Location: Toronto, ON, Canada

PostPosted: Mon Mar 21, 2011 12:09 pm    Post subject: Reply with quote

Goverp wrote:
Unlikely, but have you checked the Shutdown tab on KDE's System Settings -> Advanced -> Login Manager dialog? You need "Allow Shutdown=Everyone".


When I go there I have that box disabled/grayed out, but it does say "Allow Shutdown: Local=Everyone and Remote=Only root"
Back to top
View user's profile Send private message
MarcusXP
Apprentice
Apprentice


Joined: 18 Apr 2007
Posts: 184
Location: Toronto, ON, Canada

PostPosted: Mon Mar 21, 2011 2:14 pm    Post subject: Reply with quote

Could it be related to permissions that my user "Marcus" has ?
Maybe I didn't configure it properly when I installed kde?
Back to top
View user's profile Send private message
MarcusXP
Apprentice
Apprentice


Joined: 18 Apr 2007
Posts: 184
Location: Toronto, ON, Canada

PostPosted: Tue Mar 22, 2011 3:48 pm    Post subject: Reply with quote

What else I tried in the meanwhile:

- uninstalled all KDE packages
- uninstalled X11-drivers, xorg
- removed all .kde* folders from /root and /home/marcus
- reinstalled X11-drivers, xorg, KDE

KDE starts successfully, all my settings are gone, but I still can't restart / shutdown the computer using the KDE buttons. I can do it from command line only, but it doesn't stop the programs gracefully, and it doesn't remember the changes to my KDE session.
Any other ideas please? This issue becomes really annoying... I think there's a simple explanations, but I don't know what it can be.
Also, is there a way to save the KDE session manually, at least? That's the thing that is hurting me mostly.

I'd really appreciate some help with this...
Back to top
View user's profile Send private message
MarcusXP
Apprentice
Apprentice


Joined: 18 Apr 2007
Posts: 184
Location: Toronto, ON, Canada

PostPosted: Tue Mar 22, 2011 5:26 pm    Post subject: Reply with quote

My /etc/make.conf file, in case I put something wrong there:

Code:
CFLAGS="-march=native -O2 -pipe"
CXXFLAGS="${CFLAGS}"
MAKEOPTS="-j5"
# WARNING: Changing your CHOST is not something that should be done lightly.
# Please consult http://www.gentoo.org/doc/en/change-chost.xml before changing.
CHOST="x86_64-pc-linux-gnu"
# These are the USE flags that were used in addition to what is provided by the
# profile used for building.

UseCPU="mmx sse sse2 sse3 ssse3 smp"
UseMultimedia="-alsa -quicktime -theora -xvmc -a52 -v4l -v4l2 -phonon -pulseaudio -openal -sdl -mplayer -win32codecs -aac -cdda -flac -lame -mad -mp3 -mp4 -mpeg -midi -xv -xvid -x264 -ffmpeg -ogg -matroska -vorbis -dv -dvb -dvd -dvdr -dts -cdr -xine -gstreamer -aqua"
UseKde="kde -plasma qt3support qt4 semantic-desktop"
UseXorg="opengl X xorg -xcomposite dri -gtk"
UseImgText="-mng -png -jpeg -jpeg2k -gif -tiff -raw -wmf -pdf -gd -cairo svg truetype -pango"
UseDB="sql mysql -odbc sqlite sqlite3 -solid"
UseLanguages="perl php python python3 java javascript xml"
UseProtocols="-apache -apache2 samba nfs"
UsePNPPower="acpi apm dbus udev -hal pam consolekit policykit"
UseOther="symlink bash-completion git rtc startup-notification -mono -spell nls"
UseExclude="-oss -xprint -ipv6 -cups -doc -bluetooth -gnome -laptop -vlc -webkit -debug"
USE="${UseCPU} ${UseMultimedia} ${UseKde} ${UseXorg} ${UseImgText} ${UseDB} ${UseLanguages} ${UseProtocols} ${UsePNPPower} ${UseOther} ${UseExclude}"

INPUT_DEVICES="evdev"
VIDEO_CARDS="vmware"
SYNC="rsync://10.10.10.11/gentoo-portage"
PORTDIR_OVERLAY=/var/lib/layman/vmware
ACCEPT_LICENSE="*"
#FEATURES="distcc"
FEATURES="ccache"
CCACHE_DIR="/var/tmp/ccache"
CCACHE_SIZE="32G"


To be noted that this is a virtual machine (on a ESXi server I have at home), but I have the same problem on two other physical machines as well.
It's easier to debug the problem on the VM since I can take snapshots and revert to previous states easier in case I do something stupid.
Back to top
View user's profile Send private message
Dorsai!
Apprentice
Apprentice


Joined: 27 Jul 2008
Posts: 255
Location: Bavaria

PostPosted: Tue Mar 22, 2011 10:29 pm    Post subject: Reply with quote

I have exactly the same issue since I updated to 4.6.1 recently.
Back to top
View user's profile Send private message
cach0rr0
Moderator
Moderator


Joined: 13 Nov 2008
Posts: 4122
Location: Houston, Republic of Texas

PostPosted: Tue Mar 22, 2011 11:45 pm    Post subject: Reply with quote

works for me on 4.6.1
assuming consolekit is running, what groups are yall in?

for me:

Code:

wheel cron audio cdrom video games cdrw usb users plugdev lpadmin kvm crontab ldap android meat

_________________
Lost configuring your system?
dump lspci -n here | see Pappy's guide | Link Stash
Back to top
View user's profile Send private message
MarcusXP
Apprentice
Apprentice


Joined: 18 Apr 2007
Posts: 184
Location: Toronto, ON, Canada

PostPosted: Wed Mar 23, 2011 12:14 am    Post subject: Reply with quote

I got it figured somehow.
It was related to my USE flags... I removed a bunch of them and recompiled ran "emerge -DavuN world' which recompiled some 14 packages or so.
After I rebooted, I was able to use the 'restart' and 'shutdown' buttons in KDE.
My guess that the '-phonon' keyword was the one causing the problem, but I have yet to confirm that.
I will confirm that by tomorrow, when I will do the same thing again.. the VM was restored to a previous state due to some storage issues :)
Back to top
View user's profile Send private message
Dorsai!
Apprentice
Apprentice


Joined: 27 Jul 2008
Posts: 255
Location: Bavaria

PostPosted: Fri Mar 25, 2011 4:42 pm    Post subject: Reply with quote

It is definitely no use-flag issue, as it works fine on my notebook which is a "binclient" of my main machine and has almost the same use flags and the same world file. All differences are in /etc/portage/package.xxx.d/<hostname> files that are left out when I sync my configurations. Those differences are mostly network manager related.
Back to top
View user's profile Send private message
MarcusXP
Apprentice
Apprentice


Joined: 18 Apr 2007
Posts: 184
Location: Toronto, ON, Canada

PostPosted: Fri Mar 25, 2011 5:05 pm    Post subject: Reply with quote

It is definitely a USE-flags issue, at least on my machine. In make.conf, I split my USE flags based on categories and some flags from UseMultimedia are causing the problem.
After several hours of testing/recompiling/reverting snapshots, here's what I found so far:

A. remove (deleting) these USE flags from make.conf
Code:
-pulseaudio -sdl -mad -xv -ogg -vorbis -dts -xine -gstreamer -aqua

B. run
Code:
emerge -DavuN world
which will require kde-base/phonon-kde xine added to package.use and media-sound/phonon-xine added to package.keywords. By doing this, the following packages will be emerged:
Code:
[ebuild  N    ] media-libs/libogg-1.2.0  USE="-static-libs" 0 kB
[ebuild  N    ] media-libs/libdca-0.0.5-r2  USE="-debug -oss -static-libs" 0 kB
[ebuild  N    ] media-libs/libmad-0.15.1b-r6  USE="-debug" 0 kB
[ebuild  N    ] media-libs/libvorbis-1.3.1  USE="-static-libs" 0 kB
[ebuild   R   ] media-libs/xine-lib-1.1.19  USE="X css dts* mad* modplug musepack nls opengl samba truetype vorbis* xcb xv* -a52 -aac -aalib -alsa (-altivec) -directfb -dxr3 -esd -fbcon -flac -gnome -gtk -imagemagick -ipv6 -jack -libcaca -mmap -mng -oss -pulseaudio (-real) -sdl -speex -theora -v4l -vcd (-vidix) (-vis) -wavpack (-win32codecs) -xinerama -xvmc" 0 kB
[ebuild   R   ] media-sound/phonon-4.4.4  USE="xine* -debug -gstreamer -pulseaudio -vlc" 0 kB
[ebuild  N    ] media-sound/phonon-xine-4.4.4  USE="xcb -debug" 0 kB
[ebuild   R   ] kde-base/phonon-kde-4.4.5  USE="xine* -alsa (-aqua) -debug (-kdeenablefinal) (-kdeprefix)" 0 kB

Total: 8 packages (5 new, 3 reinstalls), Size of downloads: 0 kB


C. reboot the machine and login to KDE. Now the Restart / Shutdown buttons in KDE are working !!!

The tricky question is: why these packages are causing this behavior? They seem to be some harmless multimedia packages.. why the are affecting some basic KDE functions?

NOTE: it is possible that not all 12 of those USE flags have to be removed to achieve the same result. But this is as much as I could sort them so far.. I am still testing to see if there are actually less USE flags that are causing the problem.
Back to top
View user's profile Send private message
MarcusXP
Apprentice
Apprentice


Joined: 18 Apr 2007
Posts: 184
Location: Toronto, ON, Canada

PostPosted: Fri Mar 25, 2011 6:16 pm    Post subject: Reply with quote

Any ideas why these packages are causing this behavior?

Also, I noticed another 'bug'... if the application komparator is started, the shutdown / restart process (launched from KDE, not from command line) gets interrupted after komparator is closed.
Back to top
View user's profile Send private message
MarcusXP
Apprentice
Apprentice


Joined: 18 Apr 2007
Posts: 184
Location: Toronto, ON, Canada

PostPosted: Sun Mar 27, 2011 11:08 pm    Post subject: Reply with quote

After further investigation, I managed to find out which are the exact flags causing the problem.
Code:
-vorbis -dts -xine

After I remove these flags and run emerge -DavuN world, it installs/reinstalls the following packages:
Code:
[ebuild  N    ] media-libs/libogg-1.2.0  USE="-static-libs" 0 kB
[ebuild  N    ] media-libs/libdca-0.0.5-r2  USE="-debug -oss -static-libs" 0 kB
[ebuild  N    ] media-libs/libvorbis-1.3.1  USE="-static-libs" 0 kB
[ebuild   R   ] media-libs/xine-lib-1.1.19  USE="X css dts* modplug musepack nls opengl samba truetype vorbis* xcb -a52 -aac -aalib -alsa (-altivec) -directfb -dxr3 -esd -fbcon -flac -gnome -gtk -imagemagick -ipv6 -jack -libcaca -mad -mmap -mng -oss -pulseaudio (-real) -sdl -speex -theora -v4l -vcd (-vidix) (-vis) -wavpack (-win32codecs) -xinerama -xv -xvmc" 0 kB
[ebuild   R   ] media-sound/phonon-4.4.4  USE="xine* -debug -gstreamer -pulseaudio -vlc" 0 kB
[ebuild  N    ] media-sound/phonon-xine-4.4.4  USE="xcb -debug" 0 kB
[ebuild   R   ] kde-base/phonon-kde-4.4.5  USE="xine* -alsa (-aqua) -debug (-kdeenablefinal) (-kdeprefix)" 0 kB

After rebooting the system, the KDE's Restart and Shutdown buttons are working properly.

Anyone has any ideas why these flags are affecting KDE's functionality? Should I open a bug for this?

I also have another problem.. when rebooting/shutting down the computer (from KDE) it seems that the session doesn't get saved.. I suspect being another USE flags problem..
Back to top
View user's profile Send private message
paulj
Guru
Guru


Joined: 30 Sep 2004
Posts: 342
Location: Wales, UK

PostPosted: Sat Apr 09, 2011 10:03 pm    Post subject: Reply with quote

I had this problem, and found that the configuration file /etc/config/kdm/kdmrc has the following section:

Code:

[Shutdown]
# The command (subject to word splitting) to run to halt the system.
# Default is "/sbin/shutdown -h -P now"
# HaltCmd=
# The command (subject to word splitting) to run to reboot the system.
# Default is "/sbin/shutdown -r now"
# RebootCmd=
# Whether it is allowed to shut down the system via the global command socket.
# Default is false
# AllowFifo=true
# Whether it is allowed to abort active sessions when shutting down the
# system via the global command socket.
# Default is true
#AllowFifoNow=false


I un-commented the "AllowFifo=true" line, then the system shutdown as it used to before the latest upgrade. I didn't need to change the HaltCmd or RebootCmd from their respective defaults.

I am using kde-base/kdm-4.6.2-r1

YMMV, but it is perhaps worth a look. I can post my use flags if you like, but they are fairly standard, and I am using the desktop/kde profile.
Back to top
View user's profile Send private message
paulj
Guru
Guru


Joined: 30 Sep 2004
Posts: 342
Location: Wales, UK

PostPosted: Sat Apr 09, 2011 10:05 pm    Post subject: Reply with quote

MarcusXP wrote:
After further investigation, I managed to find out which are the exact flags causing the problem.

I also have another problem.. when rebooting/shutting down the computer (from KDE) it seems that the session doesn't get saved.. I suspect being another USE flags problem..


Have you confirmed in System Settings under "Startup and Shutdown", under "Session Management" that you want the session to be saved?
Back to top
View user's profile Send private message
lanthruster
n00b
n00b


Joined: 01 Jan 2012
Posts: 29

PostPosted: Sun Jan 01, 2012 11:32 pm    Post subject: Reply with quote

paulj wrote:
MarcusXP wrote:
After further investigation, I managed to find out which are the exact flags causing the problem.

I also have another problem.. when rebooting/shutting down the computer (from KDE) it seems that the session doesn't get saved.. I suspect being another USE flags problem..


Have you confirmed in System Settings under "Startup and Shutdown", under "Session Management" that you want the session to be saved?


Just want to tell you that you were on the right track. A few days ago I ran into the same problem with KDE 4.7.3 running @ amd64 2.6.39-gentoo-r3 #1 SMP PREEMPT. After an improper x-server shutdown caused by the recent incompatibility between vnc plug-in and x-server 1.11.2-r2 KDE lost the ability to restart and shutdown. Nothing happened when the buttons were pressed. I got to restart the system with restart, halt commands and after restart - the problem persisted.

It looks like the problem is caused by the errors in the stored kwin session files. But to fix them a user would have to close a system properly. Fortunately this could be done even without shutdown and restart buttons. That's what fixed the problem for me:

I disabled Restore previous session in Session Manager
Then I chose Switch User -> New Session

at this point instead of logging in I chose shutdown. Next time I boot - the shutdown and restart buttons work as rain.

I had many similar issues with sessions stored improperly in KDE then causing weird problems the next time system startups and I decided to live with: Start with an empty Session.

It's really not worth spending so much time on this feature. I think it should be marked as unstable.
It's very unfortunate that there is no option to clean an old session at startup or to properly close KDE from command line, without kwin.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum