Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Gvim 7.3 freezes at startup
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
shallpion
Guru
Guru


Joined: 29 Sep 2008
Posts: 331

PostPosted: Sun Nov 07, 2010 7:39 pm    Post subject: Gvim 7.3 freezes at startup Reply with quote

Hi, I find that every time I started gvim-7.3, the window just froze there as a grey box....I tried to reinstall vim/gvim/vim-core but didn't work:(. Has anybody else met this problem? Thank you.
Back to top
View user's profile Send private message
ffyring
n00b
n00b


Joined: 16 Aug 2005
Posts: 54
Location: Stockholm

PostPosted: Sun Nov 07, 2010 8:43 pm    Post subject: Re: Gvim 7.3 freezes at startup Reply with quote

shallpion wrote:
Hi, I find that every time I started gvim-7.3, the window just froze there as a grey box....I tried to reinstall vim/gvim/vim-core but didn't work:(. Has anybody else met this problem? Thank you.


Do you have a Nvidia card? There has been some issues there.

You can try 'gvim --noplugin' or 'gvim -X'. Please also try 'strace -f -i gvimout.txt gvim' and post the last lines.
Back to top
View user's profile Send private message
BitJam
Advocate
Advocate


Joined: 12 Aug 2003
Posts: 2454
Location: Silver City, NM

PostPosted: Sun Nov 07, 2010 9:42 pm    Post subject: Reply with quote

There is a problem with nvidia-drivers-260.19.06 and gvim that will create the symptom you have. Reverting to nvidia-drivers-256.53 solved the problem for me. There is a work-around using gvim -f (--nofork) but this caused a lot of other problems for me. I'm using gvim-7.2.442. I don't know if the conflict also exists with gvim-7.3 but I suspect it does.
Back to top
View user's profile Send private message
thewtex
Tux's lil' helper
Tux's lil' helper


Joined: 22 Jun 2007
Posts: 93

PostPosted: Sun Nov 21, 2010 11:52 pm    Post subject: Reply with quote

Reverting to nvidia-drivers-256.53 worked for me too.

Thanks so much for posting!
Back to top
View user's profile Send private message
shallpion
Guru
Guru


Joined: 29 Sep 2008
Posts: 331

PostPosted: Sun Nov 21, 2010 11:54 pm    Post subject: Reply with quote

I just saw your replies, sorry for that. Thank you for your explanations :)
Back to top
View user's profile Send private message
Bircoph
Apprentice
Apprentice


Joined: 27 Jun 2008
Posts: 260
Location: Moscow

PostPosted: Mon Nov 22, 2010 1:01 am    Post subject: Reply with quote

Thanks a lot, you saved me from gray hair :?

I tried a lot of thing when noticed that gvim died. But I only managed to find out a strange fact that gvim works well under strace: that is, if you run strace gvim, it will work well even with the latest nvidia driver.
Of course I reverted to 256.53 and all is ok now without any hacks.

BTW, how on the earth did you find out that nvidia driver was guilty? Just good luck or there were some indications?

P.S. Does anybody know how is that possible that application works inside strace, but fails without it? I always thought strace should not alter application behaviour aside from performance. Or is this strace bug?
P.P.S. Oh, I found something about why this happens: http://bugs.gentoo.org/show_bug.cgi?id=336837
_________________
Per aspera ad astra!
Back to top
View user's profile Send private message
Anon-E-moose
Advocate
Advocate


Joined: 23 May 2008
Posts: 2372
Location: Dallas area

PostPosted: Mon Nov 22, 2010 1:10 am    Post subject: Reply with quote

"gvim -f" seems to solve the hanging problem with the newer nvidia drivers
_________________
Asus m5a99fx, FX 8320 - amd64-multilib, 3.15.9-zen, glibc-2.17, gcc-4.7.3-r1, eudev
xorg-server-1.16, openbox w/lxpanel, nouveau, oss4
Back to top
View user's profile Send private message
Bircoph
Apprentice
Apprentice


Joined: 27 Jun 2008
Posts: 260
Location: Moscow

PostPosted: Mon Nov 22, 2010 2:08 pm    Post subject: Reply with quote

Anon-E-moose wrote:
"gvim -f" seems to solve the hanging problem with the newer nvidia drivers

This is not solution, but workaround which will hurt performance and broke some gvim plugins.

Moreover, this bug with threading system call interceptions by nvidia driver may hurt any other application and lead to hardly traceable problems. gvim is just an example and not unique case.
_________________
Per aspera ad astra!
Back to top
View user's profile Send private message
poulpillusion
n00b
n00b


Joined: 23 Nov 2006
Posts: 3

PostPosted: Mon Feb 14, 2011 11:52 pm    Post subject: Quick fix Reply with quote

Its seems it is fixed in 260.19.29 but on my distrib (Aptosid / Debian Sid) this version is still not available.

As I can't live without VIM and VIMDIFF, here is my quick fix for this problem. You can put this into your .bashrc :

Code:
alias vim="vimproxy"
alias vimdiff="vimdiffproxy"

function vimproxy() {
    strace vim $* 2> /dev/null
}

function vimdiffproxy() {
    strace vimdiff $* 2> /dev/null
}

Now you can use VIM and VIMDIFF again !
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum