Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Having trouble automounting USB drives in xfce4!!!
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
xsilentmurmurx
Apprentice
Apprentice


Joined: 23 Oct 2009
Posts: 231

PostPosted: Fri Jan 28, 2011 3:41 pm    Post subject: Having trouble automounting USB drives in xfce4!!! Reply with quote

Hey there Everyone

I recently installed Xfce4 onto my gentoo installation and I love it :) Two of the features of Xfce4 i installed are the xfce4-mount-plugin and the thunar-volman program. Both of these are supposed to facilitate the mounting process for media such as USB sticks etc.. When i connected a USB memory stick to my PC, an icon for the USB stick appears on the desktop and in Thunar, but no matter what I do, it does not automount the USB and does not give me the authority to view the contents of the USB stick. How do I go about setting up my /etc/fstab file so that a non-root user can automatically mount a USB drive whenever one is connected to the computer? What is the easiest way that you recommend, which will solve this issue?


This is my /etc/fstab file:

Code:

# cat /etc/fstab
# /etc/fstab: static file system information.
#
# noatime turns off atimes for increased performance (atimes normally aren't
# needed; notail increases performance of ReiserFS (at the expense of storage
# efficiency).  It's safe to drop the noatime options if you want and to
# switch between notail / tail freely.
#
# The root filesystem should have a pass number of either 0 or 1.
# All other filesystems should have a pass number of 0 or greater than 1.
#
# See the manpage fstab(5) for more information.
#

# <fs>         <mountpoint>   <type>      <opts>      <dump/pass>

# NOTE: If your BOOT partition is ReiserFS, add the notail option to opts.
/dev/sda1      /boot      ext2   defaults,noatime   1 2
/dev/sda3      /      ext3      noatime      0 1
/dev/sda2      none      swap      sw      0 0
/dev/cdrom      /mnt/cdrom   auto      noauto,ro   0 0
#/dev/fd0      /mnt/floppy   auto      noauto      0 0



# glibc 2.2 and above expects tmpfs to be mounted at /dev/shm for
# POSIX shared memory (shm_open, shm_unlink).
# (tmpfs is a dynamically expandable/shrinkable ramdisk, and will
#  use almost no memory if not populated with files)
proc        /proc        proc    defaults             0 0

shm         /dev/shm   tmpfs      nodev,nosuid,noexec   0 0



pardon me for the messy looking /etc/fstab.. copy and paste does not format things nicely haha
Back to top
View user's profile Send private message
Anon-E-moose
Advocate
Advocate


Joined: 23 May 2008
Posts: 2372
Location: Dallas area

PostPosted: Fri Jan 28, 2011 3:43 pm    Post subject: Reply with quote

Either have the entries in /etc/fstab and manual mount via the mount plugin

OR

comment out the entries (cdrom, usb, etc) and let them automount.
(assuming that you have permissions, etc set up right)
_________________
Asus m5a99fx, FX 8320 - amd64-multilib, 3.15.9-zen, glibc-2.17, gcc-4.7.3-r1, eudev
xorg-server-1.16, openbox w/lxpanel, nouveau, oss4
Back to top
View user's profile Send private message
xsilentmurmurx
Apprentice
Apprentice


Joined: 23 Oct 2009
Posts: 231

PostPosted: Fri Jan 28, 2011 5:03 pm    Post subject: Reply with quote

Anon-E-moose wrote:
Either have the entries in /etc/fstab and manual mount via the mount plugin

OR

comment out the entries (cdrom, usb, etc) and let them automount.
(assuming that you have permissions, etc set up right)



thanks for the response!

The thing is, even when ever I right click on the USB icon, it says "Not Authorized to do that" something of that nature. This is regardless if I have some entry like :

/dev/sdb1 /media/usb vfat 0 0

in /etc/fstab or nothing in it for the USB drive.. then when I go into Thunar and I try to right click on the USB icon and ---> unmount the USB, it says that a process is trying to write to the USB and that I will have to wait until its completed before I can unmount.. Usually at that point i just yank the USB out of the device in frustration lol.

any ideas on what I should do? or at least what entry should I put into my /etc/fstab?
Back to top
View user's profile Send private message
ssuominen
Developer
Developer


Joined: 30 Sep 2005
Posts: 2132
Location: Finland

PostPosted: Fri Jan 28, 2011 5:05 pm    Post subject: Reply with quote

xsilentmurmurx wrote:

or at least what entry should I put into my /etc/fstab?


You were already told in first response "comment out the entries", as in, fstab should have *no* entries for devices handled by udisks (like from Thunar)
Back to top
View user's profile Send private message
xsilentmurmurx
Apprentice
Apprentice


Joined: 23 Oct 2009
Posts: 231

PostPosted: Fri Jan 28, 2011 5:30 pm    Post subject: Reply with quote

ssuominen wrote:
xsilentmurmurx wrote:

or at least what entry should I put into my /etc/fstab?


You were already told in first response "comment out the entries", as in, fstab should have *no* entries for devices handled by udisks (like from Thunar)


OK thank you for the response. Now in the first response, he said "assuming you have the permissions set up correctly". What should the permissions be set to? I am away from my PC right now, so I have to try to work from memory.
Back to top
View user's profile Send private message
ssuominen
Developer
Developer


Joined: 30 Sep 2005
Posts: 2132
Location: Finland

PostPosted: Fri Jan 28, 2011 5:38 pm    Post subject: Reply with quote

That "Not authorized." stuff is handled in this duplicate thread instead: http://forums.gentoo.org/viewtopic-t-858965-highlight-tips+tricks.html
Back to top
View user's profile Send private message
xsilentmurmurx
Apprentice
Apprentice


Joined: 23 Oct 2009
Posts: 231

PostPosted: Fri Jan 28, 2011 5:54 pm    Post subject: Reply with quote

ssuominen wrote:
That "Not authorized." stuff is handled in this duplicate thread instead: http://forums.gentoo.org/viewtopic-t-858965-highlight-tips+tricks.html


looks good!

I guess for the

Code:
USE="-hal consolekit dbus device-mapper pam policykit udev"
I should add them to my /etc/make.conf USE flag list and them emerge --newuse -- deep world or should I just emerge those packages that you specified in the tutorial?
Back to top
View user's profile Send private message
ssuominen
Developer
Developer


Joined: 30 Sep 2005
Posts: 2132
Location: Finland

PostPosted: Fri Jan 28, 2011 5:58 pm    Post subject: Reply with quote

xsilentmurmurx wrote:
Code:
USE="-hal consolekit dbus device-mapper pam policykit udev"
I should add them to my /etc/make.conf USE flag list and them emerge --newuse -- deep world or should I just emerge those packages that you specified in the tutorial?


world
Back to top
View user's profile Send private message
xsilentmurmurx
Apprentice
Apprentice


Joined: 23 Oct 2009
Posts: 231

PostPosted: Fri Jan 28, 2011 6:09 pm    Post subject: Reply with quote

ssuominen wrote:
xsilentmurmurx wrote:
Code:
USE="-hal consolekit dbus device-mapper pam policykit udev"
I should add them to my /etc/make.conf USE flag list and them emerge --newuse -- deep world or should I just emerge those packages that you specified in the tutorial?


world


thank you for all of your help :) I will try this when I get home after work and I hope it works out well :)
Back to top
View user's profile Send private message
tomk
Administrator
Administrator


Joined: 23 Sep 2003
Posts: 7219
Location: Sat in front of my computer

PostPosted: Mon Jan 31, 2011 3:57 pm    Post subject: Reply with quote

Moved from Desktop Environments to Duplicate Threads, please follow up to Tips, and tricks for ConsoleKit/PolicyKit/udev, without hal.
_________________
Search | Read | Answer | Report | Strip
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum