Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge of old machine failing
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
Wizumwalt
Guru
Guru


Joined: 20 Aug 2006
Posts: 356

PostPosted: Mon Feb 14, 2011 8:28 pm    Post subject: emerge of old machine failing Reply with quote

Trying to update an old box, any idea how to get past the following?

Code:
$ sudo emerge -uDNp world                                   

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! All ebuilds that could satisfy ">=x11-misc/util-macros-1.3.0" have been masked.
!!! One of the following masked packages is required to complete your request:
- x11-misc/util-macros-1.11.0 (masked by: EAPI 3)

The current version of portage supports EAPI '2'. You must upgrade to a
newer version of portage before EAPI masked packages can be installed.

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.
(dependency required by "x11-libs/xtrans-1.2.5" [ebuild])
(dependency required by "x11-libs/libX11-1.1.5" [installed])
(dependency required by "media-libs/freetype-2.4.3-r2" [ebuild])
(dependency required by "gnome-base/libgnomeprint-2.18.7" [ebuild])
(dependency required by "dev-python/libgnomeprint-python-2.30.2" [ebuild])
(dependency required by "dev-python/gtksourceview-python-2.30.2" [ebuild])
(dependency required by "dev-vcs/git-1.6.4.5" [ebuild])
(dependency required by "sys-devel/gettext-0.18.1.1-r1" [ebuild])
(dependency required by "dev-util/intltool-0.41.1" [ebuild])


 * IMPORTANT: 3 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.



Code:

$ sudo emerge portage                                       

 * IMPORTANT: 3 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

Calculating dependencies... done!
[ebuild  N    ] dev-libs/libffi-3.0.9  USE="-debug -static-libs -test"
[ebuild  N    ] app-misc/mime-types-8
[ebuild     U ] sys-devel/automake-wrapper-4 [3-r1]
[ebuild     U ] sys-devel/autoconf-wrapper-10-r1 [4-r3]
[ebuild  N    ] app-arch/xz-utils-4.999.9_beta  USE="nls threads -static-libs"
[ebuild     U ] sys-devel/autoconf-2.65-r1 [2.61-r1]
[ebuild     U ] sys-apps/sandbox-2.4 [1.2.18.1-r2] USE="(-multilib)"
[ebuild  N    ] virtual/libffi-0
[ebuild  N    ] dev-perl/Locale-gettext-1.05-r1
[ebuild  N    ] sys-apps/help2man-1.38.2  USE="nls"
[ebuild  NS   ] sys-devel/automake-1.11.1 [1.10.1]
[ebuild     U ] sys-devel/libtool-2.2.6b [1.5.24] USE="-test%"
[ebuild  N    ] app-admin/eselect-1.2.11  USE="-bash-completion -doc"
[ebuild  N    ] app-admin/eselect-python-20100321
[ebuild  NS   ] dev-lang/python-2.6.6-r1 [2.4.4-r13] USE="gdbm ipv6 ncurses readline ssl threads (wide-unicode) xml -berkdb -build -doc -examples -sqlite -tk -wininst"
[ebuild     U ] sys-apps/portage-2.1.9.25 [2.1.6.11] USE="(ipc%*) -python3%"
*** Portage will stop merging at this point and reload itself,
    then resume the merge.
[blocks B     ] <sys-apps/portage-2.1.9 ("<sys-apps/portage-2.1.9" is blocking dev-lang/python-2.6.6-r1)
[blocks B     ] app-admin/eselect-news ("app-admin/eselect-news" is blocking app-admin/eselect-1.2.11)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  ('ebuild', '/', 'app-admin/eselect-1.2.11', 'merge') pulled in by
    >=app-admin/eselect-1.2 required by ('ebuild', '/', 'sys-apps/portage-2.1.9.25', 'merge')
    >=app-admin/eselect-1.2.3 required by ('ebuild', '/', 'app-admin/eselect-python-20100321', 'merge')

  ('ebuild', '/', 'dev-lang/python-2.6.6-r1', 'merge') pulled in by
    dev-lang/python:2.6 required by ('ebuild', '/', 'sys-apps/portage-2.1.9.25', 'merge')


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


!!! The following installed packages are masked:
- dev-lang/perl-5.8.8-r5 (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Torsten Veller <tove@gentoo.org> (06 Jan 2011)
# Next step to remove old perl and libperl versions.
# Versions prior 5.12 are masked and will be removed when 5.14 is available.
# If you are a sparc-fbsd user and your only keyworded perl version was masked,
# test perl-5.12.2 and reply to bug 288028
# For other complaints go to bug 350785

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


 * IMPORTANT: 3 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items


Code:

$ sudo emerge --info | more                                 
Portage 2.1.6.11 (default/linux/x86/10.0, gcc-4.1.2, glibc-2.6.1-r0, 2.6.25-gentoo-r7 i686)
=================================================================
System uname: Linux-2.6.25-gentoo-r7-i686-Intel-R-_Pentium-R-_4_CPU_2.00GHz-with-glibc2.0
Timestamp of tree: Mon, 14 Feb 2011 01:45:01 +0000
app-shells/bash:     3.2_p17-r1
dev-lang/python:     2.4.4-r13
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.61-r1
sys-devel/automake:  1.10.1
sys-devel/binutils:  2.18-r1
sys-devel/gcc:       4.1.2
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.24
sys-devel/make:      3.81
virtual/os-headers:  2.6.23-r3
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=i686 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -march=i686 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://gentoo.mirrors.tera-byte.com/ http://distro.ibiblio.org/pub/linux/distributions/gentoo/ http://www.gtlib.gatech.edu/pub/gentoo http://gentoo.mirrors.pair.com/ http://gentoo.mirrors.tds.net/gentoo http://mirror.datapipe.net/gentoo"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.namerica.gentoo.org/gentoo-portage"
USE="X acl alsa avahi berkdb bzip2 cairo cdx cli cracklib crypt cups cxx dbus dri dvd fortran gdbm gnome gpm gtk hal iconv imlib ipv6 jpeg jpg kde modules mudflap ncurses nls nptl nptlonly openmp pam pcre perl png pppd python qt3 qt4 readline session ssl sysfs tcpd unicode x86 xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga neomagic nouveau nv r128 radeon savage sis tdfx trident vesa via vmware voodoo" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5653

PostPosted: Mon Feb 14, 2011 8:44 pm    Post subject: Reply with quote

It will be tricky.
First, unmerge eselect-news and try to update eselect.
If that succeeds, you'll need to find correct python/portage combination (you may need to search for old ebuilds) to update portage.
Next step will be python updater, though perhaps emerging libtool beforehand would be a good idea.

And it won't get easier from here, cause now the real fun will start (glibc, gcc, kernel, udev for a start).
Back to top
View user's profile Send private message
dol-sen
Developer
Developer


Joined: 30 Jun 2002
Posts: 2569
Location: Richmond, BC, Canada

PostPosted: Mon Feb 14, 2011 10:13 pm    Post subject: Reply with quote

here, use this thread for guidance:

http://forums.gentoo.org/viewtopic-t-856878.html
_________________
Brian
Porthole, the Portage GUI frontend irc@freenode: #gentoo-guis, #porthole, Blog
layman, gentoolkit, CoreBuilder, esearch...
Back to top
View user's profile Send private message
pigeon768
l33t
l33t


Joined: 02 Jan 2006
Posts: 669

PostPosted: Tue Feb 15, 2011 1:09 am    Post subject: Reply with quote

Try emerging =sys-apps/portage-2.1.8.3, then python-2.6.something, then latest portage+latest python. Portage should handle the eselect transition by itself.

If that doesn't work, check 'ls /usr/portage/sys-apps/portage/*.ebuild /usr/portage/dev-lang/python/*.ebuild' for the available ebuilds. Start with one, attempt to update to the newest available ebuild (it will fail) and go older and older until it works. Then start with the other package and attempt the newest available ebuild and step older and older until it works. Rinse, repeat.
_________________
My political bias.
Back to top
View user's profile Send private message
Hu
Watchman
Watchman


Joined: 06 Mar 2007
Posts: 9124

PostPosted: Tue Feb 15, 2011 3:16 am    Post subject: Re: emerge of old machine failing Reply with quote

Wizumwalt wrote:
Code:
(dependency required by "dev-vcs/git-1.6.4.5" [ebuild])
(dependency required by "sys-devel/gettext-0.18.1.1-r1" [ebuild])
Set USE=-git for sys-devel/gettext, at least until you get your system current. You will have other problems, but avoiding dev-vcs/git and the resulting secondary dependencies will make your life a little easier.
Back to top
View user's profile Send private message
tomk
Administrator
Administrator


Joined: 23 Sep 2003
Posts: 7219
Location: Sat in front of my computer

PostPosted: Tue Feb 15, 2011 9:37 am    Post subject: Reply with quote

Moved from Portage & Programming to Duplicate Threads, please see update old system to 10.0 or 2008.1.
_________________
Search | Read | Answer | Report | Strip
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum