Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Minecraft (ebuild to build deps from source!)
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4, 5 ... 10, 11, 12  Next  
Reply to topic    Gentoo Forums Forum Index Gamers & Players
View previous topic :: View next topic  
Author Message
Chewi
l33t
l33t


Joined: 01 Sep 2003
Posts: 789
Location: Edinburgh, Scotland

PostPosted: Thu Jun 02, 2011 11:44 am    Post subject: Reply with quote

I've now updated the Minecraft ebuild to use LWJGL 2.7. I'd appreciate it if you could try OpenAL 1.13 again. If it still doesn't work, I'll have to try with ALSA myself because I'm not sure whether this is affecting ALSA in general or just your particular setup.
Back to top
View user's profile Send private message
yther
Apprentice
Apprentice


Joined: 25 Oct 2002
Posts: 151
Location: Charlotte, NC (USA)

PostPosted: Thu Jun 02, 2011 2:40 pm    Post subject: Reply with quote

Yesterday I decided to try installing a texture pack. As it requires the use of MCPatcher HD Fix, I'm attempting to use that. However, the patcher refuses to recognize that Minecraft is installed, and no matter how I point it to ~/.minecraft, even after removing said folder and letting the game download stuff again, it does nothing. Because of this, it seems I will not be able to use texture packs properly.

Has anyone using this ebuild encountered this problem? How did you overcome it?
Back to top
View user's profile Send private message
Dorsai!
Apprentice
Apprentice


Joined: 27 Jul 2008
Posts: 261
Location: Bavaria

PostPosted: Thu Jun 02, 2011 9:21 pm    Post subject: Reply with quote

Sorry, does not change anything. It only works with openal 1.12
Back to top
View user's profile Send private message
yther
Apprentice
Apprentice


Joined: 25 Oct 2002
Posts: 151
Location: Charlotte, NC (USA)

PostPosted: Sat Jun 04, 2011 11:19 pm    Post subject: Reply with quote

@Chewi, back in March you said you were "waiting to see what happens with Bukkit." What has been happening with it? :)

My wife wants me to install MCMMO, which requires a Bukkit-based server. I'm trying to figure out how these scripts could be modified to run Bukkit instead of the vanilla server, but I confess to getting lost. Do you plan to add Bukkit support any time soon, or is that outside the scope of this ebuild?
Back to top
View user's profile Send private message
Chewi
l33t
l33t


Joined: 01 Sep 2003
Posts: 789
Location: Edinburgh, Scotland

PostPosted: Sun Jun 05, 2011 9:29 pm    Post subject: Reply with quote

Dorsai! wrote:
Sorry, does not change anything. It only works with openal 1.12

Thanks for trying it. I tried ALSA too and it worked fine for me so I'm going to leave it as it is unless someone else also reports it.

yther, the Bukkit situation hasn't changed much as it's still legally very dubious but there has been some news. Rather than incorporate Bukkit or publish a modding API, Mojang have decided to allow access to their source code in a controlled manner. I think some people got the impression that all mod writers would have to enter into this arrangement but the way I understand it, I don't see how different mods could coexist under this setup. I haven't seen any official announcement from the Bukkit team but the only way I can see this working if is they get access to the source code and they provide the API for other people to create mods with, much as they are doing now. Presumably Mojang will allow them to do this. As to when any of this will happen, I doubt anyone really knows. When releases like 1.6 seem to break things more than they fix, we could be waiting a while.

Regarding MCPatcher, I can help there. :) All I needed to do was create a dummy lwjgl.jar and that was enough to fool it. I'm not sure why it checks for that but hey. I've released this change as -r2. The "Test Minecraft" button won't work but you don't actually need that.
Back to top
View user's profile Send private message
Chewi
l33t
l33t


Joined: 01 Sep 2003
Posts: 789
Location: Edinburgh, Scotland

PostPosted: Fri Jun 10, 2011 5:23 pm    Post subject: Reply with quote

Maybe we won't have to wait so long after all. From the mouth of Notch...

Quote:
We’re starting the modding support on a small scale with 1.7. We’ll be giving the source code out to a very VERY small group of people before the release of 1.7. We’ll use those experiences to work out the final details, then we’ll get the modding api out as soon as possible after 1.7 has been released.
Back to top
View user's profile Send private message
Chewi
l33t
l33t


Joined: 01 Sep 2003
Posts: 789
Location: Edinburgh, Scotland

PostPosted: Thu Jun 30, 2011 8:55 pm    Post subject: Reply with quote

Bumped the server to 1.7_01. Had a quick go and seems to work.
Back to top
View user's profile Send private message
Sb0y
n00b
n00b


Joined: 30 Jun 2007
Posts: 5

PostPosted: Fri Jul 01, 2011 2:45 pm    Post subject: Reply with quote

Cant download server. Got:

Code:

('Filesize does not match recorded size', 502792L, 502611)
!!! Fetched file: minecraft-server-20110630.jar VERIFY FAILED!
!!! Reason: Filesize does not match recorded size
!!! Got:      502792
!!! Expected: 502611
Back to top
View user's profile Send private message
Chewi
l33t
l33t


Joined: 01 Sep 2003
Posts: 789
Location: Edinburgh, Scotland

PostPosted: Fri Jul 01, 2011 3:13 pm    Post subject: Reply with quote

Yeah, they've bumped it again already. This is getting annoying. Now at 1.7.2.
Back to top
View user's profile Send private message
alegioit
Tux's lil' helper
Tux's lil' helper


Joined: 13 Jul 2007
Posts: 78

PostPosted: Fri Jul 01, 2011 4:22 pm    Post subject: Reply with quote

As ever a big thanks for your work!!!
I hope this time notch doesn't release 50 patches of minecraft in one day......
Back to top
View user's profile Send private message
Sb0y
n00b
n00b


Joined: 30 Jun 2007
Posts: 5

PostPosted: Fri Jul 01, 2011 5:15 pm    Post subject: Reply with quote

Chewi wrote:
Yeah, they've bumped it again already. This is getting annoying. Now at 1.7.2.


Thanks for fast solution )
Back to top
View user's profile Send private message
barul
Guru
Guru


Joined: 28 May 2010
Posts: 429
Location: France

PostPosted: Fri Jul 01, 2011 8:36 pm    Post subject: Reply with quote

I'm always asking me "But WHY don't they test their shit instead of making a hundred of patches after the release?".

And I still don't know.
_________________
Save the penguins, burn the flags!
Back to top
View user's profile Send private message
Chewi
l33t
l33t


Joined: 01 Sep 2003
Posts: 789
Location: Edinburgh, Scotland

PostPosted: Fri Jul 01, 2011 9:52 pm    Post subject: Reply with quote

The ishmodupdated.com site used to have a quote. :lol:

Quote:
I wonder how Notch failed to notice bugs that would be apparent to a blind, retarded hamster after 30 seconds of gameplay.
Back to top
View user's profile Send private message
Ant P.
Advocate
Advocate


Joined: 18 Apr 2009
Posts: 2592
Location: UK

PostPosted: Thu Jul 14, 2011 6:27 pm    Post subject: Reply with quote

Just out of curiosity I'm trying to get minecraft to run under icedtea7 - the launcher works fine but then the game throws this:
Code:
Exception in thread "Minecraft main thread" java.lang.UnsatisfiedLinkError: /usr/lib64/lwjgl-2.7/liblwjgl64.so: libjawt.so: cannot open shared object file: No such file or directory
   at java.lang.ClassLoader$NativeLibrary.load(Native Method)
   at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1933)
   at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1830)
   at java.lang.Runtime.load0(Runtime.java:787)
   at java.lang.System.load(System.java:1059)
   at org.lwjgl.Sys$1.run(Sys.java:70)
   at java.security.AccessController.doPrivileged(Native Method)
   at org.lwjgl.Sys.doLoadLibrary(Sys.java:66)
   at org.lwjgl.Sys.loadLibrary(Sys.java:82)
   at org.lwjgl.Sys.<clinit>(Sys.java:99)
   at org.lwjgl.opengl.Display.<clinit>(Display.java:130)
   at net.minecraft.client.Minecraft.a(SourceFile:244)
   at net.minecraft.client.Minecraft.run(SourceFile:716)
   at java.lang.Thread.run(Thread.java:722)


I'm pretty sure that file exists for that VM:
Code:
~ $ locate libjawt.so
/opt/icedtea6-bin-1.10.2/jre/lib/amd64/libjawt.so
/opt/sun-jdk-1.6.0.26/jre/lib/amd64/libjawt.so
/usr/lib64/debug/usr/lib64/icedtea7/jre/lib/amd64/libjawt.so.debug
/usr/lib64/icedtea7/jre/lib/amd64/libjawt.so


Any ideas?
_________________
runit-init howto | Overlay
Back to top
View user's profile Send private message
Chewi
l33t
l33t


Joined: 01 Sep 2003
Posts: 789
Location: Edinburgh, Scotland

PostPosted: Thu Jul 14, 2011 7:09 pm    Post subject: Reply with quote

Hmm I'm not sure. I think the VM should just handle this. Which VM did you merge lwjgl with? It was probably icedtea6-bin. Try emerging it with JAVA_PKG_FORCE_VM=icedtea7. Not sure if that'll make a difference but it's worth a try.
Back to top
View user's profile Send private message
Ant P.
Advocate
Advocate


Joined: 18 Apr 2009
Posts: 2592
Location: UK

PostPosted: Fri Jul 15, 2011 1:37 am    Post subject: Reply with quote

I can verify it's using it:
Code:
>>> Starting pkg_setup
 * Using: icedtea7

...but no change.

I've noticed ldd says "libjawt.so => not found" no matter what VM I'm using, even though it works with the others.

Also if I run "java-config -P icedtea7" it prints out an LDPATH containing that lib's directory. Shouldn't there be an env.d file with that stuff in it?
_________________
runit-init howto | Overlay
Back to top
View user's profile Send private message
Chewi
l33t
l33t


Joined: 01 Sep 2003
Posts: 789
Location: Edinburgh, Scotland

PostPosted: Fri Jul 15, 2011 6:27 am    Post subject: Reply with quote

I get "not found" as well, that's normal. /usr/bin/java is actually a wrapper around the real java, which sets all this stuff up so no, there is no env.d file. What you're seeing there comes from /usr/share/java-config-2/vm/icedtea7.
Back to top
View user's profile Send private message
vk4akp
n00b
n00b


Joined: 25 Nov 2007
Posts: 18
Location: Ipswich / Queensland / Australia

PostPosted: Tue Aug 23, 2011 12:20 pm    Post subject: MineCraft / MineServe Overlay? Reply with quote

Hi is there like an overlay or something that contains Minecraft and Minserve in it so I can just emerge the damn things instead of mucking with eBuilds and getting nowhere?

.-.-.
Back to top
View user's profile Send private message
Chewi
l33t
l33t


Joined: 01 Sep 2003
Posts: 789
Location: Edinburgh, Scotland

PostPosted: Tue Aug 23, 2011 12:28 pm    Post subject: Reply with quote

As my first post says, it's in java-overlay.
Back to top
View user's profile Send private message
vk4akp
n00b
n00b


Joined: 25 Nov 2007
Posts: 18
Location: Ipswich / Queensland / Australia

PostPosted: Tue Aug 23, 2011 3:31 pm    Post subject: Reply with quote

Cool! How do I add an overlay? :)


Don't worry I worked that bit out.

So the server and game installed on two different machines.

But running the server fails. :(

--
/etc/init.d/minecraft-server start
* Caching service dependencies ... [ ok ]
* Starting Minecraft server "main" ...
/etc/init.d/minecraft-server: line 24: ewaitfile: command not found [ !! ]
* ERROR: minecraft-server failed to start
--

.-.-.


Last edited by vk4akp on Tue Aug 23, 2011 4:12 pm; edited 1 time in total
Back to top
View user's profile Send private message
Chewi
l33t
l33t


Joined: 01 Sep 2003
Posts: 789
Location: Edinburgh, Scotland

PostPosted: Tue Aug 23, 2011 3:39 pm    Post subject: Reply with quote

Code:
emerge layman
layman -a java-overlay
echo "source /var/lib/layman/make.conf" >> /etc/make.conf
Back to top
View user's profile Send private message
vk4akp
n00b
n00b


Joined: 25 Nov 2007
Posts: 18
Location: Ipswich / Queensland / Australia

PostPosted: Tue Aug 23, 2011 4:20 pm    Post subject: Reply with quote

What's this bit do?

echo "source /var/lib/layman/make.conf" >> /etc/make.conf

Also I got a ewaitfile crash. What's that?

/etc/init.d/minecraft-server: line 24: ewaitfile: command not found

.-.-.
Back to top
View user's profile Send private message
Chewi
l33t
l33t


Joined: 01 Sep 2003
Posts: 789
Location: Edinburgh, Scotland

PostPosted: Tue Aug 23, 2011 4:35 pm    Post subject: Reply with quote

It adds your configured overlays to the PORTDIR_OVERLAY variable.

That error would suggest you don't have OpenRC installed but it's one of the dependencies. You definitely used the latest ebuild from the overlay, right?
Back to top
View user's profile Send private message
vk4akp
n00b
n00b


Joined: 25 Nov 2007
Posts: 18
Location: Ipswich / Queensland / Australia

PostPosted: Tue Aug 23, 2011 5:00 pm    Post subject: Reply with quote

I didn't do..

echo "source /var/lib/layman/make.conf" >> /etc/make.conf

But I'll do that now.

to install I just did.

emerge games-server/minecraft-server

It installed

Latest version available: 20110708

I googled some stuff and found something about this. so I am now trying.

emerge dev-db/mysql-init-scripts

But I still get this.

/etc/init.d/minecraft-server: line 24: ewaitfile: command not found [ !! ]

I hope I don't have RatBotz. :(
.-.-.
Back to top
View user's profile Send private message
vk4akp
n00b
n00b


Joined: 25 Nov 2007
Posts: 18
Location: Ipswich / Queensland / Australia

PostPosted: Tue Aug 23, 2011 5:07 pm    Post subject: Reply with quote

Doing

echo "source /var/lib/layman/make.conf" >> /etc/make.conf

Was a very bad idea.
Now when I try and use emerge I get this.

[Errno 2] No such file or directory: '/var/lib/layman/make.conf' in /etc/make.conf

Emerge is very broken now! :(

.-.-.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gamers & Players All times are GMT
Goto page Previous  1, 2, 3, 4, 5 ... 10, 11, 12  Next
Page 4 of 12

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum