Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Minecraft (ebuild to build deps from source!)
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... , 10, 11, 12  Next  
Reply to topic    Gentoo Forums Forum Index Gamers & Players
View previous topic :: View next topic  
Author Message
Chewi
l33t
l33t


Joined: 01 Sep 2003
Posts: 785
Location: Edinburgh, Scotland

PostPosted: Mon Aug 05, 2013 6:17 am    Post subject: Reply with quote

Are you sure that works? I found the JSON gets replaced automatically on each start. You can set it to read only though. The problem with this approach is that it only works after you've started that version of the game once. I think there may have been some other issue too, can't remember.
Back to top
View user's profile Send private message
Ant P.
Advocate
Advocate


Joined: 18 Apr 2009
Posts: 2272
Location: UK

PostPosted: Mon Aug 05, 2013 4:54 pm    Post subject: Reply with quote

It looks like the game only overwrites things it already knows about; if you copy 1.6.2/ to a different-named directory and edit the "id:" line in the JSON it'll leave it alone. The 1.6 mods I've installed use the same procedure.
Back to top
View user's profile Send private message
vootey
n00b
n00b


Joined: 24 Jul 2010
Posts: 29
Location: Austria

PostPosted: Tue Aug 27, 2013 2:05 pm    Post subject: Reply with quote

any news on this front? :)
Back to top
View user's profile Send private message
Yminus
Apprentice
Apprentice


Joined: 06 Jan 2008
Posts: 167

PostPosted: Mon Sep 02, 2013 7:41 pm    Post subject: Reply with quote

I have synced the java overlay today a got these digest verification errors:
Code:
>>> Verifying ebuild manifests

!!! Digest verification failed:
!!! /var/lib/layman/java/dev-java/jopt-simple/ChangeLog
!!! Reason: Filesize does not match recorded size
!!! Got: 917
!!! Expected: 759

!!! Digest verification failed:
!!! /var/lib/layman/java/dev-java/gson/ChangeLog
!!! Reason: Filesize does not match recorded size
!!! Got: 605
!!! Expected: 462

!!! Digest verification failed:
!!! /var/lib/layman/java/dev-java/lwjgl/ChangeLog
!!! Reason: Filesize does not match recorded size
!!! Got: 2864
!!! Expected: 2704

!!! Digest verification failed:
!!! /var/lib/layman/java/games-action/minecraft/ChangeLog
!!! Reason: Filesize does not match recorded size
!!! Got: 5341
!!! Expected: 5236

Can you please fix them? Or should I write a bug report?
_________________
Göögle is evil!
To protect your privacy search the net with
https://www.ixquick.com
Back to top
View user's profile Send private message
Chewi
l33t
l33t


Joined: 01 Sep 2003
Posts: 785
Location: Edinburgh, Scotland

PostPosted: Mon Sep 02, 2013 8:14 pm    Post subject: Reply with quote

Yminus wrote:
I have synced the java overlay today a got these digest verification errors:


Thanks for reporting that. With the switch to git, I'm now committing using repoman and I'm signing the manifests but maybe I tripped up somewhere. I'm more than familiar with git and repoman is supposed to prevent things like this so I'm not sure what happened but I'll double-check before pushing next time.

I was going to announce the new ebuild but just after pushing it, I realised the new Python script didn't work with the older versions of the game. I've fixed that now but I'm waiting for a bump of dev-java/asm in the main tree before I push it up. As things stand, the new ebuild should work with the 1.6.2.
Back to top
View user's profile Send private message
Chewi
l33t
l33t


Joined: 01 Sep 2003
Posts: 785
Location: Edinburgh, Scotland

PostPosted: Mon Sep 02, 2013 9:47 pm    Post subject: Reply with quote

Chewi wrote:
Thanks for reporting that. With the switch to git, I'm now committing using repoman and I'm signing the manifests but maybe I tripped up somewhere. I'm more than familiar with git and repoman is supposed to prevent things like this so I'm not sure what happened but I'll double-check before pushing next time.

Looks like it was a repoman bug. The problem went away after updating Portage.

Chewi wrote:
I was going to announce the new ebuild but just after pushing it, I realised the new Python script didn't work with the older versions of the game. I've fixed that now but I'm waiting for a bump of dev-java/asm in the main tree before I push it up. As things stand, the new ebuild should work with the 1.6.2.

It looks like the dev-java/asm bump may take a little longer so I've pushed out an update to the Python script anyway. For now, it just uses the upstream bundled version of asm. I've tried Minecraft 1.2.5 and even 1.0.0 and they both seem to work. Not that anyone cares about those old versions!

When updating, it'll look like a downgrade because we're now following the upstream launcher version numbers. Be sure to read the instructions after emerging, which will explain how to activate the use of Gentoo's packages. This no longer happens by default.
Back to top
View user's profile Send private message
Yminus
Apprentice
Apprentice


Joined: 06 Jan 2008
Posts: 167

PostPosted: Mon Sep 02, 2013 10:19 pm    Post subject: Reply with quote

Thank you for fixing that.

However, I could not emerge the new ebuild. Here is the build log:
Code:
 * Package:    games-action/minecraft-1.2.1
 * Repository: java
 * Maintainer: chewi at aura-online.co.uk java@gentoo.org
 * USE:        amd64 elibc_glibc kernel_linux python_targets_python2_7 python_targets_python3_2 userland_GNU
 * FEATURES:   preserve-libs sandbox userpriv usersandbox
 * Using: oracle-jdk-bin-1.7
>>> Unpacking source...
zip I/O error: Permission denied
zip error: Temporary file failure (/var/tmp/portage/games-action/minecraft-1.2.1/distdir/zizawCyL)
 * ERROR: games-action/minecraft-1.2.1 failed (unpack phase):
 *   (no error message)
 *
 * Call stack:
 *     ebuild.sh, line  93:  Called src_unpack
 *   environment, line 5313:  Called die
 * The specific snippet of code:
 *       zip -d "${DISTDIR}/${A}" -O "${PN}.jar" com/\* joptsimple/\* || die
 *
 * If you need support, post the output of `emerge --info '=games-action/minecraft-1.2.1'`,
 * the complete build log and the output of `emerge -pqv '=games-action/minecraft-1.2.1'`.
 * This ebuild is from an overlay named 'java': '/var/lib/layman/java/'
!!! When you file a bug report, please include the following information:
GENTOO_VM=oracle-jdk-bin-1.7  CLASSPATH="" JAVA_HOME="/opt/oracle-jdk-bin-1.7.0.25"
JAVACFLAGS="-source 1.6 -target 1.6" COMPILER=""
and of course, the output of emerge --info =minecraft-1.2.1
 * The complete build log is located at '/var/tmp/portage/games-action/minecraft-1.2.1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/games-action/minecraft-1.2.1/temp/environment'.
 * Working directory: '/var/tmp/portage/games-action/minecraft-1.2.1/work'
 * S: '/var/tmp/portage/games-action/minecraft-1.2.1/work'


Something wrong with the file ownership:
Code:
ls -al /var/tmp/portage/games-action/minecraft-1.2.1/distdir/
total 0
drwxr-xr-x 2 root    portage  60  3. Sep 00:09 .
drwxrwxr-x 6 portage portage 200  3. Sep 00:09 ..
lrwxrwxrwx 1 root    root     42  3. Sep 00:09 minecraft-1.2.1.jar -> /usr/portage/distfiles/minecraft-1.2.1.jar

_________________
Göögle is evil!
To protect your privacy search the net with
https://www.ixquick.com


Last edited by Yminus on Mon Sep 02, 2013 11:00 pm; edited 1 time in total
Back to top
View user's profile Send private message
Yminus
Apprentice
Apprentice


Joined: 06 Jan 2008
Posts: 167

PostPosted: Mon Sep 02, 2013 10:23 pm    Post subject: Reply with quote

Code:
ls -al /var/tmp/portage/games-action/minecraft-1.2.1/
total 0
drwxrwxr-x 6 portage portage 200  3. Sep 00:22 .
drwxrwxr-x 3 portage portage  60  3. Sep 00:22 ..
-rw-r--r-- 1 portage portage   0  3. Sep 00:22 .die_hooks
prwxrwx--- 1 root    portage   0  3. Sep 00:22 .ipc_in
prwxrwx--- 1 root    portage   0  3. Sep 00:22 .ipc_out
-rw-r--r-- 1 root    root      0  3. Sep 00:21 .setuped
drwxr-xr-x 2 root    portage  60  3. Sep 00:21 distdir
drwxrwxr-x 2 portage portage  40  3. Sep 00:21 homedir
drwxrwxr-x 3 portage portage 140  3. Sep 00:21 temp
drwx------ 2 portage portage  60  3. Sep 00:22 work

_________________
Göögle is evil!
To protect your privacy search the net with
https://www.ixquick.com
Back to top
View user's profile Send private message
Chewi
l33t
l33t


Joined: 01 Sep 2003
Posts: 785
Location: Edinburgh, Scotland

PostPosted: Tue Sep 03, 2013 6:47 am    Post subject: Reply with quote

Someone else reported this problem to me but I didn't have a chance to look at it yet. They were using Paludis so I thought that maybe that was the reason. It looks like it's actually FEATURES="userpriv". I don't try to modify the original jar but the stupid zip command creates a temporary file in /var/tmp/portage/games-action/minecraft-1.2.1/distdir, which the portage user doesn't have write access to. I'll fix this later today.
Back to top
View user's profile Send private message
Chewi
l33t
l33t


Joined: 01 Sep 2003
Posts: 785
Location: Edinburgh, Scotland

PostPosted: Tue Sep 03, 2013 6:56 am    Post subject: Reply with quote

Done it already! zip has a --temp-path option so it was a quicker fix than I thought.
Back to top
View user's profile Send private message
Yminus
Apprentice
Apprentice


Joined: 06 Jan 2008
Posts: 167

PostPosted: Tue Sep 03, 2013 7:09 am    Post subject: Reply with quote

Chewi wrote:
Done it already! zip has a --temp-path option so it was a quicker fix than I thought.

With games-action/minecraft-1.2.1-r1 I still get the same error as reported above. Did you commit the fix?
_________________
Göögle is evil!
To protect your privacy search the net with
https://www.ixquick.com
Back to top
View user's profile Send private message
Chewi
l33t
l33t


Joined: 01 Sep 2003
Posts: 785
Location: Edinburgh, Scotland

PostPosted: Tue Sep 03, 2013 9:11 am    Post subject: Reply with quote

Yminus wrote:
With games-action/minecraft-1.2.1-r1 I still get the same error as reported above. Did you commit the fix?

I was about to post a link to prove it and then realised I hadn't done a push. Could have sworn I did. Note to self: Don't rush changes when you're half way out the door on your way to work. :oops:
Back to top
View user's profile Send private message
Yminus
Apprentice
Apprentice


Joined: 06 Jan 2008
Posts: 167

PostPosted: Tue Sep 03, 2013 9:02 pm    Post subject: Reply with quote

Thank you, emerging worked. I followed the instructions after emerging and tried to start the game, but it crashed. Here is the relevant part of the log:

Code:
Client> Traceback (most recent call last):
Client>   File "/usr/games/bin/minecraft-gentoo-python2.7", line 106, in <module>
Client>     manager = EnvironmentManager(os.getenv("ROOT", ""), os.getenv("EPREFIX", ""))
Client> TypeError: __call__() takes exactly 1 argument (3 given)
Sep 03, 2013 10:59:56 PM net.minecraft.launcher.process.ProcessMonitorThread run
SEVERE: null
java.io.IOException: Stream closed
        at java.io.BufferedReader.ensureOpen(BufferedReader.java:115)
        at java.io.BufferedReader.readLine(BufferedReader.java:310)
        at java.io.BufferedReader.readLine(BufferedReader.java:382)
        at net.minecraft.launcher.process.ProcessMonitorThread.run(ProcessMonitorThread.java:26)

Game ended with bad state (exit code 1)

_________________
Göögle is evil!
To protect your privacy search the net with
https://www.ixquick.com
Back to top
View user's profile Send private message
Chewi
l33t
l33t


Joined: 01 Sep 2003
Posts: 785
Location: Edinburgh, Scotland

PostPosted: Tue Sep 03, 2013 9:26 pm    Post subject: Reply with quote

Yminus wrote:
I followed the instructions after emerging and tried to start the game, but it crashed. Here is the relevant part of the log:

Thanks, that log was very helpful. It's almost certainly because you need dev-java/java-config-2.2.0. Can you update that and try again? I'll update the ebuild accordingly if that works.
Back to top
View user's profile Send private message
Yminus
Apprentice
Apprentice


Joined: 06 Jan 2008
Posts: 167

PostPosted: Tue Sep 03, 2013 11:11 pm    Post subject: Reply with quote

Code:
WARNING: One or more updates have been skipped due to a dependency conflict:

dev-java/java-config:2

  (dev-java/java-config-2.2.0::gentoo, ebuild scheduled for merge) conflicts with
    <dev-java/java-config-2.2 required by (dev-java/icedtea-bin-6.1.12.6::gentoo, installed)
  (dev-java/java-config-2.2.0::gentoo, ebuild scheduled for merge) conflicts with
    <dev-java/java-config-2.2 required by (dev-java/oracle-jdk-bin-1.7.0.25::gentoo, installed)


I also tried only with icedtea-bin-7 installed:

Code:
WARNING: One or more updates have been skipped due to a dependency conflict:

dev-java/java-config:2

  (dev-java/java-config-2.2.0::gentoo, ebuild scheduled for merge) conflicts with
    <dev-java/java-config-2.2 required by (dev-java/icedtea-bin-7.2.4.1::gentoo, ebuild scheduled for merge)


Seems like dev-java/java-config-2.2 cannot be emerged with current java environments?.
_________________
Göögle is evil!
To protect your privacy search the net with
https://www.ixquick.com
Back to top
View user's profile Send private message
Chewi
l33t
l33t


Joined: 01 Sep 2003
Posts: 785
Location: Edinburgh, Scotland

PostPosted: Wed Sep 04, 2013 5:59 am    Post subject: Reply with quote

Yminus wrote:
Seems like dev-java/java-config-2.2 cannot be emerged with current java environments?.

It's not obvious but looking at java-vm-2.eclass, it seems the only thing blocking you from using later versions is the fact that you have eselect-java installed. Uninstall that and you should be able to update.

Edit: Sorry, I was talking out my ass before. The above is still true but eselect-java is still in the tree. I'll talk to #gentoo-java anyway.
Back to top
View user's profile Send private message
vootey
n00b
n00b


Joined: 24 Jul 2010
Posts: 29
Location: Austria

PostPosted: Wed Sep 04, 2013 11:06 am    Post subject: Reply with quote

I just want to say that it works for me.
On my system the java-overlay is masked except the packages used by minecraft.
In particular that means that java-config-2.2.0::java is masked while java-config-2.2.0::gentoo is not (therefore the official version is installed). Also there are more situations like this (like eselect-java).
Maybe these two ebuilds are different (didn't check) which could explain the behaviour on your side. (?)

Just a thought.
Back to top
View user's profile Send private message
Yminus
Apprentice
Apprentice


Joined: 06 Jan 2008
Posts: 167

PostPosted: Wed Sep 04, 2013 8:42 pm    Post subject: Reply with quote

Chewi wrote:
It's not obvious but looking at java-vm-2.eclass, it seems the only thing blocking you from using later versions is the fact that you have eselect-java installed.


eselect-java is not installed:
Code:
eix eselect-java
* app-admin/eselect-java
     Available versions:  ~0.1.0 ~0.1.0[1] **9999[1]
     Homepage:            http://www.gentoo.org/proj/en/java/
     Description:         A set of eselect modules for Java

[1] "java" /var/lib/layman/java


Searching the portage tree I found:
Code:
grep "<dev-java/java-config-2.2" --exclude-dir=metadata -r /usr/portage/
/usr/portage/sys-apps/baselayout-java/baselayout-java-0.1.0.ebuild:RDEPEND="!<dev-java/java-config-2.2"
/usr/portage/app-admin/eselect-java/eselect-java-0.1.0.ebuild:  !<dev-java/java-config-2.2
/usr/portage/eclass/java-vm-2.eclass:   || ( app-admin/eselect-java <dev-java/java-config-2.2 )"


It seems sys-apps/baselayout-java-0.1.0 is a blocker as well as java-vm-2 eclass which is inherited by icedtea among others:

Code:
egrep "inherit .* java-vm-2" --exclude-dir=metadata -r /usr/portage/
/usr/portage/dev-java/sun-jdk/sun-jdk-1.6.0.43.ebuild:inherit eutils java-vm-2 prefix versionator
/usr/portage/dev-java/sun-jdk/sun-jdk-1.6.0.45.ebuild:inherit eutils java-vm-2 prefix versionator
/usr/portage/dev-java/icedtea-web/icedtea-web-1.3.2-r7.ebuild:inherit autotools eutils java-pkg-2 java-vm-2
/usr/portage/dev-java/icedtea-web/icedtea-web-1.3.1.ebuild:inherit autotools eutils java-pkg-2 java-vm-2
/usr/portage/dev-java/icedtea-web/icedtea-web-1.3.2.ebuild:inherit autotools eutils java-pkg-2 java-vm-2
/usr/portage/dev-java/icedtea-web/icedtea-web-1.3.1-r7.ebuild:inherit autotools eutils java-pkg-2 java-vm-2
/usr/portage/dev-java/cacao/cacao-0.99.4.ebuild:inherit autotools eutils flag-o-matic java-pkg-2 java-vm-2
/usr/portage/dev-java/oracle-jdk-bin/oracle-jdk-bin-1.7.0.25.ebuild:inherit eutils java-vm-2 prefix versionator
/usr/portage/dev-java/icedtea/icedtea-7.2.3.9.ebuild:inherit java-pkg-2 java-vm-2 pax-utils prefix versionator virtualx flag-o-matic
/usr/portage/dev-java/icedtea/icedtea-6.1.12.5.ebuild:inherit java-pkg-2 java-vm-2 pax-utils prefix versionator virtualx
/usr/portage/dev-java/icedtea/icedtea-7.2.4.1.ebuild:inherit check-reqs java-pkg-2 java-vm-2 pax-utils prefix versionator virtualx flag-o-matic
/usr/portage/dev-java/icedtea/icedtea-7.2.3.8.ebuild:inherit java-pkg-2 java-vm-2 pax-utils prefix versionator virtualx flag-o-matic
/usr/portage/dev-java/icedtea/icedtea-6.1.12.4.ebuild:inherit java-pkg-2 java-vm-2 pax-utils prefix versionator virtualx
/usr/portage/dev-java/icedtea/icedtea-6.1.12.6.ebuild:inherit java-pkg-2 java-vm-2 pax-utils prefix versionator virtualx
/usr/portage/dev-java/jamvm/jamvm-1.5.4-r1.ebuild:inherit eutils flag-o-matic multilib java-vm-2 autotools
/usr/portage/dev-java/jamvm/jamvm-1.5.4-r2.ebuild:inherit eutils flag-o-matic multilib java-vm-2 autotools


vootey wrote:
On my system the java-overlay is masked except the packages used by minecraft.

Thank you for this hint, but afaik java overlay packages are masked by default and on my system only those packages are unmasked which are really needed as dependency (e.g. for minecraft or dev-util/eclipse-sdk-bin). Anyway, I tried to emerge ~sys-apps/baselayout-java-0.1.0::gentoo ~java-config-2.2.0::gentoo as well as ~sys-apps/baselayout-java-0.1.0::java ~java-config-2.2.0::java, both with the same result:

Code:
emerge -pv1 ~sys-apps/baselayout-java-0.1.0::gentoo ~java-config-2.2.0::gentoo

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N    ~] sys-apps/baselayout-java-0.1.0  71 kB
[ebuild     U ~] dev-java/java-config-2.2.0:2 [2.1.12-r1:2] PYTHON_TARGETS="python2_7 python3_2 -python2_6 (-python3_1) -python3_3" 51 kB
[blocks b      ] <dev-java/java-config-2.2 ("<dev-java/java-config-2.2" is blocking sys-apps/baselayout-java-0.1.0)

Total: 2 packages (1 upgrade, 1 new), Size of downloads: 122 kB
Conflict: 1 block


Is there anything else I could try?


EDIT: I forgot to mention that sys-apps/baselayout-java-0.1.0 is a dependency of dev-java/java-config-2.2.0. This is really weird since it is also its blocker!?!

Code:
emerge -pv1  ~java-config-2.2.0::gentoo

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N    ~] sys-apps/baselayout-java-0.1.0::java  71 kB
[ebuild     U ~] dev-java/java-config-2.2.0:2 [2.1.12-r1:2] PYTHON_TARGETS="python2_7 python3_2 -python2_6 (-python3_1) -python3_3" 51 kB
[blocks b      ] <dev-java/java-config-2.2 ("<dev-java/java-config-2.2" is blocking sys-apps/baselayout-java-0.1.0)

Total: 2 packages (1 upgrade, 1 new), Size of downloads: 122 kB
Conflict: 1 block

_________________
Göögle is evil!
To protect your privacy search the net with
https://www.ixquick.com
Back to top
View user's profile Send private message
Chewi
l33t
l33t


Joined: 01 Sep 2003
Posts: 785
Location: Edinburgh, Scotland

PostPosted: Wed Sep 04, 2013 8:48 pm    Post subject: Reply with quote

Okay, I think I get it now. sys-apps/baselayout-java-0.1.0 is not a blocker, in fact, it's the other way round. You can't install that alongside any version of java-config less than 2.2. And therein lies the problem. You can't resolve it without completely uninstalling java-config first. I can't remember if I had to do the same. Again, I'll raise it on #gentoo-java.

For what it's worth, I'll make Minecraft work with older java-config versions anyway but I'd like to see your issue fixed.
Back to top
View user's profile Send private message
Chewi
l33t
l33t


Joined: 01 Sep 2003
Posts: 785
Location: Edinburgh, Scotland

PostPosted: Wed Sep 04, 2013 9:09 pm    Post subject: Reply with quote

TomWij, a developer in #gentoo-java has pointed out that [blocks b ] means it can be automatically resolved. An upper-case B means it cannot. In other words, you just need to remove your -p option and go for it! :lol:
Back to top
View user's profile Send private message
Yminus
Apprentice
Apprentice


Joined: 06 Jan 2008
Posts: 167

PostPosted: Wed Sep 04, 2013 10:20 pm    Post subject: Reply with quote

Chewi wrote:
You can't resolve it without completely uninstalling java-config first.

Right, that did the trick.

Now there is another error (note: deleted my username and token, replaced path to my home dir by ~):
Code:
Running minecraft-gentoo -Xmx1G -Djava.library.path=~/.minecraft/versions/1.6.2/1.6.2-natives-25245724478697 -cp ~/.minecraft/libraries/net/sf/jopt-simple/jopt-simple/4.5/jopt-simple-4.5.jar:~/.minecraft/libraries/com/paulscode/codecjorbis/20101023/codecjorbis-20101023.jar:~/.minecraft/libraries/com/paulscode/codecwav/20101023/codecwav-20101023.jar:~/.minecraft/libraries/com/paulscode/libraryjavasound/20101123/libraryjavasound-20101123.jar:~/.minecraft/libraries/com/paulscode/librarylwjglopenal/20100824/librarylwjglopenal-20100824.jar:~/.minecraft/libraries/com/paulscode/soundsystem/20120107/soundsystem-20120107.jar:~/.minecraft/libraries/argo/argo/2.25_fixed/argo-2.25_fixed.jar:~/.minecraft/libraries/org/bouncycastle/bcprov-jdk15on/1.47/bcprov-jdk15on-1.47.jar:~/.minecraft/libraries/com/google/guava/guava/14.0/guava-14.0.jar:~/.minecraft/libraries/org/apache/commons/commons-lang3/3.1/commons-lang3-3.1.jar:~/.minecraft/libraries/commons-io/commons-io/2.4/commons-io-2.4.jar:~/.minecraft/libraries/net/java/jinput/jinput/2.0.5/jinput-2.0.5.jar:~/.minecraft/libraries/net/java/jutils/jutils/1.0.0/jutils-1.0.0.jar:~/.minecraft/libraries/com/google/code/gson/gson/2.2.2/gson-2.2.2.jar:~/.minecraft/libraries/org/lwjgl/lwjgl/lwjgl/2.9.0/lwjgl-2.9.0.jar:~/.minecraft/libraries/org/lwjgl/lwjgl/lwjgl_util/2.9.0/lwjgl_util-2.9.0.jar:~/.minecraft/versions/1.6.2/1.6.2.jar net.minecraft.client.main.Main --username  --session token: --version 1.6.2 --gameDir ~/.minecraft --assetsDir ~/.minecraft/assets
Client> java -Djava.library.path=/usr/lib64/lwjgl-2.9:/usr/lib64/jinput:~/.minecraft/versions/1.6.2/1.6.2-natives-25245724478697 -classpath /usr/share/jopt-simple/lib/jopt-simple.jar:/usr/share/paulscode-codecjorbis/lib/paulscode-codecjorbis.jar:/usr/share/jorbis/lib/jorbis.jar:/usr/share/paulscode-codecwav/lib/paulscode-codecwav.jar:/usr/share/paulscode-libraryjavasound/lib/paulscode-libraryjavasound.jar:/usr/share/paulscode-librarylwjglopenal/lib/paulscode-librarylwjglopenal.jar:/usr/share/paulscode-soundsystem/lib/paulscode-soundsystem.jar:~/.minecraft/libraries/argo/argo/2.25_fixed/argo-2.25_fixed.jar:/usr/share/bcprov/lib/bcprov.jar:/usr/share/guava-14/lib/guava.jar:/usr/share/commons-lang-3.1/lib/commons-lang.jar:/usr/share/commons-io-1/lib/commons-io.jar:/usr/share/jinput/lib/jinput.jar:/usr/share/jutils/lib/jutils.jar:/usr/share/gson-2.2.2/lib/gson.jar:/usr/share/lwjgl-2.9/lib/lwjgl.jar:/usr/share/lwjgl-2.9/lib/lwjgl_util.jar:~/.minecraft/versions/1.6.2/1.6.2.jar -Xmx1G net.minecraft.client.main.Main --gameDir ~/.minecraft --version 1.6.2 --username  --session token: --assetsDir ~/.minecraft/assets
Client> 2013-09-04 23:19:38 [CLIENT] [INFO] Setting user:
Client> 2013-09-04 23:19:38 [CLIENT] [INFO] (Session ID is token:
Client> Exception in thread "main" java.lang.NoClassDefFoundError: org/apache/commons/io/Charsets
Client>         at bu.<init>(SourceFile:26)
Client>         at bu.<clinit>(SourceFile:19)
Client>         at bt.<clinit>(SourceFile:7)
Client>         at yb.v(SourceFile:495)
Client>         at kz.a(SourceFile:139)
Client>         at kz.c(SourceFile:85)
Client>         at yb.<clinit>(SourceFile:310)
Client>         at aqw.<clinit>(SourceFile:362)
Client>         at kz.a(SourceFile:122)
Client>         at kz.<clinit>(SourceFile:55)
Client>         at ats.<init>(SourceFile:201)
Client>         at net.minecraft.client.main.Main.main(SourceFile:83)
Client> Caused by: java.lang.ClassNotFoundException: org.apache.commons.io.Charsets
Client>         at java.net.URLClassLoader$1.run(URLClassLoader.java:366)
Client>         at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
Client>         at java.security.AccessController.doPrivileged(Native Method)
Client>         at java.net.URLClassLoader.findClass(URLClassLoader.java:354)
Client>         at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
Client>         at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:308)
Client>         at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
Client>         ... 12 more
Game ended with bad state (exit code 1)
Ignoring visibility rule and showing launcher due to a game crash
Deleting ~/.minecraft/versions/1.6.2/1.6.2-natives-25245724478697


I upgraded dev-java/commons-io from 2.0.1 to 2.4 (which was masked and depends on app-admin/eselect-java-0.1.0, which was also masked).

Then the game started. I tried to load a saved single player game and got this:

Code:
Client> 2013-09-05 00:02:24 [SERVER] [INFO] Starting integrated minecraft server version 1.6.2
Client> 2013-09-05 00:02:24 [SERVER] [INFO] Generating keypair
Client> java.lang.NoClassDefFoundError: org/bouncycastle/crypto/io/CipherOutputStream
Client>         at bkw.d(SourceFile:104)
Client>         at net.minecraft.server.MinecraftServer.run(SourceFile:314)
Client>         at hh.run(SourceFile:582)
Client> Caused by: java.lang.ClassNotFoundException: org.bouncycastle.crypto.io.CipherOutputStream
Client>         at java.net.URLClassLoader$1.run(URLClassLoader.java:366)
Client>         at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
Client>         at java.security.AccessController.doPrivileged(Native Method)
Client>         at java.net.URLClassLoader.findClass(URLClassLoader.java:354)
Client>         at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
Client>         at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:308)
Client>         at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
Client>         ... 3 more
Client> 2013-09-05 00:02:24 [SERVER] [SEVERE] Encountered an unexpected exception NoClassDefFoundError
Client> java.lang.NoClassDefFoundError: org/bouncycastle/crypto/io/CipherOutputStream
Client>         at bkw.d(SourceFile:104)
Client>         at net.minecraft.server.MinecraftServer.run(SourceFile:314)
Client>         at hh.run(SourceFile:582)
Client> Caused by: java.lang.ClassNotFoundException: org.bouncycastle.crypto.io.CipherOutputStream
Client>         at java.net.URLClassLoader$1.run(URLClassLoader.java:366)
Client>         at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
Client>         at java.security.AccessController.doPrivileged(Native Method)
Client>         at java.net.URLClassLoader.findClass(URLClassLoader.java:354)
Client>         at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
Client>         at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:308)
Client>         at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
Client>         ... 3 more


I could only find dev-ruby/bouncy-castle-java, which I presume is not the right package.
_________________
Göögle is evil!
To protect your privacy search the net with
https://www.ixquick.com
Back to top
View user's profile Send private message
Chewi
l33t
l33t


Joined: 01 Sep 2003
Posts: 785
Location: Edinburgh, Scotland

PostPosted: Thu Sep 05, 2013 6:34 am    Post subject: Reply with quote

Gee, you're hitting every damn bump in the road here. I think this shows that maybe I need to be a little stricter about the versions. Just because two versions share the same slot, it doesn't mean the older version is forwards compatible. The package you're after is dev-java/bcprov. What version do you have now?
Back to top
View user's profile Send private message
Yminus
Apprentice
Apprentice


Joined: 06 Jan 2008
Posts: 167

PostPosted: Thu Sep 05, 2013 9:21 pm    Post subject: Reply with quote

My current version is dev-java/bcprov-1.38-r2

When I tried with 1.40 and 1.45 the problem persists. The higher versions are installed to slots, I guess minecraft does not use them. First I tried a deepclean but this kept 1.38 and unmerged the others:
Code:
emerge -avc

...

>>> These are the packages that would be unmerged:

 dev-java/bcprov
    selected: 1.40-r1
   protected: none
     omitted: 1.38-r2 1.38-r3

 dev-java/bcprov
    selected: 1.45-r1
   protected: none
     omitted: 1.38-r2 1.38-r3


I had to unmerge 1.38 explicitly and install 1.40 and 1.45 respectively to test minecraft with those versions. The good news is that both worked!

But here is the next "bump":
Code:
emerge -a --update --newuse --deep --with-bdeps=y @world
These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  NS    ] dev-java/bcprov-1.38-r3 [1.40-r1] USE="-doc -source"
[ebuild  NS    ] dev-java/bcprov-1.38-r2 [1.40-r1] USE="-doc -source"


This is caused by some packages that explicitly want dev-java/bcprov-1.38.
Code:
 equery depends dev-java/bcprov
 * These packages depend on dev-java/bcprov:
dev-java/bcmail-1.38-r2 (~dev-java/bcprov-1.38:0)
dev-java/pdfbox-0.7.3-r3 (dev-java/bcprov:1.38)
games-action/minecraft-1.2.1-r1 (dev-java/bcprov:0)


dev-java/bcmail is a dependency of dev-java/pdfbox which itself is a dependency of app-text/texlive-2012 with USE=pdfannotextractor:
Code:
equery depends dev-java/pdfbox
 * These packages depend on dev-java/pdfbox:
dev-tex/pdfannotextractor-0.1l (dev-java/pdfbox)

equery depends dev-tex/pdfannotextractor
 * These packages depend on dev-tex/pdfannotextractor:
app-text/texlive-2012 (pdfannotextractor ? dev-tex/pdfannotextractor)


Conclusion:
games-action/minecraft should depend on >dev-java/bcprov-1.38 and use the right slot.
_________________
Göögle is evil!
To protect your privacy search the net with
https://www.ixquick.com
Back to top
View user's profile Send private message
Chewi
l33t
l33t


Joined: 01 Sep 2003
Posts: 785
Location: Edinburgh, Scotland

PostPosted: Thu Sep 05, 2013 10:11 pm    Post subject: Reply with quote

The versioning and slotting of these packages is a little complicated. Your problem essentially boils down to mixing stable and unstable. However, after a long and confusing conversion with TomWij, we concluded that bcmail-1.38-r2 should depend on bcmail with slot 1.38 and not slot 0. He is now evaluating this change carefully because it will affect stable.

In the meantime, I have bumped Minecraft to -r3 so that it now depends on >=bcmail-1.47:0 and >=commons-io-2.4:1. Why 1.47? That's what upstream uses. With a current Portage tree, slot 0 will actually give you 1.49, which seems to work. I have also gone through the other dependencies and reasoned that these do not need further adjustment at this time.

I picked up the minecraft-server ebuild again tonight. It now uses many of these same dependencies. 1.6.2 runs in the foreground but I'm having some trouble running it under tmux and I haven't had time to fully diagnose it yet.
Back to top
View user's profile Send private message
TomWij
Developer
Developer


Joined: 04 Jul 2012
Posts: 1546

PostPosted: Thu Sep 05, 2013 10:34 pm    Post subject: Reply with quote

+ 05 Sep 2013; Tom Wijsman <TomWij@gentoo.org> +bcmail-1.38-r3.ebuild,
+ -bcmail-1.38-r2.ebuild:
+ Properly SLOT bcprov dependency with one that's exactly the same (except for
+ the SLOT) to resolve a blocker.
+ (http://forums.gentoo.org/viewtopic-p-7389618.html#7389618)

Wait a few hours, sync again; then the revision bump will resolve the blocker.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gamers & Players All times are GMT
Goto page Previous  1, 2, 3 ... , 10, 11, 12  Next
Page 11 of 12

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum